This document contains instructions for installing the LabVIEW 2013 FPGA Module and related products, introduces new features, and provides information about upgrading from the previous version of LabVIEW. Refer to the resources listed at the end of this document for information about developing applications with LabVIEW and the FPGA Module.

Contents

System Requirements ................................................................. 2
  Development Computer ......................................................... 2
  Remote Compile Server and Worker ....................................... 3
Installation .................................................................................. 3
  Installing the LabVIEW FPGA Module on a Development Computer .......... 4
  Installing the Compilation Tools on a Separate Computer ............... 5
Activating the LabVIEW FPGA Module ........................................ 5
Version 2013 Features and Changes .............................................. 6
  Support for Variable-Sized Arrays in FPGA VIs ......................... 6
  Improvements to Debugging and Verification .............................. 6
  Math and Analysis Functions Improvements: Linear Algebra Functions ..... 7
  AXI Protocol Exposed on Some Xilinx IP .................................. 7
  Host Interface Improvements .................................................. 7
  Improvements to Data Storage and Transfer Functions .................. 7
  Improvements to CLIP Clock Connections ................................ 7
  Performance Improvements While Executing on the Development Computer .... 8
Upgrade and Compatibility Issues ................................................ 8
  VIs that Contain an IP Integration Node ....................................... 8
Known Issues .............................................................................. 8
Where to Go from Here ............................................................. 9
  Documentation and Examples .................................................. 9
  National Instruments Website .................................................. 9
Where to Go for Support ............................................................ 10
System Requirements

The development computer is a PC or NI PXI/PXI Express system on which you install LabVIEW and the LabVIEW FPGA Module. You can use this computer to compile FPGA VIs, but if the FPGA design or target requires more than 2 GB of memory, National Instruments recommends installing the LabVIEW FPGA compilation tools on a separate computer. This computer is referred to as the remote compile server.

Development Computer

- LabVIEW 2013 Full or Professional Development Systems (32-bit)
- 1.2 GHz Pentium processor or equivalent
- 11 GB additional disk space
- Memory\(^1\):
  - At least 3 GB of RAM for Virtex-5 and earlier FPGA targets
  - At least 4 GB of RAM for Virtex-6 and later\(^2\) FPGA targets
- One of the following operating systems:
  - Windows 7 (32-bit)\(^3\)
  - Windows 7 (64-bit with 32-bit LabVIEW installed)
  - Windows Vista (32-bit)
  - Windows Vista (64-bit with 32-bit LabVIEW installed)
  - Windows XP Pro (Service Pack 3)
  - Windows Server 2003 R2 (32-bit)\(^4\)
  - Windows Server 2008 R2 (64-bit with 32-bit LabVIEW installed)

\(^1\) Memory requirements vary according to both the FPGA target and the FPGA VI you create for that target. To determine your memory needs, monitor the memory usage of the `xst.exe` process in the Windows Task Manager.
\(^2\) You must use a 64-bit OS to address 4 GB of RAM.
\(^3\) The LabVIEW FPGA Module uses Xilinx compilation tools that do not officially support Windows 7. NI obtained permission from Xilinx to allow LabVIEW FPGA Module customers to use the tools on this platform, with the disclaimer that Xilinx is not able to fix any bugs found that are specific to this platform. NI tested the Xilinx tools that the LabVIEW FPGA Module uses and did not find any issues. If you encounter problems with the Xilinx tools and Windows 7, you might need to compile using Windows XP or Vista. In such cases, you might want to install the Xilinx compilation tools on a separate computer. Refer to ni.com/info and enter the Info Code fpgakb1rcs for information about installing the compilation tools on a separate computer. NI is not liable for any problems or issues related to the use of Xilinx tools with Windows 7.
\(^4\) The LabVIEW FPGA Module does not support the Windows Server non-R2 editions.

Note The LabVIEW 2013 FPGA Module does not support Windows 8.
• FPGA device
• Device driver software—To program most devices with the LabVIEW 2013 FPGA Module, install the NI-RIO 13.0 driver software. Refer to the hardware documentation for different requirements for a specific device.

Remote Compile Server and Worker
If you install the Xilinx compilation tools on a separate computer, you can configure that computer to be either the remote compile server or a remote compile worker. This computer must meet the following specifications:
• 11 GB of disk space for the complete set of Xilinx compilation tools
• One of the following operating systems:
  • Windows 7 (32-bit and 64-bit)
  • Windows XP Professional (32-bit and 64-bit)
  • Windows Vista (32-bit and 64-bit)
  • (Worker only) Red Hat Enterprise Linux 6.3

NI also offers the LabVIEW FPGA Compile Farm Toolkit and the LabVIEW FPGA Compile Cloud Service, both of which increase your development efficiency by offloading compiles to multiple computers. Refer to the National Instruments web site at ni.com for information about these products.

Note If you are upgrading from the 2012 version of the Compile Worker, you must install Red Hat Enterprise Linux 6.3. Refer to ni.com/info and enter the Info Code FPGAcwl for more information on how to upgrade.

Installation
The following sections provide information about installing the LabVIEW FPGA Module and related components.

Note If you are upgrading from a previous version of LabVIEW, you must install LabVIEW 2013 before you install the LabVIEW 2013 FPGA Module to mass compile existing VIs successfully. If you mass compile existing FPGA VIs before you install the LabVIEW FPGA Module, some FPGA-specific VIs might have mutation issues.
Installing the LabVIEW FPGA Module on a Development Computer

Complete the following steps to install LabVIEW and the FPGA Module:

1. Log in as an administrator or as a user with administrative privileges.
2. Insert the LabVIEW Platform DVD 1.

   To request additional LabVIEW 2013 Platform DVDs, refer to ni.com/info and enter the Info Code RequestDVD. If you purchased this product with an NI Software Suite or NI Product Bundle, use the installation media that shipped with your purchase to install this product.

   **Tip** If the installer does not start automatically, double-click setup.exe from the media to launch the installer.

3. Follow the instructions on the screen to install and activate the following software:
   - **LabVIEW**
   - **FPGA Module**
   - **Compilation Tools**—Refer to your hardware documentation for information about the FPGA in your device and install the appropriate set of tools.
     - **Compilation Tools for Spartan 3, Spartan 6, Virtex 5, and Virtex 6 FPGA Devices**—Install these compilation tools on the development computer to create simulation exports, configure the IP Integration Node, incorporate Xilinx CORE Generator IP, or use the Configure Component-Level IP wizard.
     - (Optional) **Compilation Tools for Virtex-II FPGA Devices**—Install these compilation tools only if your FPGA device contains a Xilinx Virtex-II or Virtex-II Pro FPGA. To install these compilation tools, insert the 2013 Xilinx Compilation Tools installation media and follow the instructions on the screen.

   **Note** To configure the IP Integration Node, or use the Configure Component-Level IP wizard on Virtex-II devices, you must also install the compilation tools for Spartan 3, Spartan 6, Virtex 5, and Virtex 6 FPGA devices. Xilinx CORE Generator IP and simulation exports are not supported on Virtex-II FPGA devices.

   - (Optional) **FPGA Compile Farm Toolkit**—Use the FPGA Compile Farm Toolkit to distribute FPGA VI compiles across multiple remote computers. You have a temporary license for this product. During this period, you can compile two FPGA VIs simultaneously. After the evaluation period expires, you can compile one FPGA VI at a time.
• (Optional) **Real-Time Module**—Use the LabVIEW Real-Time Module to program the real-time OS on NI PXI, NI PXI Express, NI CompactRIO, and NI Single-Board RIO devices. You have a temporary license for this product.

• **Device Drivers**—NI-RIO 13.0 is the device driver software for most FPGA targets. Refer to your hardware documentation for information about additional or different device drivers you need.

In addition to installing program files and documentation in the LabVIEW directory, the installer also puts files from Xilinx in the `\NIFPGA` directory, where `x` is the drive on which you installed LabVIEW. The LabVIEW FPGA Module uses these files to compile FPGA VIs into code that runs on an FPGA target.

### Installing the Compilation Tools on a Separate Computer

#### Installing the Compilation Tools for Linux

Install the LabVIEW FPGA Compile Worker on a remote computer running Linux to use the remote computer to compile FPGA VIs:

1. Log into the system as `root`.
2. Insert the 2013 Xilinx Compilation Tools installation media. Use `mount /mnt/cdrom` to mount the media. On some systems, the media mounts automatically.
3. To change the current directory to the mounted media, enter the following command:
   ```bash
cd /mnt/cdrom/Linux/Xilinx_14/
```
4. To run the installation script, enter the following command:
   ```bash
./INSTALL
```

#### Setting Up a Remote Compile Server or Worker

- **Windows**—Refer to `ni.com/info` and enter the Info Code `fpgakblrcs` for information about installing the Xilinx compilation tools on a computer that is not the development computer.
- **Linux**—Refer to `ni.com/info` and enter the Info Code `FPGAcw1` for information about setting up a remote compile worker.

### Activating the LabVIEW FPGA Module

The LabVIEW FPGA Module relies on licensing activation. You have a temporary license that includes both the FPGA Module and the Xilinx tools that the FPGA Module uses. When the evaluation period expires, you must activate a valid FPGA Module license to continue using the software. Activating the FPGA Module license also activates the license for the Xilinx tools. You must create an `ni.com` User Profile to activate your software.
Use the NI License Manager, available in the National Instruments\NI License Manager directory, to activate NI products. Refer to the National Instruments License Manager Help, available by selecting Help»Contents in the NI License Manager, for more information about activating NI products.

Version 2013 Features and Changes

The LabVIEW 2013 FPGA Module includes the following new features. Refer to the LabVIEW Help, available by selecting Help»LabVIEW Help in LabVIEW, for more information about these features.

Support for Variable-Sized Arrays in FPGA VIs

FPGA VIs now support variable-sized, one-dimensional arrays that resolve to a single size at compile time. Previous versions of the FPGA Module only supported one-dimensional, fixed-size arrays.

Improvements to Debugging and Verification

LabVIEW 2013 brings the following improvements to debugging and verification:

Desktop Execution Node

You now can use the FPGA Desktop Execution Node to debug an FPGA VI. This node runs an FPGA VI on the desktop with simulated I/O for a number of clock ticks that you specify. Use the FPGA Desktop Execution Node to communicate with FPGA resources that you select and to verify your FPGA design.

Support for Sampling Probes

You now can use Sampling probes in FPGA VIs and host VIs to check intermediate values on a wire as a VI runs. The Sampling Probe Watch Window displays the values in a waveform viewer. Use Sampling probes to understand the way signals relate to each other over time.

Updates to Timing Behavior When Executing on a Development Computer with Simulated I/O

Some FPGA resources now use simulated time rather than real time when you execute the VI on a development computer with simulated I/O. Refer to the Introduction to Debugging FPGA VIs on the Host topic in the LabVIEW Help for more information about simulated time.
Math and Analysis Functions Improvements: Linear Algebra Functions

You now can use Linear Algebra functions to perform vector and matrix calculations in high speed and high throughput FPGA applications, such as RF applications. The new FPGA Linear Algebra subpalette includes the following functions:

- Linear Algebra Dot Product—Computes the dot product of two complex vectors.
- Linear Algebra Matrix Multiply—Computes the multiplication of two complex matrices.
- Linear Algebra Matrix Transpose—Transposes a complex matrix.
- Linear Algebra Norm Square—Computes the norm square of a complex vector.

AXI Protocol Exposed on Some Xilinx IP

National Instruments exposes the AXI, or Advanced eXtensible Interface, protocol for certain Xilinx CORE Generator IP on specific hardware targets. Refer to the IP data sheet for more information about interface and FPGA device support.

Host Interface Improvements

You now can use the Open Dynamic Bitfile Reference function to reference an FPGA bitfile by path at run time when communicating with an FPGA target.

Improvements to Data Storage and Transfer Functions

LabVIEW 2013 brings the following improvements to the Data Storage and Transfer functions:

Improvements to Data Transfer

You now can use handshake items to achieve lossless data transfer from a writing domain to a reading domain, and to notify the writing domain when the reader receives the data. This method of handshaking data saves development time over manually implementing the four-wire handshaking protocol.

Improvements to Memory Items

You now can store data in one clock domain and access the data from a different clock domain using a memory item implemented with block memory.

Improvements to CLIP Clock Connections

You now can create necessary FPGA target clocks from the Clock Selections page of the Component-Level IP Properties dialog box and link them to certain corresponding CLIP clocks automatically, which saves development time when compared to adding these clocks manually.
Performance Improvements While Executing on the Development Computer

Depending on your memory consumption and performance needs, you now can choose whether to persist memory values between VI executions while executing on the development computer.

Upgrade and Compatibility Issues

The following sections provide information about upgrading from the LabVIEW 2012 FPGA Module to the LabVIEW 2013 FPGA Module. Refer to previous editions of the *LabVIEW FPGA Module Release and Upgrade Notes*, available on ni.com, for changes in previous versions of the FPGA Module.

**Note** NI recommends you test all FPGA designs after upgrading. Upgrading the LabVIEW FPGA Module requires upgrading to a new version of the Xilinx compilation tools. This upgrade can change the timing or resource utilization characteristics of FPGA VIs you developed in previous versions or cause these VIs to fail to compile.

VIs that Contain an IP Integration Node

If you open a VI saved in a previous version of LabVIEW that contains an IP Integration Node, you must regenerate support files for the IP. To complete this task, select Tools»FPGA Module»Regenerate Support Files for IP Integration Nodes in LabVIEW 2013. Follow the on-screen instructions to generate the support files for LabVIEW 2013.

**Note** LabVIEW might not be able to update all support files. In this situation, re-add the IP Integration Node to the VI and generate the support files for the new node.

Known Issues

Refer to the National Instruments web site at ni.com/info and enter the Info Code LVFPGA2013KI to access the known issues for the LabVIEW 2013 FPGA Module.
Where to Go from Here

NI provides many resources to help you succeed with your NI products. Use the following resources as you start exploring LabVIEW and the FPGA Module.

Documentation and Examples

Use the following resources to learn more about using LabVIEW and the FPGA Module:

- **Context Help Window**—Available by pressing <Ctrl-H>. This window provides brief descriptions of VIs, functions, and dialog boxes along with a link to more detailed information.

- **LabVIEW Help**—Available by selecting Help»LabVIEW Help in LabVIEW. Browse the FPGA Module book in the Contents tab for an overview of the FPGA Module and hardware-specific information. Browse the FPGA Interface book in the Contents tab for an overview of the FPGA Interface information.

- **Hardware Documentation**—Refer to the documentation that came with the FPGA target hardware for information about that hardware. The documentation might be installed on disk instead of printed.

- **Sample Projects**—The NI-RIO driver software installs several sample projects that are designed as starting points for common applications. You can adapt these sample projects to your own applications. Access these sample projects by selecting File»Create Project in LabVIEW.

- **Examples**—The driver software for many FPGA targets includes corresponding examples. Refer to the specific hardware documentation for information about whether the FPGA target you use comes with corresponding examples.

  You can start with an existing example and use it as a starting point for developing FPGA VIs and host VIs. From LabVIEW, launch the NI Example Finder by selecting Help»Find Examples. Browse the examples by directory or by task.

National Instruments Website

Refer to ni.com/info and enter the Info Code LabVIEW_FPGA for the latest NI Developer Zone articles, examples, and support information for the FPGA Module.

Refer to ni.com/info and enter the Info Code fpgatrn to access online training for the FPGA Module.
Where to Go for Support

The National Instruments Web site is your complete resource for technical support. At ni.com/support you have access to everything from troubleshooting and application development self-help resources to email and phone assistance from NI Application Engineers.

National Instruments corporate headquarters is located at 11500 North Mopac Expressway, Austin, Texas, 78759-3504. National Instruments also has offices located around the world to help address your support needs. For telephone support in the United States, create your service request at ni.com/support and follow the calling instructions or dial 512 795 8248. For telephone support outside the United States, visit the Worldwide Offices section of ni.com/niglobal to access the branch office Web sites, which provide up-to-date contact information, support phone numbers, email addresses, and current events.