
USER GUIDE AND SPECIFICATIONS

NI USB-6501
24-Channel, 32-Bit Counter Digital I/O Device

This user guide describes how to use the National Instruments USB-6501 
data acquisition (DAQ) device and lists the device specifications.

Introduction
The NI USB-6501 is a Full-Speed USB 2.0 device that provides 24 DIO 
channels and a 32-bit counter.

Figure 1.  NI USB-6501 Top View
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Figure 2.  NI USB-6501 Back View

Dimensions
Figure 3 illustrates the dimensions of the USB-6501 device.

Figure 3.  NI USB-6501 Device In Millimeters (Inches)

 

 

81.81 mm
(3.221 in.)

76.09 mm
(2.996 in.)

63.50 mm
(2.500 in.)

72.65 mm
(2.860 in.)

85.09 mm
(3.350 in.)

23.19 mm
(0.913 in.)

 NATIONAL 
INSTRUMENTS



© National Instruments Corporation 3 NI USB-6501 User Guide and Specifications 

Safety Guidelines

Caution Operate the NI USB-6501 only as described in these operating instructions.

The following section contains important safety information that you must 
follow when installing and using the NI USB-6501.

Do not operate the NI USB-6501 in a manner not specified in this 
document. Misuse of the device can result in a hazard. You can compromise 
the safety protection built into the device if the device is damaged in any 
way. If the device is damaged, contact National Instruments for repair.

Do not substitute parts or modify the device except as described in this 
document. Use the device only with the chassis, modules, accessories, and 
cables specified in the installation instructions. You must have all covers 
and filler panels installed during operation of the device.

Do not operate the device in an explosive atmosphere or where there may 
be flammable gases or fumes. If you must operate the device in such an 
environment, it must be in a suitably rated enclosure.

If you need to clean the device, use a dry cloth. Make sure that the device 
is completely dry and free from contaminants before returning it to service.

Operate the device only at or below Pollution Degree 2. Pollution is foreign 
matter in a solid, liquid, or gaseous state that can reduce dielectric strength 
or surface resistivity. The following is a description of pollution degrees:

• Pollution Degree 1 means no pollution or only dry, nonconductive 
pollution occurs. The pollution has no influence. 

• Pollution Degree 2 means that only nonconductive pollution occurs in 
most cases. Occasionally, however, a temporary conductivity caused 
by condensation must be expected. 

• Pollution Degree 3 means that conductive pollution occurs, or dry, 
nonconductive pollution occurs that becomes conductive due to 
condensation. 

You must insulate signal connections for the maximum voltage for which 
the device is rated. Do not exceed the maximum ratings for the device. Do 
not install wiring while the device is live with electrical signals. Do not 
remove or add connector blocks when power is connected to the system. 
Avoid contact between your body and the connector block signal when hot 
swapping modules. Remove power from signal lines before connecting 
them to or disconnecting them from the device.
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Operate the device at or below the Measurement Category I1. Measurement 
circuits are subjected to working voltages2 and transient stresses 
(overvoltage) from the circuit to which they are connected during 
measurement or test. Measurement categories establish standard impulse 
withstand voltage levels that commonly occur in electrical distribution 
systems. The following is a description of measurement categories:

• Measurement Category I is for measurements performed on circuits 
not directly connected to the electrical distribution system referred 
to as MAINS3 voltage. This category is for measurements of 
voltages from specially protected secondary circuits. Such voltage 
measurements include signal levels, special equipment, limited-energy 
parts of equipment, circuits powered by regulated low-voltage sources, 
and electronics. 

• Measurement Category II is for measurements performed on circuits 
directly connected to the electrical distribution system. This category 
refers to local-level electrical distribution, such as that provided by a 
standard wall outlet (for example, 115 V for U.S. or 230 V for Europe). 
Examples of Measurement Category II are measurements performed 
on household appliances, portable tools, and similar E Series devices. 

• Measurement Category III is for measurements performed in the 
building installation at the distribution level. This category refers to 
measurements on hard-wired equipment such as equipment in fixed 
installations, distribution boards, and circuit breakers. Other examples 
are wiring, including cables, bus-bars, junction boxes, switches, 
socket-outlets in the fixed installation, and stationary motors with 
permanent connections to fixed installations. 

• Measurement Category IV is for measurements performed at the 
primary electrical supply installation (<1,000 V). Examples include 
electricity meters and measurements on primary overcurrent 
protection devices and on ripple control units.

1   Measurement Category as defined in electrical safety standard IEC 61010-1. Measurement Category is also referred to as 
Installation Category.

2   Working Voltage is the highest rms value of an AC or DC voltage that can occur across any particular insulation.
3   MAINS is defined as a hazardous live electrical supply system that powers equipment. Suitably rated measuring circuits may 

be connected to the MAINS for measuring purposes.



© National Instruments Corporation 5 NI USB-6501 User Guide and Specifications 

Related Documentation
Each application software package and driver includes information about 
writing applications for taking measurements and controlling measurement 
devices. The following references to documents assume you have 
NI-DAQmx 8.7 or later, NI-DAQmx Base 3.x, and where applicable, 
version 7.1 or later of the NI application software.

NI-DAQmx for Windows
The DAQ Getting Started Guide describes how to install your NI-DAQmx 
for Windows software, how to install your NI-DAQmx-supported DAQ 
device, and how to confirm that your device is operating properly. Select 
Start»All Programs»National Instruments»NI-DAQ»DAQ Getting 
Started Guide.

The NI-DAQ Readme lists which devices are supported by this version 
of NI-DAQmx. Select Start»All Programs»National Instruments»
NI-DAQ»NI-DAQ Readme.

The NI-DAQmx Help contains general information about measurement 
concepts, key NI-DAQmx concepts, and common applications that 
are applicable to all programming environments. Select Start»
All Programs»National Instruments»NI-DAQ»NI-DAQmx Help.

Note For information about non-Windows operating system support, refer to ni.com/
info and enter BaseGSGML.

LabVIEW
If you are a new user, use the Getting Started with LabVIEW manual 
to familiarize yourself with the LabVIEW graphical programming 
environment and the basic LabVIEW features you use to build data 
acquisition and instrument control applications. Open the Getting Started 
with LabVIEW manual by selecting Start»All Programs»National 
Instruments»LabVIEW»LabVIEW Manuals or by navigating to the 
labview\manuals directory and opening LV_Getting_Started.pdf.

Use the LabVIEW Help, available by selecting Help»Search the 
LabVIEW Help in LabVIEW, to access information about LabVIEW 
programming concepts, step-by-step instructions for using LabVIEW, and 
reference information about LabVIEW VIs, functions, palettes, menus, and 
tools. Refer to the following locations on the Contents tab of the LabVIEW 
Help for information about NI-DAQmx:
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• Getting Started»Getting Started with DAQ—Includes overview 
information and a tutorial to learn how to take an NI-DAQmx 
measurement in LabVIEW using the DAQ Assistant.

• VI and Function Reference»Measurement I/O VIs and 
Functions—Describes the LabVIEW NI-DAQmx VIs and properties.

• Taking Measurements—Contains the conceptual and how-to 
information you need to acquire and analyze measurement data 
in LabVIEW, including common measurements, measurement 
fundamentals, NI-DAQmx key concepts, and device considerations.

LabWindows/CVI
The Data Acquisition book of the LabWindows/CVI Help contains 
measurement concepts for NI-DAQmx. This book also contains Taking 
an NI-DAQmx Measurement in LabWindows/CVI, which includes 
step-by-step instructions about creating a measurement task using the DAQ 
Assistant. In LabWindows™/CVI™, select Help»Contents, then select 
Using LabWindows/CVI»Data Acquisition.

The NI-DAQmx Library book of the LabWindows/CVI Help contains 
API overviews and function reference for NI-DAQmx. Select Library 
Reference»NI-DAQmx Library in the LabWindows/CVI Help.

Measurement Studio
If you program your NI-DAQmx-supported device in Measurement Studio 
using Visual C++, Visual C#, or Visual Basic .NET, you can interactively 
create channels and tasks by launching the DAQ Assistant from MAX or 
from within Visual Studio .NET. You can generate the configuration code 
based on your task or channel in Measurement Studio. Refer to the DAQ 
Assistant Help for additional information about generating code. You also 
can create channels and tasks, and write your own applications in your 
ADE using the NI-DAQmx API.

For help with NI-DAQmx methods and properties, refer to the NI-DAQmx 
.NET Class Library or the NI-DAQmx Visual C++ Class Library included 
in the NI Measurement Studio Help. For general help with programming 
in Measurement Studio, refer to the NI Measurement Studio Help, which 
is fully integrated with the Microsoft Visual Studio .NET help. To view 
this help file in Visual Studio. NET, select Measurement Studio»
NI Measurement Studio Help.
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To create an application in Visual C++, Visual C#, or Visual Basic .NET, 
follow these general steps:

1. In Visual Studio .NET, select File»New»Project to launch the New 
Project dialog box.

2. Find the Measurement Studio folder for the language you want to 
create a program in.

3. Choose a project type. You add DAQ tasks as a part of this step.

ANSI C without NI Application Software
The NI-DAQmx Help contains API overviews and general information 
about measurement concepts. Select Start»All Programs»National 
Instruments»NI-DAQ»NI-DAQmx Help.

The NI-DAQmx C Reference Help describes the NI-DAQmx Library 
functions, which you can use with National Instruments data acquisition 
devices to develop instrumentation, acquisition, and control applications. 
Select Start»All Programs»National Instruments»NI-DAQ»
NI-DAQmx C Reference Help.

.NET Languages without NI Application Software
With the Microsoft .NET Framework version 1.1 or later, you can use 
NI-DAQmx to create applications using Visual C# and Visual Basic 
.NET without Measurement Studio. You need Microsoft Visual Studio 
.NET 2003 or Microsoft Visual Studio 2005 for the API documentation 
to be installed.

The installed documentation contains the NI-DAQmx API overview, 
measurement tasks and concepts, and function reference. This help is 
fully integrated into the Visual Studio .NET documentation. To view the 
NI-DAQmx .NET documentation, go to Start»Programs»National 
Instruments»NI-DAQ»NI-DAQmx .NET Reference Help. Expand 
NI Measurement Studio Help»NI Measurement Studio .NET 
Class Library»Reference to view the function reference. Expand 
NI Measurement Studio Help»NI Measurement Studio .NET Class 
Library»Using the Measurement Studio .NET Class Libraries to view 
conceptual topics for using NI-DAQmx with Visual C# and Visual 
Basic .NET.

To get to the same help topics from within Visual Studio, go to Help»
Contents. Select Measurement Studio from the Filtered By drop-down 
list and follow the previous instructions.
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Device Documentation and Specifications
NI-DAQmx includes the Device Document Browser, which contains online 
documentation for supported DAQ and SCXI devices, such as documents 
describing device pinouts, features, and operation. You can find, view, 
and/or print the documents for each device using the Device Document 
Browser at any time by inserting the CD. After installing the Device 
Document Browser, device documents are accessible from Start»
All Programs»National Instruments»NI-DAQ»Browse Device 
Documentation.

Note You can also download these documents at ni.com/manuals.

NI-DAQmx Base (Linux/Mac OS X/LabVIEW PDA 8.x)
The NI-DAQmx Base Getting Started Guide describes how to install your 
NI-DAQmx Base software, your NI-DAQmx Base-supported DAQ device, 
and how to confirm that your device is operating properly. In Windows, 
select Start»All Programs»National Instruments»NI-DAQmx Base»
Documentation»Getting Started Guide.

Getting Started with NI-DAQmx Base for Linux and Mac Users describes 
how to install your NI-DAQmx Base software, your NI-DAQmx 
Base-supported DAQ device, and how to confirm that your device is 
operating properly on your Mac/Linux machine.

The NI-DAQmx Base Readme lists which devices are supported by this 
version of NI-DAQmx Base. In Windows, select Start»All Programs»
National Instruments»NI-DAQmx Base»DAQmx Base Readme.

The NI-DAQmx Base VI Reference Help contains VI reference and general 
information about measurement concepts. In LabVIEW, select Help»
NI-DAQmx Base VI Reference Help.

The NI-DAQmx Base C Reference Help contains C reference and general 
information about measurement concepts. In Windows, select Start»All 
Programs»National Instruments»NI-DAQmx Base»Documentation»
C Function Reference Help.

Note All NI-DAQmx Base documentation for Linux is installed at /usr/local/
natinst/nidaqmxbase/documentation.

Note All NI-DAQmx Base documentation for Mac OS X is installed at /Applications/
National Instruments/NI-DAQmx Base/documentation.
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Training Courses
If you need more help getting started developing an application with 
NI products, NI offers training courses. To enroll in a course or obtain 
a detailed course outline, refer to ni.com/training.

Technical Support on the Web
For additional support, refer to ni.com/support or zone.ni.com.

Installing the Software
Software support for the NI USB-6501 for Windows Vista/XP/2000 is 
provided by NI-DAQmx or NI-DAQmx Base depending on the software 
you are using. The DAQ Getting Started Guide, which you can download 
at ni.com/manuals, offers NI-DAQmx users step-by-step instructions 
for installing software and hardware, configuring channels and tasks, and 
getting started developing an application. 

Note For information about non-Windows operating system support, refer to ni.com/
info and enter BaseGSGML.

Installing Other Software
If you are using other software, refer to the installation instructions that 
accompany your software.

Example Programs
The NI-DAQmx CD contains example programs that you can use to get 
started programming with the NI USB-6501. Refer to the NI-DAQmx for 
USB Devices Getting Started Guide that shipped with your device, and 
is also accessible from Start»All Programs»National Instruments»
NI-DAQ, for more information.

The NI-DAQmx Base software ships with example programs you can use 
to get started programming with the NI USB-6501. Refer to the NI-DAQmx 
Base Getting Started Guide that shipped with your device, and is also 
accessible from Start»All Programs»National Instruments»
NI-DAQmx Base»Documentation, for more information.
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Installing the NI USB-6501 Device
Before installing the device, you must install the software you plan to use 
with the device. Refer to the Installing the Software section of this guide 
and the documentation included with the software for more information.

Figure 4 shows key functional components of the NI USB-6501.

Figure 4.  Device Block Diagram

Refer to the Safety Guidelines section of this document for important safety 
information.

Setting Up the NI USB-6501 Device
Complete the following steps to set up the NI USB-6501:

1. Install combicon screw terminal blocks by inserting them into the 
combicon jacks. 

Note The NI USB-6501 kit ships with signal name labels. You can apply the signal name 
labels to the screw terminal blocks for easy signal identification.

2. Refer to Table 2 and Figure 5 for label orientation and affix provided 
signal labels to the screw terminal blocks. Until the signal name labels 
are applied, you can insert the screw terminal blocks into either of the 
combicon jacks. Refer to Figure 5 for more information about signal 
name label orientation.
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Figure 5.  Signal Name Label Application Diagram

Note Once you label the screw terminal blocks, you must only insert them into the 
matching combicon jack, as indicated by the overlay label on the NI USB-6501 device.

3. Connect the wiring to the appropriate screw terminals.

Connecting the NI USB-6501 to a Computer
Plug one end of the USB cable into the NI USB-6501 and the other end into 
an available USB port on the computer.

LED Indicator
The NI USB-6501 device has a green LED next to the USB connector. The 
LED indicator indicates device status, as listed in Table 1. When the device 
is connected to a USB port, the LED blinks steadily to indicate that the 
device is initialized and is receiving power from the connection.

If the LED is not blinking, it may mean that the device is not initialized or 
the computer is in standby mode. In order for the device to be recognized, 
the device must be connected to a computer that has NI-DAQmx or 
NI-DAQmx Base installed on it. If your device is not blinking, make sure 
your computer has the latest version of NI-DAQmx or NI-DAQmx Base 
installed on it, and the computer is not in standby mode.

1 Overlay Label with Pin Orientation Guides
2 Combicon Jack

3 Screw Terminal Blocks
4 Signal Name Labels
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I/O Connector
The NI USB-6501 ships with two detachable terminal blocks for digital 
signals. The individual terminals accept 16 AWG to 28 AWG wire.

Table 2 lists the digital terminal assignments.

Table 1.  LED State/Device Status

LED State Device Status

Not lit Device not connected or in suspend.

On, not blinking Device connected.

Single-blink Operating normally.

Table 2.  Digital Terminal Assignments

Module Terminal Signal Module Terminal Signal

1 GND 17 P0.0

2 +5 V 18 P0.1

3 P1.7 19 P0.2

4 P1.6 20 P0.3

5 P1.5 21 P0.4

6 P1.4 22 P0.5

7 GND 23 P0.6

8 GND 24 P0.7

9 P2.7/PFI 0 25 GND

10 P2.6 26 GND

11 P2.5 27 P1.0

12 P2.4 28 P1.1

13 P2.3 29 P1.2

14 P2.2 30 P1.3

15 P2.1 31 +5 V

16 P2.0 32 GND

G
N

D
+5V

P1.7
P1.6

P1.5
P1.4

G
N

D
G

N
D

P2.7
P2.6

P2.5
P2.4

P2.3
P2.2

P2.1
P2.0

G
N

D
+5

V
P1

.3
P1

.2
P1

.1
P1

.0
G

N
D

G
N

D
P0

.7
P0

.6
P0

.5
P0

.4
P0

.3
P0

.2
P0

.1
P0

.0



© National Instruments Corporation 13 NI USB-6501 User Guide and Specifications 

Signal Descriptions
Table 3 describes the signals available on the I/O connectors.

Digital I/O
The NI USB-6501 has 24 single-ended digital lines, P0.<0..7>, P1.<0..7>, 
and P2.<0..7>, which comprise the three DIO ports. P2.7/PFI 0 can also 
function as a 32-bit counter. Refer to the Event Counter section for more 
information about the counter.

Static DIO
Each of the NI USB-6501 DIO lines can be individually programmed as a 
static DI or DO line. You can use static DIO lines to monitor or control 
digital signals. All samples of static DI lines and updates of DO lines are 
software-timed.

Table 3.  Signal Descriptions

Signal Name Direction Description

P0.<0..7>
P1.<0..7>
P2.<0..6>

Input or 
Output

Digital I/O Signals—You can individually configure each signal 
as an input or output.

P2.7/PFI 0 Input or 
Output

This pin is configurable as either a digital line or an event counter.

Digital I/O Signal—As a digital line, this signal can be used as 
an input or output.

CTR—As a counter, this signal can be used as an event counter 
input source. 

+5 V Output +5 V—The voltage source provided by the USB host. The voltage 
is nominally 5 V, but varies from system to system.

GND — Ground—The reference for the digital signals and the +5 VDC 
supply.
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Digital Output Information

Note This manual revision updates naming conventions to reflect the conventions used 
in NI-DAQmx. Table 4 notes the correlation between the hardware functionality and the 
NI-DAQmx terminology.

The default configuration of the NI USB-6501 DIO ports is open collector, 
allowing 5 V operation, with an onboard 4.7 kΩ pull-up resistor. An 
external, user-provided pull-up resistor can be added to increase the source 
current drive up to a 8.5 mA limit per line, as shown in Figure 6. 

Figure 6.  Example of Connecting External User-Provided Resistor

Complete the following steps to determine the value of the user-provided 
pull-up resistor:

1. Place an ammeter in series with the load.

2. Place a variable resistor between the digital output line and the +5 V.

3. Adjust the variable resistor until the ammeter current reads as the 
intended current. The intended current must be less than 8.5 mA.

Table 4.  Digital Output Driver Type Naming Conventions

Hardware Functionality NI-DAQmx Terminology

Open-drain Open collector

Push-pull Active drive

GND

P0.0

+5 V

RpRe

Rl

VBus

4.7 KΩ Onboard Resistor

Load

A

Short Circuit Protection
Current Limiting Circuit

NI USB-6501 DIO Device

Port Pad

External
Pull-Up
Resistor
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4. Remove the ammeter and variable resistor from your circuit.

5. Measure the resistance of the variable resistor. The measured 
resistance is the ideal value of the pull-up resistor.

6. Select a static resistor value for your pull-up resistor that is greater than 
or equal to the ideal resistance.

7. Re-connect the load circuit and the pull-up resistor.

Additionally, you can configure the NI USB-6501 DIO ports as active 
drive. When configured as active drive, the total current sourced by all 
DO lines simultaneously should not exceed 65 mA.

Digital I/O Circuitry
Figure 7 shows P0.<0..7> connected to example signals configured 
as digital inputs and digital outputs. You can configure P1.<0..7> and 
P2.<0..7> similarly. Refer to Figure 7 for some common examples 
of connections of DIO lines with standard circuits.

Figure 7.  Example of Connecting a Load

Caution Exceeding the maximum input voltage ratings or maximum output ratings, which 
are listed in the Specifications section, can damage the DAQ device and the computer. 
National Instruments is not liable for any damage resulting from such signal connections.

1 P0.0 configured as an open collector digital output driving a LED
2 P0.2 configured as a active drive digital output driving a LED
3 P0.4 configured as a digital input receiving a TTL signal from a gated invertor
4 P0.7 configured as a digital input receiving a 0 V or 5 V signal from a switch
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I/O Connector
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P0.7
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I/O Protection
Each DIO signal is protected against overvoltage, undervoltage, and 
overcurrent conditions, as well as ESD events. However, you should avoid 
these fault conditions by using the following guidelines:

• If you configure a DIO line as an output, do not connect it to any 
external signal source, ground signal, or power supply.

• If you configure a DIO line as an output, understand the current 
requirements of the load connected to these signals. Do not exceed 
the specified current output limits of the DAQ device. 

• If you configure a DIO line as an input, do not drive the line with 
voltages outside of its normal operating range.

• Treat the DAQ device as you would treat any static sensitive device. 
Always properly ground yourself and the equipment when handling 
the DAQ device or connecting to it.

Power-On States
At system startup and reset, the hardware sets all DIO lines to 
high-impedance inputs. The DAQ device does not drive the signal 
high or low. Each line has a weak pull-up resistor connected to it.

Event Counter
You can configure P2.7 as the source for a 32-bit counter. In this mode, the 
device counts high to low transitions on P2.7. The counter can be armed 
and disarmed and the count can be read or reset through software. Refer 
to your software documentation for more information about counter 
programming techniques.

+5 V Power Source
The NI USB-6501 supplies a nominal 5 V from two pins, one on each screw 
terminal block. The voltage source is provided by the USB host. The 
voltage is nominally 5 V, but varies from system to system. Refer to 
the Specifications section for more information about USB bus power 
specifications. This source can be used to power external components. 

Note While the device is in USB suspend, the output is disabled.

Caution When using the 5 V source, understand the current requirements of the load 
connected. Do not exceed the specified current output limits of the USB Vbus.
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Specifications
The following specifications are typical at 25 °C, unless otherwise noted. 
All voltages are relative to COM unless otherwise noted.

Digital I/O
Number of lines

P0.<0..7>......................................... 8

P1.<0..7>......................................... 8

P2.<0..7>......................................... 8

Direction control .................................... Input or output, 
software-selectable

Output driver type .................................. Active drive (push-pull) or 
open collector (open-drain), 
software selectable

Pull-up resistor ....................................... 4.7 kΩ VBus (nominally 5 V)

Absolute voltage range........................... –0.5 to 5.8 V with respect to GND

Power-on state........................................ Input (high impedance)

Digital logic levels

Level Min Max Units

Input
Input low voltage
Input high voltage
Input leakage current

–0.3
2.0
—

0.8
5.8
50.0

V
V

μA

Output
Output low voltage

Open collector (open-drain) or active drive (push-pull)
IOL = 2 mA
IOL = 8.5 mA

Output high voltage 
Active drive (push-pull1)

IOH = –2 mA
IOH = –8.5 mA

Open collector (open-drain), IOH = –0.4 mA, nominal
Open collector (open-drain), IOH = –7.5 mA, with
 external pull-up resistor

—
—

2.8
2.0
2.0

2.0

0.4
0.8

3.6
3.5
5.0

—

V
V

V
V
V

V

1 The total current sourced by all DO lines simultaneously should not exceed 65 mA.
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Counter
Number of counters ................................1 (P2.7 can be configured 

as a counter)

Resolution ...............................................32 bits

Counter measurements ...........................Falling edge counting

Maximum input frequency .....................5 MHz

Minimum high pulse width.....................100 ns

Minimum low pulse width......................100 ns

Bus Interface
USB specification ...................................USB 2.0 Full-Speed (12 Mb/s)

External Voltage
+5 V output

Voltage ............................................4.00 V min, 5.25 V max

Current.............................................230 mA max

Power Requirements
USB

Input voltage....................................4.50 to 5.25 VDC, 
in configured state

Active current ..................................80 mA typical, 500 mA max

Suspend current ...............................500 μA max, all DIO lines 
disconnected

Physical Characteristics
Dimensions 

Without connectors..........................6.35 cm × 8.51 cm × 2.31 cm
(2.50 in. × 3.35 in. × 0.91 in.)

With connectors...............................8.18 cm × 8.51 cm × 2.31 cm
(3.22 in. × 3.35 in. × 0.91 in.)

I/O connectors.........................................USB series B receptacle, 
(2) 16 position (screw terminal) 
plug headers



© National Instruments Corporation 19 NI USB-6501 User Guide and Specifications 

Screw-terminal wiring............................ 16 to 28 AWG copper conductor 
wire with 10 mm (0.39 in.) of 
insulation stripped from the end

Torque for screw terminals .................... 0.22–0.25 N · m 
(2.0–2.2 lb · in.)

Weight .................................................... 84 g (3 oz)

Safety
If you need to clean the module, wipe it with a dry towel.

Safety Voltages
Overvoltage Protection
Connect only voltages that are within these limits.

Channel-to-COM (one channel)............. ±30 V max, 
Measurement Category I

Channels-to-COM 
(one port, all channels)........................... ±8.9 V max, 

Measurement Category I

Measurement Category I is for measurements performed on circuits not 
directly connected to the electrical distribution system referred to as 
MAINS voltage. MAINS is a hazardous live electrical supply system that 
powers equipment. This category is for measurements of voltages from 
specially protected secondary circuits. Such voltage measurements include 
signal levels, special equipment, limited-energy parts of equipment, 
circuits powered by regulated low-voltage sources, and electronics.

Caution Do not use this module for connection to signals or for measurements within 
Measurement Categories II, III, or IV.

Safety Standards
The NI USB-6501 is designed to meet the requirements of the following 
standards of safety for electrical equipment for measurement, control, 
and laboratory use:

• IEC 61010-1, EN 61010-1

• UL 61010-1, CSA 61010-1
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Note For UL and other safety certifications, refer to the product label or visit ni.com/
certification, search by model number or product line, and click the appropriate link 
in the Certification column.

Hazardous Locations
The NI USB-6501 is not certified for use in hazardous locations.

Environmental
The NI USB-6501 device is intended for indoor use only.

Operating temperature 
(IEC 60068-2-1 and IEC 60068-2-2)......0 to 55 °C 

Operating humidity 
(IEC 60068-2-56) ...................................5 to 95% RH, noncondensing

Maximum altitude...................................2,000 m (at 25 °C ambient 
temperature)

Storage temperature 
(IEC 60068-2-1 and IEC 60068-2-2)......–40 to 85 °C

Storage humidity
(IEC 60068-2-56) ...................................5 to 90% RH, noncondensing 

Pollution Degree (IEC 60664) ................2

Electromagnetic Compatibility
This product is designed to meet the requirements of the following 
standards of EMC for electrical equipment for measurement, control, 
and laboratory use:

• EN 61326 EMC requirements; Minimum Immunity

• EN 55011 Emissions; Group 1, Class A

• CE, C-Tick, ICES, and FCC Part 15 Emissions; Class A

Note For EMC compliance, operate this device with double-shielded cables.
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CE Compliance
This product meets the essential requirements of applicable European 
Directives, as amended for CE marking, as follows:

• 2006/95/EC; Low-Voltage Directive (safety)

• 2004/108/EC; Electromagnetic Compatibility Directive (EMC)

Note Refer to the Declaration of Conformity (DoC) for this product for any additional 
regulatory compliance information. To obtain the DoC for this product, visit ni.com/
certification, search by module number or product line, and click the appropriate link 
in the Certification column.

Environmental Management
National Instruments is committed to designing and manufacturing 
products in an environmentally responsible manner. NI recognizes that 
eliminating certain hazardous substances from our products is beneficial 
not only to the environment but also to NI customers.

For additional environmental information, refer to the NI and the 
Environment Web page at ni.com/environment. This page contains 
the environmental regulations and directives with which NI complies, as 
well as other environmental information not included in this document.

Waste Electrical and Electronic Equipment (WEEE)
EU Customers At the end of their life cycle, all products must be sent to a WEEE recycling 
center. For more information about WEEE recycling centers and National Instruments 
WEEE initiatives, visit ni.com/environment/weee.htm.

RoHS
National Instruments  (RoHS)

National Instruments RoHS ni.com/environment/rohs_china
(For information about China RoHS compliance, go to ni.com/environment/rohs_china.)
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appropriate location: Help»Patents in your software, the patents.txt file on your CD, or 
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Where to Go for Support
The National Instruments Web site is your complete resource for technical 
support. At ni.com/support you have access to everything from 
troubleshooting and application development self-help resources to email 
and phone assistance from NI Application Engineers.

National Instruments corporate headquarters is located at 
11500 North Mopac Expressway, Austin, Texas, 78759-3504. 
National Instruments also has offices located around the world to help 
address your support needs. For telephone support in the United States, 
create your service request at ni.com/support and follow the calling 
instructions or dial 512 795 8248. For telephone support outside the United 
States, contact your local branch office: 

Australia 1800 300 800, Austria 43 662 457990-0, 
Belgium 32 (0) 2 757 0020, Brazil 55 11 3262 3599, 
Canada 800 433 3488, China 86 21 5050 9800, 
Czech Republic 420 224 235 774, Denmark 45 45 76 26 00, 
Finland 358 (0) 9 725 72511, France 01 57 66 24 24, 
Germany 49 89 7413130, India 91 80 41190000, Israel 972 3 6393737, 
Italy 39 02 41309277, Japan 0120-527196, Korea 82 02 3451 3400, 
Lebanon 961 (0) 1 33 28 28, Malaysia 1800 887710, 
Mexico 01 800 010 0793, Netherlands 31 (0) 348 433 466, 
New Zealand 0800 553 322, Norway 47 (0) 66 90 76 60, 
Poland 48 22 3390150, Portugal 351 210 311 210, Russia 7 495 783 6851, 
Singapore 1800 226 5886, Slovenia 386 3 425 42 00, 
South Africa 27 0 11 805 8197, Spain 34 91 640 0085, 
Sweden 46 (0) 8 587 895 00, Switzerland 41 56 2005151, 
Taiwan 886 02 2377 2222, Thailand 662 278 6777, 
Turkey 90 212 279 3031, United Kingdom 44 (0) 1635 523545
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