
RELEASE NOTES

Lookout  Release Notes
Version 6.0

Welcome to Lookout 6.0, the National Instruments human machine 
interface (HMI) and supervisory control and data acquisition (SCADA) 
software system. This document describes installation, new features, and 
known issues. 

For detailed information on the new features in Lookout 6.0, consult your 
online and printed documentation. For the latest information not included 
in this document, refer to the readme.txt file on your Lookout CD.

Contents
System Requirements.............................................................................. 3
Installation............................................................................................... 4

Installing onto Computers with Existing Versions of Lookout ....... 5
Installing .......................................................................................... 5
Activating Lookout .......................................................................... 5
Uninstalling Lookout ....................................................................... 5

Activation Instructions............................................................................ 6
Activate Lookout Software .............................................................. 6
Activate Client Connection.............................................................. 6

What’s New in Lookout 6.0 .................................................................... 7
NI License Manager Activation....................................................... 7
New Toolbox ................................................................................... 7
New Object Explorer Icons.............................................................. 7
Diagnostics Menu Option Added for Ethernet Objects ................... 8
New AB_SLC500 SLC 5/05 Support .............................................. 8
Changes to Lookout Objects............................................................ 8

New S7_HMI Data Members ................................................... 8
New TextEntry Data Member .................................................. 8
New ModbusSlave Parameters ................................................. 8
New ModbusSlave Ethernet Support ....................................... 8
New Loader Data Member and Parameter ............................... 8
New HyperTrend Data Members ............................................. 8

™



Lookout Release Notes 2 ni.com

New Hitachi Object Data Member Ranges ...............................8
New CitadelControl Remote Archiving....................................8
ActiveX Object Subproperties ..................................................9

New Menu Items ..............................................................................9
File»Export Process Data Members..........................................9
File»Change Password ..............................................................9
View»Show Toolbox.................................................................9
Help»Patents..............................................................................9

New Online Help Format .................................................................9
New Getting Started Video ..............................................................9
Citadel 5 Database............................................................................9

Database Names ........................................................................10
Compatibility with Older Versions of Citadel ..........................10
Expanded Access to Citadel 5 Data ..........................................10
Citadel 5 Tables.........................................................................10
Storage and Security for Alarms and Events ............................10

New Version of Historical Data Viewer ..........................................11
Changes to NI Services ....................................................................12
New System Options Items ..............................................................12
New RenameTrace Object................................................................12
Datalogging Lifespan and Resolution ..............................................12
Limits on Lookout Instances ............................................................12

Compatibility and Conversion Issues ......................................................12
Converting Databases to Citadel 5 Format.......................................12
Opening Older Process Files in Lookout 6.0....................................13

Lookout 3.8 and Lookout 6.0 Compatibility.............................13
Converting Lookout 3.8 Processes to Lookout 6.0 ...................14

Importing Old Security Files into Lookout 6.0 ................................16
Known Issues...........................................................................................17

Pushbutton Behavior with Lookout WebBrowser............................17
Cannot Change Position of Minimized Panel ..................................17
ActiveX Pipe Control Appearance Changes ....................................17
Tiway.cbx Does Not Limit Request Length to 70 Bytes

for FACTS 405 Network ...............................................................17
Listbox ActiveX Object Does Not Work in String

Compares with =............................................................................17
Loading New Recipe Prevents State File Save ................................18
Second DataTable Connected via DDE Does Not Shrink................18
Pager Message Does Not Work if # Required by Numeric

Pager Service .................................................................................18
Moving Window Over Custom .wmf Graphic Distorts Image ........18
Displays that are Outside the Screen Area .......................................18
Lookout Control Sources and Refresh Value Operations ................18
Connection Browser Open with No Processes Visible ....................19
Missing Aggregate Definitions.........................................................20
Administrator Access Needed to Download Lookout Player...........20



© National Instruments Corporation 3 Lookout Release Notes

Pot Connected to an FP-2010 Can Fluctuate ................................... 20
ToshibaTSeries Sets PLC Values to 0 ............................................. 20
Web Clients and the Sequencer Object............................................ 20
Pulse Object Erratic Behavior.......................................................... 20
Including Custom Graphics when You Deploy ............................... 21
Expression Displays that Automatically Resize .............................. 21
Web Client Alert Has Incorrect Slashes in URL ............................. 21
Aggregate Problems with Incorrect Computer Name...................... 21
Using the ! and NOT Expression Functions .................................... 21
Tooltips Show up Only when Toolbox is Active Window.............. 21
Ethernet Drivers Not Retry .............................................................. 22
Report Object with Black Bitmap File ............................................ 22
Connection Browser Items Not Sorted ............................................ 22
Connecting Device to LPT Port Hangs Lookout ............................. 22
Circular Reference For Remote Connection with

Inaccurate Alarm........................................................................... 22
NI Keyboard Driver Filter Conflicts with Computer Standby ........ 22
Drivers Do Not Support Time/Quality ............................................ 22

Bug Fixes ................................................................................................ 23
More Information and Updates ............................................................... 24

System Requirements
Lookout requires the following:

• Pentium class or equivalent PC running at 266 MHz or faster

• At least 128 MB RAM

• 200 MB free disk space, plus possibly 100 MB or more, depending 
on how much historical data you intend to log to the Citadel storage 
system; you should also have about 50 MB of disk space for file 
swapping on Windows 2000/NT/XP computers

• Windows 2000/NT 4.0 or later/XP. Lookout requires that 
Windows NT include service pack 6a and the 6a Security Rollup 
Package, which are part of the July 26, 2001 security update available 
at www.windowsupdate.com. Lookout does not support 
Windows Me/9x.

• Internet Explorer 5 or later

• Monitor display setting of at least 800 × 600 pixels

• Network card and TCP/IP networking installed on the computers 
you want to connect, if you intend to take advantage of Lookout 
networking

http://www.windowsupdate.com
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Note Performance of Lookout depends on the number, size, and complexity of processes 
you are running. While the minimum requirements are fine for some processes, you should 
plan on using more powerful computer configurations for complex and data intensive 
applications.

• You must be properly set up on a network with TCP/IP protocols 
installed if you want to use the networking capabilities of Lookout. 
You must be able to ping any computer on your network that you 
intend to have as a part of your Lookout network. To test this, access 
a command prompt and enter the following command:

Ping compname

where compname is the name of the computer you want to ping.

If TCP/IP is functioning properly on your computer, you should 
receive a response that looks something like the following example:

Pinging compname [123.45.67.89] with 32 bytes of 
data:

Reply from 123.45.67.89: bytes=32 time<10ms TTL=128

Reply from 123.45.67.89: bytes=32 time<10ms TTL=128

Reply from 123.45.67.89: bytes=32 time<10ms TTL=128

Reply from 123.45.67.89: bytes=32 time<10ms TTL=128

If TCP/IP is not working properly on your computer, consult your system 
administrator. Refer to the Lookout Developer’s Manual for more 
information on networking and network configuration with Lookout.

Tip If your computer does not have a command prompt available in the Windows Start 
menu or in Start»Programs, select Start»Run and enter cmd.exe in the Run dialog box. 
This opens a command prompt you can use for the ping command.

Installation
Installing Lookout is more than just copying files to your computer. 
You must register Lookout for long-term use of your I/O points, and for 
instances of Lookout that are intended to run server processes, you also 
must register to activate your client connections. There are also a number 
of Lookout system configuration options you should set when you install. 
If you plan on networking with Lookout, you also should test to make sure 
TCP/IP is present and running on all the computers you intend to use.
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Installing onto Computers with Existing Versions of Lookout
• (Lookout 3.8 or earlier) Avoid installing Lookout 6.0 over Lookout 3.8 

or earlier. Either uninstall Lookout 3.8, or put Lookout 6.0 in a new 
directory. You can then move or copy Lookout 3.8 process files 
to the Lookout 6.0 directory. 

• (Lookout 4.0 or later) To get the maximum stability, National 
Instruments recommends that you install Lookout 6.0 on a clean 
computer without previous versions installed. If you really want to 
have Lookout 6.0 and the previous versions on the same computer, 
National Instruments strongly recommends that you not run them at 
the same time. 

Installing
Complete the following steps to install Lookout:

1. Run the Lookout setup.exe. If you are installing from a Lookout 
CD, insert the CD in your CD-ROM drive. If your computer has the 
AutoPlay feature enabled, the installation begins automatically. If your 
system does not use AutoPlay, run x:\Lookout\setup.exe where 
x is the letter of your CD-ROM drive.

2. Follow the onscreen instructions. 

3. Reboot your computer. 

Activating Lookout
If this is the first installation of Lookout on the computer you are using, 
or if you have any lost or corrupted your activation, you are prompted to 
activate Lookout the first time you launch it. Until you activate it, Lookout 
is limited to 50 I/O points and one client connection, and it only runs for 
30 days.

When you activate Lookout, you unlock it for permanent use at your 
appropriate I/O count. If you do not activate Lookout by the end of the 
30-day period, it lapses to a demo system. Refer to Chapter 1, Introduction 
to Lookout, of the Lookout Developer’s Manual for more information about 
activating Lookout.

Uninstalling Lookout
To uninstall Lookout, select Start»Settings»Control Panel»
Add/Remove Programs. Select National Instruments Software and 
choose to remove NI Lookout 6.0.
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Activation Instructions

Activate Lookout Software
Complete the following steps to activate Lookout software:

1. Launch the Lookout software.

2. The Lookout – Unlicensed Version message box opens when you 
launch Lookout for the first time. Click Activate Lookout, which 
launches the NI Activation Wizard. 

You also can run an evaluation version of Lookout. The evaluation 
version of Lookout is limited to 50 I/O points and one client 
connection, and it only runs for 30 days. If you do not activate Lookout 
by the end of the 30-day period, it lapses to a demo system.

3. In the NI Activation Wizard, select a method to acquire the activation 
code and click Next:

• Automatically activate through a secure Internet 
connection—Automatically receive an activation code.

• Use a Web browser, email client, telephone, or fax machine to 
acquire an activation code—Contact National Instruments to 
obtain an activation code. You will then enter the code in the 
NI Activation Wizard to activate Lookout software.

• Apply a 20-character activation code previously acquired for this 
computer—Enter a code you have obtained to activate Lookout 
software.

4. Enter or verify your serial number. Click Next.

5. Follow the instructions on the screen to complete the activation.

6. For all options other than Auto, you must run the NI License Wizard 
again and select Apply a 20-character activation code previously 
acquired for this computer. Enter the activation code you obtained 
from National Instruments.

7. When you successfully activate Lookout, click Finish.

Activate Client Connection
Complete the following steps to activate client connection for Lookout.

1. Launch the Lookout software.

2. Select Options»System from the menu, and click the Activate Client 
Connection button, which launches the NI Activation Wizard.
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3. In the NI Activation Wizard, select a method to acquire the activation 
code and click Next:

• Automatically activate through a secure Internet 
connection—Automatically receive an activation code.

• Use a Web browser, email client, telephone, or fax machine to 
acquire an activation code—Contact National Instruments to 
obtain an activation code. You will then enter the code in the 
NI Activation Wizard to activate client connection.

• Apply a 20-character activation code previously acquired for this 
computer—Enter a code you have obtained to activate client 
connection.

4. Enter or verify your serial number. Click Next.

5. Follow the instructions on the screen to complete the activation.

6. For all options other than Auto, you must run the NI License Wizard 
again and select Apply a 20-character activation code previously 
acquired for this computer. Enter the activation code you obtained 
from National Instruments.

7. When you successfully activate Lookout Client Connection, click 
Finish.

What’s New in Lookout 6.0
The following additions and changes are included in Lookout 6.0.

NI License Manager Activation
Previous versions of Lookout required registration, keycodes, and in some 
cases, hardware keys. Instead of these mechanisms, Lookout 6.0 uses the 
NI License Manager to activate Lookout with the appropriate I/O count and 
client connections. For more information about activation and licensing, 
refer to the Activate Lookout topic in the Lookout Help. 

New Toolbox
The new floating toolbox in Lookout gives you quick access to some of the 
most common menu commands and objects. 

New Object Explorer Icons
New distinctive icons help you identify different objects in the Object 
Explorer and anywhere the Lookout object navigation tree appears.



Lookout Release Notes 8 ni.com

Diagnostics Menu Option Added for Ethernet Objects
When you create a driver object that communicates via Ethernet, an 
Options»Object Ethernet Options menu item appears so that you can 
choose to generate a diagnostic file.

New AB_SLC500 SLC 5/05 Support
The AB_SLC500 driver object now supports the SLC 5/05 port through 
either a serial or Ethernet connection.

Changes to Lookout Objects

New S7_HMI Data Members
MD0F - MD65532F and DB0.DBD0F - DB65535.DBD65532F 

New TextEntry Data Member
enterValue

New ModbusSlave Parameters
Identifier, Mode

New ModbusSlave Ethernet Support
The ModbusSlave object now supports Modbus Ethernet mode. You can 
use ModbusSlave object to simulate a Modbus Ethernet or Modbus Serial 
device.

New Loader Data Member and Parameter
DatabaseLifespan, DatabaseName

New HyperTrend Data Members
Start, StartTime, CursorPos

New Hitachi Object Data Member Ranges
L0 - L3FFF changed to L0 - L13FFF
WL0 - WL3FF changed to WL0 - WL13FF
DL0 - DL3FE changed to DL0 - DL13FE

New CitadelControl Remote Archiving
In Lookout 6.0, you now can archive data remotely with the CitadelControl 
object.  You cannot do that in Lookout 5.1 or earlier.
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ActiveX Object Subproperties
In Lookout 6.0, ActiveX object now supports both to-level properties and 
subproperties. Subproperties are shown in hierarchical folders.

New Menu Items

File»Export Process Data Members
Edit mode only. This command exports all data members used in a process 
to a CSV file. 

File»Change Password
This command allows you to change the password for the current account. 

View»Show Toolbox
Edit mode only. This command displays or hides the floating toolbox.

Help»Patents
This command displays National Instruments Patents information.

New Online Help Format
The Lookout Help is now in compiled HTML (.chm) format rather than 
WinHelp (.hlp) format.

New Getting Started Video
Lookout 6 includes a new Getting Started Video on the installation CD. 
The video provides a short introduction to the Lookout environment and 
development concepts. You can launch the video from the Lookout 
Autorun utility. The video file, lookout.wmv, is available under the root 
directory of the Lookout CD. To play the video, you may need to download 
the latest Windows Media Player from www.microsoft.com.

Citadel 5 Database
Lookout 6.0 includes Citadel 5, a new version of the Citadel historical 
database. Citadel 5 introduces data access from ActiveX Data Objects 
(ADO) clients and improved Open Database Connectivity (ODBC) 
support.
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Database Names
Citadel 4.x identified databases exclusively by their path. Citadel 5 uses 
database names. Because of the new Citadel 5 format, some Lookout 
dialog boxes have been revised, the ODBC data source setup has changed, 
and the Historical Data Viewer has been updated.

Compatibility with Older Versions of Citadel
Lookout 6.0 logs to and retrieve from Citadel 5 databases only. You must 
convert Citadel 3.8 or 4.x databases to Citadel 5 if you want to use them 
with the current version of Lookout. Refer to the Converting Databases to 
Citadel 5 Format section for information about converting existing 
databases.

Expanded Access to Citadel 5 Data
The Citadel 5 ODBC driver is compliant with SQL 92 and ODBC 2.5 
standards. All clients that follow these standards can retrieve data from a 
Citadel 5 database. ADO clients can access the Citadel 5 database using the 
ODBC driver through the Microsoft OLE DB Provider for ODBC Drivers. 
You can use a Microsoft Query Wizard to build queries.

Citadel 5 Tables
Citadel 5 tables are different than Citadel 4.x tables. For more information 
about Citadel 5 tables, refer to the Structured Query Language appendix of 
the Lookout Developer’s Manual.

Storage and Security for Alarms and Events
Citadel 5 uses Microsoft SQL Server or MSDE 2000 (Microsoft SQL 
Server Desktop Engine 2000) to store alarms and events. MSDE 2000 
is a light version of Microsoft SQL Server. The major restriction of 
MSDE 2000 is that the size of one database is limited to 2 GB, so you must 
upgrade to the full version of SQL Server 2000 if an application exceeds 
this 2 GB limit. 

To connect to and access a remote SQL Server database, local and network 
clients can use one of two security modes: Windows Authentication Mode 
or Mixed Mode. Windows Authentication Mode security uses the built-in 
Windows security system and takes advantage of Windows NT domains. 
All clients that need to access SQL Server remotely must be properly 
configured on the same domain to access data stored on remote SQL Server 
computers. Clients must connect through the Windows security system on 
the server. 
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Mixed Mode security allows clients to connect to a server using either 
Windows Authentication or SQL Server Authentication. With SQL Server 
Authentication, all user accounts are stored within the SQL Server, and 
clients do not need to go through the built-in Windows NT security system. 
Mixed Mode security is simple to set up because clients need not be on the 
same domain. They only need to have the correct user name and password 
to access the SQL Server. However, SQL Server Authentication is more 
vulnerable than Windows Authentication Mode. 

Citadel 5 uses SQL Server Authentication by default, so network clients do 
not need to be explicitly configured. The installer enables Mixed Mode 
security on existing SQL Servers or installs MSDE 2000 with Mixed Mode 
security if the target computer does not have SQL Server installed. 

The default password for the SQL Server administrator sa is left blank. 
NI recommends that you assign a strong password to the sa user. Use the 
following command line utility to set the SQL Server administrator 
password: 

osql -U"sa" -P"" -Q"sp_password NULL, 'new_password', 'sa'"

Use the following command to change an existing password:

osql -U"sa" -P"old_password" -Q"sp_password 'old_password', 

'new_password', 'sa'"

If Mixed Mode security is not acceptable, change both the SQL Server 
and Citadel login modes by setting the registry DWORD values 
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer\MSSQL

Server\LoginMode and HKEY_LOCAL_MACHINE\SOFTWARE\
National Instruments\Citadel\5.0\IntegratedSecurity to 1. 
This forces the use of Windows Authentication mode.

NI recommends changing the login mode immediately after installing 
Lookout. If you change the login mode after you have logged data, you 
must reattach all existing Citadel databases. Restart the SQL Server and 
Citadel services to implement the changes. If you use Windows 
Authentication Mode, remember that you might need to explicitly 
configure the server computer and all clients.

New Version of Historical Data Viewer
With the Historical Data Viewer that comes with Lookout 6.0, you can 
view both Citadel 4.x and Citadel 5 databases in Measurement & 
Automation Explorer (MAX). You also can convert Citadel 4.x databases 
to Citadel 5 format. 
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Changes to NI Services
Lookout 6.0 introduces a new version of the Citadel service, which 
appears as National Instruments Citadel in Windows Services and 
nicitdl5.exe in the Task Manager. To start and stop this or other 
NI services, use Windows Services available in the Control Panel.

New System Options Items
User cannot open or close processes: This option prevents an 
unauthorized operator from opening or closing processes.

Always show Object Explorer in edit mode: Select this checkbox if you 
want to always show Object Explorer when you switch Lookout from run 
mode to edit mode. 

New RenameTrace Object
Use the new RenameTrace object to rename the computer names, paths to 
a process, folders, or traces in a Citadel database. For more information 
about the RenameTrace object, refer to the Lookout Help.

Datalogging Lifespan and Resolution
The lifespan of data logged to Citadel 5 is now set per-process instead of 
per-data member. All traces in a process have the same lifespan setting of 
the process. You are not able to specify lifespan for the Data Member 
Configuration or the Logger object.

For numeric data members, you can choose an appropriate Resolution in 
the Data Member Configuration dialog. This sets the level of precision for 
the logged data.

Limits on Lookout Instances
In Lookout 5.1 or earlier, you can launch unlimited instances of Lookout.  
However, in Lookout 6.0, due to some limitations with Citadel 5, you can 
launch only one instance of Lookout on one computer.

Compatibility and Conversion Issues

Converting Databases to Citadel 5 Format
To log new data to an existing database, do not log data until you convert 
the database to Citadel 5. If you log data from a converted application 
before converting the database, Lookout creates a new, empty Citadel 5 
database in the same location as the older Citadel database and logs data to 
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that new database. To get all the logged data back into one database after 
that happens, you must use the Historical Data Viewer to convert the older 
Citadel database and then merge it with the new Citadel 5 database.

In Historical Data Viewer, right-click the Historical Data category, select 
Create New from the shortcut menu, and choose the appropriate 
conversion in the dialog box that appears. If you cannot locate the database 
you want to convert, you might need to create a Citadel 4.x version of it in 
Historical Data Viewer before choosing to convert it to Citadel 5.

You cannot convert a database remotely. You must convert it on the 
computer where it exists.

Opening Older Process Files in Lookout 6.0
(Lookout 4.0, 4.5, and 5.x) To open Lookout 4.0, 4.5, and 5.x processes in 
Lookout 6.0, open the .lks file instead of the .l4p file when you load a 
process. As soon as the process opens, save it to update the .l4p file.

(Lookout 3.8) If you are upgrading from Lookout 3.8, open the .lks file in 
Lookout 6.0, then save the process to create a new .l4p file. Some minor 
adjustments might have to be made in some processes, and you will have 
to change redundancy using backup computers. Refer to the following 
sections for more information about compatibility and conversion issues 
when upgrading from Lookout 3.8.

Lookout 3.8 and Lookout 6.0 Compatibility
The following list contains known compatibility issues and fixes for 
Lookout 6.0 that might affect Lookout 3.8 users who are upgrading. 

• Lookout 6.0 does not run on Windows NT version 3.51 or earlier. 
You must be using Windows NT 4.0 or later.

• Earlier versions of Lookout process files used the file extension .lkp, 
and state files used the extension .lst. Lookout now uses the .l4p 
extension for process files and .l4t for state files.

If you want to continue to run your old 3.8 processes in a 3.8 version, 
save backups of the files. Otherwise, recompiling a 3.8 process in 
Lookout 4 or later will create (if you save) new .lks, .l4p, and .l4t 
files. Lookout also creates new security files using the .lka extension.

• Avoid installing Lookout 6.0 over Lookout 3.x.xx. Either uninstall your 
previous version of Lookout, or put Lookout 6.0 in a new directory, 
transferring or copying files for conversion.

• Lookout 3.x.xx can run on the same computer with Lookout 6.0, and a 
process in one can be networked to a process in the other using DDE. 
If you intend to run both versions at one time, start the earlier version 
of Lookout first.
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• Lookout 3.8 Citadel files cannot be used by Lookout 6.0. You should 
maintain old Citadel files separately from Lookout 6.0 database files.

• Events are now stored with alarms and process data in the Citadel 
database. 

• The default location for data logged with the Spreadsheet object is the 
Lookout directory. The Lookout directory is also the default for any 
spreadsheet files you might export from the DataTable object or .csv 
(comma separated value) files you might create with the Print Alarms 
dialog box. If you do not want these files to be created in the Lookout 
directory, enter a complete path (including file name) for the location 
where you want the file created.

Converting Lookout 3.8 Processes to Lookout 6.0
To load a Lookout 3.8 process file in Lookout 6.0, select File»Open and 
set the Files of type to Lookout Source Files (*.lks), as shown in the 
following illustration.

 

Select the file you want to convert and click the Open button 
(or double-click the file name). Lookout uses the built-in CBL compiler 
to recompile the 3.8 source file into a Lookout 6.0 process file.

Converting 3.8 files might require the following adjustments:

• Lookout 3.8 versions of the Pot, Switch, Pushbutton, and TextEntry 
objects that are remoted convert as L3Pot, L3Switch, and so on, and 
continue to function as they formerly did. You cannot create new 
3.8 objects like these through Lookout 6.0.

Because remote position source connections have changed in response 
to the demands of networking, you might find you want to replace 
L3 versions of these controls with the new Lookout 6.0 versions, 
especially if you want these controls to operate over a network. Delete 
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the old controls and replace them with new controls using the same 
names. The Connection Browser and Object Explorer can help you 
track all the connections that might need to be re-established if you 
decide to make these replacements.

• ODBC/SQL limitations: With the introduction of networking and 
hierarchical arrangement of objects within processes, it is easy to 
exceed the 62 character limit that exists in Microsoft Access and 
Microsoft Query. Even fully-compliant ODBC programs are limited 
to 126 characters, so some consideration of these limitations when 
assigning computer, process, and object names is necessary if you 
intend to use SQL queries.

• The old LKSwap CBX no longer works. If you used this special object 
from the old Lookout Evaluation Guide, you will have to replace it 
with the Lookout Loader object, which is more flexible and powerful 
than the old LKSwap object. Lookout 6.0 can run multiple processes, 
so it is not necessary to shut one process down before running another.

• Fonts are preserved when converting Lookout 3.8 process files to 
Lookout 6.0 using the .lks file, but font code page information is lost. 
This appears to mostly affect international users whose languages use 
a different code page than the US code page. 

• The $Alarm object syntax in a .lks file has changed. The full URL 
for a $Alarm object will be as follows:

\\machine\process\$Alarm

• Your custom built Lookout 3.8 .cbx files should run in Lookout 6.0 
as long as they were developed using the Lookout Object Developer 
Toolkit. If you have problems with a custom .cbx, contact National 
Instruments technical support for help in resolving the problem.

• The Lookout HyperTrend object now accesses data through a URL 
connection. The data source for that connection must be logged to the 
Citadel database for the HyperTrend to display the data.

• When you convert a process with a Lookout 3.xx HyperTrend in it, 
Lookout automatically creates a named expression to make the URL 
connection to. Lookout automatically logs this named expression to 
the Citadel database. To maintain your converted HyperTrend objects, 
you must use or replace these named expressions.

• If you have Lookout 3.8 processes that use the NI DAQ or NI SCXI 
objects, and you have a version 6.5.1 or earlier of NI-DAQ installed on 
your computer, you must upgrade to NI-DAQ 6.5.2 or later to use 
Lookout 6.0. You can download the current version of NI-DAQ 
software from the National Instruments Web site.

If your Lookout process will be running on the same computer as 
your National Instruments Data Acquisition or SCXI hardware, we 
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recommend that you edit your process to use the OPCClient object 
to connect to NI-DAQ for performance reasons.

Importing Old Security Files into Lookout 6.0
If you are upgrading from Lookout 4.0 or later, Lookout converts your 
security file automatically when you open it with the National Instruments 
User Account Manager. If you are upgrading from Lookout 3.8, you can 
import the user account information into Lookout 6.0 using the User 
Account Manager, as follows:

1. In edit mode, select Options»User Manager from the Lookout menu. 
The User Account Manager dialog box appears.

2. Select User»Import Security File. The following dialog box appears.
 

3. Navigate to your old Lookout 3.8 security file lookout.sec, and 
select it. Lookout 3.8 kept the lookout.sec security file in the 
Lookout directory.

4. Click the Open button.

5. If you have already created any user accounts in an earlier version of 
Lookout that are the same as accounts you used in Lookout 3.8, you 
will receive a message informing you that a user account with that 
name already exists. You may replace your recently created account, 
or choose not to use the old account information.

6. Exit the User Account Manager.

Note Unlike Lookout 3.8, Lookout 6.0 maintains the lookout.sec security file in the 
Windows System directory. To implement the accounts that you have defined when you 
deploy your process, you must use the same lookout.sec file for each copy of Lookout 
running on your network. Copy your lookout.sec file to the Windows System directory 
in every computer you intend to run Lookout on.
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Known Issues
The following known issues exist for Lookout 6.0. Internal tracking codes 
are shown in parentheses for applicable issues.

Pushbutton Behavior with Lookout WebBrowser
If a Pushbutton is connected to the saveAs data member of the Lookout 
WebBrowser ActiveX, it stays pressed in when you click it. To release it, 
click it again. (2V5DL402)

Cannot Change Position of Minimized Panel
If a panel is minimized, you cannot programmatically change its position. 
Changes to its X and Y data members are ignored. If you want to use 
pushbuttons to open a panel in more than one location, create two panels 
that look the same but open in different locations. (2UIEAACP)

ActiveX Pipe Control Appearance Changes
ActiveX pipe controls in Lookout show white lines around the object 
border. When you save and reopen the process, the RelX and RelY settings 
in the Property Pages are changed. (2UGH8TR3)

Tiway.cbx Does Not Limit Request Length to 70 Bytes for FACTS 405 
Network

When using a TI 435 PLC with a 405 FACTS network, there is a 70 byte 
response limit. One Tiway object with multiple connections and I/O points 
might cause the PLC to go offline. The Lookout Tiway driver object does 
not enforce this limitation. To avoid exceeding the 70 byte response limit, 
create multiple Tiway objects, each of which requests only a few data 
members or values. (2NT882PE)

Listbox ActiveX Object Does Not Work in String Compares with =
When a Lookout Listbox ActiveX object is used in an expression with =, 
the expression does not evaluate correctly. For example, 
ListBox1.properties.selectedItem="Text1" is not TRUE when 
it should be. Use an EXACT(Text1, Text2) function instead, which 
returns TRUE when Text1 = Text2. (2MGDMCI1)
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Loading New Recipe Prevents State File Save
If you have edit access to a process in a development version of Lookout, 
loading a new recipe, which is a process change, prevents Lookout from 
saving the state file. Select File»Save to save the process after loading the 
recipe file, and Lookout will save the state file properly. Run-time versions 
of Lookout do not have this problem. (2ICAIECC)

Second DataTable Connected via DDE Does Not Shrink
A second DataTable connected to a source DataTable through DDE will 
not shrink when the source table shrinks. If the number of rows in the 
source DataTable is reduced, the second DataTable receives the new data 
but does not clear the extra rows of old data. To avoid this problem, use the 
enable data member to disable and re-enable the second DataTable 
whenever the source DataTable changes size. (25TEA49L)

Pager Message Does Not Work if # Required by Numeric Pager Service
The Pager object might not send a message to a numeric pager service that 
asks for # key at end of message. To send a message to a numeric pager that 
uses the # key to indicate the end of the message, put the phone number and 
message in the phone number field separated by commas, and leave the 
message field empty. (2ET9BFCC)

Moving Window Over Custom .wmf Graphic Distorts Image
If you drag another window over some custom .wmf graphics on a control 
panel, the graphic might appear partially erased. Minimize and restore the 
control panel to redraw the graphic. (2G39SQ26)

Displays that are Outside the Screen Area
If you move a display off the screen, you cannot delete it from Object 
Explorer due to remaining dependencies. Either edit the display 
coordinates in the .lks file or increase the screen size to make the display 
visible again. (1XF9K97F)

Lookout Control Sources and Refresh Value Operations
A Lookout control with a Local source and a direct connection does not 
change if something acts to alter the value or status of the PLC or object it 
is connected to. Instead, Lookout restores the control value to the PLC or 
object in the following circumstances:

• When the driver object is modified or I/O is reconfigured

• When the process is reloaded



© National Instruments Corporation 19 Lookout Release Notes

• When communication is restored after a communications failure

• After 100 polls in some cases (this varies from driver to driver and 
might depend on .ini file settings)

If you operate a Lookout control with a Remote source connection, and the 
PLC register it is connected to cannot or does not change when Lookout 
writes the new value out to the PLC, the control snaps back to display the 
actual PLC register value or status. Whether or not this problem occurs 
depends on data transmission time between your Lookout computer and the 
field hardware. To prevent this problem, Lookout has built-in delays for 
most driver objects. The following driver objects do not have a built-in 
delay:

• AdvantechPCL

• DeltaTau

• Dynamic

• ProfibusDP

• ProfibusL2

• Reliance

• Sixnet

• Wizdom

The following two driver objects do not support remote source connections 
at all because the underlying protocols do not allow this sort of connection:

• Aquatrol

• DeviceNet

Another way to correct snap-back problems caused by slow 
communication is to adjust the SnapDelay setting that is available with 
some control objects. For Switch and Pushbutton objects, use the 
SnapDelay data member; for the Pot object, use the SnapDelay 
lookout.ini setting.

Connection Browser Open with No Processes Visible
Occasionally the Connection Browser might open with no processes visible 
in the window. Close the Connection Browser and then reopen it. This 
usually clears the problem. If for some reason it does not, close the 
Connection Browser again and make sure you select a process in your 
Object Explorer before reopening the Connection Browser.
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Missing Aggregate Definitions
If you load a process that includes an Aggregate object, but the 
corresponding aggregate definition is unavailable, the Aggregate does not 
function properly. It appears in the Object Explorer as expandable, but it 
does not expand. (270DIAYZ)

Administrator Access Needed to Download Lookout Player
If you want to use the Lookout Web Client feature on a computer running 
Windows 2000/NT/XP, you must have administrator privileges to install 
the Lookout Player component of the Web Client. After the Lookout Player 
is installed, administrator privileges are not required to use the Lookout 
Web Client successfully.

Pot Connected to an FP-2010 Can Fluctuate
When you change the value of a Pot object that is remotely connected to a 
published data member of the FieldPoint FP-2010, the Pot can fluctuate in 
value before it reaches its final state. To address this problem, try changing 
the snapDelay setting in the lookout.ini file. Refer to the Lookout Help for 
more information on this setting. (28I89I7M)

ToshibaTSeries Sets PLC Values to 0
If the ToshibaTSeries object does a write before a read, it sets all the PLC 
values to 0. (1V5HS5M0)

Web Clients and the Sequencer Object
If you use the Web Client to browse a Lookout process that uses a 
Sequencer, and you browse to another URL while the Sequencer is active, 
Lookout might stop the process and reset the Sequencer, inserting a huge 
wait value in the active sequence step. Avoid using the Web Client with 
Lookout processes that use a Sequencer object. (28FGCNBD)

Pulse Object Erratic Behavior
The Lookout Pulse object might operate erratically, including missing 
some pulses, if you use period or duration numbers that are not simple. 
Using an expression to calculate a pulse period or duration is one way to 
encounter this problem; using too precise a number such as 1.26 seconds is 
another way. (28B89NBD)
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Including Custom Graphics when You Deploy
Remember that graphics are not included in Lookout source files (.lks). 
When you move processes from one computer to another, you must copy 
all graphics, including custom graphics. (2D6F3BDF)

Expression Displays that Automatically Resize
Lookout resizes expression displays when reopening a project. If an 
expression value has more characters than can be displayed in the given 
size of the expression display, it shows ####. If you close the project and 
reopen it, Lookout automatically resizes the expression display so that the 
string stored in the state file fits. This can be a significant problem if, for 
example, an expression is displaying input that is several hundred 
characters long. (2AJCJQTM)

Web Client Alert Has Incorrect Slashes in URL
No matter what URL you enter in the Web Client export options, the 
slashes are always shown as forward slashes in a Web Client Alert. If you 
use back slashes with an http URL, the URL does not work, but the 
Lookout alert message displays the correct URL with forward slashes. If 
you are confused because the URL looks correct in an alert message, check 
the direction of the slashes in your export options. (28B9OI9L)

Aggregate Problems with Incorrect Computer Name
If you have the incorrect computer name entered in the System Options 
dialog box and you drag and drop an Aggregate object data member on a 
panel, you get bad quality (a red X) for the data member. Additionally, you 
might find that some data members you did not intend to expose in the 
Aggregate object are visible in the Object Explorer. Select Options»
System and make sure the computer name matches the name in your 
Windows networking configuration. (246FA49L)

Using the ! and NOT Expression Functions
In Lookout expressions, the ! function has a transient TRUE value, but the 
NOT function does not. To negate an expression without a glitch, use NOT 
rather than !. (239957E9)

Tooltips Show up Only when Toolbox is Active Window
Tooltips show up only when toolbox is the current active window. 
(39J9NAPQ)
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Ethernet Drivers Not Retry
Modbus Ethernet does not retry when it is not getting a valid response. The 
parameter “Retry Attempts” is ignored. (2VCBRUCP)

Report Object with Black Bitmap File
Report object may generate a black .bmp file on computers with 256 colors 
(8 bits) display settings. Increase the color depth to 16 bits or higher to 
correct this. (2X0AKM02)

Connection Browser Items Not Sorted
Sometimes the items in Connection Browser are not sorted. (2M6H2BB4)

Connecting Device to LPT Port Hangs Lookout
If you create a driver object (like Modbus) and connect it to a LPT port (like 
LPT1), Lookout hangs.  To prevent this from happening, you need to 
configure the driver object corresponding to the physical connection.  For 
example, if you connect the Modbus device to COM1, you need to 
configure the Modbus driver object to COM1 as well. (32TAH9A3) 

Circular Reference For Remote Connection with Inaccurate Alarm
If Lookout detects a circular reference for remote connection, like 
Pot1:=Pot1.value, it reports an alarm as “Circular reference in logic: 
Source -> Source -> ...”.  The alarm is not accurate enough for you to locate 
the problem.  You can first check all the remote connections in your 
application to see if there is circular reference.  If you still cannot locate the 
problem after checking the remote connections, contact National 
Instruments for help. (33C0T3PQ)

NI Keyboard Driver Filter Conflicts with Computer Standby
If you chose to install the NI Keyboard Driver Filter, and when your 
computer is going to enter standby mode, the Windows system may hang. 
Avoid installing the NI Keyboard Driver Filter if you want to use computer 
standby. (39K19CGO)

Drivers Do Not Support Time/Quality
The following driver objects do not support the time/quality feature:

• AdvantecPCL

• All Applicom Objects

• DeltaTau

• NIDeviceNet and NIDeviceNetExplicit
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• Dynamic

• FF (FOUNDATION FieldBus) Objects

• ProfibusDP

• ProfiSinecL2

• Sixnet

• Wizdom

Without the time/quality support, these objects will not tell their data 
members are invalid (by a red X) when they have a problem communicating 
with the devices. Also, the Lookout quality functions will not work on these 
objects. (3C8CD8ZU)

Bug Fixes
The following bugs have been fixed for Lookout 6.0:

• Problem of writing to individual Modbus bits has been resolved. 
(2C7GHH85)

• Lookout Panel function keys act like pushbuttons instead of switches 
now. (2EACD8PE)

• When changing V datamember in “Edit Data Member 
Configuration”, Tiway object does not crash lookout any more. 
(2ZH7UIE9)

• Web Client process does not crash when you close Internet Explorer. 
(2KO7R5O7)

• “Edit Data Member Configuration” dialog box has resizable 
windows. You can see full tag names by moving the horizontal 
scrollbar. (2JHB2CPE)

• Modbus MOSCAD Ethernet driver does not crash Lookout any more. 
(2WH7P9I1)

• BOUT data member of the DNP Driver in Lookout is writable now. 
(2YB978CP)

• The GE Versamax driver is able to Poll the %R Register in the 
1024 range. (2LL9FEB4)

• Lookout can read the Modbus 32-bit unsigned holding register in a 
reverse order. If you want to enable this option, please set "[all] 
ReverseByteOrder=1" in modbus.ini file. (2S9GSJ02)

• User with a security level allowed to exit Lookout can exit now. 
(2OM4IR8D)

• The Lookout Web Client will not crash if running on a multiprocessor 
machine. (3CACOTZU)
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• The Commfail data member within the Lookout pager object resets 
after a communications failure. (313B6S7N)

• S7 HMI driver can correctly translating data now. (35BCO0D3)

• You can unregister computer in Lookout now. (33AEFAY1)

• OPC Client can indicate communication failure correctly if 
Use Asynchronous I/O is not checked. (32JAFUY1)

• You can change your login password in Lookout now. (2UQDTDE9)

• Lookout can launch Component Works Control help file (cwui.chm) 
now. (2UO3ACH7)

• SQLExec Object does not cause memory to leak any more. 
(3AKETPI1)

• The Alternator object would cause a crash on a computer with 
NI PCI-485-2 installed.  This problem has been fixed. (2VK9JKCP)

• You cannot save a process with a read-only LKS file, but Lookout 
considers this operation as successful. This problem has been fixed. 
(270DANYZ)

• You cannot use the CitadelControl object to log data remotely over the 
network.  This problem has been fixed. (29MCRKMV)

• S7_HMI datamember I0.0–I65535.7 should be read-only. This 
problem has been fixed. (3AR8USH7)

More Information and Updates
For the most recent Lookout news and updates, visit ni.com/lookout.

To download the newest patches and other updates, visit ni.com/
downloads.
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