
LabVIEW  Real-Time Module 
Release and Upgrade Notes
Version 8.0

This document provides installation instructions, system requirements, 
upgrade information, and descriptions of the new features for version 8.0 
of the LabVIEW Real-Time Module.

Refer to the Getting Started with the LabVIEW Real-Time Module manual 
for exercises you can complete to familiarize yourself with the new features 
and enhancements to the Real-Time Module.
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System Requirements
Table 1 describes the system requirements to run version 8.0 of the 
Real-Time Module. The Real-Time Module system requirements are in 
addition to the LabVIEW system requirements listed in the LabVIEW 
Release Notes.

Table 1.  System Requirements for the Real-Time Module 8.0

Platform
Media and System 

Requirements Important Notes

Windows 2000/XP National Instruments 
recommends that you have 
at least 200 MB of disk 
space for the minimum 
Real-Time Module 
installation or 700 MB of 
disk space for the complete 
Real-Time Module 
installation, which includes 
the Real-Time and 
Embedded drivers from the 
National Instruments 
Device Drivers CD.

(RTX) You must install 
Service Pack 2 for 
Windows XP.

LabVIEW does not support Windows 
NT/Me/9x.

You might need more memory than 
the LabVIEW-recommended 
minimum of 128 MB of RAM 
depending on the size of the 
application you design in LabVIEW 
on the host computer.

To use the LabVIEW Help, the NI 
Measurement & Automation 
Explorer (MAX) interactive help 
system, and the NI Example Finder, 
you must have Microsoft Internet 
Explorer 5.0 or later.

To view and control the front panel of 
a VI running on an RT target 
remotely using a Web browser, 
National Instruments recommends 
Internet Explorer 5.5 with Service 
Pack 2 or later.
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Installing the Real-Time Module 8.0
This section includes information about installing the Real-Time Module 
and the Real-Time Module for RTX Targets on a development, or host, 
computer.

Note You must install LabVIEW 8.0 before attempting to install the Real-Time 
Module 8.0. Refer to the LabVIEW Release Notes for the LabVIEW installation 
instructions.

LabVIEW Real-Time Module
Complete the following steps to install the LabVIEW Real-Time Module 
on the host computer.

1. Disable any automatic virus detection programs before you install. 
Some virus detection programs interfere with the installation program.

2. Log on as an administrator or as a user with administrator privileges.

3. Insert the LabVIEW Real-Time Module installation CD into the 
CD-ROM drive. The LabVIEW Real-Time Module installation 
program runs automatically.

4. Follow the instructions that appear on the screen.

5. Install the Real-Time and Embedded drivers and any other drivers that 
you require from the National Instruments Device Driver CD.

LabVIEW Real-Time Module for RTX Targets
Complete the following steps to install the LabVIEW Real-Time Module 
for RTX Targets on the host computer.

1. Disable any automatic virus detection programs before you install. 
Some virus detection programs interfere with the installation program.

2. Log on as an administrator or as a user with administrator privileges.

3. Install the Ardence RTX 6.1 Runtime and restart the computer. Refer 
to the Ardence RTX 6.1 documentation for information about 
installing and configuring the RTX 6.1 Runtime on the host computer.

4. Insert the LabVIEW Real-Time Module CD into the CD-ROM drive. 
The LabVIEW Real-Time Module installation program runs 
automatically.

5. Follow the instructions that appear on the screen.

6. Install the Real-Time and Embedded drivers and any other drivers that 
you require from the National Instruments Device Driver CD.
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RT Target Configuration
Use MAX to configure RT targets and to install software and drivers on 
targets.

• Networked RT Targets—Refer to the Remote Systems section of the 
Measurement & Automation Explorer Help, available by selecting 
Help»MAX Help from MAX, for information about configuring 
networked RT targets.

• RT Series Plug-in Devices—Refer to the RT Series DAQ Devices 
(NI PCI-7041/6040E) topic of the Measurement & Automation 
Explorer Help for information about configuring RT Series plug-in 
devices.

• Desktop PC Targets—Refer to the Using Desktop PCs as RT Targets 
with the LabVIEW Real-Time Module document for information about 
configuring a desktop PC as a networked RT target.

Note RTX targets do not require configuration.

Upgrade Issues
The following section provides a description of changes to VIs, structures, 
utilities, dialog boxes, menus, and documentation resources when you 
upgrade to version 8.0 of the Real-Time Module from a previous version. 
Refer to the LabVIEW Help for more information about the following 
topics.

Changes to VIs and Structures

Real-Time FIFO VIs
The Real-Time FIFO VIs now support 64-bit signed and unsigned integer 
data types. Use 64-bit signed and unsigned integer data types to use, view, 
and store integers with high precision.

Timed Loop
You can set a deadline for the execution of the Timed Loop subdiagram. If 
the subdiagram does not complete before the deadline, the Finished 
Late? [i-1] output of the Left Data node returns TRUE in the next iteration 
of the Timed Loop. However, missing a deadline does not affect the 
execution of the Timed Loop.

You can add frames to a Timed Loop that execute sequentially within the 
loop and use a secondary clock source to control the timing of the frames 
independent of the structure timing.
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Changes to Real-Time Utilities and Dialog Boxes

LabVIEW Application Builder
Use Build Specifications, located under an RT target in the 
Project Explorer window, to create build specifications for and to build 
stand-alone real-time applications that can run automatically when you 
power on an RT target.

Version 8.0 of the Real-Time Module does not support creating installers 
for stand-alone real-time applications. You must use LabVIEW to deploy a 
stand-alone real-time application to an RT target.

RT Communication Wizard
The RT Communication Wizard supports the LabVIEW shared 
variable for sending data to and receiving data from RT target VIs. Select 
Tools»Real-Time Module»Communication Wizard to launch the 
RT Communication Wizard.

Advanced Ethernet Settings Dialog Box (ETS)
Use the Advanced Ethernet Settings dialog box in MAX to configure 
advanced Ethernet settings for networked RT targets and to add a 
secondary Ethernet device on RT Series PXI targets. Refer to the 
Measurement & Automation Explorer Help for information about the 
Advanced Ethernet Settings dialog box.

Changes to the Real-Time Module Documentation
The LabVIEW Help now contains conceptual content from the LabVIEW 
Real-Time Module User Manual. The Real-Time Module therefore no 
longer ships with a PDF library or with print and PDF versions of the 
LabVIEW Real-Time Module User Manual. Refer to the Real-Time Module 
Concepts book on the Contents tab of the LabVIEW Help for information 
about the Real-Time Module features.

Refer to the Getting Started with the LabVIEW Real-Time Module 
document for exercises you can complete to familiarize yourself with the 
new features and enhancements to the Real-Time Module.
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Menu Reorganization
Menu items have moved or been renamed for version 8.0 of the Real-Time 
Module. Table 2 lists the menu items that have changed.

New Real-Time Module 8.0 Features
The Real-Time Module includes the following new features. Refer to the 
LabVIEW Help for more information about the following new features.

LabVIEW Projects
Use LabVIEW projects to group LabVIEW files and non-LabVIEW files, 
create real-time build specifications, and deploy files to an RT target. When 
you save a project, LabVIEW creates a project file (.lvproj), which 
includes references to files in the project, configuration information, build 
information, and deployment information.

Table 2.  LabVIEW Menu Changes for the Real-Time Module

LabVIEW 7.1 Menu Item Equivalent LabVIEW 8.0 Menu Item

File»Exit without closing RT Engine VIs Use the Project Explorer window to 
disconnect from RT targets and then exit 
LabVIEW. Right-click an RT target and select 
Disconnect from the shortcut menu to 
disconnect from the target.

Operate»Download Application From the Project Explorer window, right-click 
a VI and select Deploy from the shortcut menu.

Operate»Switch Execution Target Use the Project Explorer window to add and 
connect to RT targets. Right-click the project 
root and select New»Targets and Devices from 
the shortcut menu to add RT targets. Right-click 
an RT target and select Connect from the 
shortcut menu to connect to the target.

Tools»Build Application or Shared Library 
(DLL)

From the Project Explorer window, right-click 
Build Specifications under an RT target and 
select New»Real-Time Application from the 
shortcut menu.

Tools»RT Communication Wizard Tools»Real-Time Module»Communication 
Wizard

Tools»RT Target Options From the Project Explorer window, right-click 
an RT target and select Properties from the 
shortcut menu.
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You can create a new project with the Real-Time Project Wizard, available 
by selecting Tools»Real-Time Module»Project Wizard from the Getting 
Started window. You also can create a project manually by selecting 
File»New Project from the Getting Started window and then using the 
Project Explorer window to add RT targets, VIs, and other support files to 
the project. Refer to the Getting Started with the LabVIEW Real-Time 
Module document for exercises you can complete to familiarize yourself 
with projects.

Real-Time Project Wizard
Use the Real-Time Project Wizard to create a new project that defines 
RT targets and includes VIs and other application files. You can create 
projects using one of three architectures with the Real-Time Project 
Wizard—continuous communication, state machine, or custom.

• Continuous communication architecture—Use a continuous 
communication architecture to create data acquisition applications that 
log data to disk and continuously communicate with a host computer 
or to create applications that perform continuous deterministic tasks.

• State machine architecture—Use a state machine architecture to 
implement complex decision-making algorithms represented by state 
diagrams or flow charts. A state machine implements any algorithm 
described by a Moore machine, which performs a specific action for 
each state in the diagram. 

• Custom project—Use a custom project architecture to add a blank VI 
or import existing VIs to run on the host computer or RT target.

Project Explorer Window
The Project Explorer window enables you to manage the targets, VIs, and 
other support files of a project from one location. Use the Project Explorer 
window to connect to RT targets, to set target properties, and to deploy VIs 
to targets. The Project Explorer window includes the following sections.

• Project root—Contains the host computer and the RT targets assigned 
to the current project.

– My Computer—Represents the host computer as a target in the 
project.

– RT Target—Represents the RT targets in the project. By default, 
the heading for an RT target is the name of the target as specified 
in MAX.

VIs and libraries that you add to an RT target appear under the target in the 
Project Explorer window.
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Shared Variables for Deterministic Communication
Use shared variables to read and write data from VIs in a project or across 
a network. Shared variables are configured software items that can send 
data between two locations in a block diagram that cannot be connected 
with wires, between two VIs running on an RT target, or between two VIs 
across a network running on different targets.

Use single-process shared variables to share data between two locations in 
a block diagram or VIs running on an RT target. Use network-published 
shared variables to share data between VIs running on different targets. 
Right-click an RT target in the Project Explorer window and select 
New»Variable from the shortcut menu to open the Shared Variable 
Properties dialog box.

The Real-Time Module adds a real-time FIFO—first in, first out buffer—to 
the shared variable. By enabling the real-time FIFO of a shared variable, 
you can deterministically share data without affecting the determinism of 
VIs running on an RT target. From the Real-Time FIFO page of the 
Shared Variable Properties dialog box, place a checkmark in the Enable 
Real-Time FIFO checkbox to enable the real-time FIFO for a shared 
variable.

RT Target Properties Dialog Box
Use the RT target Properties dialog box to configure the project settings 
of an RT target. You can configure general, VI Server, Web Server, access, 
and miscellaneous target settings. For example, you can enable the 
VI Server on the RT target from the RT target Properties dialog box.

Right-click an RT target in the Project Explorer window and select 
Properties from the shortcut menu to open the RT target Properties dialog 
box. After configuring the settings of an RT target, you must deploy the 
settings to the target by right-clicking the target and selecting Deploy from 
the shortcut menu.

LabVIEW Timed Structures (ETS)
Use the Timed Structures, located on the Timed Structures palette, when 
you want to develop VIs with precise timing, execution feedback, timing 
characteristics that change dynamically, or several levels of execution 
priority.

Timed Sequence
The Timed Sequence consists of one or more task subdiagrams, or frames, 
that execute sequentially. You can control the execution of the Timed 
Sequence using an internal or external clock source. 
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You also can use a secondary clock source to control the timing of the 
frames independent of the structure timing.

Timed Loop with Frames
You can add frames that execute subdiagrams sequentially for every loop 
iteration to a Timed Loop. You can control the execution of each iteration 
of a Timed Loop using an internal or external clock source.

You also can use a secondary clock source to control the timing of the 
frames independent of the structure timing.

Real-Time Benchmarking VIs
Use the Real-Time Benchmarking VIs, located on the Real-Time Utilities 
palette, to benchmark the performance of VIs and sections of VIs running 
on an RT target. You can use the benchmark information to optimize the 
design of RT target VIs.

RT Get Timestamp VI
Use the RT Get Timestamp VI to return a 64-bit timestamp value from a 
high-precision timing source.

RT Timestamp Analysis VI
Use the RT Timestamp Analysis VI to analyze the timestamp values 
returned by the RT Get Timestamp VI.

RT Target Errors Dialog Box
Use the RT Target Errors dialog box to view error logs for the 
RT sessions of an RT target. An RT session begins when you power on an 
RT target and ends when you reboot the target. The RT Target Errors 
dialog box displays LabVIEW errors, real-time operating system errors, 
and crash logs for an RT target. Right-click an RT target in the Project 
Explorer window and select Utilities»View Error Log from the shortcut 
menu to view the error logs of the target using the RT Target Errors 
dialog box.
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Dual Ethernet Device Support for NI PXI Targets (ETS)
The Advanced Ethernet Settings dialog box in MAX was updated to 
support configuration of multiple Ethernet devices for RT Series 
PXI targets. You can create applications that use multiple Ethernet devices 
to send multiple copies of data over different networks from an RT target 
and to prioritize or isolate network traffic. In MAX, click the Advanced 
Ethernet Settings button on the Network Settings tab of an RT target to 
open the Advanced Ethernet Settings dialog box.

Real-Time Module Examples
Use the NI Example Finder, available by selecting Help»Find Examples 
from LabVIEW, to browse or search for example VIs. You also can access 
the example VIs from the labview\examples\Real-Time directory. 
The Real-Time Module includes examples of multithreaded 
communication, network communication, and shared memory access.

• Multithreaded Communication—Example VIs that use functional 
global variables, Real-Time FIFO VIs, and shared variables to 
communicate between the sections of a multithreaded application.

• Network Communication—Example VIs that use shared variables, 
TCP, UDP, and the VI Server to communicate between the host 
computer and an RT target.

• Shared Memory—Example VIs that use the Real-Time Shared 
Memory VIs to communicate between a host computer and an 
RT Series plug-in device or RTX target.

Known Issues with the Real-Time Module 8.0
Refer to the readme_RT.html file on the LabVIEW Real-Time 
Module 8.0 installation CD for information about known issues with the 
Real-Time Module 8.0.

You also can launch the readme_RT.html file from Windows after you 
install the Real-Time Module. Complete the following steps to access the 
readme_RT.html file from Windows.

1. Select Start»All Programs»National Instruments»LabVIEW 8.0» 
Readme to open the labview\readme directory.

The labview\readme directory contains the HTML readme files for 
LabVIEW, the LabVIEW modules, and add-ons installed on the 
computer.

2. Double-click readme_RT.html to open the LabVIEW Real-Time 
Module Readme.
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