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Introduction
The LabVIEW DSP Module supports the design, implementation, and 
analysis of digital signal processor-based algorithms and systems. You can 
apply the concepts of digital signal processing techniques, such as spectral 
analysis or filtering, with the DSP Module and one of the following 
evaluation boards:

• National Instruments SPEEDY-33

• Spectrum Digital 6416 DSK

• Spectrum Digital 6713 DSK

• Texas Instruments 6711 DSK

The DSP Module adds features and VIs to LabVIEW that focus on creating 
signal processing applications that run on embedded digital signal 
processors (DSPs). With LabVIEW and the DSP Module you can focus on 
concepts and results rather than on implementation details.

System Requirements
The DSP Module has the following requirements:

• A desktop computer with Windows Vista/2000 or Windows XP SP 2 
or later

• LabVIEW 8.5 Full or Professional Edition

• One of the following evaluation boards and corresponding driver:

– National Instruments SPEEDY-33

– Spectrum Digital 6416 DSK

– Spectrum Digital 6713 DSK

– Texas Instruments 6711 DSK

Note The Texas Instruments 6711 DSK is not compatible with Windows Vista.

Refer to the LabVIEW Release Notes, available by selecting Start»
All Programs»National Instruments»LabVIEW»LabVIEW Manuals 
and opening LV_Release_Notes.pdf, for standard LabVIEW 
development system requirements.
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Installation
Complete the following steps to install the DSP Module. After you install 
the DSP Module, you must install the driver(s) for the DSP target.

1. Log on as an administrator or as a user with administrator privileges.

2. Unplug the DSP device from the host computer if the device is 
connected.

3. Insert the LabVIEW DSP Module CD and follow the instructions that 
appear on the screen.

Note The DSP Module installation process installs the NI SPEEDY-33 driver by default.

Installing the Drivers
You must install the appropriate driver for the DSP target. 

• National Instruments SPEEDY-33—Install the SPEEDY-33 driver 
during the DSP Module installation process. Do not plug in the 
SPEEDY-33 device to the host computer until after you install the DSP 
Module software. Refer to the NI SPEEDY-33 Installation Guide for 
more information about setting up the SPEEDY-33.

• Spectrum Digital 6416 DSK—Refer to the 6416 DSK documentation 
from Spectrum Digital for information about installing the drivers.

• Spectrum Digital 6713 DSK—Refer to the 6713 DSK documentation 
from Spectrum Digital for information about installing the drivers.

• Texas Instruments 6711 DSK—Refer to the Setting Up the Texas 
Instruments 6711 DSK Target document, available by selecting 
Start»All Programs»National Instruments»LabVIEW»
LabVIEW Manuals and opening DSP_6711DSK_Setup.pdf, for 
information about setting up the 6711 DSK target.

Note The Texas Instruments 6711 DSK is not compatible with Windows Vista.

Setting Up the Hardware
Refer to the documentation that came with your DSP hardware for 
information about setting up and configuring the hardware. You can use the 
default configuration for the DSP Module.

(6711 DSK Only) Refer to the Setting Up the Texas Instruments 6711 DSK 
Target document, available by selecting Start»All Programs»National 
Instruments»LabVIEW»LabVIEW Manuals and opening 
DSP_6711DSK_Setup.pdf, for information about setting up the 
6711 DSK target.

http://www.ni.com/manuals
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Installing Third-Party Tools to Use the MIDI Read Control
You must install MIDI Yoke and MIDI-OX to use the new MIDI Read 
control on the Mixed Target palette for DSP targets. The MIDI Read 
control reads MIDI data that MIDI-OX generates. 

If you do not plan to use the MIDI Read control in a DSP application, you 
do not need to install MIDI Yoke or MIDI-OX.

Installing and Configuring MIDI Yoke
MIDI Yoke is free software that you can download from 
www.midiox.com/myoke.htm. Refer to the Web site for special 
instructions on installing MIDI Yoke with Windows Vista.

Complete the following steps to install and configure MIDI Yoke on 
Windows XP/2000.

1. Log on as an administrator or as a user with administrator privileges.

2. Download the MIDI Yoke NT 1.74 installer (MidiYokeSetup.msi) 
from the www.midiox.com/myoke.htm Web site. 

3. Run the MIDI Yoke installer and follow the instructions on the screen.

4. Restart your computer when the installer prompts you.

5. Open Windows Control Panel.

6. (Windows XP) Double-click Sound and Audio Devices.

(Windows 2000) Double-click Sounds and Multimedia.

7. Click the Audio tab.

http://www.midiox.com/myoke.htm
http://www.midiox.com/myoke.htm
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8. Select a MIDI Yoke device from the (Windows XP) Default device 
pull-down menu or the (Windows 2000) Preferred device pull-down 
menu in the MIDI music playback section as shown in Figure 1, and 
click the OK button. LabVIEW can use any MIDI Yoke device.

Figure 1.  Selecting a MIDI Yoke Device in the Windows XP Control Panel

Note If you do not see any MIDI Yoke devices in the pull-down menu, you might need 
to reinstall MIDI Yoke manually. Download the MIDI Yoke NT 1.74 manual installer 
(myokent.exe) from the www.midiox.com/myoke.htm Web site and follow the 
instructions.

Installing and Configuring MIDI-OX
Complete the following steps to install and configure MIDI-OX.

1. Log on as an administrator or as a user with administrator privileges.

2. Download the MIDI-OX 7.0 installer (midioxse.exe) from the 
www.midiox.com Web site.

3. Run the MIDI-OX installer and follow the instructions on the screen.

4. Launch MIDI-OX after the installation is complete.

5. Select Options»MIDI Devices to open the MIDI Devices dialog box.

http://www.midiox.com/myoke.htm
http://www.midiox.com
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6. Select a MIDI device in the MIDI Inputs list as shown in Figure 2 and 
click the OK button. You must select the same device you selected in 
step 8 of the Installing and Configuring MIDI Yoke section.

Figure 2.  Selecting a MIDI Input Device

Testing the Configuration of MIDI Yoke and MIDI-OX
Complete the following steps to make sure MIDI-OX can play MIDI files 
properly.

1. Launch MIDI-OX if it is not running already.

2. Select Actions»Play MIDI to open MIDIBar. 

If MIDIBar does not open, you might need to reinstall MIDI Yoke. 
Refer to the Installing and Configuring MIDI Yoke section for 
information about installing MIDI Yoke.

3. Click the Open button, shown at left, in MIDIBar and browse to the 
MIDI file you want to play.

4. Select the file you want to play and click the OK button.

5. Select View»Input Monitor in MIDI-OX if the Monitor - Input 
window is not already visible.

6. Click the Play button, shown at left, in MIDIBar to play the file. If the 
installation and configuration of MIDI-OX and MIDI Yoke is correct, 
data displays in the MIDI-OX Monitor - Input window.
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7. Click the Stop button, shown at left, in MIDIBar to stop the playback.

8. Close MIDI-OX and MIDIBar before launching LabVIEW.

Upgrading from the DSP Module 2.0
DSP VIs and projects you created with the DSP Module 2.0 are compatible 
with the DSP Module 2.5. 

Upgrading from the DSP Module 1.0
If you created DSP VIs using the DSP Module 1.0, you must create projects 
and update the VIs for use with LabVIEW 8.5 and the DSP Module 2.5.

Caution National Instruments recommends you back up your files before you begin 
updating your DSP Module 1.0 VIs for use with the DSP Module 2.5. For example, 
DSP-specific Express VIs and Elemental I/O Nodes are not backward-compatible so you 
cannot save DSP VIs that use those items in a previous version of LabVIEW.

Managing DSP Targets and VIs in LabVIEW Projects
LabVIEW 8.x features the Project Explorer window and the LabVIEW 
project to manage applications that include multiple VIs and resources, 
such as DSP targets. The DSP Module 2.5 uses the Project Explorer 
window to manage the components of a DSP application, including DSP 
VIs and Elemental I/O items. 

Note You must create projects to create DSP VIs. You can use the DSP Project Wizard, 
available by selecting DSP Project from the Targets pull-down menu in the Getting 
Started window and clicking the Go button, if you want to create a new project that 
includes a DSP target. 

Adding I/O to the Project
You first must add Elemental I/O items to the DSP project to use the analog 
input and output resources available on the DSP target or to access the 
LEDs and switches on the DSP target. 
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You can add Elemental I/O items to a project when you create the project 
using the DSP Project Wizard. The DSP Project Wizard adds all available 
I/O resources by default, as shown in Figure 3. Click the Finish button to 
create the project with the I/O resources you select.

Figure 3.  Adding I/O Resources through the Wizard

Tip You also can add Elemental I/O items by right-clicking a DSP target in the Project 
Explorer window and selecting New»Elemental I/O from the shortcut menu. 

To use the Elemental I/O item in a DSP VI, place an Elemental I/O Node 
on the block diagram of a DSP VI. To configure the Elemental I/O Node, 
right-click the terminal name in the Elemental I/O Node and select 
Properties from the shortcut menu. 

Tip You can use the same Elemental I/O Node on the block diagram to access all of the 
Elemental I/O items in the Project Explorer window. Refer to the LabVIEW Help for more 
information about using Elemental I/O Nodes.

New Features in the DSP Module 2.5
The DSP Module 2.5 includes the following new features:

• Customizable Lesson Manager Window—Provides a way to 
organize and present custom example VIs to students in a lab situation. 
Refer to the Customizing and Using the LabVIEW Lesson Manager 
manual, available by selecting Start»All Programs»National 
Instruments»LabVIEW»LabVIEW Manuals and opening 
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LV_Custom_Lesson_Manager.pdf, for information about 
customizing the Lesson Manager for LabVIEW and the DSP Module.

LabVIEW includes the following new Mixed Target controls to use with 
VIs for DSP targets:

• 2D Spectrograph—Appears as an intensity chart in a front panel 
window. The 2D Spectrograph control displays two-dimensional data 
as a spectrograph of a signal. 

• Keyboard Input—Appears as a custom text control in a front panel 
window. Use the Keyboard Input control to type text using the 
computer keyboard so that the DSP target can process the text. The 
output of this control is the ASCII character value for the last keyboard 
entry. 

• MIDI Read—Appears as a custom numeric control in a front panel 
window. This control works with the MIDI-OX software. The MIDI 
Read control reads MIDI data for any MIDI file the MIDI-OX 
software plays. The output of the MIDI Read control is an array of five 
notes that represent the musical content of a MIDI file that MIDI-OX 
generates. 

• Multipurpose Display—Appears as a graph display in a front panel 
window. The display provides a method of displaying waveform data 
in both the time and frequency domains. Click the tabs to switch 
between time and frequency domains. You can select user options 
including manual or auto-scaling of the y-axis and cursor readout of 
waveform data. 

• Sketchwave—Appears as a graph display in a front panel window. 
With the Sketchwave control you can generate an arbitrary custom 
waveform by using the computer mouse to drag the shape of the 
waveform directly in the graph display. Click the buttons on the 
Sketchwave control to use pre-defined waveform signals, including 
sine waveform, triangle waveform, positive ramp, negative ramp, and 
empty waveform. 

• Receive Character—Allows for a scrolling history of up to twenty 
letters of the alphabet. The letters scroll from right to left until the 
characters scroll off the left side of the indicator. Input values for the 
letters a to z range from 10 to 35, where 10 = a and 35 = z. Use a value 
of 36 for a space. Separate identical consecutive input values with a 
value of zero. For example, to scroll the word hello on the indicator, 
use the following input sequence: 17 14 21 0 21 24. 
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Where to Go from Here 
National Instruments provides many resources to help you succeed with 
your NI products. Use the following resources as you start exploring 
LabVIEW and the DSP Module.

Examples and Tutorials
Many of the features of the DSP Module include corresponding examples. 
You can start with an existing example and use it as a framework for 
developing DSP VIs. From LabVIEW, launch the NI Example Finder by 
selecting Help»Find Examples. Browse the examples by task or by 
directory structure. You can locate example VIs specifically for the DSP 
Module in the EmbeddedDSP directory.

The Getting Started with the DSP Module manual contains step-by-step 
exercises to teach you how to create a DSP application with the Project 
Explorer window. From Windows, select Start»All Programs» 
National Instruments»LabVIEW»LabVIEW Manuals and open 
DSP_Getting_Started.pdf to view this manual.

Software- and Web-Based Resources
Refer to the LabVIEW Help for information about LabVIEW and the DSP 
Module, and refer to the Context Help window for information about using 
VIs and functions.

• LabVIEW Help—Available by selecting Help»Search the LabVIEW 
Help in LabVIEW. Browse the DSP Module book in the Contents tab 
for an overview of the DSP Module. 

• Context Help window—Available by selecting Help»Show Context 
Help or by pressing the <Ctrl-H> keys.

Visit ni.com for the latest NI Developer Zone examples, Knowledgebase 
articles, and support information for the DSP Module. Refer to 
ni.com/info and enter the info code dspsupport to access Web-based 
resources.

Academic Resources
The Customizing and Using the LabVIEW Lesson Manager manual 
describes how you can organize and present custom LabVIEW-based labs 
in a classroom setting. From Windows, select Start»All Programs»
National Instruments»LabVIEW»LabVIEW Manuals and open 
LV_Custom_Lesson_Manager.pdf for information about using the 
LabVIEW Lesson Manager.

Visit ni.com/dsp for other academic and training resources. 

http://ni.com
http://ni.com/info
http://ni.com/dsp
http://ni.com
http://ni.com/info
http://ni.com/dsp
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Known Issues
Refer to the readme_dsp.html file on the LabVIEW DSP Module 
installation CD for information about known issues with the DSP Module. 
You also can find the readme_dsp.html file installed in the labview\
readme directory. Select Start»All Programs»National Instruments»
LabVIEW»Readme to open the labview\readme directory. 

Where to Go for Support
The National Instruments Web site is your complete resource for technical 
support. At ni.com/support you have access to everything from 
troubleshooting and application development self-help resources to email 
and phone assistance from NI Application Engineers.

National Instruments corporate headquarters is located at 
11500 North Mopac Expressway, Austin, Texas, 78759-3504. 
National Instruments also has offices located around the world to help 
address your support needs. For telephone support in the United States, 
create your service request at ni.com/support and follow the calling 
instructions or dial 512 795 8248. For telephone support outside the United 
States, contact your local branch office: 

Australia 1800 300 800, Austria 43 662 457990-0, 
Belgium 32 (0) 2 757 0020, Brazil 55 11 3262 3599, 
Canada 800 433 3488, China 86 21 5050 9800, 
Czech Republic 420 224 235 774, Denmark 45 45 76 26 00, 
Finland 385 (0) 9 725 72511, France 01 57 66 24 24, 
Germany 49 89 7413130, India 91 80 41190000, Israel 972 3 6393737, 
Italy 39 02 413091, Japan 81 3 5472 2970, Korea 82 02 3451 3400, 
Lebanon 961 (0) 1 33 28 28, Malaysia 1800 887710, 
Mexico 01 800 010 0793, Netherlands 31 (0) 348 433 466, 
New Zealand 0800 553 322, Norway 47 (0) 66 90 76 60, 
Poland 48 22 3390150, Portugal 351 210 311 210, Russia 7 495 783 6851, 
Singapore 1800 226 5886, Slovenia 386 3 425 42 00, 
South Africa 27 0 11 805 8197, Spain 34 91 640 0085, 
Sweden 46 (0) 8 587 895 00, Switzerland 41 56 2005151, 
Taiwan 886 02 2377 2222, Thailand 662 278 6777, 
Turkey 90 212 279 3031, United Kingdom 44 (0) 1635 523545

http://ni.com/support
http://ni.com/support
http://ni.com/support
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