
Getting Started with the 
LabVIEW Mobile Module
Version 8.6

Contents
Overview................................................................................................. 2
System Requirements.............................................................................. 2
Installing the Mobile Module.................................................................. 2
Uninstalling the Mobile Module ............................................................. 3
Installing Additional Tools ..................................................................... 4

Shared Variable Support .................................................................. 4
PNG Image Support......................................................................... 4
NI-VISA Support ............................................................................. 5
WIDCOMM Bluetooth DLLs.......................................................... 5
LabVIEW SMS Client ..................................................................... 5
Emulators for Windows Mobile ...................................................... 6

What’s New............................................................................................. 7
Smartphone Key Navigation............................................................ 7
New VIs and Functions.................................................................... 7
New Front Panel Control ................................................................. 8
New VI-Specific Code Generation Options .................................... 8
New Project-Level Code Generation Options ................................. 8
Fixed-Point Support ......................................................................... 9

Tutorial.................................................................................................... 12
Creating the LabVIEW Project........................................................ 12
Creating the Build Specification...................................................... 15
Building the VI into an Application and Deploying........................ 18
Closing the Application ................................................................... 20
Debugging the Application .............................................................. 20

Related Documentation........................................................................... 25
Where to Go for Support......................................................................... 26

™



Getting Started with the LabVIEW Mobile Module 2 ni.com

Overview
The LabVIEW Mobile Module extends the LabVIEW graphical 
development environment to devices that run Windows Mobile and Pocket 
PC. You can create portable solutions for a wide spectrum of applications, 
such as field test systems, remote control and monitoring systems, and 
portable data acquisition systems.

This manual contains new features for version 8.6, system requirements, 
installation instructions, and a tutorial that shows you how to create a 
LabVIEW project and build, run, deploy, and debug a Mobile application.

System Requirements
The Mobile Module has the following requirements:

• A computer with Windows Vista/XP or Windows 2000 with Service 
Pack 4.0 or later

• LabVIEW 8.6 Base, Full, or Professional Edition

• 2.5 GB available disk space

• A Mobile device running Windows Mobile 5.0, Windows Mobile 6.0, 
or Pocket PC 2003

Note For more information about additional software requirements and supported devices 
for Windows Mobile and Pocket PC, refer to KnowledgeBase 3ANADAKN: LabVIEW 
Mobile Module Software Requirements and Supported Devices at ni.com.

Refer to the LabVIEW Release Notes, available by selecting Start»All 
Programs»National Instruments»LabVIEW»LabVIEW Manuals and 
opening LV_Release_Notes.pdf, for standard LabVIEW development 
system requirements.

Installing the Mobile Module
Complete the following steps to install the Mobile Module.

1. On Windows Vista/XP/2000, log in as an administrator or as a user 
with administrator privileges.

2. Install LabVIEW 8.6, if not already installed. Refer to the LabVIEW 
Release Notes for standard LabVIEW installation instructions.

http://digital.ni.com/express.nsf/express?openagent&code=pdaversion
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3. Install the Mobile Module. The Mobile Module includes Microsoft 
tools, such as Microsoft ActiveSync on Windows XP/2000 and ARM 
emulators for Windows Mobile. Some of these Microsoft tools might 
interfere with any existing installations of Visual Studio, Windows 
Embedded, or Windows CE toolkits.

Note (Windows XP/2000) The Mobile Module installs ActiveSync 4.2 if you do not already 
have ActiveSync 4.2 or later installed. The Mobile Module works with ActiveSync 4.2 
or later.

4. Activate the Mobile Module.

You must activate the Mobile Module before you can build VIs into 
Mobile applications. The Mobile Module runs in evaluation mode if 
you do not activate it. In evaluation mode, you can create VIs, but any 
Mobile applications you build run only for five minutes. You have the 
option of activating the Mobile Module at the end of the installation. 
You also can use the NI License Manager, available by selecting 
Start»All Programs»National Instruments»NI License Manager, 
to activate National Instruments products. Refer to the National 
Instruments License Manager Help, available by selecting 
Help»Contents in the National Instruments License Manager, 
for more information about activating NI products.

5. Restart the computer when the installer completes.

6. (Windows Vista) You must install Windows Mobile Device Center 
to use the Mobile Module. Refer to the Microsoft Web site at 
www.microsoft.com to download Windows Mobile Device Center.

7. Install the additional tools you need. Refer to the Installing Additional 
Tools section for more information about additional tools.

Uninstalling the Mobile Module
In addition to uninstalling the Mobile Module, you also must uninstall the 
following:

• (Windows XP/2000) Microsoft ActiveSync

• Microsoft Device Emulator version 1.0 – ENU

• Microsoft Visual C++ 2005 Redistributable

http://www.microsoft.com
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Installing Additional Tools
You must install additional tools on the target depending on the 
functionality you need.

Shared Variable Support
To use front panel data binding and Shared Variable nodes in Mobile 
applications, you must install the latest version of shared variable support 
on the target.

Complete the following steps to install or uninstall support for shared 
variables on a Mobile target.

1. Connect the device to the host computer using ActiveSync/FTP.

2. Navigate to and run labview\PDA\Utilities\Variables\
PocketPC\Setup.exe.

Tip You also can right-click the target in the Project Explorer window and select 
Install»Support for Shared Variables from the shortcut menu.

(ARM Emulators) You also must install Virtual PC 2007 on the host 
computer. Download the appropriate installer from the Microsoft 
Download Center at www.microsoft.com/downloads.

PNG Image Support
You must install support for PNG images on the target if the VI contains 
PNG images on the user interface.

Complete the following steps to install or uninstall support for PNG images 
on a Mobile target.

1. Connect the device to the host computer using ActiveSync/FTP.

2. Navigate to and run labview\PDA\Utilities\LVPNG\
PocketPC\Setup.exe.

Tip You also can right-click the target in the Project Explorer window and select 
Install»Support for PNG Images from the shortcut menu.

http://www.microsoft.com/downloads
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NI-VISA Support
You must install NI-VISA on the target to use VISA in Mobile 
applications. If you did not install NI-VISA when you installed the Mobile 
Module, select Start»All Programs»National Instruments»VISA»
Windows Mobile Driver Installation to install NI-VISA.

Tip You also can right-click the target in the Project Explorer window and select 
Install»Support for NI-VISA from the shortcut menu.

WIDCOMM Bluetooth DLLs
You can use the WIDCOMM Bluetooth DLLs on a Mobile device to run 
applications that use Bluetooth communication if you do not have the 
Microsoft Bluetooth driver. 

Note The Mobile Module supports the WIDCOMM BTW-CE 1.4 or later driver. Do not 
install the WIDCOMM Bluetooth DLLs if you are using the Microsoft Bluetooth driver 
or you receive an error when you use the Bluetooth VIs and functions. If your device uses 
the Broadcom Bluetooth driver, install the LabVIEW WIDCOMM Bluetooth driver by 
manually copying LVBtw.dll from the labview\PDA\Utilities\Bluetooth 
directory to the Windows directory. Do not run Setup.exe and do not copy 
BtCoreIf.dll or BtSdkCE30.dll if they already exist on the device.

Complete the following steps to install the WIDCOMM Bluetooth DLLs.

1. Connect to ActiveSync on the host computer.

2. On the host computer, run labview\PDA\Utilities\Bluetooth\
Setup.exe to install the DLLs on the device.

Tip You also can right-click the target in the Project Explorer window and select 
Install»Support for WIDCOMM Bluetooth from the shortcut menu.

Refer to README.txt, located in the labview\PDA\Utilities\
Bluetooth directory, for more information about manually installing the 
WIDCOMM Bluetooth DLLs.

LabVIEW SMS Client
You must install and run the LabVIEW SMS Client, which is located in 
labview\PDA\Utilities\SMS\Setup.exe, on the host computer to 
receive Short Message Service (SMS) messages or to use the Request 
Make Call VI. The LabVIEW SMS Client notifies the Mobile application 
if there is an incoming SMS message and stores the incoming message 
in LVSMSClient.dat, which is located in the \Program Files\
National Instruments\labview\SMS directory on the target.
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Complete the following steps to install or uninstall the 
LabVIEW SMS Client on a Mobile target.

1. Perform a soft reset on the device. Refer to your device documentation 
for information about performing soft resets.

2. Connect the device to the host computer using ActiveSync.

3. Run Setup.exe on the host computer to install or uninstall the 
required DLLs.

You also can right-click the target in the Project Explorer window and 
select Install»Support for SMS Client from the shortcut menu.

Emulators for Windows Mobile
Emulators are tools you can use during development to run and test Mobile 
VIs quickly without having to download the application to the target.

ARM Emulators
If you are using ARM-based emulators, you must install Virtual PC 2007.

(Windows Vista) If you want to use emulators on host computers that use 
Windows Vista, you must download the Microsoft Device Emulator 2.0.

Download Virtual PC 2007 and the Microsoft Device Emulator 2.0 from 
the Microsoft Download Center at www.microsoft.com/downloads.

x86 Emulators
On host computers with Windows XP/2000, the Mobile Module installs 
ARM targets for Windows Mobile and Pocket PC, including emulators. 
If you need x86 emulator targets, install the following Microsoft eMbedded 
Visual Tools:

• Microsoft eMbedded Visual C++ 4.0

• Microsoft eMbedded Visual C++ SP 4 or later

• SDK for Windows Mobile 2003-based Pocket PCs

Refer to the National Instruments KnowledgeBase at ni.com/info and 
enter the info code pdaevc for the most recent information about 
downloading and installing the Microsoft eMbedded Visual Tools.

http://www.microsoft.com/downloads
http://www.ni.com/info
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What’s New
Refer to the LabVIEW Upgrade Notes, available by selecting Start»
All Programs»National Instruments»LabVIEW»LabVIEW Manuals 
and opening LV_Upgrade_Notes.pdf, for more information about new 
features and changes in the LabVIEW development system.

Refer to the Mobile Module book on the Contents tab of the LabVIEW 
Help, available by selecting Help»Search the LabVIEW Help in 
LabVIEW, for more information specific to the Mobile Module and Mobile 
applications.

Refer to the Mobile Module Readme file, available by selecting Start»
All Programs»National Instruments»LabVIEW 8.6»Readme and 
opening readme_Mobile.html for known issues.

The LabVIEW 8.6 Mobile Module includes the following enhancements 
and features.

Smartphone Key Navigation
You can use the arrow keys on a smartphone to navigate the controls or 
indicators in Mobile VIs. Set the tab order of all front panel controls and 
indicators on the front panel interface to enable key navigation.

The right and down arrow keys move the focus to the next item in the tab 
order list. The up and left arrow keys move the focus to the previous item 
in the tab order. For some controls, the arrow keys can increment or 
decrement the control. For example, if the control is a vertical slide control, 
the up and down arrow keys adjust the slide control and the left and right 
arrow keys move to the previous or next item in the tab order. If the control 
is a horizontal slide control, the left and right arrow keys adjust the control 
and the up and down arrow keys move to the previous or next item in the 
tab order.

New VIs and Functions
Refer to the LabVIEW Help for more information about the new and newly 
supported VIs and functions.

In Place Element Structure Support
The In Place Element structure is now supported. The In Place Element 
structure controls how the LabVIEW compiler performs certain operations 
and, in some cases, increases memory and VI efficiency.
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Synchronization Functions Support
The following new Synchronization functions are supported:

• Lossy Enqueue Element

• Wait on Notification from Multiple and Notifier History

• Wait on Notification with Notifier History

New Front Panel Control
Multicolumn listboxes are now supported. The Top Left Visible Cell 
property sets and returns only the top row element of the cluster.

New VI-Specific Code Generation Options
You can now optimize subVI calls and inline subVIs into callers, which can 
eliminate overhead and increase code optimization.

• Optimize subVI calls—Generates C code for subVI calls with as little 
default data initialization as possible. You cannot debug a VI with 
optimized subVI calls.

• Allow inlining—Allows inlining of subVIs into callers. Inlining 
subVIs is most useful for small subVIs, VIs with many calls in a loop, 
or subVIs with only one call site. The default is True. This option only 
allows inlining. To actually inline a subVI, you must select True from 
the Inline subVI pull-down menu on the Source File Settings page in 
the Build Specification dialog box.

To set code generation options for a VI, select File»VI Properties from the 
front panel window or block diagram window to open the VI Properties 
dialog box. Select C Code Generation Options from the Category 
pull-down menu. You can select From project, True, or False. Select 
True to enable the option and False to disable it. The default is From 
project, so you only need to set the options in VI Properties if you want to 
override the code generation settings in the project.

New Project-Level Code Generation Options
You now can allocate constants for arrays, clusters, strings, variants, and 
waveforms with build options on the Application Information page in the 
Build Specification Properties dialog box.
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Using stack variables overrides constant allocation. If you place a 
checkmark in the Use stack variables checkbox, Allocate constants is 
always First Use and Deallocate constants is always Out of Scope. 
First Use and Out of Scope was the default behavior in previous versions.

• Allocate constants—Specifies when LabVIEW allocates memory for 
constants.

– First Use—Allocates memory the first time you use constants on 
the block diagram.

– Containing Loop—Allocates memory outside of the loop that 
contains constants.

– VI Initialization—Allocates memory when the VI that contains 
the constants is called.

– Application Initialization—Allocates memory when the built 
application begins running on the target.

• Deallocate constants—Specifies when LabVIEW frees memory 
resources for constants.

– Out of Scope—Frees memory resources when the constants 
are no longer used.

– VI End—Frees memory resources when a VI containing 
constants finishes executing.

– Application End—Frees memory resources when the built 
application finishes executing on the target.

Fixed-Point Support
The fixed-point data type has limited support.

Note Overflow mode is supported, but overflow status is not supported.

Supported Numeric Functions
The following Numeric functions support the fixed-point data type:

• Absolute Value

• Add

• Decrement

• Increment

• Multiply

• Negate

• Round To Nearest

• Round Toward +Infinity

• Round Toward –Infinity
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• Scale By Power Of 2 Function

• Sign

• Subtract

• Square

Comparison Functions
The following Comparison functions support the fixed-point data type:

• Equal?

• Equal To 0?

• Greater Or Equal?

• Greater Or Equal To 0?

• Greater?

• Greater Than 0?

• Less Or Equal?

• Less Or Equal To 0?

• Less?

• Less Than 0?

• Not Equal?

• Not Equal To 0?

Conversion Functions
The following Conversion functions support the fixed-point data type:

• Boolean Array To Number

• Number To Boolean Array

• To Byte Integer

• To Double Precision Float

• To Extended Precision Float

• To Fixed-Point

• To Long Integer

• To Quad Integer

• To Single Precision Float

• To Unsigned Byte Integer

• To Unsigned Long Integer
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• To Unsigned Quad Integer

• To Unsigned Word Integer

• To Word Integer

Data Manipulation Functions
The following Data Manipulation functions support the fixed-point data 
type:

• Flatten To String

• Logical Shift

• Rotate Left With Carry

• Rotate Right With Carry

• Type Cast

• Unflatten From String

String/Number Conversion Functions
The following String/Number Conversion functions support the 
fixed-point data type:

• Decimal String To Number

• Fract/Exp String To Number

• Hexadecimal String To Number

• Number To Decimal String

• Number To Engineering String

• Number To Exponential String

• Number To Fractional String

• Number To Hexadecimal String

• Number To Octal String

• Octal String To Number
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Tutorial
Use this tutorial to learn how to use the Mobile Project Wizard to create a 
LabVIEW project and build, run, and debug a Mobile application.

The VI in this tutorial simulates a sine wave with configurable offset and 
frequency values and displays the result in a graph.

Creating the LabVIEW Project
Use LabVIEW projects to group together LabVIEW files and 
non-LabVIEW files, create build specifications for building a Mobile VI 
into an application, and deploy the application to the target. You must use 
a project to build a Mobile VI into an application.

Using the Mobile Project Wizard, complete the following steps to create a 
LabVIEW project, add the target, and add an existing VI to the project.

1. Launch LabVIEW. In the Getting Started window, select Mobile 
Project from the Targets pull-down menu. Click the Go button to 
launch the Mobile Project Wizard.

2. Define the project information as shown in Figure 1.

a. Select New Mobile project, import VI from the Project type 
pull-down menu to create the LabVIEW project using an existing 
VI.

Tip The blank VI project type creates a project with a new Mobile template VI rather than 
importing an existing VI.

b. Specify a project name and the location where you want to save 
the project and the VI in the Project location text box. Save the 
project to a location other than the default location so you do not 
overwrite the shipping example with your changes. The default 
project name is Untitled project.lvproj. For this tutorial, 
name the project Mobile Tutorial.lvproj in the Project 
location text box.
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c. Click the Browse button next to the VI path text box and navigate 
to labview\examples\WindowsMobile\tutorial\
Mobile Tutorial.vi to select the VI to import. Click the OK 
button to add the VI to the project you are creating.

Figure 1.  Defining the Project Information

3. Click the Next button.
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4. Select Windows Mobile 5.0 Pocket PC Emulator from the Device 
type pull-down menu as shown in Figure 2.

Figure 2.  Selecting the Target

5. Click the Next button.
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6. Click the Finish button. Because the Create a build specification 
checkbox contains a checkmark, as shown in Figure 3, the Mobile 
Build Specification Properties dialog box opens. Refer to the 
Creating the Build Specification section for more information about 
creating a build specification.

Figure 3.  Previewing the Project

Creating the Build Specification
Build specifications contain the build settings and code generation options 
to use when you build a Mobile VI into an application. You can create the 
build specification when you create a project or wait until you are ready to 
build the application. You must create a build specification before you can 
build a Mobile VI into an application.

You can have multiple build specifications for the same target. For example, 
you might want one build specification that generates debugging 
information and another build specification that does not generate this extra 
information.

Note This tutorial creates the build specification through the Mobile Project Wizard. You 
also can create a build specification at any time by right-clicking Build Specifications 
under the target in the Project Explorer window and selecting New»Mobile Application 
(EXE) from the shortcut menu.
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Complete the following steps to create a Mobile build specification.

1. Define the settings for the Mobile application as shown in Figure 4. 

a. Enter Mobile Tutorial in the Build specification name text 
box. This is the name that appears under Build Specifications in 
the Project Explorer window. 

b. (Optional) By default, the name of the application is the same as 
the top-level VI. If you do not want to use the top-level VI name 
for the application name, remove the checkmark from the Same 
as top-level VI checkbox and enter a name in the Target 
filename text box.

c. Browse to and select the destination directory for the application 
on the host computer, which is where LabVIEW saves the .exe, 
in the Destination directory text box.

d. Enter the destination directory for the application on the target in 
the Remote path for target application text box.

Figure 4.  Defining the Application Information

Note Although it is common to use the same name for the VI, application, and build 
specification, you are not required to do so.



© National Instruments Corporation 17 Getting Started with the LabVIEW Mobile Module

2. Click the Help button to open the LabVIEW Help and read a 
description of each build setting.

3. Select the Device Information category to view which target and 
processor this build specification applies to.

4. Select the Source Files category to select the source files to include 
when you build the VI into an application. When you use the Mobile 
Project Wizard to create a build specification, LabVIEW automatically 
uses the VI you import as the top-level VI. When you create build 
specifications outside of the wizard, you must manually select the 
top-level VI and click the blue arrow button to move the VI to the 
Top-level VI text box as shown in Figure 5. Mobile applications can 
have only one top-level VI.

Figure 5.  Selecting the Source Files

Note The Source File Settings and Machine Aliases categories are not used in this 
tutorial. You use the Source File Settings page to view and set VI-level code generation 
options. You use the Machine Aliases page to overwrite the default IP address of a target 
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hosting shared variables so you can move the shared variables to a different host without 
rebuilding the application. Refer to the Using Shared Variables (Mobile Module) topic in 
the LabVIEW Help for more information about using shared variables.

5. Select the Generated Files category to view the filenames and paths 
to the files the Mobile Module will generate when you build the VI into 
an application.

6. Click the OK button. The build specification you just created appears 
in the Project Explorer window under the target as shown in Figure 6.

Figure 6.  Project Explorer Window

7. Select File»Save Project in the Project Explorer window to save the 
project. LabVIEW saves any build specifications with the project.

Building the VI into an Application and Deploying
After you develop the VI on the host computer, you build the VI into an 
executable application that you can run on a Mobile target. Pick one of the 
options in the Using the Shortcut Menu section or the Using the Run Button 
section to build, deploy, and run the application.

Click the Run button in the application on the target to start simulating the 
sine wave.
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Note ARM emulators for Windows Mobile require a few minutes to load the OS before 
you see the application running on the emulator target.

Using the Shortcut Menu
Right-click the build specification in the Project Explorer window and 
select one of the following options from the shortcut menu:

• Deploy—Builds the VI into an application, if necessary, and deploys 
the application to the target. This option does not run the application 
automatically.

• Run—Builds the VI into an application, if necessary; deploys the 
application to the target, and runs the application automatically.

• Build—Builds the VI into an application. This option does not deploy 
or run the application automatically.

Using the Run Button
When you run a VI under a Mobile target in the Project Explorer window, 
the Run button behaves differently from when you run a VI under 
My Computer in the Project Explorer window:

• If you want to build, deploy, and run—Click the Run button in a VI 
to build the VI into an application, deploy the application to the target, 
and run the application on the target. LabVIEW prompts you to create 
a build specification if you do not have an existing build specification 
for the VI. If you have multiple build specifications, LabVIEW 
prompts you to select a build specification in the Select a Build 
Specification dialog box. Alternatively, you can specify a default build 
specification by right-clicking a build specification in the Project 
Explorer window and selecting Set as Default from the shortcut 
menu. LabVIEW indicates the default build specification with a green 
square around the build specification glyph in the Project Explorer 
window.

• If you want to build without deploying or running—Press the 
<Ctrl> key while you click the Run button in a VI to build the VI into 
an application without deploying or running the application. 
LabVIEW prompts you to create a build specification if you do not 
have an existing build specification for the VI. If you have multiple 
build specifications, LabVIEW prompts you to select a build 
specification in the Select a Build Specification dialog box. 
Alternatively, you can specify a default build specification by 
right-clicking a build specification in the Project Explorer window 
and selecting Set as Default from the shortcut menu. LabVIEW 
indicates the default build specification with a green square around the 
build specification glyph in the Project Explorer window.
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Closing the Application
Tap the Exit button in the application on the Mobile target to close the 
application.

Debugging the Application
You must create a build specification that enables debugging before you 
can debug a Mobile application. Enabling debugging generates extra 
debugging information and can significantly increase the size of the 
application.

When LabVIEW on the host computer connects to the Mobile target, the 
application runs on the target. The front panel is fully functional on the 
target. However, the front panel controls have no effect on the application, 
and the indicators in the VI on the host computer do not reflect the 
execution of the application on the target.

The block diagram acts as a conduit between the application running on the 
target and the VI running on the host computer, where you can probe 
signals, set breakpoints, and step through code as you do in any other VI.

Tip You can modify an existing build specification by double-clicking the build 
specification in the Project Explorer window or right-clicking the build specification 
and selecting Properties from the shortcut menu. This tutorial creates a second build 
specification for debugging.

Creating a Debugging Build Specification
Complete the following steps to create a debugging build specification.

1. Right-click Build Specifications under the Mobile target and select 
New»Mobile Application (EXE) from the shortcut menu to open the 
Mobile Build Specification Properties dialog box.

2. Enter (Debug) Mobile Tutorial in the Build specification name 
text box.

3. Remove the checkmark from the Same as top-level VI checkbox so 
you can change the application name.

4. Enter (Debug) Mobile Tutorial.exe in the Target filename text 
box.
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5. Place a checkmark in the Enable debugging checkbox to generate 
debugging information when you build the VI into an application as 
shown in Figure 7.

Figure 7.  Creating the Debugging Build Specification

6. Select Source Files from the Category list and select 
Mobile Tutorial.vi in the Project Files list. Click the blue right arrow 
button to move the VI from the source files list to the Top-level VI text 
box.
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7. Click the OK button. The build specification you just created appears 
in the Project Explorer window as shown in Figure 8.

Figure 8.  Two Build Specifications in the Project Explorer Window

Adding a Probe to the VI
Probes display information about the data that passes through a wire. As 
you interact with the application on the target, you can see the data passing 
through the wire in the corresponding VI on the host computer.

Complete the following steps to add a probe to the Mobile Tutorial VI.

1. Select Window»Show Block Diagram in the VI to open the block 
diagram if it is not visible.

The block diagram acts as a conduit between the application running 
on the target and the VI running on the host computer.

Tip Double-click the VI in the Project Explorer window to open the VI if the VI is not 
already open.
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2. Right-click the wire connecting the Frequency control to the For Loop 
and select Probe from the shortcut menu.

A floating Probe window appears when you create a probe. LabVIEW 
numbers the Probe windows automatically and displays the same 
number in a glyph on the wire you probe as shown in Figure 9.

Figure 9.  Adding a Probe to the Block Diagram

Deploying and Debugging a Mobile Application
You must use the debugging build specification to deploy the application, 
which contains debugging information, to the target before the probe in the 
VI on the host computer can update the values passing through the wire.

Complete the following steps to deploy and debug the Mobile application.

1. Right-click the debugging build specification you want to build and 
deploy and select Debug from the shortcut menu. Save any VIs if 
prompted.

LabVIEW builds the VI into an application, deploys the application to 
the target, and runs the application on the target as shown in Figure 10. 
A new instance of the emulator opens each time you build and deploy 
an application.
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Figure 10.  Running the Application on the Emulator

2. Click the Run button in the application on the target.

3. Move the Frequency slider in the application running on the target and 
click the Run button again. The value in the Probe window on the 
block diagram updates as you move the slider in the application on the 
target.

Note Any changes you make on the front panel of the VI on the host computer have no 
effect on the application running on the target.

4. Click the Exit button in the application on the target to stop the 
application and end the debugging session.
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Related Documentation
LabVIEW includes extensive online and print documentation for new 
and experienced LabVIEW users. The following documents contain 
information that you might find helpful as you use the Mobile Module:

• LabVIEW Help—Refer to the LabVIEW Help, available by selecting 
Help»Search in LabVIEW, for information about LabVIEW 
programming concepts, step-by-step instructions for using LabVIEW, 
and reference information about LabVIEW VIs, functions, palettes, 
menus, and tools. Refer to the Mobile Module book on the Contents 
tab of the LabVIEW Help for information specific to the Mobile 
Module and Mobile applications. LabVIEW Help uses (Mobile) in the 
index to indicate Mobile-specific topics.

• Mobile Module Readme—Refer to the Mobile Module Readme file, 
available by selecting Start»All Programs»National Instruments»
LabVIEW 8.6»Readme and opening readme_Mobile.html, 
for last-minute information and known issues.

• Mobile Module Examples—Use the Mobile Module examples to learn 
how to use certain VIs and functions as well as a starting point for 
developing your own VIs and applications. You can modify an 
example to fit an application, or you can copy and paste from one or 
more examples into a VI that you create. Browse or search the example 
VIs with the NI Example Finder by selecting Help»Find Examples. 

• Documentation for your device.

• LabVIEW PDFs—In addition to this document, the Getting Started 
with LabVIEW manual, LabVIEW Quick Reference Card, LabVIEW 
Fundamentals manual, LabVIEW Release Notes, and LabVIEW 
Upgrade Notes are available as PDFs by selecting Start»
All Programs»National Instruments»LabVIEW»LabVIEW 
Manuals.

Note You must have Adobe Reader 6.0.1 or later installed to view or search the PDF 
versions of these manuals. Refer to the Adobe Systems Incorporated Web site at 
www.adobe.com to download Adobe Reader. Refer to the National Instruments Product 
Manuals Library at ni.com/manuals for updated documentation resources.

http://www.adobe.com/
http://sine.ni.com/manuals/
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Where to Go for Support
The National Instruments Web site is your complete resource for technical 
support. At ni.com/support you have access to everything from 
troubleshooting and application development self-help resources to email 
and phone assistance from NI Application Engineers.

National Instruments corporate headquarters is located at 
11500 North Mopac Expressway, Austin, Texas, 78759-3504. 
National Instruments also has offices located around the world to help 
address your support needs. For telephone support in the United States, 
create your service request at ni.com/support and follow the calling 
instructions or dial 512 795 8248. For telephone support outside the United 
States, contact your local branch office: 

Australia 1800 300 800, Austria 43 662 457990-0, 
Belgium 32 (0) 2 757 0020, Brazil 55 11 3262 3599, 
Canada 800 433 3488, China 86 21 5050 9800, 
Czech Republic 420 224 235 774, Denmark 45 45 76 26 00, 
Finland 358 (0) 9 725 72511, France 01 57 66 24 24, 
Germany 49 89 7413130, India 91 80 41190000, Israel 972 3 6393737, 
Italy 39 02 41309277, Japan 0120-527196, Korea 82 02 3451 3400, 
Lebanon 961 (0) 1 33 28 28, Malaysia 1800 887710, 
Mexico 01 800 010 0793, Netherlands 31 (0) 348 433 466, 
New Zealand 0800 553 322, Norway 47 (0) 66 90 76 60, 
Poland 48 22 3390150, Portugal 351 210 311 210, Russia 7 495 783 6851, 
Singapore 1800 226 5886, Slovenia 386 3 425 42 00, 
South Africa 27 0 11 805 8197, Spain 34 91 640 0085, 
Sweden 46 (0) 8 587 895 00, Switzerland 41 56 2005151, 
Taiwan 886 02 2377 2222, Thailand 662 278 6777, 
Turkey 90 212 279 3031, United Kingdom 44 (0) 1635 523545

http://www.ni.com/support/
http://www.ni.com/support/
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