
Getting Started with the 
LabVIEW  PDA Module for 
Windows Mobile
Version 8.2 

The LabVIEW PDA Module extends the LabVIEW graphical development 
environment to PDA devices so you can create PDA applications that run 
on Pocket PC and Windows Mobile devices. Use the PDA Module to build 
applications that run in the smaller memory space common to PDA devices. 
You can create portable solutions for a wide spectrum of applications, such 
as field test systems, remote control and monitoring systems, and portable 
data acquisition systems.

This manual contains new features for version 8.2; system requirements; 
installation instructions; and a tutorial that shows you how to create a 
LabVIEW project and build, run, deploy, and debug a PDA application.
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What’s New in the LabVIEW 8.2 PDA Module
The LabVIEW 8.2 PDA Module features and changes include support for 
shared variables as well as expanded support for front panel controls.

Refer to the LabVIEW Upgrade Notes, available by selecting Start»
All Programs»National Instruments»LabVIEW 8.2»LabVIEW 
Manuals and opening LV_Upgrade_Notes.pdf for more information 
about new features in LabVIEW 8.2.

Refer to the PDA Module book on the Contents tab of the LabVIEW Help, 
available by selecting Help»Search the LabVIEW Help in LabVIEW, for 
more information specific to the PDA Module and PDA applications.

Refer to the PDA Module Readme file, available by selecting Start»
All Programs»National Instruments»LabVIEW 8.2»Readme and 
opening readme_PDA.html for known issues with version 8.2 of the PDA 
Module.

General
• Shared variables—You can use single-process and 

network-published shared variables to share data among VIs in the 
same PDA application or to read data from and write data to other 
network-published shared variables. If you are unfamiliar with using 
shared variables, refer to the LabVIEW Help, available by selecting 
Help»Search the LabVIEW Help, for information about shared 
variables. The PDA Module does not support hosting shared variables. 
Refer to the Using Shared Variables book, available by selecting PDA 
Module»Creating PDA VIs on the Contents tab of the LabVIEW 
Help for more information about using shared variables in PDA VIs.
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• PNG files—You can use transparent .png files in PDA user interfaces 
you build with the PDA Module. The PDA Module does not support 
loading transparent .png files into a picture control. You must install 
support for .png images on the PDA device if the PDA VI contains 
.png images on the front panel. Navigate to and run labview\PDA\
Utilities\LVPNG\Setup.exe to install .png support.

• Bundling and unbundling elements in nested clusters—You now 
can use a single Bundle By Name function to bundle elements into 
nested clusters. You now can use a single Unbundle By Name function 
to unbundle elements from nested clusters.

• Microsoft Bluetooth driver support—You can use the Bluetooth VIs 
and functions with the WIDCOMM or Microsoft Bluetooth driver to 
develop Bluetooth PDA applications. Do not install the WIDCOMM 
Bluetooth DLLs if you have the Microsoft Bluetooth driver. If you use 
the Microsoft Bluetooth driver, the Bluetooth RFCOMM Service 
Discovery VI does not return the service name in the service list 
output. All other outputs in this VI return the correct information.

• Microsoft eMbedded Visual Tools—You no longer need to 
download and install the eMbedded Visual Tools unless you need 
x86 emulator support.

Front Panel Controls and Indicators
• Tree controls—You can use single-column tree controls in PDA user 

interfaces.

• Gauge control—You can use gauge controls in PDA user interfaces.

• Password display support for string controls—PDA VIs support 
password display on string controls and indicators.

• Transparency in Boolean controls—The PDA Module supports 
transparency in front panel Boolean controls that are not based on the 
native Pocket PC and Windows Mobile built-in controls.

• Ring controls—You are no longer restricted to sequential numeric 
values in ring controls. Remove the checkmark from the 
Sequential values checkbox on the Edit Items tab of the 
Ring Properties dialog box to assign a specific numeric value to each 
item in a ring control.

• Scroll bars in tables—Vertical scroll bars on tables are now hidden in 
PDA applications if you hide scroll bars in the PDA VI.

• Current VI’s Path function—If you use the Current VI’s Path 
function, which is unsupported in PDA VIs, you now receive a broken 
Run button.
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Newly Supported VIs and Functions
• Invoke Node—You can use the Invoke Node to invoke a method. The 

PDA Module supports a select collection of methods you can use with 
the Invoke Node. Refer to the Supported Methods topic, available by 
selecting PDA Module»Creating PDA VIs on the Contents tab of 
the LabVIEW Help, for more information about which methods are 
supported in PDA VIs.

• Semaphore VIs—The PDA Module supports the Semaphore VIs. 
Use the Semaphore VIs to limit the number of tasks that can 
simultaneously operate on a shared (protected) resource. You can use 
these VIs when you want certain VIs or parts of a block diagram to 
wait until another VI or part of a block diagram is finished with the 
execution of a critical section of code.

• VISA support—You can use the VISA VIs and functions in PDA VIs 
instead of the Serial Compatibility VIs if you install the VISA driver, 
which is available by selecting Start»All Programs»National 
Instruments»VISA»Windows Mobile-CE Driver Installation. The 
target must have a serial port to use the serial VISA VIs and functions. 
The target must be USB host-enabled to use the VISA USB VIs.

Deprecated VIs
The following VIs have been deprecated in version 8.2 of the PDA Module:

• Configure PDA XY Scales—Use a Property Node with the Range, 
Range:Maximum, and Range:Minimum properties instead.

• PDA Set Listbox Strings—Use a Property Node with the Item Names 
property instead.

• PDA Set Ring Strings—Use a Property Node with the Strings [] 
property instead.

• Read PDA XY Scales—Use a Property Node with the 
Mapping Mode, Range:Maximum, and Range:Minimum properties 
instead.

• Show or Hide Control—Use a Property Node with the Visible 
property instead. 

Note Deprecating these VIs does not break existing PDA VIs that use them.
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System Requirements
The PDA Module has the following requirements:

• A desktop computer with Windows 2000 with Service Pack 4.0 or later 
or Windows XP.

• LabVIEW 8.2 Base, Full, or Professional Edition.

• 2.5 GB available disk space.

• A PDA device running Pocket PC 2003 or Windows Mobile 5.0.

Note The PDA Module no longer supports Palm OS.

Refer to the LabVIEW Release Notes, available by selecting Start»
All Programs»National Instruments»LabVIEW 8.2»LabVIEW 
Manuals and opening LV_Release_Notes.pdf, for standard LabVIEW 
development system requirements.

Installing the PDA Module
Complete the following steps to install the PDA Module.

1. On Windows 2000/XP, log in as an administrator or as a user with 
administrator privileges.

2. Install LabVIEW 8.2, if not already installed. Refer to the LabVIEW 
Release Notes, available by selecting Start»All Programs»National 
Instruments»LabVIEW 8.2»LabVIEW Manuals and opening 
LV_Release_Notes.pdf, for standard LabVIEW installation 
instructions.

3. Install the PDA Module.

The PDA Module includes Microsoft ActiveSync and ARM Windows 
Mobile emulators. Installing the PDA Module could interfere with any 
existing installations of Visual Studio, Windows Embedded, or 
Windows CE toolkits.

4. Activate the PDA Module.

You must activate the PDA Module before you can build PDA VIs into 
PDA applications. The PDA Module runs in evaluation mode if you do 
not activate it, which means you can create PDA VIs, but you cannot 
build the PDA VIs into PDA applications. You have the option of 
activating the PDA Module at the end of the installation. You also can 
use the NI License Manager, available by selecting Start»All 
Programs»National Instruments»NI License Manager, to activate 
National Instruments products. Refer to the National Instruments 
License Manager Help, available by selecting Help»Contents in the 
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National Instruments License Manager, for more information about 
activating NI products.

5. Restart the computer when the installer completes.

6. Install the additional tools you need. Refer to the Installing Additional 
Tools section for more information about the additional tools.

Uninstalling the PDA Module
In addition to uninstalling the PDA Module, you also must uninstall the 
following:

• Microsoft ActiveSync

• Microsoft Device Emulator version 1.0 - ENU

• Microsoft Visual C++ 2005 Redistributable

Installing Additional Tools
You must install additional tools depending on the functionality you need.

Shared Variable Support
You must install support for shared variables on the PDA target before you 
can run a PDA application with shared variables.

Complete the following steps to install or uninstall support for shared 
variables on a PDA target.

1. Connect the PDA device to ActiveSync on the host computer.

2. Navigate to and run labview\PDA\Utilities\Variables\
Setup.exe.

You also can right-click the PDA target in the Project Explorer window 
and select Install»Support for Shared Variables from the shortcut menu.

(PDA Emulators) You also must install the Virtual PC Network Driver. 
Download the installer from the Windows Mobile 5.0 Web site at 
www.microsoft.com/windowsmobile.

PNG Image Support
You must install support for PNG images on the PDA target if the PDA VI 
contains PNG images on the user interface.

Complete the following steps to install or uninstall support for PNG images 
on a PDA target.

1. Connect the PDA device to ActiveSync on the host computer.
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2. Navigate to and run labview\PDA\Utilities\LVPNG\
Setup.exe.

You also can right-click the PDA target in the Project Explorer window 
and select Install»Support for PNG Images from the shortcut menu.

WIDCOMM Bluetooth DLLs
You can use the WIDCOMM Bluetooth DLLs on a PDA device to run PDA 
applications that use Bluetooth communication if you do not have the 
Microsoft Bluetooth driver. 

Note The PDA Module supports the WIDCOMM BTW-CE 1.4 or later driver.

Complete the following steps to install the WIDCOMM Bluetooth DLLs.

Note Do not install the WIDCOMM Bluetooth DLLs if you are using the Microsoft 
Bluetooth driver or you receive an error when you use the Bluetooth VIs and functions.

1. Connect to ActiveSync on the host computer.

2. On the host computer, run labview\PDA\Utilities\
Bluetooth\setup.exe to install the DLLs on the PDA device.

Refer to readme.txt, located in the labview\PDA\Utilities\
Bluetooth directory, for more information about manually installing the 
WIDCOMM Bluetooth DLLs.

LabVIEW SMS Client
You must install and run the LabVIEW SMS Client, which is located in 
labview\PDA\Utilities\SMS\Pocket PC\Setup.exe, on the host 
computer to receive Short Message Service (SMS) messages or to use the 
Request Make Call VI. The LabVIEW SMS Client notifies the PDA 
application if there is an incoming SMS message and stores the incoming 
message in LVSMSClient.dat, which is located in the \Program 
Files\National Instruments\labview\SMS directory on the PDA 
target.

Complete the following steps to install or uninstall the 
LabVIEW SMS Client on a PDA target.

1. Perform a soft reset on the PDA target. Refer to your PDA device 
documentation for information about performing soft resets.

2. Connect the PDA target to ActiveSync on the host computer.

3. Run Setup.exe on the host computer to install or uninstall the 
required DLLs.
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You also can right-click the PDA target in the Project Explorer window 
and select Install»Support for SMS client from the shortcut menu.

PDA Emulators
Emulators are useful tools you can use during development to quickly 
run and test PDA VIs without having to download the PDA application to 
the PDA device.

ARM Emulators
If you are using ARM-based emulators, which are the emulators the PDA 
Module installs, you must install the Virtual PC Network Driver. 
Download the installer from the Windows Mobile 5.0 Web site at 
www.microsoft.com/windowsmobile.

x86 Emulators
The PDA Module installs ARM Pocket PC and Windows Mobile targets, 
including the emulators. If you need x86 emulator targets, install the 
following Microsoft eMbedded Visual Tools:

• Microsoft eMbedded Visual C++ 4.0

• Microsoft eMbedded Visual C++ SP 4 or later

• SDK for Windows Mobile 2003-based Pocket PCs

Refer to the National Instruments KnowledgeBase at ni.com/info and 
enter the info code pdaevc for the most recent information about 
downloading and installing the Microsoft eMbedded Visual Tools.

Tutorial
Use this tutorial to learn how to create a LabVIEW project and build, run, 
and debug a PDA application.

The VI in this tutorial simulates a signal, computes the averaged auto power 
spectrum of the signal, and displays the result in a graph.

Tip You also can use the PDA Project Wizard to create the project, the PDA target, and 
the PDA build specification. Refer to the Creating a Project Using the PDA Project Wizard 
topic in the LabVIEW Help, available by selecting Help»Search the LabVIEW Help, for 
information about the PDA Project Wizard.
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Creating the LabVIEW Project
Use LabVIEW projects to group together LabVIEW files and 
non-LabVIEW files, create build specifications for building a PDA VI into 
a PDA application, and deploy the PDA application to a PDA device or 
emulator. You must use a project to build a PDA VI into a PDA application.

Complete the following steps to create a LabVIEW project, add a PDA 
target, and add an existing PDA VI to the project.

1. Launch LabVIEW. In the Getting Started window, select Empty 
Project to open an empty LabVIEW project in the Project Explorer 
window as shown in Figure 1. LabVIEW creates an empty project with 
a Windows target, shown in Figure 1 as My Computer.

Figure 1.  Project Explorer Window
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2. Right-click the project, which is Project:Untitled Project 1 in 
Figure 1, in the Project Explorer window and select New»Targets 
and Devices from the shortcut menu to open the Add Targets 
and Devices dialog box as shown in Figure 2.

Figure 2.  Add Targets and Devices Dialog Box
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3. Expand the PDA folder and select Windows Mobile 5.0 Pocket PC 
Emulator as shown in Figure 3.

Note You might see additional Pocket PC and/or Windows Mobile targets if you configure 
additional devices through the Microsoft Device Emulator Manager.

Figure 3.  Adding a New Device
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4. Click the OK button to add the target to the project. The target appears 
in the Project Explorer window as shown in Figure 4.

Figure 4.  Adding the Windows Mobile 5.0 Pocket PC Emulator 
to the Project Explorer Window

5. Expand the PDA target. In Figure 5, the PDA target is Windows 
Mobile 5.0 Pocket PC Emulator. LabVIEW automatically adds 
Dependencies and Build Specifications under the target. SubVIs 
appear under Dependencies when you add a VI that contains subVIs 
to a project. Build specifications you create for a target in a project 
appear under Build Specifications in the Project Explorer window. 
Refer to the Creating the PDA Build Specification section for more 
information about creating a build specification.

Figure 5.  Expanding the PDA Target in the Project Explorer Window

6. Right-click the PDA target and select Add File from the shortcut menu 
to open a file dialog box.
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7. Add the PDA Tutorial - Pocket PC VI to the project by navigating to 
labview\examples\PDA\PocketPC\tutorial and selecting 
PDA Tutorial - Pocket PC.vi. Click the Add File button to add 
the VI to the project. The VI appears in the Project Explorer window 
under the PDA target as shown in Figure 6.

Figure 6.  Adding a VI to the Project

8. Double-click the VI in the Project Explorer window to open the VI.

Creating the PDA Build Specification
Build specifications contain the build settings and code generation options 
to use when you build a PDA VI into a PDA application. You can create 
the build specification when you create a project or wait until you are ready 
to build the PDA VI into a PDA application.

You can have multiple build specifications for the same target. For example, 
you might want one build specification that generates debugging 
information and another build specification that does not generate this extra 
information.

Complete the following steps to create a build specification.

1. Right-click Build Specifications under the PDA target and select 
New»Application (EXE) from the shortcut menu.

2. LabVIEW prompts you to save the project. Click the Save button when 
prompted and save the project as PDA Tutorial - Pocket PC.

3. Click the Help button to open the LabVIEW Help and read a 
description of each build setting.
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4. Enter PDA Tutorial - Pocket PC in the Build specification name 
text box as shown in Figure 7. 

Figure 7.  Creating the Build Specification
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5. Select Source Files from the Category list and select 
PDA Tutorial - Pocket PC.vi in the source files list. Click the blue 
right arrow button, shown at left, to move the VI from the source files 
list to the Top-level VI text box as shown in Figure 8.

Figure 8.  Selecting the Top-Level VI for the Build Specification

Note The Machine Alias category is not used in this tutorial. You use the Machine Alias 
category to overwrite the default IP address of a shared variable host target so you can 
move the shared variable to a different host without rebuilding the application. Refer to the 
Using Shared Variables in PDA and Touch Panel VIs topic in the LabVIEW Help for more 
information about using shared variables.

6. Select the Generated Files category to view the filenames and path to 
the files the PDA Module will generate when you build the PDA VI 
into a Touch Panel application.
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7. Click the OK button. The build specification you just created appears 
in the Project Explorer window under the PDA target as shown in 
Figure 9.

Figure 9.  PDA Build Specification in the Project Explorer Window

8. Select File»Save Project in the Project Explorer window to save the 
project. Build specifications are saved with the project.

Building the PDA VI into a PDA Application and Deploying
After you develop the PDA VI on the host computer, you build the PDA VI 
into an executable PDA application that you can run on a PDA target. Pick 
one of the options in the Using the Shortcut Menu section or the Using the 
Run Button section to build, run, and deploy a PDA application.

Note ARM PDA emulators require a few minutes to load the OS before you see the PDA 
application running on the emulator target.

Using the Shortcut Menu
Right-click the build specification and select one of the following from the 
shortcut menu:

• Deploy—Builds the PDA VI into a PDA application, if necessary, and 
deploys the application to the PDA target. This option does not 
automatically run the PDA application.

• Run—Builds the PDA VI into a PDA application, if necessary; 
deploys the application to the PDA target, if necessary; and 
automatically runs the PDA application.

• Build—Builds the PDA VI into a PDA application. This option does 
not deploy or automatically run the PDA application.
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Using the Run Button
The behavior of the Run button differs from LabVIEW for Windows:

• If you want to build, run, and deploy—Click the Run button in a 
PDA VI to build the PDA VI into a PDA application, deploy the PDA 
application to the PDA target, and run the PDA application on the PDA 
target. LabVIEW prompts you to create a build specification if you do 
not have an existing build specification for the PDA VI. If you have 
multiple build specifications, the PDA Module uses the default build 
specification, which the PDA Module indicates with a green square 
around the PDA build specification glyph in the Project Explorer 
window.

• If you want to build without deploying or running—Press the 
<Ctrl> key while you click the Run button in a PDA VI to build the 
PDA VI into a PDA application without deploying or running the PDA 
application. LabVIEW prompts you to create a build specification if 
you do not have an existing build specification for the PDA VI. If you 
have multiple build specifications, the PDA Module uses the default 
build specification, which the PDA Module indicates with a green 
square around the PDA build specification glyph in the Project 
Explorer window.

Closing the PDA Application
Click the Exit button in the PDA application on the PDA target to close the 
PDA application.

Debugging the PDA Application
You must create a build specification that enables debugging before you 
can debug a PDA application. Enabling debugging generates extra 
debugging information and can significantly increase the size of the PDA 
application.

When LabVIEW on the host computer connects to the PDA target, the PDA 
application runs on the PDA target. The front panel is fully functional on 
the PDA target. However, the front panel controls have no effect on the 
PDA application, and the indicators of the PDA VI on the host computer do 
not reflect the execution of the PDA application on the PDA target.

The block diagram acts as a conduit between the PDA application running 
on the PDA target and the PDA VI running on the host computer, where you 
can probe signals, set breakpoints, and step through code as you do in any 
other VI.
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Tip You can modify an existing build specification by double-clicking the build 
specification in the Project Explorer window or right-clicking the build specification and 
selecting Properties from the shortcut menu. This tutorial creates a second build 
specification for debugging.

Creating a Debugging Build Specification
Complete the following steps to create a debugging build specification.

1. Right-click Build Specifications under the PDA target and select 
New»Application (EXE) from the shortcut menu.

2. Enter (Debug) PDA Tutorial - Pocket PC in the Build 
specification name text box.

3. Remove the checkmark from the Same as top-level VI checkbox so 
you can change the PDA application name.

4. Enter (Debug) PDA Tutorial - Pocket PC.exe in the 
Target filename text box.

5. Place a checkmark in the Enable debugging checkbox to generate 
debugging information when you build the PDA VI into a PDA 
application as shown in Figure 10.

 

Figure 10.  Creating the Debugging Build Specification
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6. Select Source Files from the Category list and select 
PDA Tutorial - Pocket PC.vi in the source files list. Click the blue 
right arrow button, shown at left, to move the VI from the source files 
list to the Top-level VI text box.

7. Click the OK button. The build specification you just created appears 
in the Project Explorer window as shown in Figure 11.

Figure 11.  Two PDA Build Specifications in the Project Explorer Window

Adding a Probe to the PDA VI
Probes display information about the data that passes through a wire. As 
you interact with the PDA application on the PDA device, you can see the 
data passing through the wire in the PDA VI on the host computer.

Complete the following steps to add a probe to the PDA VI.

1. Select Window»Show Block Diagram in the VI to open the block 
diagram if it is not visible.

Note Double-click the VI in the Project Explorer window to open the VI if the VI is not 
already open.

The block diagram acts as a conduit between the PDA application 
running on the PDA target and the PDA VI running on the host 
computer.

2. Change the event case in the Event structure to 
“Frequency”: Value Change.
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3. Right-click the wire flowing into the frequency input of the Sine 
Waveform VI and select Probe from the shortcut menu.

A floating Probe window appears after you create a probe. LabVIEW 
numbers the Probe windows automatically and displays the same 
number in a glyph on the wire you probe as shown in Figure 12.

Figure 12.  Adding a Probe to the Block Diagram

Deploying and Debugging a PDA Application
You must use the debug build specification to deploy the PDA VI, which 
contains debugging information, to the PDA device before the probe in the 
PDA VI on the host computer can update the values passing through the 
wire.

Complete the following steps to deploy and debug the PDA application.

1. Right-click the build specification for the PDA VI you want to build 
and deploy, which is (Debug) PDA Tutorial - Pocket PC in 
Figure 11, and select Debug from the shortcut menu. Save any VIs if 
prompted.
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The PDA Module builds the PDA VI into a PDA application, deploys 
the PDA application to the PDA target, and runs the PDA application 
on the PDA target as shown in Figure 13.

Tip You also can start a debugging session by clicking the Step Over or Step Into buttons 
or by clicking the Pause button and then clicking the Run button on the block diagram 
toolbar.

Figure 13.  Running the PDA Application on the PDA Emulator

2. Move the Frequency slider in the PDA application running on the 
PDA target. The value in the Probe window on the block diagram 
updates as you move the slider in the PDA application.

Note Any changes you make on the front panel of the PDA VI on the host computer have 
no effect on the PDA application running on the PDA target.

3. Click the Exit button in the PDA application on the PDA target to stop 
the PDA application and end the debugging session.
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Related Documentation
LabVIEW includes extensive online and print documentation for new and 
experienced LabVIEW users. The following documents contain 
information that you might find helpful as you use the PDA Module:

• LabVIEW Help—Refer to the LabVIEW Help, available by selecting 
Help»Search the LabVIEW Help in LabVIEW, for information 
about LabVIEW programming concepts, step-by-step instructions for 
using LabVIEW, and reference information about LabVIEW VIs, 
functions, palettes, menus, and tools. Refer to the PDA Module book 
on the Contents tab of the LabVIEW Help for information specific to 
the PDA Module and PDA applications. LabVIEW Help uses (PDA) in 
the index to indicate PDA-specific topics.

• PDA Module Readme—Refer to the PDA Module Readme file, 
available by selecting Start»All Programs»National Instruments»
LabVIEW 8.2»Readme and opening readme_PDA.html, for 
last-minute information and known issues with version 8.2.

• LabVIEW PDFs—In addition to this document, the Getting Started 
with LabVIEW manual, LabVIEW Quick Reference Card, LabVIEW 
Fundamentals manual, LabVIEW Release Notes, and LabVIEW 
Upgrade Notes are available as PDFs by selecting Start»All 
Programs»National Instruments»LabVIEW 8.2»LabVIEW 
Manuals.

Note You must have Adobe Reader with Search and Accessibility 5.0.5 or later installed 
to view the PDFs. You must have Adobe Reader with Search and Accessibility 6.x or later 
installed to search PDF versions of these manuals. Refer to the Adobe Systems 
Incorporated Web site at www.adobe.com to download Adobe Reader. Refer to the 
National Instruments Product Manuals Library at ni.com/manuals for updated 
documentation resources.

• Documentation for the PDA target you use.
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Where to Go for Support
The National Instruments Web site is your complete resource for technical 
support. At ni.com/support you have access to everything from 
troubleshooting and application development self-help resources to email 
and phone assistance from NI Application Engineers.

National Instruments corporate headquarters is located at 
11500 North Mopac Expressway, Austin, Texas, 78759-3504. 
National Instruments also has offices located around the world to help 
address your support needs. For telephone support in the United States, 
create your service request at ni.com/support and follow the calling 
instructions or dial 512 795 8248. For telephone support outside the United 
States, contact your local branch office: 

Australia 1800 300 800, Austria 43 0 662 45 79 90 0, 
Belgium 32 0 2 757 00 20, Brazil 55 11 3262 3599, 
Canada 800 433 3488, China 86 21 6555 7838, 
Czech Republic 420 224 235 774, Denmark 45 45 76 26 00, 
Finland 385 0 9 725 725 11, France 33 0 1 48 14 24 24, 
Germany 49 0 89 741 31 30, India 91 80 41190000, 
Israel 972 0 3 6393737, Italy 39 02 413091, Japan 81 3 5472 2970, 
Korea 82 02 3451 3400, Lebanon 961 0 1 33 28 28, 
Malaysia 1800 887710, Mexico 01 800 010 0793, 
Netherlands 31 0 348 433 466, New Zealand 0800 553 322, 
Norway 47 0 66 90 76 60, Poland 48 22 3390150, 
Portugal 351 210 311 210, Russia 7 095 783 68 51, 
Singapore 1800 226 5886, Slovenia 386 3 425 4200, 
South Africa 27 0 11 805 8197, Spain 34 91 640 0085, 
Sweden 46 0 8 587 895 00, Switzerland 41 56 200 51 51, 
Taiwan 886 02 2377 2222, Thailand 662 278 6777, 
United Kingdom 44 0 1635 523545
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