GETTING STARTED GUIDE
NI High-Speed Digitizers

This document explains how to install, configure, and test NI high-speed
digitizers, and how to begin programming them using the NI-SCOPE
instrument driver software. This document applies to the following digitizers:
NI 5102, NI 5105, NI 5112, NI 5114, NI 5122, NI 5124, NI 5142, NI 5620,
NI 5621, NI 5911, and NI 5922.

For more information on features and programming, refer to the

NI High-Speed Digitizers Help. For NI high-speed digitizer specifications,
refer to the specifications document included with your digitizer. Both
documents are available at Start»Programs»National Instruments»
NI-SCOPE»Documentation.

For the most current versions of documentation, visit ni . com/manuals.
For the latest version of NI-SCOPE, visit ni .com/idnet.
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Conventions

The following conventions are used in this manual:

» The » symbol leads you through nested menu items and
dialog box options to a final action. The sequence File»
Page Setup»Options directs you to pull down the File
menu, select the Page Setup item, and select Options
from the last dialog box.

* The ¢ symbol indicates that the following text applies
only to a specific product, a specific operating system,
or a specific software version.

This icon denotes a tip, which alerts you to advisory
information.

information.

This icon denotes a caution, which advises you of
precautions to take to avoid injury, data loss, or a
system crash.

@ This icon denotes a note, which alerts you to important

bold Bold text denotes items that you must select or click in the
software, such as menu items and dialog box options.

italic Italic text denotes emphasis or a cross reference.
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monospace  Text in this font denotes text or characters that you should
enter from the keyboard, sections of code, programming
examples, and syntax examples. This font is also used for
disk drives, paths, directories, filenames, and extensions.

monospace  Bold textin this font denotes the messages and responses that

bold the computer automatically prints to the screen. This font
also emphasizes lines of code that are different from the
other examples.

monospace  Italic text in this font denotes text that is a placeholder for a
italic word or value that you must supply.

1. Verifying System Requirements

To use NI high-speed digitizers with NI-SCOPE, your system must meet the
listed Minimum System requirements and must have one of the listed
operating systems installed. For optimal performance, your system should
meet the Recommended System requirements. If you are developing
applications, you need one of the listed Application Development
Environments (ADEs) and its documentation.

Minimum System

¢ Pentium 200 MHz or equivalent processor
¢ 64 MB RAM
¢ Microsoft Internet Explorer 5.5 or later

e Screen resolution of 800 x 600 with 256 colors—required for Scope
Soft Front Panel (SFP)

¢ Windows 2000/XP with all available critical updates and service
packs installed

Recommended System

¢ Pentium III/Celeron 600 MHz or equivalent processor
e 256 MB RAM

*  Microsoft Internet Explorer 5.5 or later

e Screen resolution of 1024 x 768 with 256 colors

¢ Windows 2000/XP with all available critical updates and service
packs installed
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Application Development Environments
e LabVIEW 7.0 or later (LabVIEW 7.1 or later is required to use the
NI-SCOPE Express VI)

¢ LabVIEW Real-Time Module 7.1 or later (SMC-based PXI modules
only)

e LabWindows™/CVI™ 7.0 or later

e Measurement Studio 6.0 or later

¢ Microsoft Visual C++ (MSVC) 6.0 or later
e Microsoft Visual Basic 6.0

@ Note Ifyou use the Scope SFP to interactively control the digitizer,
an ADE is not required. The Scope SFP is included on the
NI-SCOPE CD.

2. Unpacking

NI high-speed digitizers are shipped in an antistatic bag to protect them from
electrostatic discharge (ESD). Prior to removing the digitizer from the bag,

touch the antistatic bag to a metal part of the chassis to remove any built up
static charge.

A Caution When handling the digitizer, make sure that you are
grounded with a grounding strap or you are touching a grounded
metal object. Handle the digitizer carefully to avoid touching any
exposed pins or electronic circuitry.

Remove the digitizer from the package, remove the packing foam and rubber
screw covers (PXI devices only), and inspect the digitizer for loose
components or any sign of damage. Notify NI if the digitizer appears
damaged in any way. Do not install a damaged digitizer into your computer
or chassis.

Store the digitizer in the antistatic bag when not in use.
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3. Verifying the Kit Contents

The following items are included in the NI high-speed digitizer kit:

U One of the following NI high-speed digitizers.

Table 1. NI High-Speed Digitizers

Traditional NI-DAQ (Legacy) Devices SMC-Based Devices
NI PXI/PCI-5102 NI PXI-5105
NI PXI/PCI-5112 NI PXI/PCI-5114
NI PXI-5620 NI PXI/PCI-5122
NI PXI-5621 NI PXI/PCI-5124
NI PCI-5911 NI PXI/PCI-5142
NI PXI/PCI-5922

@ Note Legacy devices are those devices that are configurable in
MAX under Traditional NI-DAQ (Legacy) Devices. SMC-based
devices are based on the National Instruments Synchronization and
Memory Core (SMC) architecture. SMC-based devices are
configurable in MAX under NI-DAQmx Devices. Refer to the NI
High-Speed Digitizers Help for more information.

U NI-SCOPE instrument driver DVD-sized case, which contains the
following:

— NI-SCOPE driver software CD
— NI-SCOPE Instrument Driver Quick Reference
— NI High-Speed Digitizers Getting Started Guide

U Other included items:
—  The specifications document for the digitizer
— Read Me First: Safety and Radio-Frequency Interference

—  Maintain Forced-Air Cooling Note to Users (SMC-based devices
only)

— NI Spectral Measurements Toolkit CD (SMC-based devices with
memory options higher than 8 MB only)

© National Instruments Corporation 5 NI High-Speed Digitizers Getting Started Guide



Other Required ltems

In addition to the items contained in the kit, you need the following:
U 1/8 in. flat-head screwdriver

¢ For PXI Devices

¢ A PXI chassis, a PXI/SCXI combination chassis, or a
PXI/CompactPCI chassis—with a controller and the chassis
documentation

@ Note If your application uses NI-TClk synchronization, you must
use a PXI chassis. Refer to NI High-Speed Digitizers Help»
Programming»NI-TClk Synchronization Help for more
information.
¢ For PCI Devices

* A desktop computer and its documentation

4. Installing the Software

Caution Make sure you install the software before you install the
hardware.

To install the software, complete the following steps:

1. If you are using an ADE such as LabVIEW or if you are using a
third-party tool, install it now. You must install the ADE before installing
the NI-SCOPE instrument driver.

2. Install NI-SCOPE by inserting the NI-SCOPE CD into the CD drive and
clicking Install Software in the displayed window.

@ Note If the installation window does not appear automatically,
navigate to the CD drive and double-click setup. exe.

3. If you are using a system running the LabVIEW Real-Time Module,
download NI-SCOPE to the target using Measurement & Automation
Explorer (MAX). For more information, refer to the Measurement &
Automation Explorer Remote Systems Help by selecting Help»Help
Topics»Remote Systems in MAX.
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9. Installing the Hardware

This section describes how to install hardware for PXI and PCI platforms.

@ Note You must install the software before you install the hardware.

To prevent damage to the device caused by ESD or contamination, handle the
device using the edges or the metal bracket. Refer to the Read Me First:
Safety and Radio Frequency Interference document for more information.

Caution  You must power off and unplug your PC or chassis before
installing the hardware.

PXI Modules

NI PXI modules are sensitive instruments that should be handled carefully.
Do not expose the module to temperatures or humidity beyond the rated
maximums. Keep the module free of dust by cleaning with compressed

air only. Do not clean the device with any solvents or liquids.

You can install PXI modules in any PXI slot marked with a peripheral slot
compatibility glyph (a circle containing the slot number).

To install a PXI module, complete the following steps:

1. Power off and unplug the PXI chassis before installing a PXI module.

2. Ifthe PXI chassis has multiple fan speed settings, make sure that the fans
are set to high.

3. Position the PXI chassis so that inlet and outlet vents are not obstructed.
For more information, refer to the chassis documentation.

4. Make sure that the ejector handle is in the unlatched (downward)
position.
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5. Holding the PXI module by the ejector handle, slide it into an empty slot.
Make sure that the base engages with the guides in the chassis as shown
in Figure 1.
e
e
1 PXI Chassis 3 Captive Screws
2 NI PXI Device 4 Ejector Handle
Figure 1. PXI Installation
6. Slide the module completely into the chassis and latch it by pulling up on
the ejector handle.
7. Tighten the captive screws at the top and bottom of the module front
panel. Performance may suffer if both screws are not tightened properly.
8. Verify that the PXI chassis fans are operable and free of dust and other
contaminants that may restrict airflow.
9. Before operating the module, cover all empty PXI slots using PXI filler
panels.
10. Plug in and power on the PXI chassis.
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PCI Devices

To install a PCI device, complete the following steps:
1. Power off and unplug the PC.

2. Remove the PC cover.

3. Insert the device into an open PCI slot as shown in Figure 2.

| 1 NI PCI Device 2 PCI Slot 3 PC

Figure 2. PCI Installation

@ Tip To maximize airflow and extend the life of the PCI device,
s leave any adjacent PCI slots empty.

¢ NIPCI-5911

When you install the NI PCI-5911, verify that the BNC connector is
centered in the metal frame of the chassis, as shown in Figure 3. Signal
degradation can occur if the outer shell of the BNC connector touches the
computer chassis. To minimize noise, do not allow the shell of the
BNC connector to touch or lie near the metal on the PC.
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Figure 3. NI 5911 Installation

Multiple NI 5911 devices in the same computer can raise operating
temperatures beyond specification and produce imprecise data.

NI strongly recommends leaving an empty PCI slot between multiple
NI 5911 devices or adding a fan.

4. Secure the device to the PCI chassis with a screw.

Caution It is important to completely screw the device front panel
into the PCI slot, both for mechanical stability and to create a solid
ground connection. Improperly secured devices may affect the
accuracy of the device.

(SMC-based devices only) Some computer manufacturers use a
securing lever made of plastic to secure PCI devices; such a lever is
unacceptable and must be removed. Use the screw provided in the kit
to screw down the digitizer. Otherwise, you must use a different
computer chassis. This caution does not apply to Traditional
NI-DAQ (Legacy) devices.

5. Replace the PC cover.
6. Plug in and power on the PC.
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Caution (SMC-based devices only) Spread-spectrum clocking

A varies the clock signal to spread the timing clock signal over a small
frequency range. Disabling spread-spectrum clocking may affect
the accuracy of device specifications.

7. (SMC-based devices only) Verify that spread-spectrum clocking is
enabled in the PC BIOS. Refer to the PC user documentation for
information about how to verify this setting.

6. Configuring and Testing in MAX

@ Note When you configure your device in MAX, remember that all
SMC-based devices are configured under NI-DAQmx, and are
referred to in MAX as NI-DAQmx devices. However, after you
configure these devices in MAX, you use NI-SCOPE to program

them.

1. Launch MAX.

2. Expand Devices and Interfaces to see the list of installed devices. If you
are using a digitizer with the LabVIEW Real-Time Module, expand
Remote Systems. Find your target IP address or name, expand it, and

then expand Devices and Interfaces.

The configuration tree lists both Traditional NI-DAQ (Legacy) devices
and NI-DAQmx devices, as shown in Figure 4.

Configuration
EI@ Iy System

&3 Data Neighborhood
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=-E3 Devices and Interfares

S-{@@ Traditional MI-DAQ Devices
B NI5911 for PCI (Device &)
R MIS102 for PXI (Device 3)
ER MIS112 for PXI (Device 1)
R MIS411 For PXI (Device 15)
R MI 5620 for PXI (Device 5)
[—]@ MI-DACmx Devices

[+-PX0 PRI System (Unidentified)
|:|---’_},';i Ports {Serial & Parallel)
=-A Scales

[]--@ Software

[]--E IV Drrivers

[]--@ Remote Systems

Figure 4. MAX Configuration Tree
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Note If your device is not listed, press <F5> to refresh. If the device

@ is still not listed, repeat the steps in section 5. Installing the
Hardware. For more information about using MAX, refer to the
help files available within MAX.

@ Tip Refer to Start»Programs»National Instruments»

s LabVIEW<version>»Module Documents»Search the Real-Time
Module Bookshelf for more information about using the
LabVIEW Real-Time Module.

3. Record the device number or device name assigned by MAX. You need
this number when you program your device.

¢ Traditional NI-DAQ (Legacy) Devices—Select the device to see
its properties in the configuration view. The device number appears
in the Value column. By default, the resource name for the device is
DAQ: : n, where n is the device number MAX assigned to your
device. NI-SCOPE devices that are configurable under Traditional
NI-DAQ are not supported by the LabVIEW Real-Time Module.

¢ NI-DAQmx Devices —The assigned device name is appended to the
device in its configuration tree label. For example, after you install
the digitizer, the device configuration tree label may appear as
NI PXI-5122: "Devi1",where Dev1 is the device name. When you
develop your application, the resource name is the device name
assigned by MAX. Only the NI-SCOPE devices that appear under
NI-DAQmx Devices are supported by the LabVIEW Real-Time
Module.

@ Note To avoid modifying existing applications that use a

Traditional NI-DAQ (Legacy) device number, change the assigned
NI-DAQmx device name. To change an NI-DAQmx device name,
right-click on the device, select Rename, and enter the Traditional
NI-DAQ (Legacy) device number used in your application. For
more information about device naming conventions, refer to the
niScope_init function or the niScope Initialize VI at
NI High-Speed Digitizers Help»Programming»References.

4. Perform a self-test on the device to verify installation.

¢ Traditional NI-DAQ (Legacy)—Right-click the device, select
Properties, and click Test Resources. Traditional NI-DAQ does not
have test panels for LabVIEW Real-Time Series products.

¢ NI-DAQmx—Right-click the device and select Self-Test.

A dialog box appears and indicates whether the device has passed
the test.
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@ Note If the device does not pass the self-test, repeat the
instructions in section 5. Installing the Hardware. If the device still
does not pass, visit NI Technical Support at ni . com/support.

5. Run the test panels on the device to verify the signal.

a. Connect a signal to the digitizer and select the appropriate device
parameters for this signal such as range, input limits, sample rate, and
sample mode.

b. Access the test panel.

¢ Traditional NI-DAQ (Legacy)—Click Run Test Panels in the
Properties window.

¢ NI-DAQmx—Right-click the device and select Test Panels.

@ Notes For both types of devices, you can enable triggering by
clicking the Advanced button on the test panel.

All NI digitizers have self-calibration capabilities. You can access
this feature for all NI digitizers programmatically with NI-SCOPE
and your ADE, or you can use the Scope SFP. However, only
NI-DAQmx devices (SMC-based devices) can be self-calibrated
using MAX.

6. Exit MAX when you have finished configuring and testing the digitizer.

Acquiring Data Interactively

Launch the Scope SFP from Start»Programs»National Instruments»
NI-SCOPE»NI-SCOPE Soft Front Panel. The Scope SFP provides
context-sensitive help for its controls.

Acquiring Data Programmatically

You can use NI-SCOPE to begin programming the digitizer in your ADE.
Programming examples for using NI-SCOPE with LabVIEW, CVI, and C
are located at Start»Programs»National Instruments»NI-SCOPE»
Examples.

For more information about programming with NI-SCOPE, refer to the
NI High-Speed Digitizers Help at Start»Programs»National Instruments»
NI-SCOPE»Documentation.
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7. Making Your First Measurement

To begin making measurements with an NI high-speed digitizer, complete the
following steps:

1.
2.

6.

Launch your ADE.

Navigate to Start»Programs»National Instruments»NI-SCOPE»
Examples and open one of the examples. If you are not sure which
example to run, begin with the Getting Started example.

Enter the correct string into the resource name control or parameter.
This string varies depending on whether the digitizer is a Traditional
NI-DAQ device or an NI-DAQmx device. You can refer to any of the
following resources for more information about device names.

e Section 6. Configuring and Testing in MAX
* NI-SCOPE VI Reference Help»niScope Initialize
¢ NI-SCOPE C Function Reference Help»niScope_init

Adjust the parameters, if necessary, to capture the input signal that you
want to acquire.

Connect the signal that you want to acquire to one of the input channels
of the digitizer. Refer to Appendix A: Front Panels for SMC-Based
Devices or Appendix B: Front Panels for Traditional NI-DAQ (Legacy)
Devices for the appropriate connections.

Run the example program.

Appendix A: Front Panels for SMC-Based
Devices

This appendix describes digitizer front panels and signal connections for
SMC-based devices: NI 5105, NI 5114, NI 5122, NI 5124, NI 5142, and
NI 5922.
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NI 5105 Front Panel
Figure 5 shows the NI PXI-5105 front panel.

WiNsTrdmenTs
NI PXI-5105
12-Bit 60 MS/s Digitizer

L]

Figure 5. NI PXI-5105 Front Panels

Table 2 describes the signal connections for the NI 5105.

Table 2. NI 5105 Front Panel Signal Connections

Connector Description Function
CHO-CH7 Standard SMB jack Analog input connection; digitizes
connector data and triggers acquisitions.
PFI 1 Standard SMB jack Multipurpose PFI line for trigger
connector in/out, external clock in, reference
clock in/out, and timebase out.

© National Instruments Corporation
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NI 5114 Front Panels
Figure 6 shows the NI PXI/PCI-5114 front panels. Refer to Figure 8 for the
AUX connector pinout information.

N INSTROMENTS
NI PXI-5114

(e]e)

ACCESS  ACTIVE

CHO

CHO

CH1

TRIG

45V
AUX /0 max
NI PCI-5114

A

Figure 6. NI PXI/PCI-5114 Front Panels

Table 3 describes the signal connections for the NI 5114.

Table 3. NI PXI/PCI-5114 Front Panel Signal Connections

Connector Description Function

CH O, Standard BNC Analog input connection; digitizes data and

CH1 female connector triggers acquisitions.

TRIG Standard BNC External analog trigger connection; signals
female connector on the TRIG connector cannot be digitized.
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Table 3. NI PXI/PCI-5114 Front Panel Signal Connections (Continued)

Connector

Description

Function

CLK IN

Standard SMB
jack connector

Input for an external reference or sample clock
to the digitizer.

AUX 1/0

9-pin mini-circular
DIN connector

Provides access to the multipurpose digital
timing and triggering lines, PFI 0, and PFI 1
(with optional cable). Refer to Figure 8 pinout
information.

NI 5122/5124/5142/5922 Front Panels
Figure 7 shows the NI PXI/PCI-5122/5124/5142/5922 front panels.

®

‘7 NATIONAL
’ INSTRUMENTS

ACCESS ACTIVE

CLKIN

Q,

AUX /0 max

CLK OUT

AN

Figure 7. NI PXI/PCI-5122/5124/5142/5922 Front Panels
Table 4 describes the signal connections for the NI 5122/5124/5142/5922.

© National Instruments Corporation
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Table 4. NI 5122/5124/5142/5922 Front Panel Signal Connections

Connector Description Function

CHO, Standard BNC Analog input connection; digitizes data and

CH1 female connector triggers acquisitions.

TRIG Standard BNC External analog trigger connection; signals
female connector on the TRIG connector cannot be digitized.

CLK IN Standard SMB NI 5122/5124/5142: Input for an external
jack connector reference or sample clock to the digitizer.

NI 5922: Input for an external reference clock
to the digitizer.

CLK OUT | Standard SMB NI 5122/5124/5142: Output for the reference
jack connector or sample clock.

NI 5922: Output for the reference clock.

AUX /O 9-pin mini-circular | Provides access to the multipurpose digital
DIN connector timing and triggering lines, PFI 0, and PFI 1
(with optional cable). Refer to Figure 8 pinout
information.

Figure 8 shows the pin assignments for the 9-pin DIN connector.

@@ e ©
)

1 +5V (Fused) 4 Reserved 7 Reserved
2 GND 5 Reserved 8 Reserved
3 Reserved 6 PFI1 9 PFIO

Figure 8. 9-Pin DIN Connector Pin Assignments for NI 5114/5122/5124/5142/5922
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Appendix B: Front Panels for Traditional NI-DAQ
(Legacy) Devices

This appendix describes digitizer front panels and signal connections for the
following Traditional NI-DAQ (Legacy) devices: NI 5102, NI 5112,
NI 5620/5621, and NI 5911.

NI 5102 Front Panels
The NI 5102 is available for PXI and PCI platforms. This section describes
the front panels and signal connections for both types of NI 5102 digitizers.

¢ NI PXI-5102—Figure 9 shows the NI PXI-5102 front panel. Refer to
Figure 10 for the AUX connector pinout information.

NATIONAL
INSTRUMENTS

NI 5102

Figure 9. NI PXI-5102 Front Panel
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Table 5 describes the signal connections for the NI PXI-5102.

Table 5. NI PXI-5102 Front Panel Signal Connections

Connector Description Function

CH O, Standard BNC Analog input connection; digitizes data and

CH 1 female connector triggers acquisitions.

TRIG Standard BNC External analog trigger connection; signals
female connector on the TRIG connector cannot be digitized.

PFI 1 Standard SMB jack | Multipurpose digital timing and triggering
connector signal.

AUX 9-pin mini-circular | Access to PFI 2 (with optional cable).
DIN connector Refer to Figure 10 for pinout information.

Figure 10 shows the pin assignments for the 9-pin DIN connector on the

NI PXI-5102.

@ ® © ©

1 +5V (Fused) 4 Reserved 7 Reserved
2 GND 5 Reserved 8 Reserved
3 Reserved 6 PFI2 9 Reserved

Figure 10. 9-Pin DIN Connector for NI PXI-5102, NI PXI/PCI-5112, and NI PCI-5911

@ Note The +5 V signalis fused at 1.1 A. However, NI recommends
limiting the current from this pin to 30 mA. The fuse is
self-resetting.

NI High-Speed Digitizers Getting Started Guide

20

ni.com



¢ NI PCI-5102—Figure 11 shows the NI PCI-5102 front panel.

Figure 11. NI PCI-5102 Front Panel

Refer to Table 6 for signal connection information.
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Table 6. NI PCI-5102 Front Panel Signal Connections

Connector Description Function

CHO, Standard BNC Analog input connection; digitizes data and
CH1 female connector | triggers acquisitions.

TRIG Standard BNC External analog trigger connection; signals

female connector

on the TRIG connector cannot be digitized.

Multipurpose digital timing and triggering

PFI 1 Standard SMB
jack connector signal.
PFI 2 Standard SMB Multipurpose digital timing and triggering

jack connector

signal.

5

Note When used as inputs, NI 5102 PFI lines can trigger an

acquisition and/or allow an external sample clock connection.
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NI 5112 Front Panels

Figure 12 shows the NI PXI-5112 and the NI PCI-5112 front panels. Refer to
Figure 10 for the AUX connector pinout information.

.

N7 NATIONAL
PV INSTRUMENTS

NI PXI-5112
100 MHz

Digital Oscilloscope.

@

PFI1

Figure 12. NI PXI/PCI-5112 Front Panels
Table 7 describes the signal connections on the NI PXI/PCI-5112.

Table 7. NI PXI/PCI-5112 Front Panel Signal Connections

Connector Description Function

CH O, Standard BNC Analog input connection; digitizes data and

CH1 female connector triggers acquisitions.

TRIG Standard BNC External analog trigger connection; signals
female connector on the TRIG connector cannot be digitized.

PFI 1 Standard SMB Multipurpose digital timing and triggering
jack connector signal.

AUX 9-pin mini-circular | Access to PFI 2 (with optional cable). Refer
DIN connector to Figure 10 for pinout information.
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NI 5620/5621 Front Panels

Figure 13 shows the NI PXI-5620/5621 front panels.

NATIONAL
VINSTRUMENTS
NI PXI-5620
64 MS/s Digitizer

INPUT

+20 dBm MAX
+2VDC MAX

REF CLK IN

+16 dBm MAX
+10 VDC MAX

TTL (+5 V MAX)

p—

o1

y NATIONAL

INSTRUMENTS
NI PXI-5621
64 MS/s Digitizer

INPUT

50Q
+20 dBm MAX
+3 VDC MAX

REF CLK IN

+20 dBm MAX
+10 VDC MAX

1

TTL (+5 V MAX)

—

Jo |

Figure 13. NI PXI-5620/5621 Front Panels

Table 8 describes the signal connections for the NI 5620/5621.

Table 8. NI 5620/5621 Front Panel Signal Connections

Connector Description Function
INPUT Standard SMA Analog input connection; digitizes data and
female connector | triggers acquisitions.
NI 5620—50 ©, AC coupled.
NI 5621—50 Q, DC coupled.
REF CLK IN Standard SMA 50 Q, 10 MHz, AC coupled reference input.
female connector
PFI 1 Standard SMB External digital trigger connection.
jack connector

NI High-Speed Digitizers Getting Started Guide

24

ni.com



NI 5911 Front Panel

Figure 14 shows the NI 5911 front panel. Refer to Figure 10 for the
PFI 2 (AUX) connector pinout information.
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Figure 14. NI 5911 Front Panel

Table 9 describes the signal connections for the NI 5911.

Table 9. NI 5911 Front Panel Signal Connections

Connector Description Function
CHO Standard BNC female | Analog input connection; digitizes data
connector and triggers acquisitions.
PFI 1 Standard SMB jack Multipurpose digital timing and triggering
connector signal.
PFI 2 (AUX) | 9-pin mini-circular Access to PFI 2 (with optional cable).
DIN connector Refer to Figure 10 for pinout information.

© National Instruments Corporation 25 NI High-Speed Digitizers Getting Started Guide



Appendix C: Troubleshooting

Front Panel ACCESS LED on PXI Module is Off
When PXI Chassis is On

If the ACCESS LED on the digitizer is not lit after you power on the PXI
chassis, a problem may exist with the PXI power rails, a hardware device, or
the LED.

@ Note The LEDs may not light until the device has been configured
in MAX. Before troubleshooting this issue, verify that the device
appears in MAX.

Complete the following steps to troubleshoot this issue:
1. Power off your PXI chassis.
2. Disconnect any signals from the PXI module front panel.

3. Remove the PXI module and inspect for signs of damage. Do not reinstall
a damaged device.

4. Reinstall the PXI module as described in step 5. Installing the Hardware.
5. Power on the PXI chassis.

6. Verify that the device appears in MAX.

7

Reset the device in MAX and perform a self-test. Refer to
step 6. Configuring and Testing in MAX for information on performing
device resets and self-tests in MAX.

8. If the ACCESS LED still fails to light, contact NI Technical Support at

ni.com/support.

Device Does Not Appear in MAX
Complete the following steps if the device does not appear in MAX:

1. Inthe MAX Configuration pane, click Devices and Interfaces to expand
the category.

2. Click Traditional NI-DAQ Devices or NI-DAQmx Devices and press
<F5> to refresh the list of installed devices.

3. [If the device is still not listed, power down the system, verity that the
device is correctly installed, and restart.

4. If the device still does not appear under Devices and Interfaces, contact
NI Technical Support at ni . com/support.
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Device Failed the Self-Test

The MAX self-test performs a brief test of device resources. If the device

does not pass the self-test, complete the following steps:

1. Reboot your system.

2. Launch MAX and perform the self-test again. If the device still fails the
self-test, proceed to step 3.

3. Uninstall and reinstall NI-SCOPE.

If the device still fails the self-test, contact NI Technical Support at
ni.com/support.

Thermal Shutdown Error

I received an over temperature (or thermal shutdown) error, and my device
shut down. What should I do next?

To reenable your device after thermal shutdown, complete the following

steps:

1. Power down the computer or chassis that contains the device.

2. Review the procedure in step 5. Installing the Hardware and make any
necessary adjustments to make sure that your device is effectively
cooled.

3. Power up the computer or chassis.

@ Note The thermal shutdown error is reported until the device has
cooled down to an acceptable operating temperature and has been
successfully reset.

Performance Issues Using MXI Connections

If you are using a MXI interface to control a PXI chassis and you encounter
performance or initialization issues, refer to the MXI documentation to
verify that the MXI interface is properly set up. Software optimization
might be necessary.

¢ MXI-3—For MXI-3 optimization, select Start»Programs»National
Instruments MXI-3»MXI-3 Optimization. Using a MXI-3 connection
without running this application may result in an error message such as
the following:
* maximum amount of time exceeded
¢ internal software error
If the software optimization application is not installed on your system,
use the MXI software CD or the National Instruments Driver CD
included with your kit to install the software. After installation, you may
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¢

need to reboot your computer before running the MXI Optimization
Application.

MXI-4— MXI-4 optimization is performed automatically by the MXI-4
hardware.

If you continue to have initialization or performance issues, refer to the MXI
documentation at Start»Programs»National Instruments MXI, or visit
NI Technical Support at ni . com/support.

Setting Up SMC-Based Devices for Synchronization

@ Note The following step is required for any type of

synchronization involving an SMC-based device, including
NI-TCIk synchronization. For information about NI-TClk
synchronization, refer to NI High-Speed Digitizers Help»
Programming»NI-TClk Synchronization Help.

If you plan to share triggers and/or clocks for the purpose of synchronizing
SMC-based devices (NI 5105/5114/5122/5124/5142/5922), you must
identify or configure certain components in MAX.

L2

For PXI devices, you must identify the PXI system controller by
completing the following steps:

In the MAX configuration tree,
a. Right-click PXI System»Identify As.

b. Select your controller from the list. For example, select External PC
if you are using a MXI controller in an external PC.

Expand the PXI System tree and right-click the name of the chassis you
are using.

For PCI devices, you must configure the RTSI cable by completing the
following steps:

Connect a RTSI cable between the PCI devices to physically share
triggers and/or clocks.

In the MAX configuration tree,
a. Right-click NI-DAQmx Devices.
b. Select Create New NI-DAQmx Device»RTSI Cable.

c. Right-click the RTSI cable, then select the device to add to the RTSI
cable.
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NI 5112 Programming Practices

NI 5112 digitizers contain electromechanical relays that may require special
programming practices to prevent excessive wear. For more information,
refer to the NI High-Speed Digitizers Help»Devices»NI 5112
Overview»Electromechanical Relays.

Appendix D: Where to Go for Support

The National Instruments Web site is your complete resource for technical
support. At ni.com/support you have access to everything from
troubleshooting and application development self-help resources to email
and phone assistance from NI Application Engineers.

A Declaration of Conformity (DoC) is our claim of compliance with the
Council of the European Communities using the manufacturer’s declaration
of conformity. This system affords the user protection for electronic
compatibility (EMC) and product safety. You can obtain the DoC for your
product by visiting ni . com/certification. If your product supports
calibration, you can obtain the calibration certificate for your product at
ni.com/calibration.

National Instruments corporate headquarters is located at

11500 North Mopac Expressway, Austin, Texas, 78759-3504.

National Instruments also has offices located around the world to help
address your support needs. For telephone support in the United States, create
your service request at ni . com/support and follow the calling
instructions or dial 512 795 8248. For telephone support outside the United
States, contact your local branch office:

Australia 1800 300 800, Austria 43 0 662 45 79 90 0,

Belgium 32 0 2 757 00 20, Brazil 55 11 3262 3599, Canada 800 433 3488,
China 86 21 6555 7838, Czech Republic 420 224 235 774,

Denmark 45 45 76 26 00, Finland 385 09 725 725 11,

France 33 0 1 48 14 24 24, Germany 49 0 89 741 31 30,

India 91 80 41190000, Israel 972 0 3 6393737, Italy 39 02 413091,

Japan 81 3 5472 2970, Korea 82 02 3451 3400, Lebanon 961 0 1 33 28 28,
Malaysia 1800 887710, Mexico 01 800 010 0793,

Netherlands 31 0 348 433 466, New Zealand 0800 553 322,

Norway 47 0 66 90 76 60, Poland 48 22 3390150,

Portugal 351 210 311 210, Russia 7 095 783 68 51,

Singapore 1800 226 5886, Slovenia 386 3 425 4200,

South Africa 27 0 11 805 8197, Spain 34 91 640 0085,

Sweden 46 0 8 587 895 00, Switzerland 41 56 200 51 51,

Taiwan 886 02 2377 2222, Thailand 662 278 6777,

United Kingdom 44 0 1635 523545
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