GETTING STARTED GUIDE
NI High-Speed Digitizers

This document explains how to install, configure, and test NI high-speed
digitizers, and how to begin acquiring data. This document applies to
NI 5102, NI 5112, NI 5122/5124, NI 5620/5621, and NI 5911 digitizers.

For more information on features and programming, refer to the

NI High-Speed Digitizers Help at Start»Programs»National Instruments»
NI-SCOPE»Documentation»NI High Speed Digitizers Help.

For NI high-speed digitizer specifications, refer to the specifications
document included with your digitizer.

For the most current versions of documentation, visit ni . com/manuals.
For the latest version of NI-SCOPE, visit ni .com/idnet.
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Conventions

The following conventions are used in this manual:

» The » symbol leads you through nested menu items and
dialog box options to a final action. The sequence File»
Page Setup»Options directs you to pull down the File
menu, select the Page Setup item, and select Options
from the last dialog box.

. The o symbol indicates that the following text applies
only to a specific product, a specific operating system,
or a specific software version.

This icon denotes a tip, which alerts you to advisory
information.

This icon denotes a note, which alerts you to important
information.

This icon denotes a caution, which advises you of
precautions to take to avoid injury, data loss, or a
system crash.

> @

bold Bold text denotes items that you must select or click in the
software, such as menu items and dialog box options.

italic Italic text denotes emphasis or a cross reference.
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monospace  Text in this font denotes text or characters that you should
enter from the keyboard, sections of code, programming
examples, and syntax examples. This font is also used for
disk drives, paths, directories, filenames, and extensions.

monospace ltalic text in this font denotes text that is a placeholder for a
italic word or value that you must supply.

1. Verifying System Requirements

To use an NI high-speed digitizer and NI-SCOPE, your system must meet the
listed Minimum System Requirements and must have one of the listed
operating systems installed. For optimal performance, your system should
meet the Recommended System Requirements. If you are developing
applications, you need one of the listed Application Development
Environments (ADESs) and its documentation.

Minimum System Requirements

¢ Processor: Pentium 200 MHz or equivalent
* RAM: 64 MB
¢ Microsoft Internet Explorer 5.5 or later

e Screen resolution of 640 x 480 with 256 colors—required for Scope Soft
Front Panel (SFP)

Recommended System

¢ Processor: Pentium III/Celeron 600 MHz or equivalent
« RAM: 256 MB
¢  Microsoft Internet Explorer 5.5 or later
e Screen resolution of 640 x 480 with 256 colors—required for Scope SFP
¢ One of the following operating systems:
—  Windows 2000
— Windows NT 4.0 Service Pack 6A
—  Windows XP
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Application Development Environments

e LabVIEW 7.0 or later

¢ LabVIEW Real-Time Module 7.1 or later (NI 5122/5124 only)
e LabWindows™/CVI™ 6.0 or later

¢ Measurement Studio 6.0 or later

¢ Microsoft Visual C++ (MSVC) 6.0 or later

e Microsoft Visual Basic 6.0

@ Note If you use the Scope SFP to interactively control the digitizer,
an ADE is not required. The Scope SFP is included on the
NI-SCOPE CD.

2. Unpacking

NI high-speed digitizers are shipped in an antistatic bag to protect them from
electrostatic discharge (ESD). Prior to removing the digitizer from the bag,
touch the antistatic bag to a metal part of the chassis to remove any built up
static charge.

A Caution When handling the digitizer, ensure that you are grounded
with a grounding strap or touching a grounded metal object. Handle
the digitizer carefully to avoid touching any exposed pins or
electronic circuitry.

Remove the digitizer from the package, remove the packing foam and rubber
screw covers (PXI devices only), and inspect the digitizer for loose
components or any sign of damage. Notify NI if the digitizer appears
damaged in any way. Do not install a damaged digitizer into your computer
or chassis.

Store the digitizer in the antistatic bag when not in use.

3. Verifying the Kit Contents

The following items are included in the NI high-speed digitizer kit:

U One of the following NI high-speed digitizers:
— NI PXI/PCI/USB/PCMCIA/AT-5102 (NI 5102)
— NIPXI/PCI-5112 (NI 5112)
— NI PXI/PCI-5122/5124 (NI 5122/5124)
— NI PXI-5620/5621 (NI 5620/5621)
— NIPCI-5911 (NI 5911)
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U NI-SCOPE instrument driver DVD case, which contains the following:
— NI-SCOPE driver software CD
—  NI-SCOPE Quick Reference
— NI High-Speed Digitizers Getting Started Guide
U Other included items:
— The specifications document for the digitizer
— Read Me First: Safety and Radio-Frequency Interference
— (NI 5122/5124 only)—Maintain Forced-Air Cooling Note to Users

— (NI 5122/5124: 32 MB, 256 MB, and 512 MB memory options
only)—NI Spectral Measurements Toolkit CD

Other Required ltems
In addition to the items contained in the kit, you need the following:

U 1/8 in. flat-head screwdriver

For PXI Devices

L A PXI chassis, a PXI/SCXI combination chassis, or a PXI/CompactPCI
chassis—with a controller and the chassis documentation

@ Note If your application uses NI-TCIlk synchronization, you must
use a PXI chassis. You cannot use a CompactPCI chassis that is not
also a PXI chassis. Refer to NI High-Speed Digitizers Help»
Programming»NI-TCIk Synchronization Help for more
information.

For PCI Devices

aa desktop computer and its documentation

4. Installing the Software

Caution Make sure you install the software before you install the
hardware.

To install the software, complete the following steps:

1. If you are using an ADE or third-party tool, install it now if you have
not already done so.

2. Install NI-SCOPE by inserting the NI-SCOPE CD and clicking
Install Software in the window that appears.
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@ Note If the installation window does not appear automatically,
navigate to the CD drive and double-click setup. exe.

3. Ifyou are using a system running the LabVIEW Real-Time Module,
restart. Download NI-SCOPE to the target using Measurement &
Automation Explorer (MAX). For more information, refer to the
Measurement & Automation Explorer Remote Systems Help by selecting
Help»Help Topics»Remote Systems in MAX.

9. Installing the Hardware

This section describes how to install hardware for the following platforms:
PXI, PCI, PCMCIA, USB, and AT.

@ Note For all platforms, you must install the software before you
install the hardware.

To prevent damage to the device caused by ESD or contamination, handle the
device using the edges or the metal bracket. Refer to the Read Me First:
Safety and Radio Frequency Interference for more information.

Caution You must power off and unplug your PC or chassis before
installing hardware.

Installing PXI Devices

NI PXI devices are sensitive instruments that should be handled carefully.
Do not expose the device to temperatures or humidity beyond the rated
maximums. Keep the device free of dust by cleaning with compressed

air only. Do not clean the device with any solvents or liquids.

You can install PXI devices in any PXI slot marked with a peripheral slot
compatibility glyph (a circle containing the slot number) by completing the
following steps:

1. Power off and unplug the PXI chassis before installing a PXI device.

2. If the PXI chassis has multiple fan speed settings, ensure that the fans are
set to high.

3. Position the PXI chassis so that inlet and outlet vents are not obstructed.
For more information, refer to the chassis documentation.

Ensure that the ejector handle is in the unlatched (downward) position.

5. Holding the device by the ejector handle, slide it into an empty slot,
ensuring that the base card (the card on the left when looking at the front
of the device) engages with the card guides in the chassis, as shown in
Figure 1.
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PXI Chassis 3 Captive Screws
2 NI PXI Device 4 Ejector Handle

Figure 1. PXI Installation
6. Slide the device completely into the chassis and latch by pulling up on
the ejector handle.

7. Tighten the captive screws at the top and bottom of the device front panel.
Performance may suffer if both screws are not tightened properly.

8. Verify that the PXI chassis fans are operable and free of dust and other
contaminants restricting airflow.

9. Before operating the device, cover all empty PXI slots using blank
PXI filler panels.

10. Plug in and power on the PXI chassis.
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NI PXI-5122/5124 Cooling Considerations

A Caution When installing hardware, follow the guidelines in the
Maintain Forced-Air Cooling Note to Users that shipped with the
device to ensure that the device is cooled effectively. If the device
overheats, it shuts down and Measurement & Automation Explorer
(MAX) or NI-SCOPE notifies you with an error message.

To re-enable your device after thermal shutdown, you must perform a hard
reset using one of the following methods:

*  Power down the computer or chassis that contains the digitizer.

OR

¢ Call niScope_ResetDevice or perform a device reset in MAX.
For more information on resetting a device in MAX, go to Help»
Help Topics»NI-DAQmx»Measurement & Automation Explorer
Help NI-DAQmx within MAX.

Review the guidelines in the Maintain Forced-Air Cooling Note to Users
and make any necessary adjustments. The thermal shutdown error is reported
until the device is successfully reset.

Uninstalling PXI Devices

When removing PXI devices from the chassis, ensure that you are grounded
with a grounding strap or are touching a grounded metal surface. To avoid
ESD, do not touch the exposed pins of the PXI connector or any exposed
circuitry on the device. When not in use, PXI devices should be stored in the
antistatic bag to avoid damage.

A Caution During operation, the metal surfaces of PXI devices may
become hot. Be careful when removing the device from the chassis
or when moving it to a different peripheral slot. When removing the

device, hold it by the ejector handle and front panel only.
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Installing PCI Devices

To install a PCI device (NI PCI-5102, NI PCI-5112, NI PCI-5122,
NI PCI-5124, or NI PCI-5911), complete the following steps:

1. Power off and unplug the PC.

2. Remove the PC cover.

3. Insert the device into an open PCI slot, as shown in Figure 2.

| 1 NI PCI Device 2 PCI Slot 3 PC

Figure 2. PCI Installation

@ Tip To maximize airflow and extend the life of the device, leave
s any adjacent PCI slots empty.

¢ NIPCI-5911

When you install the NI PCI-5911, verify that the BNC connector is centered
in the metal frame of the chassis, as shown in Figure 3. Signal degradation
can occur if the outer shell of the BNC connector touches the computer
chassis. Also, to minimize noise, do not allow the shell of the BNC connector

to touch or lie near the metal on a PC.
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Figure 3. NI 5911 Installation

Multiple NI 5911 devices in the same computer can raise operating
temperatures beyond specification and produce imprecise data. NI strongly
recommends leaving an empty PCI slot between multiple NI 5911 devices or
adding a fan.

4. Secure the device with a screw.

Caution It is important to completely screw the device into the
PCI slot both for mechanical stability and to create a solid ground
connection. Improperly secured devices may affect the accuracy of
device specifications.

(NI PCI-5122/5124 only) Some computer manufacturers use a
securing lever made of plastic to secure PCI devices; such a lever is
unacceptable and must be removed. Use the screw provided in the kit
to screw down the NI PCI-5122/5124. Otherwise, you must use a
different computer chassis.

5. Replace the PC cover.

6. Plug in and power on the PC.
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7. (NIPCI-5122/5124 only) Verify that spread-spectrum clocking is
enabled in the PC BIOS. Refer to the PC user documentation for
information about how to verify this setting.

Caution Spread-spectrum clocking varies the clock signal to
spread the timing clock signal over a small frequency range.
Disabling spread-spectrum clocking may affect the accuracy of
the NI PCI-5122/5124 specifications.

NI PCI-5122/5124 Cooling Considerations

Caution When installing hardware, follow the guidelines in the
Maintain Forced-Air Cooling Note to Users that shipped with the
device to ensure that the device is cooled effectively. If the device
overheats, it shuts down and MAX or NI-SCOPE notifies you with
an error message.

To re-enable your device after thermal shutdown, you must perform a hard
reset using one of the following methods:

¢ Power down the computer or chassis that contains the digitizer.

OR

¢ Call niScope_ResetDevice or perform a device reset in MAX.
For more information on resetting a device in MAX, go to Help»Help
Topics»NI-DAQmx»Measurement & Automation Explorer Help
NI-DAQmx within MAX.

Review the guidelines in the Maintain Forced-Air Cooling Note to Users
and make any necessary adjustments. The thermal shutdown error is reported
until the device is successfully reset.
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Installing PCMCIA Devices

To install the NI PCMCIA-5102, complete the following steps:
1. Power off and unplug the laptop.

2. [Install the digitizer as shown in Figure 4.

3. Power on your laptop.

1 Laptop 3 PSH32-C5
2 PCMCIA Socket 4 NI PCMCIA-5102

Figure 4. PCMCIA Installation
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Installing USB Devices

To install the NI USB-5102, complete the following steps:

1. Power down the PC and the NI USB-5102.

2. Connect the USB cable to the PC and the digitizer, as shown in Figure 5.

1 Power Jack 4 NIUSB-5102
2 AC/DC Converter 5 USB Connector (Downstream)
3 AC/DC Plug 6 USB Connector to PC (Upstream)

Figure 5. USB Installation

3. Plug the power cord into the power jack on the NI USB-5102.
Plug the AC/DC plug on the power cord into the power source.
5. Power on the computer.
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Installing AT Devices

To install the NI AT-5102, complete the following steps:

1. Power off and unplug the PC.

2. Remove the PC cover.

3. Insert the NI AT-5102 into an open ISA slot as shown in Figure 6.

1 NIAT-5102 2 PC 3 ISA Slot

Figure 6. NI AT-5102 Installation

. Secure the device with a screw.
5. Replace the PC cover.
Plug in and power on the PC.
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6. Configuring and Testing in MAX

1. Launch MAX.

2. Expand Devices and Interfaces to see the list of installed devices. If you
are using a digitizer with the LabVIEW Real-Time Module, expand
Remote Systems. Find your target IP address or name, expand it, and

then expand Devices and Interfaces.

The configuration tree lists both Traditional NI-DAQ devices and

NI-DAQmx devices, as shown in Figure 7.

Configuration

EI@ Iy System

ﬁ Data Meighborhood

=-E3 Devices and Interfares

S-{@@ Traditional MI-DAQ Devices
B NI5911 for PCI (Device &)
R MIS102 for PXI (Device 3)
ER MIS112 for PXI (Device 1)
R MIS411 For PXI (Device 15)

----- R MI 5620 for PXI (Device 5)

Devi

=g MI-Da

[+-PX0 PRI System (Unidentified)
|:|---’_},';i Ports {Serial & Parallel)

=-A Scales
[]--@ Software
[]--E IV Drrivers
[]--@ Remote Systems

Figure 7. MAX Configuration Tree

5

Note If your device is not listed, press <F5> to refresh. If the device
is still not listed, repeat the steps in section 5. Installing the

Hardware. For more information about using MAX, navigate to the

help files available within MAX.

@ Tip Refer to Start»Programs»National Instruments»
s LabVIEW 7.x»Module Documents»Search the Real-Time
Module Bookshelf for more information about using the

LabVIEW Real-Time Module.

3. Record the device number or device name assigned to the device. You
need this number when programming your device.

¢ Traditional NI-DAQ (NI 5102/5112/5620/5621/5911)—Select
the device to see its properties in the configuration view. The

© National Instruments Corporation
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device number appears in the Value column. When developing
your application, the resource name for the device is DAQ: : n,
where n is the device number MAX assigned to your device. Devices
configurable under Traditional NI-DAQ are not supported by
LabVIEW Real-Time.

NI-DAQmx (NI 5122/5124)—The assigned device name is
appended to the device in its configuration tree label. For example,
after installing the NI 5122/5124, the device configuration tree label
may appear as NI PXI-5122: "Devl", where Dev1 is the device
name. When developing your application, the resource name is the
device name assigned by MAX. Only the devices that appear under
NI-DAQmx are supported by the LabVIEW Real-Time Module.

Note To avoid modifying existing applications that use a
Traditional NI-DAQ device number, change the assigned
NI-DAQmx device name. To change an NI-DAQmx device name,
right-click on the device, select Rename, and enter the Traditional
NI-DAQ device number used in your application. For more
information about device naming conventions, refer to the
niScope_init function at NI High-Speed Digitizers Help»
Programming»NI-SCOPE Function Reference Help.

4. Perform a self-test on the device to verify installation.

*

*

Traditional NI-DAQ—Right-click the device, select Properties,
and click Test Resources. Traditional NI-DAQ does not have test
panels for LabVIEW Real-Time Series products.

NI-DAQmx—Right-click the device and select Self-Test.

A dialog box appears and indicates whether the device has passed the
test.

5

Note If the device does not pass the test, repeat the instructions in
section 5. Installing the Hardware. If the device still does not pass
the test, visit NI Technical Support at ni . com/support.

5. Run the test panels on the device to verify the signal.

a.

Connect a signal to the digitizer, and select the appropriate
parameters such as range, input limits, sample rate, and sample
mode.

Access the test panel.

¢ Traditional NI-DAQ—Click Run Test Panels in the
Properties window.

¢ NI-DAQmx—Right-click the device and select Test Panels.
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@ Notes For both types of devices, you can enable triggering by

6.

clicking the Advanced button on the test panel.

All NI digitizers have self-calibration capabilities. You can access
this feature for all NI digitizers programmatically with NI-SCOPE
and your ADE, or you can use the Scope SFP. However, only the
NI 5122/5124 can be self-calibrated using MAX.

Exit MAX when you have finished configuring and testing the device.

Setting Up NI-DAQmx Devices for Synchronization

@ Note The following step is required for any type of

synchronization involving an NI-DAQmx device, including
NI-TClIk synchronization. For information about NI-TClk
synchronization, refer to NI High-Speed Digitizers Help»
Programming»NI-TClk Synchronization Help.

If you plan to share triggers and/or clocks for the purpose of synchronizing
NI-DAQmx devices (for example, the NI 5122/5124), you must identify or
configure certain components in MAX.

*

For PXI devices, you must identify the PXI system controller by
completing the following steps:

1. Inthe MAX configuration tree,
a. Right-click PXI System»Identify As.

b. Select your controller from the list. For example, select
External PC if you are using a MXI-3 controller in an
external PC.

2. Expand the PXI System tree and right-click the name of the chassis
you are using.

For PCI devices, you must configure the RTSI cable by completing the

following steps:

1. Connect a RTSI cable between the PCI devices to physically share
triggers and/or clocks.

2. Inthe MAX configuration tree,
a. Right-click NI-DAQmx Devices.
b. Select Create New NI-DAQmx Device»RTSI Cable.

c. Right-click the RTSI cable, then select the device to add to the
RTSI cable.
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1. Acquiring Data

You can control your digitizer interactively with the Scope SFP or
programmatically with an ADE using the supplied NI-SCOPE
Interchangeable Virtual Instrument (IVI) driver. The two options for
controlling your digitizer are described in the following sections.

Acquiring Data Interactively

Launch the Scope Soft Front Panel from Start»Programs»National
Instruments»NI-SCOPE»NI-SCOPE Soft Front Panel. The Scope SFP
provides context-sensitive help for using its controls. You also can find more
information in the Scope Soft Front Panel Help.

Acquiring Data Programmatically

You can use NI-SCOPE to begin programming the digitizer in your ADE.
Programming examples for using NI-SCOPE with LabVIEW, CVI, and C
are located at Start»Programs»National Instruments»NI-SCOPE»
Examples.

For more information about programming with NI-SCOPE, refer to the
NI High-Speed Digitizers Help at Start»>Programs»National Instruments»
NI-SCOPE»Documentation.

8. Making Your First Measurement

To begin making measurements with an NI high-speed digitizer, complete the
following steps:

1. Open your ADE.

2. Navigate to the example programs for your ADE and open one of the
examples. If you are not sure which example to choose, begin with the
Getting Started example.

3. Enter the correct string into the resource name control or parameter. This
string varies depending on whether the digitizer is a Traditional NI-DAQ
device or an NI-DAQmx device. You can refer to any of the following
resources for more information about device names.

e Section 6. Configuring and Testing in MAX
* NI-SCOPE VI Reference Help»niScope Initialize
¢ NI-SCOPE C Function Reference Help»niScope_init

4. Adjust the parameters, if necessary, to capture the input signal that you
want to acquire.
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5. Connect the signal that you want to acquire to one of the input channels
of the digitizer. Refer to the Appendix A: Front Panels section for the
appropriate connection.

6. Run the example program.
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Appendix A: Front Panels

This appendix describes digitizer front panels and signal connections.

NI 5102 Front Panels

The NI 5102 is available for five platforms: PXI, PCI, AT, PCMCIA, and
USB. This section describes the front panels and signal connections for each

type of NI 5102 digitizer.

¢ NI PXI-5102—Figure 8 shows the NI PXI-5102 front panel. Refer to

Figure 9 for the AUX connector pinout information.

(D)

NATIONAL
INSTRUMENTS

NI'5102

PFI1

AUX

o,

o,

fe)

s

Figure 8. NI PXI-5102 Front Panel
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Table 1 describes the signal connections for the NI PXI-5102.

Table 1. NI PXI-5102 Front Panel Connector Signals

Connector Description Function

CHO,CH 1 | Standard BNC Analog input connection; digitizes data and
female connector triggers acquisitions.

TRIG Standard BNC External analog trigger connection; signals
female connector on the TRIG connector cannot be digitized.

PFI 1 Standard SMB jack | Multipurpose digital timing and triggering
connector signal.

AUX 9-pin mini-circular | Access to PFI 2 (with optional cable).
DIN connector Refer to Figure 9 for pinout information.

Figure 9 shows the pin assignments for the 9-pin DIN connector on the
NI PXI-5102.

®

®
® @ @

@®

1 +5V (Fused) 4 Reserved 7 Reserved
2 GND 5 Reserved 8 Reserved
3 Reserved 6 PFI2 9 Reserved

Figure 9. 9-Pin DIN Connector for NI PXI-5102, NI PXI/PCI-5112, and NI PCI-5911

@ Note The +5 V signalis fused at 1.1 A. However, NI recommends
limiting the current from this pin to 30 mA. The fuse is
self-resetting.
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¢ NI PCI/AT-5102 Front Panel—Figure 10 shows the NI PCI/AT-5102
front panel.

Ok

(@]
T

® 2(

_U
o
-

©

'U
o
()

Figure 10. NI PCI/AT-5102 Front Panel
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¢ NI PCMCIA-5102 Front Panel—Figure 11 shows the
NI PCMCIA-5102 front panel. Use the cable assembly provided with
your digitizer for the connections on the NI PCMCIA-5102.

ORO RO Rl

CHO CH1 TRIG PFI2@

Figure 11. NI PCMCIA-5102 Front Panel

¢ NI USB-5102 Front Panel—Figure 12 shows the NI USB-5102 front

panel.
Device
Configured
PFl2 PFI1 : : :
WiRsTRUMENTS TRIG CHO CH 1
NI 5102

Figure 12. NI USB-5102 Front Panel
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Table 2 describes the signal connections for all NI 5102 digitizer buses

except PXI.

Table 2. NI PCI/AT/PCMCIA/USB-5102 Front Panel Connector Signals

Connector Description Function

CHO0, CH 1 | Standard BNC Analog input connection; digitizes data and
female connector | triggers acquisitions.

TRIG Standard BNC External analog trigger connection; signals
female connector | on the TRIG connector cannot be digitized.

PFI 1 Standard SMB Multipurpose digital timing and triggering
jack connector signal.

PFI 2 Standard SMB Multipurpose digital timing and triggering
jack connector signal.

@ Note When used as inputs, NI 5102 PFI lines can trigger an
acquisition and/or allow an external sample clock connection.

NI High-Speed Digitizers Getting Started Guide
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NI 5112 Front Panels

The NI 5112 is available for both PXI and PCI buses. Figure 13 shows the
NI PX1I-5112 and the NI PCI-5112 front panels. Refer to Figure 9 for the
AUX connector pinout information.

v NATIONAL
’ INSTRUMENTS

NI PXI-5112
100 MHz
Digital Oscilloscope

G
=~k

C]

PFI 1

l> oIT O

gz :

@
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<
O
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I
o

CAT1

oo
Q)

L]

Figure 13. NI PXI/PCI-5112 Front Panels
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Table 3 describes the signal connections on the NI PXI/PCI-5112.

Table 3. NI PXI/PCI-5112 Front Panel Connector Signals

Connector Description Function

CHO0, CH 1 | Standard BNC Analog input connection; digitizes data and
female connector triggers acquisitions.

TRIG Standard BNC External analog trigger connection; signals
female connector on the TRIG connector cannot be digitized.

PFI 1 Standard SMB Multipurpose digital timing and triggering
jack connector signal.

AUX 9-pin mini-circular | Access to PFI 2 (with optional cable). Refer
DIN connector to Figure 9 for pinout information.
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NI 5122/5124 Front Panels

Figure 14 shows the NI PXI-5122 and the NI PCI-5122 front panels. Refer to
Figure 16 for the AUX connector pinout information.

@

W insTRomENTs NI PCI-5122
NI PXI-5122
14-Bit 100 MS/s Digitizer

ACCESS ACTIVE

TRIG

5V
AUX /O \1ax

CLK OUT

Figure 14. NI PXI/PCI-5122 Front Panels
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Figure 15 shows the NI PXI-5124 and the NI PCI-5124 front panels. Refer to
Figure 16 for the AUX connector pinout information.
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Figure 15. NI PXI/PCI-5124 Front Panels
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Table 4 describes the signal connections on the NI 5122/5124.

Table 4. NI 5122 Front Panel Connector Signals

Connector Description Function

CHO,CH 1 | Standard BNC Analog input connection; digitizes data and
female connector triggers acquisitions.

TRIG Standard BNC External analog trigger connection; signals
female connector on the TRIG connector cannot be digitized.

CLK IN Standard SMB Input for an external reference or sample clock
jack connector to the digitizer.

CLK OUT | Standard SMB Output for the reference or sample clock.
jack connector

AUX /O 9-pin mini-circular | Provides access to the multipurpose digital
DIN connector timing and triggering lines, PFI 0 and PFI 1

(with optional cable).

Figure 16 shows the pin assignments for the 9-pin DIN connector on the
NI 5122/5124.

®

®©
® @

@®

1 +5V (Fused) 4 Reserved 7 Reserved
2 GND 5 Reserved 8 Reserved
3 Reserved 6 PFI1 9 PFIO

Figure 16. 9-Pin DIN Connector for the NI 5122/5124
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NI 5620/5621 Front Panels

Figure 17 shows the NI PXI-5620/5621 front panels.
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Figure 17. NI PXI-5620 Front Panel
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Table 5 describes the signal connections for the NI 5620/5621.

Table 5. NI 5620/5621 Front Panel Connector Signals

Connector Description Function
INPUT Standard SMA Analog input connection; digitizes data and
female connector | triggers acquisitions.
NI 5620—50 Q, AC-coupled
NI 5621—50 Q, DC-coupled
REF CLK IN Standard SMA 50 Q, 10 MHz, AC-coupled reference input.
female connector
PFI 1 Standard SMB External digital trigger connection.

jack connector
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NI 5911 Front Panel

Figure 18 shows the NI 5911 front panel. Refer to Figure 9 for the

PFI 2 (AUX) connector pinout information.
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Figure 18. NI 5911 Front Panel
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Table 6 describes the signal connections for the NI 5911.

Table 6. NI 5911 Front Panel Connector Signals

Connector Description Function
CHO Standard BNC female | Analog input connection; digitizes data
connector and triggers acquisitions.
PFI 1 Standard SMB jack Multipurpose digital timing and triggering
connector signal.
PFI 2 (AUX) | 9-pin mini-circular Access to PFI 2 (with optional cable).
DIN connector Refer to Figure 9 for pinout information.

Appendix B: Technical Support Resources

NI Web Support

National Instruments Web support is your first stop for help in solving
installation, configuration, and application problems and questions. Online
problem-solving and diagnostic resources include frequently asked
questions, knowledge bases, product-specific troubleshooting wizards,
manuals, drivers, software updates, and more. Web support is available
through the Technical Support section of ni . com.

A Declaration of Conformity (DoC) is our claim of compliance with the
Council of the European Communities using the manufacturer’s declaration
of conformity. This system affords the user protection for electronic
compatibility (EMC) and product safety. You can obtain the DoC for your
product by visiting ni . com/certification. If your product supports
calibration, you can obtain the calibration certificate for your product at
ni.com/calibration.
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Worldwide Support

National Instruments corporate headquarters is located at 11500 North
Mopac Expressway, Austin, Texas, 78759-3504. National Instruments also
has offices located around the world to help address your support needs.
You can access our branch office Web sites from the Worldwide Offices
section of ni . com. Branch office Web sites provide up-to-date contact
information, support phone numbers, email addresses, and current events.

If you have searched the technical support resources on our Web site and still
cannot find the answers you need, contact your local office or National
Instruments corporate. For telephone support in the United States, dial

512 795 8248. For telephone support outside the United States, contact your
local branch office:

Australia 1800 300 800, Austria 43 0 662 45 79 90 0,

Belgium 32 0 2 757 00 20, Brazil 55 11 3262 3599,

Canada (Calgary) 403 274 9391, Canada (Ottawa) 613 233 5949,
Canada (Québec) 450 510 3055, Canada (Toronto) 905 785 0085,
Canada (Vancouver) 604 685 7530, China 86 21 6555 7838,

Czech Republic 420 224 235 774, Denmark 45 45 76 26 00,
Finland 385 09 725 725 11, France 33 0 1 48 14 24 24,

Germany 49 0 89 741 31 30, India 91 80 51190000, Israel 972 0 3 6393737,
Italy 39 02 413091, Japan 81 3 5472 2970, Korea 82 02 3451 3400,
Malaysia 603 9131 0918, Mexico 01 800 010 0793,

Netherlands 31 0 348 433 466, New Zealand 0800 553 322,
Norway 47 0 66 90 76 60, Poland 48 22 3390150,

Portugal 351 210 311 210, Russia 7 095 783 68 51,

Singapore 65 6226 5886, Slovenia 386 3 425 4200,

South Africa 27 0 11 805 8197, Spain 34 91 640 0085,

Sweden 46 0 8 587 895 00, Switzerland 41 56 200 51 51,

Taiwan 886 2 2528 7227, Thailand 662 992 7519,

United Kingdom 44 0 1635 523545
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