
GETTING STARTED

NI SoftMotion  Controller
For Copley Controls CANopen Drives

This document provides step-by-step instructions for installing and getting 
started with the NI SoftMotion Controller for Copley Controls Corporation 
Accelnet and Xenus CANopen drives and the LabVIEW Real-Time 
Module.

Refer to the Related Documentation section of this guide for a list of 
additional documents associated with the NI SoftMotion Controller. Many 
of these documents are available in Portable Document Format (PDF) on 
ni.com/manuals.
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Conventions
The following conventions are used in this guide:

» The » symbol leads you through nested menu items and dialog box options 
to a final action. The sequence File»Page Setup»Options directs you to 
pull down the File menu, select the Page Setup item, and select Options 
from the last dialog box.

This icon denotes a tip, which alerts you to advisory information.

This icon denotes a note, which alerts you to important information.

This icon denotes a caution, which advises you of precautions to take to 
avoid injury, data loss, or a system crash.

bold Bold text denotes items that you must select or click in the software, such 
as menu items and dialog box options. Bold text also denotes parameter 
names.

italic Italic text denotes variables, emphasis, cross-references, or an introduction 
to a key concept. Italic text also denotes text that is a placeholder for a word 
or value that you must supply.

monospace Text in this font denotes text or characters that you should enter from the 
keyboard, sections of code, programming examples, and syntax examples. 
This font is also used for the proper names of disk drives, paths, directories, 
programs, subprograms, subroutines, device names, functions, operations, 
variables, filenames, and extensions.

Related Documentation
This section summarizes the documentation associated with the 
NI SoftMotion Controller. Use this information to determine which 
document is appropriate for your task. Many of the documents listed
are available as PDFs on ni.com/manuals.

• NI SoftMotion Controller ReadMe—This document contains 
information about changes and new features in the NI SoftMotion 
Controller, system requirements, and known issues.

• Measurement & Automation Explorer Help for Motion—This help
file provides information on using MAX to configure your motion 
controller.

• NI-Motion ReadMe—This document contains information about 
changes and new features in the NI-Motion software, system 
requirements, and known issues.
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• NI-Motion User Manual—This document provides task-based 
information to guide you through each phase of designing and 
executing a motion application. This document contains information 
on selecting a motor, designing a basic move, designing a multi-axis 
move, incorporating machine vision and data acquisition into motion 
applications, and other common motion concepts, such as Bode 
analysis, contouring, and breakpoints.

• NI-Motion VI Help—This help file for LabVIEW applications 
provides detailed information about each VI, including a description, 
control and input terminals, usage, illustrations (diagram or code), and 
error codes.

• NI-Motion Function Help—This help file for C and Visual Basic 
applications includes dedicated function reference files, and provides 
detailed information about each function, including a description of 
the function, a list of the function parameters, illustrations, and error 
codes.

• Refer to the documentation included with your NI CAN interface card 
for specific information about the NI CAN interface card and NI-CAN 
driver software.

• Refer to the documentation included with your Copley Controls 
CANopen drive for specific information about the Copley Controls 
CANopen drive and Copley Controls CME 2 configuration software.

Required Software
The following sections describe National Instruments software packages 
that are required for setting up and developing your motion control 
application.

Measurement & Automation Explorer (MAX)
MAX, the National Instruments configuration utility, installs with the 
NI SoftMotion Controller. You can use MAX to configure your motion 
controller and other National Instruments hardware devices and to update 
your National Instruments software.

To run MAX, double-click the MAX icon on your desktop, or navigate to 
Start»Programs»National Instruments»Measurement & Automation.
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Figure 1 shows the MAX configuration window demonstrating an installed 
NI SoftMotion Controller.

Figure 1.  MAX Configuration Window

NI-Motion
NI-Motion is the driver software for National Instruments motion 
controllers. You can use NI-Motion to create motion control applications 
using LabVIEW, C/C++, and Microsoft Visual Basic.

Refer to the NI-Motion User Manual for more information about creating 
motion control applications using NI-Motion.
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Step 1. Verify Components Before Installation
Before you begin installing and configuring your motion control system, 
make sure you have the following hardware and software components 
available for installation:

Hardware
❑ Development computer running Microsoft Windows Vista/XP/2000 

for configuring the CANopen drive and developing your application.

❑ LabVIEW Real-Time (RT) 8.0 or later target.

– NI RT Series PXI embedded controller running LabVIEW 
Real-Time.

or

PC running LabVIEW Real-Time.

Note To use the NI SoftMotion Controller on a PC, you must purchase the LabVIEW 
Real-Time Deployment License for Standard PCs-ETS RTOS (National Instruments 
part number 777849-03).

– LabVIEW Real-Time Target Software or the LabVIEW 8.0 or 
later Real-Time Module.

– NI CAN (Controller Area Network) series 2 high-speed
interface card and documentation.

– NI-CAN driver software (included on the NI SoftMotion 
Controller CD).

❑ Copley Controls Accelnet or Xenus CANopen drive and 
documentation.

– Copley Controls Connector/Cable Kit for connecting to your I/O.

– Copley Controls RS-232 Serial Cable Kit for connecting to the 
development computer.

– Copley Controls CANopen Network Kit for connecting to a CAN 
interface on the RT target.

❑ Compatible motor and power supply for the drive.
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Software
❑ NI SoftMotion Controller CD. This CD contains the following 

NI software products:

– NI SoftMotion Controller

– NI-Motion driver software

– NI-CAN driver software

– Measurement & Automation Explorer (MAX) configuration 
software

– NI Motion Assistant application prototyping software (optional)

❑ Copley Controls Motion Explorer (CME 2) 4.0 or later configuration 
software and documentation.

❑ Copley Controls drive firmware 4.12 or later. Drive firmware is 
available from Copley Controls.

❑ Application programming software and documentation.

– To create applications that run under Windows, use one of the 
following software packages:

• LabVIEW

• LabWindows™/CVI™

• Microsoft Visual C++

• Microsoft Visual Basic

Note Refer to the NI SoftMotion Controller ReadMe for currently supported versions.

– To create applications that run on LabVIEW RT targets, use the 
LabVIEW 8.0 or later Real-Time Module (ETS).

Step 2. Install Copley Controls Software
Complete the following steps to install the Copley Controls CME 2 
configuration software on the development computer.

Note To install software on the computer, you must be logged on with administrator-level 
access.

1. Insert the CME 2 CD into your CD-ROM drive to launch the CME 2 
installation wizard.

2. Follow the installer prompts through the rest of the installation.

The CME 2 configuration software is installed.
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Step 3. Connect the CANopen Drive
Complete the following steps to connect your I/O, motor, and power supply 
to the CANopen drive:

Tip Refer to the CANopen drive documentation for more information about completing 
the following steps.

1. Connect the I/O necessary for your application to the drive using the 
Connector Kit available from Copley Controls. Table 1 shows how the 
NI SoftMotion Controller uses the CANopen Drive terminals.

Table 1.  CANopen Drive Terminals Used by the NI SoftMotion Controller

Drive Terminal
NI SoftMotion Controller Signal 

For Accelnet
NI SoftMotion Controller Signal 

For Xenus

IN1 Inhibit in/drive fault Inhibit in/drive fault

IN2 Forward limit Forward limit

IN3 Reverse limit Reverse limit

IN4 Home Home

IN5 E-Stop, polarity is active-low E-Stop, polarity is active low

IN6 Digital input 0 Digital input 0

IN7 Digital input 1 Digital input 1

IN8 Digital input 2 Digital input 2

IN9 Digital input 3 Digital input 3

IN10 Digital input 4 Digital input 4

IN11 Digital input 5 Digital input 5

IN12 Digital input 6 Digital input 6

Ref + — Analog positive input

Ref – — Analog negative input

OUT1 Inhibit out/brake Digital output 0

OUT2 Digital output 0 Digital output 1

OUT3 Digital output 1 Digital output 2

OUT 4 — Inhibit out/brake
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2. Connect the motor and power supply to the drive.

3. Connect the drive to the development computer using the CME 2 
RS-232 cable kit available from Copley Controls.

Step 4. Configure the CANopen Drive
Complete the following steps to configure the CANopen drive using the 
Copley Controls CME 2 configuration software.

Caution The following steps refer to CME 2 version 4.0. These steps may differ in later 
versions of CME 2.

Tip Refer to the documentation installed with CME 2 for specific instructions about 
completing these steps.

1. Power on the development computer.

2. Launch CME 2.

3. Configure a communications port on the development computer 
through which you want to communicate with the drive.

a. Select Tools»Communications Wizard to launch the 
Communication Wizard.

Note If this is the first time launching CME 2, the Communications Wizard dialog box 
launches automatically when you launch CME 2.

b. Follow the prompts to specify settings and configure the COM 
port.

4. Set the drive operating mode to Position, and the position loop input 
to CAN.

a. Select Amplifier»Basic Setup.

b. Select Position from the Operating Mode drop-down list.

c. Select CAN from the Position Loop Input drop-down list.

d. Click OK.

5. Confirm the firmware on the drive is version 4.12 or later. 

a. Select Amplifier»Amplifier Properties to view the current 
firmware version.

b. If necessary, select Tools»Download Firmware to download the 
latest firmware to your drive.
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6. Set the motor/feedback parameters for the motor connected to 
the drive.

Caution Refer to Using CME 2 with XXXX, where XXXX is the name of the drive model, 
for important information about how these values are calculated. In CME 2, select Help»
Using CME 2 with XXXX to launch a PDF version of the document.

a. Click the Motor/Feedback button on the functional diagram.

b. In the Motor/Feedback dialog box, enter values for the specified 
parameters. Refer to the motor specifications in the 
documentation for your motor for the correct values.

c. Click the Calculate button to generate initial tuning values and 
limits based on the parameter values entered in step 3.

d. Click OK.

7. Set the CAN address for the drive. The CAN address for the drive can 
be set manually, using the address selector switch located on the drive, 
or programmatically, using CME 2, and can be any integer from 1 to 
the total number of activated axes.

Complete the following steps in CME 2 to programmatically set the 
CAN address and bit rate for the drive:

a. Click the CAN Configuration button on the functional diagram.

b. Select the appropriate bit rate from the Bit Rate drop-down list.

Tip Use the highest bit rate your drive supports. In noisy environments, setting a lower bit 
rate may improve signal integrity.

Note The bit rate you select in CME2 must match the baud rate you set in MAX in Step 9. 
Configure the CANopen Settings.

c. In the CAN Configuration dialog box, select Use Programmed 
Value to set the address for the CAN Address Configuration.

d. Enter the correct CAN address in the programmed value textbox. 
This number matches the address set on the drive using the CAN 
address selector switch.

Note The CAN address can be any integer from 1 to the total number of activated axes. 
For example, if the NI SoftMotion Controller is licensed for four axes, the CAN address 
can be any number between 1 and 4.

Note You may activate and connect up to 30 drives to the NI SoftMotion Controller.

e. Click OK.
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f. Power cycle the drive so that the CAN address changes take affect.

Note Each CANopen drive in your system must have a unique CAN address that is less 
than or equal to the number of licensed axes on the NI SoftMotion Controller. Otherwise, 
the system will not recognize the drive. Refer to the Duplicate CAN Addresses section for 
more information.

8. Tune the current, position, and velocity loops.

Tip Refer to Using CME 2 with XXXX, where XXXX is the name of the drive model, for 
detailed information about tuning the Current, Velocity, and Position Loops. In CME 2, 
select Help»Using CME 2 with XXXX to launch a PDF version of the document.

9. Configure the drive I/O.

a. Click the Input/Output button on the functional diagram.

b. For IN1, select Amp Enable-LO Enables from the drop-down 
list.

c. Select Not Configured from the drop-down list for the remaining 
inputs and outputs.

d. Select either Pull Up +5 V or Pull Down for the drive digital 
inputs depending on your motion control system.

Other than configuring IN1 and the digital inputs for pull up or 
pull down, it is not necessary to use CME 2 to configure the drive 
I/O. The NI SoftMotion Controller uses the I/O settings specified 
in Table 1. However, to avoid confusion, National Instruments 
recommends that you set the drive I/O to Not Configured 
wherever possible.

e. Click the Close button.

10. Configure any additional settings necessary for your application.

11. Save the configuration data to the Flash memory on the drive by 
clicking the Save amplifier working memory to flash button.

Tip To configure multiple drives using the same configuration settings, save the 
configuration data to a disk before saving it to the Flash memory on the drive. You can then 
reload the saved configuration settings from the disk and configure additional drives.

12. Select Amplifier»Control Panel and verify that the Under CAN 
Control button is selected in the Control section.

13. Exit the application. Save the configuration data to disk if desired.

The CANopen drive is configured.
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Duplicate CAN Addresses
If you have two or more drives in your system with the same CAN address, 
complete the following steps to resolve the conflict and assign a unique 
value to each drive:

1. Set the CAN address of the drive to a unique value and reset the drive.

Note You must cycle power to the drive before changes to the CAN address will take 
affect.

2. Set the CAN address and bit rate for the drive in CME2. Ensure that 
the bit rate you select in MAX matches the baud rate you set in CME2.

3. Add the axes in MAX.

Step 5. Install LabVIEW RT Target Support
Complete the following steps to install LabVIEW RT target support on the 
development computer.

Note If the LabVIEW Real-Time Module 8.0 or later is installed, you can skip this step.

1. On the development computer, insert the LabVIEW Real-Time Target 
Software CD into the CD-ROM drive to display the installation 
wizard.

2. Confirm that LabVIEW 8.0 Real-Time Target Support or later is 
selected.

3. Follow the installer prompts through the rest of the installation.

LabVIEW RT target support is installed on the development computer.

Step 6. Install NI CAN Hardware
Install the NI CAN interface card in the RT target. Refer to the CAN 
Hardware and NI-CAN Software for Windows Installation Guide for 
specific installation instructions.

Note The NI-CAN software is installed during installation of the NI SoftMotion 
Controller. Refer to Step 7. Install the NI SoftMotion Controller for more information.

Ensure that the NI CAN interface card is installed in the RT target before 
proceeding to the next step.
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Step 7. Install the NI SoftMotion Controller
Complete the following steps to install the NI SoftMotion Controller on the 
development computer.

1. Insert the NI SoftMotion Controller CD into your CD-ROM drive to 
display the NI SoftMotion Controller installation wizard.

2. Click Install NI SoftMotion Controller.

3. Follow the installer prompts through the rest of the installation.

4. Refer to the NI SoftMotion Controller ReadMe.htm file after 
installation is complete for last-minute information not contained in 
this document.

The NI SoftMotion Controller is installed on the development computer.

Tip To find updates for the NI SoftMotion Controller, visit ni.com/motion and select 
Drivers and Updates. For support questions, visit ni.com/support/motion.

Step 8. LabVIEW RT Target Configuration
Complete the following steps to install software on the RT target and 
configure the target for use with the NI SoftMotion Controller:

1. Make sure the RT target is connected to the same network as the 
development computer. If necessary, connect the RT target to the 
network.

Tip Refer to the MAX Remote Systems Help for information about configuring the 
network settings.

2. Install the NI SoftMotion Controller on the RT target:

a. Launch MAX.

b. Expand Remote Systems»RT Target»Software. 

c. Click the Add/Remove Software button.

d. In the LabVIEW Real-Time Software Wizard dialog box, select 
NI SoftMotion Controller for CANopen to install the 
NI SoftMotion Controller for CANopen software on the RT 
target. In addition, select any other software required on the RT 
target for operations such as data or image acquisition. Refer to 
Remote Systems Help for more information about installing 
software on an RT target. To access this help file from MAX select 
Help»Help Topics»Remote Systems.
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Note Selecting NI SoftMotion Controller for CANopen automatically selects NI-CAN, 
LabVIEW Real-Time, NI Motion SoftMotion Controller Support, and any other required 
files for installation.

3. Right-click the NI SoftMotion Controller in Remote Systems»
RT Target»Devices and Interfaces»NI Motion Devices and select 
Map to local machine to map the NI SoftMotion Controller on the 
RT target to a local system such as the development computer. Refer to 
Remote Systems and NI-Motion in the Measurement & Automation 
Explorer Help for Motion for more information.

4. Connect the CANopen drive to the CAN port on the RT target using 
the CANopen network kit available from Copley Controls.

The RT target is configured.

Step 9. Configure the CANopen Settings
Complete the following steps to configure the CANopen settings using 
MAX:

1. Click the name of the motion controller to configure.

2. Click the CANopen Settings tab.

3. Set the appropriate values for Drive Vendor, Baud Rate, Interface, and 
Extended. These values must match the settings on the CANopen 
drives.

Note The port number on your NI CAN device will not match the Interface value set 
using MAX. For example, CAN0 corresponds to Port 1 on the first CAN device.

4. Click Save Settings to Controller.

Step 10. Add Axes to the Controller
Complete the following steps to add axes to the NI SoftMotion Controller:

1. Right-click the name of the motion controller and select Add Axis.

Each drive connected to the controller shows up as an axis, up to the 
maximum number of axes licensed.

2. Verify that the axis information for each axis is correct in the dialog 
box that appears, and click Next.

To change the axis information, double-click the Name and Axis 
Number fields and enter the correct information.
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Note If your axes do not appear in the dialog box, verify that you do not have two drives 
with the same CAN address. Refer to Duplicate CAN Addresses for information about 
resolving this issue.

3. Click Finish.

Axes have been added to the NI SoftMotion Controller.

Step 11. Initialize the NI SoftMotion Controller
Before you initialize the controller and test your motion control system, 
verify that all the motion hardware—including motors, amplifiers, 
encoders, and limits—is correctly installed. Refer to the appropriate 
hardware documentation for installation instructions.

Note You must have a complete hardware setup to configure and test your motion control 
system.

1. Expand My System»Devices and Interfaces»NI Motion Devices.

2. Select the NI SoftMotion Controller.

3. Click the Initialize button on the MAX toolbar.

The NI SoftMotion Controller installation and configuration is complete. 
Use the MAX configuration software to configure the axes and NI-Motion 
to program moves.

Note For detailed instructions about adding more than eight axes to the NI SoftMotion 
Controller refer to the National Instruments Web site at ni.com/info and enter the 
info code rdaasm.

NI Motion Assistant
National Instruments Motion Assistant is a graphical prototyping tool you 
can use to prototype motion control applications. Motion Assistant contains 
features for simple and complex moves, graphical prototyping, and code 
creation.

Simple and Complex Moves
Motion Assistant offers several move types that represent the most often 
used moves in motion control. Supported moves include the following:

• Reference moves reset axes to a known location or state.

• Straight-line moves create simple point-to-point movement for basic 
motion applications.
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• Arc moves enable circular, three-dimensional, and helical arc types.

• Contouring moves allow any trajectory specified by a series of 
coordinates.

• CAD moves create a series of moves based on an imported CAD file.

Graphical Prototyping
Motion Assistant is a fully graphical interface that makes it easy for you to 
prototype a motion application by creating a series of moves. The position, 
velocity, and acceleration of the moves are graphed and editable in two and 
three dimensions.

Code Creation
When you are finished creating a prototype of a motion control application, 
you can use the Motion Assistant code creation feature to export LabVIEW 
or C code. You can use the exported code to complete the application in 
LabVIEW, C, or C++. You also can use Motion Assistant to generate code 
recipes that you can use to code a motion control application in other text 
languages, such as Microsoft Visual Basic.

The code generation feature of Motion Assistant also creates placeholders 
in the generated code or code recipes for non-motion code, such as data or 
image acquisition, in any location you specify.

Advanced Features
Motion Assistant supports the digital output feature available with 
NI SoftMotion Controllers. This feature is designed to synchronize or 
coordinate external processes with moves.

The digital output feature allows you to write an ancillary digital output line 
to the NI SoftMotion Controller under the following conditions:

• Before Move Completes

• After Move Completes

• After Blend Completes

Hardware Support
The NI SoftMotion Controller supports Motion Assistant reference, 
straight-line, arc, contoured, and CAD moves. Position compare outputs 
are not currently supported.
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