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Conventions

The following conventions are used in this manual:

[ ] Square brackets enclose optional items—for example, [response].

» The » symbol leads you through nested menu items and dialog box options 
to a final action. The sequence File»Page Setup»Options directs you to 
pull down the File menu, select the Page Setup item, and select Options 
from the last dialog box.

This icon denotes a note, which alerts you to important information.

bold Bold text denotes items that you must select or click in the software, such 
as menu items and dialog box options. Bold text also denotes parameter 
names.

italic Italic text denotes variables, emphasis, a cross-reference, or an introduction 
to a key concept. Italic text also denotes text that is a placeholder for a word 
or value that you must supply.

monospace Text in this font denotes text or characters that you should enter from the 
keyboard, sections of code, programming examples, and syntax examples. 
This font is also used for the proper names of disk drives, paths, directories, 
programs, subprograms, subroutines, device names, functions, operations, 
variables, filenames, and extensions.

monospace bold Bold text in this font denotes the messages and responses that the computer 
automatically prints to the screen. This font also emphasizes lines of code 
that are different from the other examples.

monospace italic Italic text in this font denotes text that is a placeholder for a word or value 
that you must supply.
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1
Introduction

This guide provides a summary of how to use HyperBuild to accelerate the 
simulation of any SystemBuild model. This includes the following major 
topics: 

• Chapter 1, Introduction

• Chapter 2, Running HyperBuild from SystemBuild

• Chapter 3, Running HyperBuild from Xmath

• Chapter 4, Using HyperBuild

Overview
HyperBuild provides a way to decrease the computer simulation time of 
SystemBuild models, especially medium and large models. The more 
complex the SystemBuild model, the more significant the decrease in 
simulation speed when using HyperBuild. 

HyperBuild achieves this improvement by converting a SystemBuild block 
diagram into highly optimized C code (called HyperCode). The HyperCode 
version of a model executes much faster than the original model itself, 
because the simulator is interpretive. The simulator normally evaluates a 
model block-by-block, whereas HyperBuild typically takes an existing 
SystemBuild model and replaces it with a new model built from 
HyperBuild blocks, which are derivatives of UserCode Blocks (UCBs). 
Since the new model has only a single HyperBuild block per subsystem, the 
simulator can evaluate it quickly. DataStores from the original model are 
transferred to the new model outside of the HyperCode.

You can use HyperBuild to generate code for most models, including 
multirate models and those containing procedures or blocks with state 
events. 



Chapter 1 Introduction

SystemBuild HyperBuild User Guide 1-2 ni.com

HyperBuild provides support for most SystemBuild features, including the 
following:

• Software constructs

• Models with algebraic loops

• Zero-crossing blocks

• Implicit blocks (including implicit UCBs)

• Read From and Write To Variable blocks

• Resettable integrators

• Procedure SuperBlocks (includes Standard, Startup, Macro, 
Background, Interrupt, and Inline Procedure SuperBlocks)

• Multirate models

• Condition SuperBlocks

For specific information on any of these features, refer to the SystemBuild 
User Guide or the MATRIXx Help. For additional information about 
HyperBuild performance and limitations, refer to Chapter 4, Using 
HyperBuild.

Simulation Process
Figure 1-1 shows an overview of the HyperBuild simulation process. This 
figure traces the progress of the imaginary UFO model through the steps of 
loading, analyzing, simulating, compiling, and relinking. Each of the 
HyperBuild steps is described in Chapter 2, Running HyperBuild from 
SystemBuild. The SystemBuild process is described in the SystemBuild 
User Guide.
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Figure 1-1.  HyperBuild Simulation Process
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2
Running HyperBuild from 
SystemBuild

Running HyperBuild and Generating HyperCode
To run HyperBuild and generate HyperCode, complete the following steps:

1. Select a top-level SuperBlock of your model from the SystemBuild 
Catalog Browser and then select Tools»HyperBuild. 

The HyperBuild dialog box appears.

2. From this dialog box, select the options you want and click OK. 

HyperBuild generates HyperCode and creates a catalog in your 
working directory named blockname.hyb.

The available options include:

Typecheck Enables data type checking in the
generated code. Default is unchecked.

Generate KR Enables the generation of Kernigan
Compatible and Ritchie style C code declarations.
Declarations Default is unchecked.

Error Checking Enables error checking in the generated
code. Default is unchecked.

User RP/IP Actuals Provides for a selection between RP/IP
for UCBs (real parameter/integer parameter)

hardcoded numbers and %var encoding
for UCBs. Default is unchecked.
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Block Defaults or Provides a choice between putting
Xmath %Vars  default variable block parameters or

%vars into the HyperBuild code. Default
is Xmath %Vars.

SystemBuild automatically loads the modelname.hyb model after it is 
generated as the component _HB_Model.

Loading and Using HyperCode
After you have run HyperBuild on your model, you select the _HB_Model 
component. Then select Tools»Simulate from the Catalog Browser. The 
SystemBuild Simulation Parameters dialog box appears.
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To simulate your HyperCode, enter the following required parameters:

Parameters tab: Requires a time column vector
Time Vector/Variable (for example, [0:0.1:300]’).

Parameters tab: Required variable for models with
Input Data/Variable 1 or more inputs (for example, u).

To make the best use of your HyperCode, select from the following options:

Parameters tab: Keep at a minimum for best performance.
Output Variable

Parameters tab: Select Float for best performance.
Sim type Note: If the original model uses fixed-point

types, these will be simulated last in the
HyperBuild object, not by the simulator.
Therefore, select Float even if there are
fixed-point types within the HyperCode.

Parameters tab: Select actiming if you plan to use
Scheduling AutoCode to generate C or Ada code.

Numerics tab: Set to a low number to minimize delays
Time Delay Buffer (20 is the default).

Initialization tab: Leave unchecked to minimize simulation
Remake sim executable time.

Note The LINKHYPER Xmath command is no longer supported. HyperCode is linked to 
the simulator immediately after generation.

Simulation Example
As an example, load the super_cruise model from the MTXHOME/
sysbld/demo directory, select a top level block such as the continuous 
automobile with IA block, and then simulate the model with and without 
HyperBuild. 

Simulation Without HyperBuild
To simulate a model without HyperCode, complete the following steps:

1. Select Tools»Simulate, which opens the SystemBuild Simulation 
Parameters dialog box. 

2. In the Parameters tab, set the Time Vector/Variable to 
[0:0.1:300]’, enter an Output Variable of u, and select any of the 
optional checkboxes such as Typecheck and Plot Output.
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3. Select Show Simulation Clock (optional), Show Analyzer/
Simulation Messages (optional), and Display Simulation CPU 
Statistics (to display comparative results) from the Outputs tab.
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After the simulation, you see output similar to the following:

Using variable step Variable Kutta-Merson integration.

Continuous states are solved explicitly.

Continuous outputs are solved explicitly.

Initialization Complete.

The solution is   1% complete.

The solution is   2% complete.

The solution is   5% complete.

The solution is  10% complete.

The solution is  20% complete.

The solution is  40% complete.

The solution is  60% complete.

The solution is  80% complete.

elapsed:  0 00:00:01.07   cpu:  0 00:00:01.06

The solution is 100% complete.

Simulation With HyperBuild
Using the same model and simulation parameters as in the Simulation 
Without HyperBuild section, you can compare your simulation time using 
HyperBuild.

In this example, you again use the super_cruise model and complete the 
following steps from the SystemBuild - Catalog Browser.

1. Load (or open) the super_cruise model from the MTXHOME/sysbld/
demo directory.

2. Select the continuous automobile with IA block.

3. Select Tools»HyperBuild to create the _HB_Model component.

4. Simulate the model with HyperBuild by clicking _HB_Model and 
then selecting Tools»Simulate.

The output from the simulation with HyperBuild is identical to the “without 
HyperBuild” example except for the elapsed and cpu times. 

elapsed:  0 00:00:00.54   cpu:  0 00:00:00.52

Because the super_cruise model is a small demonstration model, you do not 
see the full power of the tool. However, you see about a 50% improvement 
in the simulation speed even with this small model.

Note If you simulate a model and then load another model, you may need to delete some 
of the generated files (for example, ucbhook.*) before simulating the _HB_Model 
component again.
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3
Running HyperBuild from Xmath

Running HyperBuild from the Xmath 
Commands Window

To run HyperBuild from the Xmath Commands window, you can use the 
following HyperBuild command:

hyperbuild "topSB", {keywords}

where topSB (a text string) is the name of the top SuperBlock of the model 
and keywords are described in Table 3-1.

The hyperbuild command generates three files: the C file (topSB.c), the 
model file containing the _HB_Model component (topSB.hyb), and the 
real-time file (topSB.rtf).

Table 3-1.  HyperBuild Keyword Options

Keyword Type Description

errorcheck Integer Enables error checking in the 
generated code. Default = 0.

file File Output file to receive generated code.

Note: The keyword has no suffix.

typecheck Boolean Enables data type checking in the 
generated code. Default = 0.

ucbparams Boolean Lets the user configure UCBs to use 
either RP/IP (real parameter/integer 
parameter) hardcoded numbers or 
%var encoding.

vars Boolean If 1 (default), put %Variables into 
the HyperBuild code.
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For example, to generate HyperCode for the super_cruise model, enter the 
following command sequence from the Xmath Commands window:

load file = "cruise_d.cat";

main.t = [0:0.1:300]’;

hyperbuild "continuous automobile w IA", {typecheck};

where continuous automobile with IA is a top-level SuperBlock. 
HyperBuild code is generated for the SuperBlocks contained in this topSB. 
The _HB_Model component that is generated contains UCBs that 
reference the HyperCode.

Linking a Simulation (Optional)
With HyperBuild, you can generate HyperCode and simulate the 
_HB_Model component directly, or you can use the linksim command to 
link your code with other UserCode Block files.

The linksim command has the following syntax:

linksim model, {csource, fsource}

where model is a string specifying the SystemBuild model to search for 
UserCode Block source files, csource is a string specifying the C source 
files to be compiled and linked into the simulator, and fsource is a string 
specifying the FORTRAN source files to be compiled and linked into the 
simulator. 

Note File names must be separated by spaces, and files specified in the UCB dialog boxes 
need not be included.

The linksim command compiles and links UserCode Block source files 
and creates a UCB shared library (simucb.*, where the extension is 
platform dependent), in your local directory. For Windows, the extension is 
.dll. For Solaris, SGI, and IBM platforms, the extension is .so.1.0. For 
Compaq Tru64 platforms, the extension is .so. For HP platforms, the 
extension is .sl.

Source files can be specified in the parameter dialog of each UserCode 
Block reference in a model (no more than one file reference per UserCode 
Block reference). The specified SystemBuild model is searched for source 
files listed in any UCB, or referenced by the values of the csource and 
fsource values set using setsbdefault.
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Simulating Linked HyperCode or linksim Output
To simulate linked HyperBuild code (the _HB_Model component) or the 
output from linksim, use the following sim command (for example):

outputPDM = sim ("_HB_Model", InputPDM, {keywords})

where inputPDM is a PDM with domain as a time vector, the range is the 
input, and keywords are as described in the MATRIXx Help.

Note Simulation of a HyperBuild model is exactly the same as simulation of any other 
SystemBuild model and is described fully in the MATRIXx Help.

Running HyperBuild from a Script
The hyperbuild command is especially useful if you want to run a script 
to perform your HyperCode creation and simulation. For example, the 
following script loads the super_cruise model, runs HyperBuild, and then 
simulates the continuous automobile with IA. This script also 
simulates the _HB_Model component:

load file = "cruise_d.cat";

pause 6;

main.t = [0:0.1:300]’;

hyperbuild "continuous automobile w IA", {typecheck};

[,main.ycsim] = sim("continuous automobile w IA",main.t, 

{simtimer, typecheck});

[,main.ychyp] = sim("_HB_Model",main.t, {simtimer, 

typecheck});

For additional information about writing Xmath scripts, refer to the Xmath 
User Guide.
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4
Using HyperBuild

Usage Notes
When you are using HyperBuild, give special consideration to the 
following:

• If your regular SystemBuild simulation takes more than a few minutes, 
or if you want to run it repeatedly, NI recommends the use of 
HyperCode.

• Only one HyperCode model at a time can be linked with the simulation 
engine.

• Because the HyperCode SuperBlock _HB_Model is automatically 
generated, the best way to change initial states, connections, or 
parameters is to edit the original SuperBlock in the SystemBuild 
model and then regenerate the HyperCode. 

• The generated code has comments that indicate the original 
SuperBlock name, block name, and block type for each section 
of code. 

• UserCode Blocks (UCBs) are allowed in HyperBuild models, just as 
in conventional SystemBuild models. If you use the UPDUSR interface 
to UCBs, you must specify all required source code files as csource 
in Xmath, by using the SETSBDEFAULT command, and specify a 
positive integer for the function name in the block dialog box. UCBs 
created prior to version 4.0 are in this format.

Performance Results
Performance results will vary, but simulation speeds using HyperBuild 
have been tested at seven to 10 times the speed of simulations without 
HyperBuild. You can improve performance results by simplifying your 
model in the following ways:

• Avoid implicit outputs and algebraic loops if possible.

• Minimize the number of inputs and outputs.
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• Use procedure states instead of task states where possible in discrete 
subsystems.

• Use floating-point signals instead of other types of signals for 
subsystem inputs and outputs.

For additional information on improving performance, refer to the Code 
Optimizations chapter of the AutoCode Reference. 

Limitations
HyperBuild has the following limitations:

• Algebraic loops within procedures are supported but discouraged for 
efficiency reasons.

• MathScript blocks are not supported.

• %var data from the Xmath stack are re-initialized. HyperCode takes 
the %var values that are set within Xmath at the time of code 
generation. To change these values, you must change them in Xmath 
and regenerate the code. 

For specific information on SystemBuild topics, refer to the SystemBuild 
User Guide or the MATRIXx Help.
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A
Technical Support and 
Professional Services

Visit the following sections of the National Instruments Web site at 
ni.com for technical support and professional services:

• Support—Online technical support resources at ni.com/support 
include the following:

– Self-Help Resources—For answers and solutions, visit the 
award-winning National Instruments Web site for software drivers 
and updates, a searchable KnowledgeBase, product manuals, 
step-by-step troubleshooting wizards, thousands of example 
programs, tutorials, application notes, instrument drivers, and 
so on.

– Free Technical Support—All registered users receive free Basic 
Service, which includes access to hundreds of Application 
Engineers worldwide in the NI Discussion Forums at 
ni.com/forums. National Instruments Application Engineers 
make sure every question receives an answer.

For information about other technical support options in your 
area, visit ni.com/services or contact your local office at 
ni.com/contact. 

• Training and Certification—Visit ni.com/training for 
self-paced training, eLearning virtual classrooms, interactive CDs, 
and Certification program information. You also can register for 
instructor-led, hands-on courses at locations around the world.

• System Integration—If you have time constraints, limited in-house 
technical resources, or other project challenges, National Instruments 
Alliance Partner members can help. To learn more, call your local 
NI office or visit ni.com/alliance.

If you searched ni.com and could not find the answers you need, contact 
your local office or NI corporate headquarters. Phone numbers for our 
worldwide offices are listed at the front of this manual. You also can visit 
the Worldwide Offices section of ni.com/niglobal to access the branch 
office Web sites, which provide up-to-date contact information, support 
phone numbers, email addresses, and current events.



© National Instruments Corporation I-1 SystemBuild HyperBuild User Guide

Index

Symbols
_HB_Model component, 2-2

A
algebraic loops, 4-2

B
blockname.hyb catalog, 2-1
blocks

condition, 1-2
implicit, 1-2
MathScript, 4-2
Read From Variable, 1-2
UserCode, 1-1
variable, 1-2
WriteTo Variable, 1-2
zero-crossing, 1-2

C
catalog blockname.hyb, 2-1
commands, sim, 3-3
component, _HB_Model, 2-2
constructs, software, 1-2
conventions used in the manual, iv

D
diagnostic tools (NI resources), A-1
documentation

conventions used in the manual, iv
NI resources, A-1

drivers (NI resources), A-1

E
examples (NI resources), A-1

G
generated code comments, 4-1
generated files, 2-5

H
hardware in-the-loop testing, 1-3
Help, MATRIXx, 4-2
help, technical support, A-1
HP, 3-2
HyperBuild, 1-1, 1-2

_HB_Model, 3-2
limitations, 4-2
options

block defaults or Xmath %Vars, 2-2
error checking, 2-1
Generate KR compatible 

declarations, 2-1
Typecheck, 2-1
User RP/IP actuals for UCBs, 2-1

HyperCode, simulating, 3-3

I
IBM, 3-2
implicit blocks, 1-2
instrument drivers (NI resources), A-1
integrators, resettable, 1-2

K
KnowledgeBase, A-1



Index

SystemBuild HyperBuild User Guide I-2 ni.com

L
limitations, 4-2
linksim, 3-2
loops, algebraic, 4-2

M
MathScript blocks, 4-2
MATRIXx Help, 4-2
model, Super_Cruise, 2-3
models with algebraic loops, 1-2
multirate models, 1-2

N
National Instruments support and 

services, A-1
NI support and services, A-1

P
performance, 4-1
procedure SuperBlocks, 1-2
programming examples (NI resources), A-1

R
required parameters, 2-3
resettable integrators, 1-2

S
SGI, 3-2
simulating HyperCode, 3-3
simulation parameters

output variable, 2-3
remake sim executable, 2-3
scheduling, 2-3
sim type, 2-3
time delay buffer, 2-3
time vector/variable, 2-3

software (NI resources), A-1
software constructs, 1-2
subroutine, UPDUSR, 4-1
Sun, 3-2
super_cruise model, 2-5
SuperBlocks, procedure, 1-2
support, technical, A-1

T
technical support, A-1
topSB.c, 3-1
topSB.hyb, 3-1
topSB.rtf, 3-1
training and certification (NI resources), A-1
troubleshooting (NI resources), A-1

U
UCBs, 1-1, 4-1
UPDUSR subroutine, 4-1
UserCode Blocks, 1-1, 4-1

V
variable blocks, 1-2

W
Web resources, A-1

Z
zero-crossing blocks, 1-2


	SystemBuild HyperBuild User Guide
	Support
	Worldwide Technical Support and Product Information
	National Instruments Corporate Headquarters
	Worldwide Offices

	Important Information
	Warranty
	Copyright
	Trademarks
	Patents
	WARNING REGARDING USE OF NATIONAL INSTRUMENTS PRODUCTS

	Conventions
	Contents
	Chapter 1 Introduction
	Overview
	Simulation Process
	Figure 1-1. HyperBuild Simulation Process


	Chapter 2 Running HyperBuild from SystemBuild
	Running HyperBuild and Generating HyperCode
	Loading and Using HyperCode
	Simulation Example
	Simulation Without HyperBuild
	Simulation With HyperBuild


	Chapter 3 Running HyperBuild from Xmath
	Running HyperBuild from the Xmath Commands Window
	Table 3-1. HyperBuild Keyword Options

	Linking a Simulation (Optional)
	Simulating Linked HyperCode or linksim Output
	Running HyperBuild from a Script

	Chapter 4 Using HyperBuild
	Usage Notes
	Performance Results
	Limitations

	Appendix A Technical Support and Professional Services
	 Index
	Symbols
	A-K
	L-Z




