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The media on which you receive National Instruments software are warranted not to fail to execute programming instructions, due to defects
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accuracy. In the event that technical or typographical errors exist, National Instruments reserves the right to make changes to subsequent
editions of this document without prior notice to holders of this edition. The reader should consult National Instruments if errors are suspected.
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MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. CUSTOMER’S RIGHT TO RECOVER DAMAGES CAUSED BY FAULT OR NEGLIGENCE ON THE PART OF
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THEREOF. This limitation of the liability of National Instruments will apply regardless of the form of action, whether in contract or tort, including
negligence. Any action against National Instruments must be brought within one year after the cause of action accrues. National Instruments
shall not be liable for any delay in performance due to causes beyond its reasonable control. The warranty provided herein does not cover
damages, defects, malfunctions, or service failures caused by owner’s failure to follow the National Instruments installation, operation, or
maintenance instructions; owner’s modification of the product; owner’s abuse, misuse, or negligent acts; and power failure or surges, fire,
flood, accident, actions of third parties, or other events outside reasonable control.

Copyright
Under the copyright laws, this publication may not be reproduced or transmitted in any form, electronic or mechanical, including photocopying,

recording, storing in an information retrieval system, or translating, in whole or in part, without the prior written consent of National
Instruments Corporation.

Trademarks

AutoCode™, MATRIXx"™, National Instruments™, NI"™, ni.com"™, SystemBuild™, and Xmath™ are trademarks of National Instruments
Corporation.

Product and company names mentioned herein are trademarks or trade names of their respective companies.

Patents
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INSTRUMENTS, THE USER OR APPLICATION DESIGNER IS ULTIMATELY RESPONSIBLE FOR VERIFYING AND VALIDATING
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Conventions

»

5

bold
italic

monospace

monospace bold

monospace italic

The following conventions are used in this manual:
Square brackets enclose optional items—for example, [response].

The » symbol leads you through nested menu items and dialog box options
to a final action. The sequence File»Page Setup»Options directs you to
pull down the File menu, select the Page Setup item, and select Options
from the last dialog box.

This icon denotes a note, which alerts you to important information.

Bold text denotes items that you must select or click in the software, such
as menu items and dialog box options. Bold text also denotes parameter
names.

Italic text denotes variables, emphasis, a cross reference, or an introduction
to a key concept. This font also denotes text that is a placeholder for a word
or value that you must supply.

Text in this font denotes text or characters that you should enter from the
keyboard, sections of code, programming examples, and syntax examples.
This font is also used for the proper names of disk drives, paths, directories,
programs, subprograms, subroutines, device names, functions, operations,
variables, filenames, and extensions.

Bold text in this font denotes the messages and responses that the computer
automatically prints to the screen. This font also emphasizes lines of code
that are different from the other examples.

Italic text in this font denotes text that is a placeholder for a word or value
that you must supply.
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Introduction

This guide provides a summary of how to use HyperBuild to accelerate the
simulation of any SystemBuild model. This includes the following major
topics:

e Chapter 1, Introduction

*  Chapter 2, Running HyperBuild from SystemBuild
»  Chapter 3, Running HyperBuild from Xmath

*  Chapter 4, Using HyperBuild

Overview

HyperBuild provides a way to decrease the computer simulation time of
SystemBuild models, especially medium and large models. The more
complex the SystemBuild model, the more significant the decrease in
simulation speed when using HyperBuild.

HyperBuild achieves this improvement by converting a SystemBuild block
diagram into highly optimized C code (called HyperCode). The HyperCode
version of a model executes much faster than the original model itself,
because the simulator is interpretive. The simulator normally evaluates a
model block-by-block, whereas HyperBuild typically takes an existing
SystemBuild model and replaces it with a new model built from
HyperBuild blocks, which are derivatives of UserCode Blocks (UCBs).
Since the new model has only a single HyperBuild block per subsystem, the
simulator can evaluate it quickly. DataStores from the original model are
transferred to the new model outside of the HyperCode.

You can use HyperBuild to generate code for most models, including
multirate models and those containing procedures or blocks with state
events.

© National Instruments Corporation 1-1 SystemBuild HyperBuild User Guide



Chapter 1

Introduction

HyperBuild provides support for most SystemBuild features, including the
following:

e Software constructs

*  Models with algebraic loops

e Zero-crossing blocks

* Implicit blocks (including implicit UCBs)
e  Read From and Write To Variable blocks
e Resettable integrators

*  Procedure SuperBlocks (includes Standard, Startup, Macro,
Background, Interrupt, and Inline Procedure SuperBlocks)
e Multirate models

*  Condition SuperBlocks

For specific information on any of these features, refer to the SystemBuild
User Guide or the MATRIXx Help. For additional information about
HyperBuild performance and limitations, refer to Chapter 4, Using
HyperBuild.

Simulation Process

Figure 1-1 shows an overview of the HyperBuild simulation process. This
figure traces the progress of the imaginary UFO model through the steps of
loading, analyzing, simulating, compiling, and relinking. Each of the
HyperBuild steps is described in Chapter 2, Running HyperBuild from
SystemBuild. The SystemBuild process is described in the SystemBuild
User Guide.

SystemBuild HyperBuild User Guide 1-2 ni.com



Chapter 1 Introduction

SystemBuild HyperBuild Script
Catalog Data (IPC)
r— — — — — — — — — — — A
I
1. Execute HyperBuild Script
d Load HYB Fil
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Figure 1-1. HyperBuild Simulation Process
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Running HyperBuild from

SystemBuild

Running HyperBuild and Generating HyperCode

To run HyperBuild and generate HyperCode, complete the following steps:

1.

© National Instruments Corporation

Select a top-level SuperBlock of your model from the SystemBuild
Catalog Browser and then select Tools»HyperBuild.

The HyperBuild dialog box appears.

0K |

HyperBuild E
r [~ Ermor Checking

[~ Generate KB Compatible Declarations [~ Use RPAP Actuals for UICEs

Block Parameters From IXmath i arg j

Cancel | Help |

From this dialog box, select the options you want and click OK.

HyperBuild generates HyperCode and creates a catalog in your
working directory named blockname.hyb.

The available options include:

Typecheck

Generate KR
Compatible
Declarations

Error Checking

User RP/IP Actuals
for UCBs

2-1

Enables data type checking in the
generated code. Default is unchecked.

Enables the generation of Kernigan
and Ritchie style C code declarations.
Default is unchecked.

Enables error checking in the generated
code. Default is unchecked.

Provides for a selection between RP/IP
(real parameter/integer parameter)
hardcoded numbers and %var encoding
for UCBs. Default is unchecked.

SystemBuild HyperBuild User Guide



Chapter 2

Block Defaults or
Xmath % Vars

Running HyperBuild from SystemBuild

Provides a choice between putting
default variable block parameters or

Yvars into the HyperBuild code. Default

is Xmath % Vars.

SystemBuild automatically loads the modeIname.hyb model after it is
generated as the component _HB_Model.

ESyslemBuild - Catalog Browser M= 3
File Edit “iew Toolz Options ‘Window Help

D|=(E|8| @ &[=[2]x| 2)=]x] 2

|E0ntents of Main._HE_Model:

|Eatalog: I ain

3 Main

E-£3 SupeBlocks

@ State Diagrams

-3 DataStores

-3 Components
D _HB_Model:

Libraries

Ready i

Loading and Using HyperCode

After you have run HyperBuild on your model, you select the _HB_Model
component. Then select Tools»Simulate from the Catalog Browser. The
SystemBuild Simulation Parameters dialog box appears.

SystemBuild HyperBuild User Guide

Parameters | Numericsl Output Heportingl Initializationl

Time Yectar/Variable I Sim Type IFIoat VI

Input D atay ariable I Mintd i Variablel

l— Scheduling IDefauIt 'l
™ Plot Dutputs

Block Parameters IXmath Hars j' ™ Interactive
Integration Algarithm IVariabIe Kutta-Merson 'l I Background

™ Typecheck

Output Y ariable

SystemBuild Simulation Parameters E
Top Level SuperBlock Inputs Outputs
Contraller 3 2

Lancel | Feset | Help

2-2
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Chapter 2 Running HyperBuild from SystemBuild

To simulate your HyperCode, enter the following required parameters:

Parameters tab:
Time Vector/Variable

Parameters tab:
Input Data/Variable

Requires a time column vector
(for example, [0:0.1:3001").

Required variable for models with
1 or more inputs (for example, u).

To make the best use of your HyperCode, select from the following options:

Parameters tab:
Output Variable

Parameters tab:
Sim type

Parameters tab:
Scheduling

Numerics tab:
Time Delay Buffer

Initialization tab:
Remake sim executable

Keep at a minimum for best performance.

Select Float for best performance.

Note: If the original model uses fixed-point
types, these will be simulated last in the
HyperBuild object, not by the simulator.
Therefore, select Float even if there are
fixed-point types within the HyperCode.

Select actiming if you plan to use
AutoCode to generate C or Ada code.

Set to a low number to minimize delays
(20 is the default).

Leave unchecked to minimize simulation
time.

@ Note The LINKHYPER Xmath command is no longer supported. HyperCode is linked to
the simulator immediately after generation.

Simulation Example

As an example, load the super_cruise model from the MTXHOME/
sysbld/demo directory, select a top level block such as the continuous
automobile with IA block, and then simulate the model with and without
HyperBuild.

Simulation Without HyperBuild

To simulate a model without HyperCode, complete the following steps:

1.

© National Instruments Corporation

Select Tools»Simulate, which opens the SystemBuild Simulation

Parameters dialog box.

In the Parameters tab, set the Time Vector/Variable to
[0:0.1:300] ", enter an Qutput Variable of u, and select any of the
optional checkboxes such as Typecheck and Plot Output.

2-3
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Chapter 2

Running HyperBuild from SystemBuild

» SystemBuild Simulation Parameters

Top Level SuperBlock
contimwous antomobile w TA

Inputs Dutputs
1] 2

Parameters ] Numerics ] Outputs ] Initialization ]

Time Vector/Variable [l]:l].1:3l]l]]’_§_
Input Data/Variable I

Output Variable Iu

Block Parameters Ib{math %Vars

J [7 Plot Outputs
Y _| Interactive
| Backegound

Integration Algorithm IIVariahle Eutta-Merson j

|~ Typecheck

Sim Type I_E_rloat j
MinMax Variable Iv
Scheduling Ivact:l.m:mg j

0K | Cancel | Reset | Help |

3. Select Show Simulation Clock (optional), Show Analyzer/

Simulation Messages (optional), and Display Simulation CPU
Statistics (to display comparative results) from the Outputs tab.

» SystemBuild Simulation Parameters

Top Level SuperBlock
contimwous antomobile w TA

Inputs Dutputs
1] 2

Parameters ] Numerics ] ] Initialization ]

r— Output:

r—Progress Report

Reporting Period |in

_| Write Final Values of VAR Blocks

_| Use Extended Time Vector

I~ Show Sirmlation Clock

|~ show Analyzer/Sivulation Messages

| show Sivmlation Monitor

[~ Display Siwulation CPU Statistics

0K | Cancel | Reset | Help |

SystemBuild HyperBuild User Guide 2-4
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Chapter 2 Running HyperBuild from SystemBuild

After the simulation, you see output similar to the following:

Using variable step Variable Kutta-Merson integration.
Continuous states are solved explicitly.
Continuous outputs are solved explicitly.

Initialization Complete.
The solution is 1% complete.
The solution is 2% complete.

o°®

The solution is 5% complete.
The solution is 10% complete.
The solution is 20% complete.
The solution is 40% complete.
The solution is 60% complete.
The solution is 80% complete.
elapsed: 0 00:00:01.07 cpu: 0 00:00:01.06

The solution is 100% complete.

Simulation With HyperBuild

Using the same model and simulation parameters as in the Simulation
Without HyperBuild section, you can compare your simulation time using
HyperBuild.

In this example, you again use the super_cruise model and complete the
following steps from the SystemBuild - Catalog Browser.

1. Load (or open) the super_cruise model from the MTXHOME/sysbld/
demo directory.

2. Select the continuous automobile with IA block.
Select Tools»HyperBuild to create the _HB_Model component.

4. Simulate the model with HyperBuild by clicking _HB_Model and
then selecting Tools»Simulate.

The output from the simulation with HyperBuild is identical to the “without
HyperBuild” example except for the elapsed and cpu times.

elapsed: 0 00:00:00.54 cpu: 0 00:00:00.52

Because the super_cruise model is a small demonstration model, you do not
see the full power of the tool. However, you see about a 50% improvement
in the simulation speed even with this small model.

@ Note If you simulate a model and then load another model, you may need to delete some
of the generated files (for example, ucbhook . *) before simulating the _HB_Model
component again.

© National Instruments Corporation 2-5 SystemBuild HyperBuild User Guide



Running HyperBuild from Xmath

Running HyperBuild from the Xmath
Commands Window

To run HyperBuild from the Xmath Commands window, you can use the
following HyperBuild command:

hyperbuild "topSB", {keywords}

where topsSB (a text string) is the name of the top SuperBlock of the model
and keywords are described in Table 3-1.

Table 3-1. HyperBuild Keyword Options

Keyword Type Description

errorcheck | Integer Enables error checking in the
generated code. Default = 0.

file File Output file to receive generated code.

Note: The keyword has no suffix.

typecheck Boolean Enables data type checking in the
generated code. Default = 0.

ucbparams Boolean Lets the user configure UCBs to use
either RP/IP (real parameter/integer
parameter) hardcoded numbers or
Yovar encoding.

vars Boolean If 1 (default), put $variables into
the HyperBuild code.

The hyperbuild command generates three files: the C file (topSB. c), the
model file containing the _HB_Model component (topSB. hyb), and the
real-time file (topSB.rtf).

© National Instruments Corporation 3-1 SystemBuild HyperBuild User Guide



Chapter 3

Running HyperBuild from Xmath

For example, to generate HyperCode for the super_cruise model, enter the
following command sequence from the Xmath Commands window:

load file = "cruise_d.cat";
main.t = [0:0.1:300]";
hyperbuild "continuous automobile w IA", {typecheck};

where continuous automobile with IAis a top-level SuperBlock.
HyperBuild code is generated for the SuperBlocks contained in this topSB.
The _HB_Model component that is generated contains UCBs that
reference the HyperCode.

Linking a Simulation (Optional)

5

With HyperBuild, you can generate HyperCode and simulate the
_HB_Model component directly, or you can use the 1inksim command to
link your code with other UserCode Block files.

The 1inksim command has the following syntax:

linksim model, {csource, fsource}

where model is a string specifying the SystemBuild model to search for
UserCode Block source files, csource is a string specifying the C source
files to be compiled and linked into the simulator, and £source is a string
specifying the FORTRAN source files to be compiled and linked into the
simulator.

Note File names must be separated by spaces, and files specified in the UCB dialog boxes
need not be included.

The 1inksim command compiles and links UserCode Block source files
and creates a UCB shared library (simucb. *, where the extension is
platform dependent), in your local directory. For Windows, the extension is
.d11. For Solaris, SGI, and IBM platforms, the extension is . so.1.0. For
Compaq Tru64 platforms, the extension is . so. For HP platforms, the
extension is .s1.

Source files can be specified in the parameter dialog of each UserCode
Block reference in a model (no more than one file reference per UserCode
Block reference). The specified SystemBuild model is searched for source
files listed in any UCB, or referenced by the values of the csource and
fsource values set using setsbdefault.

SystemBuild HyperBuild User Guide 3-2 ni.com



Chapter 3 Running HyperBuild from Xmath

Simulating Linked HyperCode or linksim Qutput

To simulate linked HyperBuild code (the _HB_Model component) or the
output from linksim, use the following sim command (for example):

outputPDM = sim ("_HB_Model", InputPDM, {keywords})

where inputPDM is a PDM with domain as a time vector, the range is the
input, and keywords are as described in the MATRIXx Help.

@ Note Simulation of a HyperBuild model is exactly the same as simulation of any other
SystemBuild model and is described fully in the MATRIXx Help.

Running HyperBuild from a Script

The hyperbuild command is especially useful if you want to run a script
to perform your HyperCode creation and simulation. For example, the
following script loads the super_cruise model, runs HyperBuild, and then
simulates the continuous automobile with IA. This script also
simulates the _HB_Model component:

load file = "cruise_d.cat";

pause 6;

main.t = [0:0.1:300]";

hyperbuild "continuous automobile w IA", {typecheck};
[,main.ycsim] = sim("continuous automobile w IA",main.t,
{simtimer, typecheck});

[,main.ychyp] = sim("_HB_Model",main.t, {simtimer,
typecheck}) ;

For additional information about writing Xmath scripts, refer to the Xmath
User Guide.

© National Instruments Corporation 3-3 SystemBuild HyperBuild User Guide



Using HyperBuild

Usage Notes

When you are using HyperBuild, give special consideration to the
following:

If your regular SystemBuild simulation takes more than a few minutes,
or if you want to run it repeatedly, NI recommends the use of
HyperCode.

Only one HyperCode model at a time can be linked with the simulation
engine.

Because the HyperCode SuperBlock _ HB_Model is automatically
generated, the best way to change initial states, connections, or
parameters is to edit the original SuperBlock in the SystemBuild
model and then regenerate the HyperCode.

The generated code has comments that indicate the original
SuperBlock name, block name, and block type for each section
of code.

UserCode Blocks (UCBs) are allowed in HyperBuild models, just as
in conventional SystemBuild models. If you use the UPDUSR interface
to UCBs, you must specify all required source code files as csource
in Xmath, by using the SETSBDEFAULT command, and specify a
positive integer for the function name in the block dialog box. UCBs
created prior to version 4.0 are in this format.

Performance Results

Performance results will vary, but simulation speeds using HyperBuild
have been tested at seven to 10 times the speed of simulations without
HyperBuild. You can improve performance results by simplifying your
model in the following ways:

© National Instruments Corporation

Avoid implicit outputs and algebraic loops if possible.

Minimize the number of inputs and outputs.
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Chapter 4 Using HyperBuild

Use procedure states instead of task states where possible in discrete
subsystems.

Use floating-point signals instead of other types of signals for
subsystem inputs and outputs.

For additional information on improving performance, refer to the Code
Optimizations chapter of the AutoCode Reference.

Limitations

HyperBuild has the following limitations:

Algebraic loops within procedures are supported but discouraged for
efficiency reasons.

MathScript blocks are not supported.

Yovar data from the Xmath stack are re-initialized. HyperCode takes
the %var values that are set within Xmath at the time of code
generation. To change these values, you must change them in Xmath
and regenerate the code.

For specific information on SystemBuild topics, refer to the SystemBuild
User Guide or the MATRIXx Help.

SystemBuild HyperBuild User Guide
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Technical Support and
Professional Services

Visit the following sections of the National Instruments Web site at
ni.com for technical support and professional services:

Support—Online technical support resources at ni . com/support
include the following:

Self-Help Resources—For immediate answers and solutions,
visit the award-winning National Instruments Web site for
software drivers and updates, a searchable KnowledgeBase,
product manuals, step-by-step troubleshooting wizards, thousands
of example programs, tutorials, application notes, instrument
drivers, and so on.

Free Technical Support—All registered users receive free Basic
Service, which includes access to hundreds of Application
Engineers worldwide in the NI Developer Exchange at
ni.com/exchange. National Instruments Application Engineers
make sure every question receives an answer.

Training and Certification—Visit ni . com/training for
self-paced training, eLearning virtual classrooms, interactive CDs,
and Certification program information. You also can register for
instructor-led, hands-on courses at locations around the world.

System Integration—If you have time constraints, limited in-house
technical resources, or other project challenges, NI Alliance Program
members can help. To learn more, call your local NI office or visit
ni.com/alliance.

If you searched ni . com and could not find the answers you need, contact
your local office or NI corporate headquarters. Phone numbers for our
worldwide offices are listed at the front of this manual. You also can visit
the Worldwide Offices section of ni . com/niglobal to access the branch
office Web sites, which provide up-to-date contact information, support
phone numbers, email addresses, and current events.

© National Instruments Corporation
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multirate models, 1-2

National Instruments support and
services, A-1
NI support and services, A-1

P

performance, 4-1
procedure SuperBlocks, 1-2
programming examples (NI resources), A-1

R

required parameters, 2-3
resettable integrators, 1-2

S
SGI, 3-2
simulating HyperCode, 3-3
simulation parameters
output variable, 2-3
remake sim executable, 2-3
scheduling, 2-3
sim type, 2-3
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