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Important Information

Warranty
The AT-FBUS and AT-FBUS/2 are warranted against defects in materials and workmanship for a period of one year from the date of shipment,
as evidenced by receipts or other documentation. National Instruments will, at its option, repair or replace equipment that proves to be defective
during the warranty period. This warranty includes parts and labor.

The media on which you receive National Instruments software are warranted not to fail to execute programming instructions, due to defects
in materials and workmanship, for a period of 90 days from date of shipment, as evidenced by receipts or other documentation. National
Instruments will, at its option, repair or replace software media that do not execute programming instructions if National Instruments receives
notice of such defects during the warranty period. National Instruments does not warrant that the operation of the software shall be
uninterrupted or error free.

A Return Material Authorization (RMA) number must be obtained from the factory and clearly marked on the outside of the package before
any equipment will be accepted for warranty work. National Instruments will pay the shipping costs of returning to the owner parts which are
covered by warranty.

National Instruments believes that the information in this document is accurate. The document has been carefully reviewed for technical
accuracy. In the event that technical or typographical errors exist, National Instruments reserves the right to make changes to subsequent
editions of this document without prior notice to holders of this edition. The reader should consult National Instruments if errors are suspected.
In no event shall National Instruments be liable for any damages arising out of or related to this document or the information contained in it.

EXCEPT AS SPECIFIED HEREIN, NATIONAL INSTRUMENTS MAKES NO WARRANTIES, EXPRESS OR IMPLIED, AND SPECIFICALLY DISCLAIMS ANY WARRANTY OF

MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. CUSTOMER’S RIGHT TO RECOVER DAMAGES CAUSED BY FAULT OR NEGLIGENCE ON THE PART OF

NATIONAL INSTRUMENTS SHALL BE LIMITED TO THE AMOUNT THERETOFORE PAID BY THE CUSTOMER. NATIONAL INSTRUMENTS WILL NOT BE LIABLE FOR

DAMAGES RESULTING FROM LOSS OF DATA, PROFITS, USE OF PRODUCTS, OR INCIDENTAL OR CONSEQUENTIAL DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY

THEREOF. This limitation of the liability of National Instruments will apply regardless of the form of action, whether in contract or tort, including
negligence. Any action against National Instruments must be brought within one year after the cause of action accrues. National Instruments
shall not be liable for any delay in performance due to causes beyond its reasonable control. The warranty provided herein does not cover
damages, defects, malfunctions, or service failures caused by owner’s failure to follow the National Instruments installation, operation, or
maintenance instructions; owner’s modification of the product; owner’s abuse, misuse, or negligent acts; and power failure or surges, fire,
flood, accident, actions of third parties, or other events outside reasonable control.

Copyright
Under the copyright laws, this publication may not be reproduced or transmitted in any form, electronic or mechanical, including photocopying,
recording, storing in an information retrieval system, or translating, in whole or in part, without the prior written consent of National
Instruments Corporation.

Trademarks
FieldPoint™, LabVIEW™, Lookout™, National Instruments™, NI™, NI-FBUS™, NI-FMON™, and ni.com™ are trademarks of
National Instruments Corporation.

Product and company names mentioned herein are trademarks or trade names of their respective companies.

Patents
For patents covering National Instruments products, refer to the appropriate location: Help»Patents in your software, the patents.txt file
on your CD, or ni.com/patents.

WARNING REGARDING USE OF NATIONAL INSTRUMENTS PRODUCTS
(1) NATIONAL INSTRUMENTS PRODUCTS ARE NOT DESIGNED WITH COMPONENTS AND TESTING FOR A LEVEL OF
RELIABILITY SUITABLE FOR USE IN OR IN CONNECTION WITH SURGICAL IMPLANTS OR AS CRITICAL COMPONENTS IN
ANY LIFE SUPPORT SYSTEMS WHOSE FAILURE TO PERFORM CAN REASONABLY BE EXPECTED TO CAUSE SIGNIFICANT
INJURY TO A HUMAN.

(2) IN ANY APPLICATION, INCLUDING THE ABOVE, RELIABILITY OF OPERATION OF THE SOFTWARE PRODUCTS CAN BE
IMPAIRED BY ADVERSE FACTORS, INCLUDING BUT NOT LIMITED TO FLUCTUATIONS IN ELECTRICAL POWER SUPPLY,
COMPUTER HARDWARE MALFUNCTIONS, COMPUTER OPERATING SYSTEM SOFTWARE FITNESS, FITNESS OF COMPILERS
AND DEVELOPMENT SOFTWARE USED TO DEVELOP AN APPLICATION, INSTALLATION ERRORS, SOFTWARE AND
HARDWARE COMPATIBILITY PROBLEMS, MALFUNCTIONS OR FAILURES OF ELECTRONIC MONITORING OR CONTROL
DEVICES, TRANSIENT FAILURES OF ELECTRONIC SYSTEMS (HARDWARE AND/OR SOFTWARE), UNANTICIPATED USES OR
MISUSES, OR ERRORS ON THE PART OF THE USER OR APPLICATIONS DESIGNER (ADVERSE FACTORS SUCH AS THESE ARE
HEREAFTER COLLECTIVELY TERMED “SYSTEM FAILURES”). ANY APPLICATION WHERE A SYSTEM FAILURE WOULD
CREATE A RISK OF HARM TO PROPERTY OR PERSONS (INCLUDING THE RISK OF BODILY INJURY AND DEATH) SHOULD
NOT BE RELIANT SOLELY UPON ONE FORM OF ELECTRONIC SYSTEM DUE TO THE RISK OF SYSTEM FAILURE. TO AVOID
DAMAGE, INJURY, OR DEATH, THE USER OR APPLICATION DESIGNER MUST TAKE REASONABLY PRUDENT STEPS TO
PROTECT AGAINST SYSTEM FAILURES, INCLUDING BUT NOT LIMITED TO BACK-UP OR SHUT DOWN MECHANISMS.
BECAUSE EACH END-USER SYSTEM IS CUSTOMIZED AND DIFFERS FROM NATIONAL INSTRUMENTS' TESTING
PLATFORMS AND BECAUSE A USER OR APPLICATION DESIGNER MAY USE NATIONAL INSTRUMENTS PRODUCTS IN
COMBINATION WITH OTHER PRODUCTS IN A MANNER NOT EVALUATED OR CONTEMPLATED BY NATIONAL
INSTRUMENTS, THE USER OR APPLICATION DESIGNER IS ULTIMATELY RESPONSIBLE FOR VERIFYING AND VALIDATING
THE SUITABILITY OF NATIONAL INSTRUMENTS PRODUCTS WHENEVER NATIONAL INSTRUMENTS PRODUCTS ARE
INCORPORATED IN A SYSTEM OR APPLICATION, INCLUDING, WITHOUT LIMITATION, THE APPROPRIATE DESIGN,
PROCESS AND SAFETY LEVEL OF SUCH SYSTEM OR APPLICATION.



Compliance

FCC/Canada Radio Frequency Interference Compliance*

Determining FCC Class
The Federal Communications Commission (FCC) has rules to protect wireless communications from interference. The FCC
places digital electronics into two classes. These classes are known as Class A (for use in industrial-commercial locations only)
or Class B (for use in residential or commercial locations). Depending on where it is operated, this product could be subject to
restrictions in the FCC rules. (In Canada, the Department of Communications (DOC), of Industry Canada, regulates wireless
interference in much the same way.)
Digital electronics emit weak signals during normal operation that can affect radio, television, or other wireless products. By
examining the product you purchased, you can determine the FCC Class and therefore which of the two FCC/DOC Warnings
apply in the following sections. (Some products may not be labeled at all for FCC; if so, the reader should then assume these are
Class A devices.)
FCC Class A products only display a simple warning statement of one paragraph in length regarding interference and undesired
operation. Most of our products are FCC Class A. The FCC rules have restrictions regarding the locations where FCC Class A
products can be operated.
FCC Class B products display either a FCC ID code, starting with the letters EXN,
or the FCC Class B compliance mark that appears as shown here on the right.
Consult the FCC Web site at http://www.fcc.gov for more information.

FCC/DOC Warnings
This equipment generates and uses radio frequency energy and, if not installed and used in strict accordance with the instructions
in this manual and the CE Mark Declaration of Conformity**, may cause interference to radio and television reception.
Classification requirements are the same for the Federal Communications Commission (FCC) and the Canadian Department
of Communications (DOC).
Changes or modifications not expressly approved by National Instruments could void the user’s authority to operate the
equipment under the FCC Rules.

Class A
Federal Communications Commission
This equipment has been tested and found to comply with the limits for a Class A digital device, pursuant to part 15 of the FCC
Rules. These limits are designed to provide reasonable protection against harmful interference when the equipment is operated
in a commercial environment. This equipment generates, uses, and can radiate radio frequency energy and, if not installed and
used in accordance with the instruction manual, may cause harmful interference to radio communications. Operation of this
equipment in a residential area is likely to cause harmful interference in which case the user will be required to correct
the interference at his own expense.

Canadian Department of Communications
This Class A digital apparatus meets all requirements of the Canadian Interference-Causing Equipment Regulations.
Cet appareil numérique de la classe A respecte toutes les exigences du Règlement sur le matériel brouilleur du Canada.

Class B
Federal Communications Commission
This equipment has been tested and found to comply with the limits for a Class B digital device, pursuant to part 15 of the
FCC Rules. These limits are designed to provide reasonable protection against harmful interference in a residential installation.
This equipment generates, uses, and can radiate radio frequency energy and, if not installed and used in accordance with the
instructions, may cause harmful interference to radio communications. However, there is no guarantee that interference will not
occur in a particular installation. If this equipment does cause harmful interference to radio or television reception, which can
be determined by turning the equipment off and on, the user is encouraged to try to correct the interference by one or more of
the following measures:
• Reorient or relocate the receiving antenna.
• Increase the separation between the equipment and receiver.
• Connect the equipment into an outlet on a circuit different from that to which the receiver is connected.
• Consult the dealer or an experienced radio/TV technician for help.



Canadian Department of Communications
This Class B digital apparatus meets all requirements of the Canadian Interference-Causing Equipment Regulations.
Cet appareil numérique de la classe B respecte toutes les exigences du Règlement sur le matériel brouilleur du Canada.

Compliance to EU Directives
Readers in the European Union (EU) must refer to the Manufacturer’s Declaration of Conformity (DoC) for information**
pertaining to the CE Mark compliance scheme. The Manufacturer includes a DoC for most every hardware product except for
those bought for OEMs, if also available from an original manufacturer that also markets in the EU, or where compliance is not
required as for electrically benign apparatus or cables.
To obtain the DoC for this product, click Declaration of Conformity at ni.com/hardref.nsf/. This Web site lists the DoCs
by product family. Select the appropriate product family, followed by your product, and a link to the DoC appears in Adobe
Acrobat format. Click the Acrobat icon to download or read the DoC.

* Certain exemptions may apply in the USA, see FCC Rules §15.103 Exempted devices, and §15.105(c). Also available in
sections of CFR 47.

** The CE Mark Declaration of Conformity will contain important supplementary information and instructions for the user or
installer.
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About This Manual

This manual contains instructions on how to install and configure the
National Instruments AT-FBUS board and the NI-FBUS software. The
AT-FBUS board is intended for use in PCs equipped with 16-bit ISA slots.

The NI-FBUS software is intended for use with Windows 2000/NT
because Windows 9x is less robust than Windows 2000/NT. This manual
assumes that you are already familiar with your Windows operating system.

How To Use the Manual Set
Use the Foundation Fieldbus Overview to learn the basics of Fieldbus. The
Foundation Fieldbus Overview also includes tutorials to lead you through
developing a simple Fieldbus application.

Use this getting started manual to install and configure your AT-FBUS
board and the NI-FBUS software. To install your AT-FBUS board in the
Windows 2000/XP system environment, use the Installation Guide:
Foundation Fieldbus Hardware and NI-FBUS Software for Windows
2000/XP.

If you are using the NI-FBUS Configurator, use the NI-FBUS Configurator
User Manual to install and use the NI-FBUS Configurator software.

If you are using the NI-FBUS Communications Manager Application
Programmer Interface (API), use the NI-FBUS Communications Manager
User Manual to learn how to use the NI-FBUS Communications Manager
API for your application. Use the NI-FBUS Communications Manager
Function Reference Manual to look up specific information about
NI-FBUS Communications Manager functions, such as syntax and error
messages.

Conventions
The following conventions appear in this manual:

» The » symbol leads you through nested menu items and dialog box options
to a final action. The sequence File»Page Setup»Options directs you to
pull down the File menu, select the Page Setup item, and select Options
from the last dialog box.
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♦ The ♦ symbol indicates that the following text applies only to a specific
product, a specific operating system, or a specific software version.

This icon denotes a tip, which alerts you to advisory information.

This icon denotes a note, which alerts you to important information.

This icon denotes a caution, which advises you of precautions to take to
avoid injury, data loss, or a system crash.

AT-FBUS In this manual, the term AT-FBUS refers to both the single-port AT-FBUS
board and the dual-port AT-FBUS/2 board, unless otherwise indicated.

bold Bold text denotes items that you must select or click on in the software,
such as menu items and dialog box options. Bold text also denotes
parameter names.

Fieldbus The generic term Fieldbus refers to any bus that connects to field devices.
This includes Foundation Fieldbus, CAN, DNET, and Profibus. In this
manual, the term Fieldbus refers specifically to the Foundation Fieldbus.

italic Italic text denotes variables, emphasis, a cross reference, or an introduction
to a key concept. This font also denotes text that is a placeholder for a word
or value that you must supply.

monospace Text in this font denotes text or characters that you should enter from the
keyboard, sections of code, programming examples, and syntax examples.
This font is also used for the proper names of disk drives, paths, directories,
programs, subprograms, subroutines, device names, functions, operations,
variables, filenames and extensions, and code excerpts.

monospace bold Bold text in this font denotes the messages and responses that the computer
automatically prints to the screen. This font also emphasizes lines of code
that are different from the other examples.

monospace italic Italic text in this font denotes text that is a placeholder for a word or value
that you must supply.

NI-FBUS software In this manual, the term NI-FBUS software refers to either the NI-FBUS
Communications Manager or NI-FBUS Configurator software.

Platform Text in this font denotes a specific platform and indicates that the text
following it applies only to that platform.
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Related Documentation
The following documents contain information that you might find helpful
as you read this manual:

General Fieldbus Web sites

• Fieldbus Foundation—responsible for the definition of the Foundation
Fieldbus specification. www.fieldbus.org

• Relcom, Inc.—Wiring and test equipment for Foundation Fieldbus.
www.relcominc.com/fieldbus

• Fieldbus, Inc.—Device developers and Foundation Fieldbus
consulting. www.fieldbusinc.com

Fieldbus system development documentation

• Fieldbus Foundation resources

– Wiring and Installation 31.25 kbit/s, Voltage Mode, Wire Medium

• Relcom Fieldbus resources online

– Wiring Design and Installation Guide

– Online Tutorial

– FAQ

– Sample Fieldbus Topologies

• Fieldbus Standard for Use in Industrial Control Systems, Part 2,
ISA-S50.02.1992

Fieldbus device development documentation

• Developing Your First Foundation Fieldbus Device, available from the
Fieldbus, Inc. Web site at www.fieldbusinc.com

• Foundation Specification: 31.25 kbit/s Physical Layer Profile for the
Foundation Fieldbus Physical Layer Specifications

• Function Block Application Process, Part 1

• Function Block Application Process, Part 2

• IEC Standard 1158-2 and ISA Standard ISA S50.02
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1
Introduction

This chapter lists what you need to get started and includes a brief
description of the AT-FBUS board and the NI-FBUS software.

What You Need to Get Started
To install your NI-FBUS software, you need the following items:

❑ AT-FBUS board

❑ Installation disks

❑ Windows 2000/NT/9x installed on your computer

Note Because Windows 9x is less robust than Windows 2000/NT, National Instruments
strongly suggests that you use a Windows 2000/NT system with the National Instruments
Fieldbus software.

Hardware Description
The AT-FBUS is a plug-in board that handles communication between a
network-configurable device that complies with the Fieldbus Foundation
H1 specification and a PC that has a 16-bit ISA slot. The AT-FBUS uses an
Intel 386EX embedded processor, shared memory, and an interrupt to
communicate with its driver. The AT-FBUS supports the Fieldbus H1
transfer rate of 31.25 Kbits/s.

The single-port AT Fieldbus board is called the AT-FBUS and the dual-port
AT Fieldbus board is called the AT-FBUS/2. In this manual, the term
AT-FBUS refers to both the single-port AT-FBUS board and the dual-port
AT-FBUS/2 board, unless otherwise indicated.
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Software Description
Your kit includes either the NI-FBUS Communications Manager software
or the NI-FBUS Configurator software. Depending on the system you
purchase, you may receive both disks; if this is the case, you should use the
NI-FBUS Configurator software.

The NI-FBUS Communications Manager software is used by the interface
boards to communicate over the bus. Additionally, it provides a high-level
API advanced users can use to interface with the National Instruments
Foundation Fieldbus communication stack and hardware.

Most users use the NI-FBUS Configurator. In addition to providing the
functionality of the NI-FBUS Communications Manager in a graphical
format, it includes additional functionality to allow you to configure a
Fieldbus network. It can automatically generate the schedule for the
network and configure field devices and hosts to transmit and receive
alarms and trends.

NI-FBUS Interface Configuration Utility
The NI-FBUS Interface Configuration utility lets you view and change
the hardware configuration parameters for your Fieldbus interfaces. In
Windows 2000/NT, you can also edit your hardware configuration
parameters and add and delete interfaces.

The NI-FBUS Interface Configuration utility helps you to configure the
following information:

• Logical name for each port on your Fieldbus board; you can access the
port using the interface name

• Device description information

– Base directory for device description files

– Location of the standard text dictionary

You need to import device descriptions if you use the NI-FBUS
Communications Manager to communicate with devices that have
manufacturer-specific blocks or parameters.

• Fieldbus communication parameters for each Fieldbus interface
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In Windows 2000/NT, the NI-FBUS Configuration utility (fbconf.exe)
helps you to configure the following hardware information. In Windows 9x,
you can view (but not change) this information:

• Number of boards

• Base address of each board

• IRQ line assigned to each board

To change the base address or IRQ settings in Windows 9x, you must use
the Windows Device Manager and Add New Hardware wizard, as
described in Configure the AT-FBUS Board section in Chapter 2,
Installation and Configuration.

Caution Although the NI-FBUS Interface Configuration utility can be used to set certain
low-level network software parameters, you should not modify the Advanced parameters
without good reason. If you must modify parameters for certain devices, the device
manufacturer will recommend settings. Modifying these parameters can have an adverse
affect on data throughput rates. If settings are incorrectly modified, some devices might
disappear off the bus.

Choosing Configuration Software
Foundation Fieldbus links must be configured. Only with configuration
software can you do things like set device addresses, clear devices, and
download (necessary if you are setting up a system for the first time). Your
configuration software must match the interface board your computer is
using to connect to the bus. National Instruments offers the NI-FBUS
Configurator with a National Instruments Foundation Fieldbus interface
board to let you configure your Fieldbus links.

Interface boards and configuration software are sold separately because
multiple interface boards can reside in the same computer. The NI-FBUS
Configurator, by default, is licensed for use on one machine, with up to four
Fieldbus links (segments). If you have more than four links (ports on the
boards), you need to purchase a link upgrade for each link in excess of four.
To do so, download the order form from ni.com/fieldbus.

Note The connection to one interface port on the interface board is viewed as one link by
the NI-FBUS Configurator, regardless of how many links might actually be joined by
repeaters (important for software licensing of the NI-FBUS Configurator).
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If you only want to use the board to read and write values only (not
configure) and you are a programmer, you can make calls to the API in the
NI-FBUS Communications Manager and would not need the NI-FBUS
Configurator. This would be possible only if you have already used a
third-party’s hardware and configuration software to configure the link.

The following table describes the National Instruments Fieldbus software.

Table 1-1. National Instruments Fieldbus Software

Software Application Short Name Description File Name

NI-FBUS
Communications
Manager

NIFB process “The Blue Box”. This
must be running for
you to use your
AT-FBUS board as a
Fieldbus interface to
communicate between
the board and the bus.

nifb.exe

NI-FBUS Interface
Configuration Utility

Interface Config Used to configure your
AT-FBUS board.

fbconf.exe

NI-FBUS
Configurator

NI-FBUS
Configurator

Used to configure the
devices on the bus, set
the parameters for
control loops, and
other Fieldbus
configuration tasks.

fcs.exe

NI-FBUS Dialog
System

NI-FBUS Dialog Used to view the
devices on the bus and
manually read and
write parameter
values. Not for
configuration.

nifbdlg.exe

NI-FBUS Fieldbus
Monitor

NI-FMON
(also known as
NI Fieldbus
Monitor)

Functions as a bus
monitor, letting you
view all packets sent
over the bus. Primarily
used by developers to
debug new devices.

ni-fmon.exe
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Optional Fieldbus Network Tools
Your kit includes either the NI-FBUS Communications Manager software,
NI-FBUS Configurator software, or both. In addition, you can order the
NI-FBUS Monitor, LabVIEW DSC, and/or Lookout from National
Instruments. If you have not already done so, you can also order the
NI-FBUS Configurator.

The NI-FBUS Monitor helps you monitor and debug Fieldbus data traffic.
It is primarily used to debug the development of device and host
applications. It symbolically decodes data packets from the Fieldbus,
monitors the live list (devices currently on the bus), and performs statistical
analysis of packets.

Note If you are using this interface as a bus monitor, the other interface (if this is a
two-port board) cannot be used for NI-FBUS. This means that you must have another link
master on the link—either another AT-FBUS board, or a device with link master
capabilities. An interface board can either run NI-FBUS software or NI-FMON software
at any given time. If the board has two ports, they both must have the same usage. This is
because a different stack is downloaded to the board for it to be used in conjunction with
NI-FMON. Your interface board must be running NI-FBUS to act as the Link Active
Scheduler. This means that if your interface board is the only link master on the link, you
cannot use that board for running NI-FMON (even if the board has two ports) since that
would leave the link without a link master. In this situation, you would need to obtain either
a link master field device or another link master interface board in order to use NI-FMON.

LabVIEW DSC helps you perform data acquisition and analysis, create a
human-machine interface (HMI), or develop an advanced supervisory
control application in a graphical development environment.
LabVIEW DSC includes real-time process monitoring, historical trending,
alarm and event reporting, online configuration, and PLC connectivity.

Server Explorer Server Explorer Lets you configure
the attributes of the
communication
resource, device, and
items of your network,
and the groups and
items of your OPC
server.

serverexplorer.exe

Table 1-1. National Instruments Fieldbus Software (Continued)

Software Application Short Name Description File Name
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Lookout helps you create graphical representations on a computer screen
of real-world devices such as switches, dial gauges, chart recorders,
pushbuttons, knobs, sliders, and meters. After linking these images to your
field instruments, you can configure Lookout to generate alarms, log data
to disk, animate custom graphics, print reports, automatically adjust
setpoints, historically trend information, warn operators of malfunctions,
and so on.
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2
Installation and Configuration

Install the Software
♦ Windows 2000/NT—Complete the following steps to install your NI-FBUS

software:

Caution If you are reinstalling the NI-FBUS software over an existing version, write down
your board configuration and any port configuration parameters you changed from their
defaults. Reinstalling may cause you to lose any existing board and port configuration
information.

1. Log in as Administrator or as a user that has Administrator
privileges.

2. Insert installation disk 1 or your F-BUS program CD.

3. Select Start»Run.

4. In the Run dialog box, type the following:

x:\setup

where x is the letter of the drive containing the disk (usually a or b).

5. The interactive setup program takes you through the necessary steps to
install the software.

6. At the end of the setup, an Add New Board dialog box may appear.
If you have not yet installed your board, click on Cancel. You will
install your board in a later step.

The installation program copies nifb.dll and drvintf.dll into your
\System32 directory, and it copies the nifb.sys driver into the
\drivers directory. The installation program also adds information to the
Windows registry.

♦ Windows 9x—Complete the following steps to install your NI-FBUS
software:

The NI-FBUS software for Windows 9x requires DCOM. If you do not
already have DCOM installed on your computer, you need to install it
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before you install your NI-FBUS software. You can download a copy of
DCOM from the MicrosoftCOM Web site at www.microsoft.com/Com.

1. Insert installation disk 1.

2. Select Start»Run.

3. In the Run dialog box, type the following:

x:\setup

where x is the letter of the drive containing the disk (usually a or b).

4. The interactive setup program takes you through the necessary steps to
install the software.

The installation program copies nifb.dll, nifb.vxd, and
drvintf.dll into the \System directory. The installation program also
adds information to the Windows Registry.

Continue to the next section to configure and install your board.

Configure the AT-FBUS Board
By default, the AT-FBUS board is set to use Memory Base Address
0x0D0000 and Interrupt Line (IRQ) 11. The default board settings are
suitable for many computer systems. However, if these default settings
conflict with another device in your system, or if you need to install more
than one AT-FBUS board, you must change the default settings before you
install the board. If you are installing more than one AT-FBUS board, each
board must use a unique memory base address.

♦ Windows 2000—Select Start»Settings»Control Panel»Administrative
Tools»Computer Management»System Tools»System Information»
Hardware Information. Then, click on the Memory item.

♦ Windows NT—Select Start»Programs»Administrative Tools
(Common)»Windows NT Diagnostics. Then, click on the Resources tab.

♦ Windows 9x—Select Start»Settings»Control Panel»System. Click on the
Device Manager tab. Select Computer and click on the Properties button.
The Computer Properties dialog box appears.
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Select an Unused Interrupt Request Line
PCs that support AT boards have a series of interrupt lines available to
devices. Devices use interrupts to get immediate service from the CPU for
asynchronous events.

1. Click on the IRQ button or select the Interrupt request (IRQ) radio
button to view IRQ lines that your system is currently using.

2. Select an unused IRQ line. By default, your board is set to use IRQ11.
Use this address if it is available. You can configure the AT-FBUS
board to use any of the following interrupt lines: 3, 4, 5, 6, 7, 9, 10, 11,
12, 14, or 15.

Note The AT-FBUS cannot use an interrupt line that another device in your system is
already using.

3. Write some unused IRQ line(s) in Table 2-1.

Select an Unused Memory Base I/O Address
The AT-FBUS board is a memory-mapped device, which means that the
driver software can use the AT-FBUS memory registers as if they were
standard memory. The memory base address of the AT-FBUS is the first
position in the total memory address space occupied by the AT-FBUS.

The AT-FBUS is configured to use the default memory base address
0x0D0000. With this setting, the board uses the memory space
from 0x0D0000 through 0x0D3FFF. Your computer’s conventional DRAM
and all other devices cannot use the memory space you assign to the
AT-FBUS board.

1. Click on the Memory button or select the Memory radio button to
view the I/O addresses that your system is currently using.

2. Select a base I/O address that does not appear in this window. By
default, your board is set to use 0x0D0000. Use this address if it is
available. Memory base address 0x0D4000 is unused in many systems.
Table 2-2 lists all address ranges used by NI-FBUS.

3. Write some unused base I/O addresses in Table 2-1.

Table 2-1. Your Conflict-Free Resources

Hardware Setting Selected Resource

IRQ Line

Memory Base Address
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Note Even though an address does not show up in the device manager, it still may have
conflicts. You will verify that your resources are conflict-free in the Set the NI-FBUS
Software to Use Your NI-FBUS Board section.

Change the Hardware Settings

Caution Before you remove the AT-FBUS from the package, touch the antistatic plastic
package to a metal part of your system chassis to discharge electrostatic energy, which can
damage several components on your board.

Follow these instructions if you need to change the hardware settings of the
AT-FBUS board.

Figure 2-1 shows the location of the switches, jumpers, and two connectors
on the AT-FBUS/2 board. If you are using the single-port AT-FBUS, your
board has only one connector.

Figure 2-1. AT-FBUS/2 Parts Locator Diagram

1 Product Name
2 Serial Number

3 Fieldbus Connectors
4 Jumpers for IRQ

5 Memory Base Address Switches
6 Assembly Number

1

45

2

3

6

1 2 3 4 5 6

O
F
F

64321 5
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Change the Interrupt Request Line
If you need to use an IRQ other than the default or if you are installing more
than one board, complete the following steps to reconfigure the interrupt
request line.

1. Find the jumpers that set the interrupt request line. Refer to Figure 2-1.
The jumpers are located on the lower edge of your AT-FBUS board.
The number on the board under each pair of pins corresponds to an
AT bus interrupt level.

2. Change the jumper settings to configure the AT-FBUS board to a
conflict-free interrupt request line that you wrote in Table 2-1. Place
the jumper on the pair of pins directly above the number of the
interrupt level you want.

By default, the AT-FBUS board uses interrupt request line 11. Figure 2-2
shows the setting for IRQ11.

Figure 2-2. Interrupt Jumper Setting for IRQ11

Using Polled Mode
If you are installing more than one AT-FBUS board, no two boards can be
configured for the same IRQ. If you do not have a free IRQ, you can
configure your Fieldbus interface to operate in polled mode (no IRQ line).
Polled mode allows the board to operate without an IRQ. In this situation,
the board cannot request immediate service from the CPU. Instead, it is
periodically polled by the driver to determine if an event needs handling.
This results in a slow-down on the order of a few milliseconds.

To use polled mode, do not place the jumper across any pair of pins. To
avoid losing your jumper, you can place it over any one pin, as shown in
Figure 2-3.

3

W1

456791011121415
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Figure 2-3. Interrupt Jumper Setting for No IRQ

Note Polled mode consumes more processor time, so you should only use it if there are
no free IRQs in your system for the Fieldbus hardware to use. For more information about
polled mode, refer to Appendix B, Troubleshooting and Common Questions.

Change the Memory Base Address
1. Locate the memory base address switches on your AT-FBUS board.

Refer to Figure 2-1.

2. In Table 2-2, find one of the conflict-free memory base addresses you
wrote in Table 2-1. Bold italic denotes default setting. Change the
switch settings as indicated in Table 2-2. If 0x0D4000 was on your
conflict-free list, this is often a good address to choose. Figure 2-4
shows the switches set to memory base address setting 0x0D4000.

Figure 2-4. Memory Base Address 0x0D4000 Switch Setting

Table 2-2. Memory Base Address Switch Settings

Base
Address

Top of
Range

Hardware
Setting

Switch Setting

SW1 SW2 SW3 SW4 SW5 SW6

0C0000 0C1FFF ON ON OFF ON ON OFF

0C4000 0C5FFF ON ON OFF ON OFF OFF

3

W1

456791011121415

Push this side down for (ON)

Push this side down for (OFF)

64321 5
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0C8000 0C9FFF ON ON OFF OFF ON OFF

0CC000 0CDFFF ON ON OFF OFF OFF OFF

0D0000 0D1FFF ON ON ON ON ON OFF

0D4000 0D5FFF ON ON ON ON OFF OFF

0D8000 0D9FFF ON ON ON OFF ON OFF

0DC000 0DDFFF ON ON ON OFF OFF OFF

0E0000 0E1FFF ON OFF OFF ON ON OFF

0E4000 0E5FFF ON OFF OFF ON OFF OFF

0E8000 0E9FFF ON OFF OFF OFF ON OFF

0EC000 0EDFFF ON OFF OFF OFF OFF OFF

0F0000 0F1FFF ON OFF ON ON ON OFF

Table 2-2. Memory Base Address Switch Settings (Continued)

Base
Address

Top of
Range

Hardware
Setting

Switch Setting

SW1 SW2 SW3 SW4 SW5 SW6
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0F4000 0F5FFF ON OFF ON ON OFF OFF

0F8000 0F9FFF ON OFF ON OFF ON OFF

0FC000 0FDFFF ON OFF ON OFF OFF OFF

8C0000 8C1FFF OFF ON OFF ON ON OFF

8C4000 8C5FFF OFF ON OFF ON OFF OFF

8C8000 8C9FFF OFF ON OFF OFF ON OFF

8CC000 8CDFFF OFF ON OFF OFF OFF OFF

8D0000 8D1FFF OFF ON ON ON ON OFF

8D4000 8D5FFF OFF ON ON ON OFF OFF

8D8000 8D9FFF OFF ON ON OFF ON OFF

8DC000 8DDFFF OFF ON ON OFF OFF OFF

Table 2-2. Memory Base Address Switch Settings (Continued)

Base
Address

Top of
Range

Hardware
Setting

Switch Setting

SW1 SW2 SW3 SW4 SW5 SW6
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Install the AT-FBUS Board

Note Before you install your board, double-check to make sure the settings on your board
match the resources you have chosen.

1. Shut down your operating system and power off your computer. Keep
the computer plugged in so that it remains grounded while you install
the AT-FBUS board.

2. Remove the top cover or access port of the I/O channel.

8E0000 8E1FFF OFF OFF OFF ON ON OFF

8E4000 8E5FFF OFF OFF OFF ON OFF OFF

8E8000 8E9FFF OFF OFF OFF OFF ON OFF

8EC000 8EDFFF OFF OFF OFF OFF OFF OFF

8F0000 8F1FFF OFF OFF ON ON ON OFF

8F4000 8F5FFF OFF OFF ON ON OFF OFF

8F8000 8F9FFF OFF OFF ON OFF ON OFF

8FC000 8FDFFF OFF OFF ON OFF OFF OFF

Table 2-2. Memory Base Address Switch Settings (Continued)

Base
Address

Top of
Range

Hardware
Setting

Switch Setting

SW1 SW2 SW3 SW4 SW5 SW6
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3. Remove the expansion slot cover on the back panel of the computer.

4. As shown in Figure 2-5, insert the AT-FBUS board into any unused
16-bit ISA slot with the Fieldbus connector sticking out of the opening
on the back panel. Make sure all pins are equally far into the connector.
Although it might be a tight fit, do not force the board into place.

Figure 2-5. Installing the AT-FBUS Board

5. Screw the mounting bracket of the AT-FBUS board to the back panel
rail of the computer.

6. Keep the top cover or access port off until you have verified that your
resources are non-conflicting, as described in the next section, Set the
NI-FBUS Software to Use Your NI-FBUS Board.

7. Power on your computer.

Proceed to the next section, Set the NI-FBUS Software to Use Your
NI-FBUS Board.
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Set the NI-FBUS Software to Use Your NI-FBUS Board
The physical settings on your AT-FBUS board must match the software
settings you configure. Use the hardware settings you selected in the
Configure the AT-FBUS Board section.

Note You can only connect one NI-FBUS port to a link or Fieldbus.

Set the Base Address and IRQ
♦ Windows 2000/NT—Use the NI-FBUS Interface Configuration utility to add,

view, or change your base address or IRQ settings.

1. Start the NI-FBUS Interface Configuration utility. Select Start»
Programs»National Instruments»NI-FBUS»Interface Config.

2. In the Interface Config window, select the icon of the board you want
to change and click on the Edit button. If you are adding a board, click
on the Add Interface Device button.

3. Choose ISA as the Bus Type. The NI-FBUS Interface Configuration
utility displays the default base address and IRQ line.

4. Change the base memory address and interrupt request settings to
match the settings you used when installing your board.

If you have configured your AT-FBUS board not to use interrupts,
select No Interrupt from the IRQ drop-down list, and check the
Polled Mode checkbox.

5. If you are adding a board, select the number of ports that matches your
AT-FBUS. For example, select two ports for the AT-FBUS/2.

6. After verifying the information you just entered, click on the OK or
Add button. The dialog box for entering port information for the
Fieldbus interface appears.

7. Click on OK.

Proceed to the next section, Set the Communication Parameters and
Interface Name.

♦ Windows 9x—Use the Add New Hardware wizard to add your AT-FBUS
board, and use the Device Manager to configure resources for the AT-FBUS
board.

1. Add your AT-FBUS board:

a. To open the Add New Hardware Wizard, select Start»Settings»
Control Panel»Add New Hardware.
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b. When asked if Windows should search for new hardware, select
No to keep Windows from trying to detect the hardware
automatically (Windows cannot detect Fieldbus adapters). Click
on the Next button.

c. Select Other Devices from the Hardware Types list that appears,
and click on Next.

d. In the dialog box that appears, select National Instruments in the
Manufacturers list on the left. In the Models list, select
AT-FBUS (1 Port) or AT-FBUS/2 (2 Port), depending on which
board you are installing. Click on the Next button, twice in a row.

e. Click on the Finish button. In the dialog box that asks if you want
to shut down, click on No.

2. Verify that the computer has assigned valid resources.

a. To open the Device Manger, select Start»Settings»Control
Panel»System, then click on the Device Manager tab.

b. Click on the Fieldbus adapters icon, select the AT-FBUS board,
and click on the Properties button. The AT-FBUS Properties
dialog box appears.

c. Click on the Resources tab.

d. Configure resources for your AT-FBUS board. If you want to use
polled mode, select a Basic Configuration that does not include
an IRQ.

Make sure the Resource Settings match the jumper and switch
settings configured on your AT-FBUS board. You can change a
setting by double-clicking on the setting in the Resource settings
list, or by selecting the resource type and clicking on the Change
Settings button. The Conflicting device list field shows if there
are any known conflicts with the resources you choose.

e. After you have selected nonconflicting resources, click on the
OK button twice to save your changes.

Set the Communication Parameters and Interface Name
Use the NI-FBUS Interface Configuration utility to set the Fieldbus
communication parameters and interface name.

1. Start the NI-FBUS Interface Configuration utility. Select Start»
Programs»National Instruments»NI-FBUS»Interface Config.

2. Select the port you want to edit, and click on the Edit button.

3. The NI-FBUS Interface Configuration utility displays the default
interface name and some configuration information.
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4. Enter an interface name for the port, or use the default name. The
interface name is for local use on the PC.

5. Enter a unique tag in the Device Tag field, or use the default device
tag. The device tag is the name visible on the Fieldbus to the other
devices.

6. Your interface must be given either a fixed or visitor device address for
you to start using NI-FBUS. This address must be unique on the link
to which the interface is connected.

a. To assign a fixed address to your Fieldbus interface, choose Fixed
Address and enter a value in the range 0x10 to 0xF7.

By convention, the lower addresses starting at 0x10 are usually
used for interface boards and link masters. Upper addresses,
starting at 0xF7 and working down, are generally used for other
devices. Using a lower address for your interface will reduce the
likelihood that the interface will conflict with another device on
the bus.

b. If you want your interface to be a temporary device that you do not
intend to connect to the Fieldbus for an extended time, choose
Visitor Address. Over a long period of time, using a visitor
address could break VCR endpoints and cause VCR_FULL_ERROR
errors.

c. If you want third-party Fieldbus configuration software to assign
an address to your interface over the Fieldbus, choose Default
Address. You should only choose to use a default address when
you want third-party configuration software to assign a permanent
address. A device at a default address cannot be communicated
with until a permanent address has been assigned by the
configuration software.

7. Select a Device Type. You should choose to use Link Master Device.

8. Make sure that NI-FBUS is selected for Usage, unless you will be
using the board in conjunction with the NI-FMON software.

If you are using this interface as a bus monitor, the other interface
(if this is a two-port board) cannot be used for NI-FBUS. This means
that you must have another link master on the link—either another
AT-FBUS board, or a device with link master capabilities. See the
Optional Fieldbus Network Tools section in Chapter 1, Introduction,
for more information.

NI-FBUS assigns default values for other network communication
parameters.
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Caution Do not modify the Advanced parameters without good reason. If you must
modify parameters for certain devices, the device manufacturer will recommend settings.
Modifying these parameters can have an adverse affect on data throughput rates. If settings
are incorrectly modified, some devices might disappear off the bus.

9. Click on OK, then click on OK again to exit the configuration utility.

10. Restart the NIFB process by selecting Start»Programs»
National Instruments»NI-FBUS»NIFB to make the changes you
made in the NI-FBUS Interface Configuration utility take effect.

11. Under Windows NT, if you change or delete the interface configuration,
you must stop and restart the NI-FBUS Communications Manager
nifb.exe so that the new configuration will take effect. You can start
or stop the driver by selecting Start»Settings»Control Panel»
Devices»Nifb, and clicking on the Stop/Start button.

12. Replace the top cover on your computer, if you have not done so
already.

Configure Driver for Windows 2000
1. Select Start»Settings»Control Panel»System»Hardware»Device

Manager. From the menu, select View»Show hidden devices.

2. From the list of non-Plug & Play devices, right-click on NIFB and
select Properties.

3. Select Driver from the Properties page that appears. You can now
start the driver by clicking on the Start button. To set the driver to be
started up automatically at system start-up, set the Startup Type to
Automatic.

4. To view/troubleshoot the hardware resources being used by your
AT-FBUS interface board, select Nifb»Properties»Resources. The
Nifb Properties dialog box appears. If you need to change any
resources, use the Interface Configuration utility. Do not change
properties from this dialog box.

5. If you cannot find the NIFB device in non-Plug & Play devices list in
Device Manager, enter the following command at the command
prompt:

net start nifb

You will find the nifb in Non-Plug and Play Drivers list and it will
start.
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Test the Installation
♦ Windows 2000—To make sure that your NI-FBUS software is installed

correctly and is working properly, complete the following steps:

1. Select Start»Settings»Control Panel»System»Hardware»Device
Manager. From the menu, select View»Show Hidden Devices.

2. From the list of non-Plug & Play devices, right-click on NIFB and
select Properties.

3. Select Driver from the Properties page that appears. You can now
start the driver by clicking on the Start button.

4. Start the NIFB process by selecting Start»Programs»
National Instruments»NI-FBUS»NIFB.

♦ Windows NT—To make sure that your NI-FBUS software is installed
correctly and is working properly, complete the following steps:

1. After you configure your installation, restart Windows. You must
restart your computer before you can use the NI-FBUS software.

2. Start the kernel-mode device driver NIFB by selecting Start»
Settings»Control Panel»Devices»Nifb and clicking on the Start
button.

Tip You can have the device driver start automatically when your computer boots. Refer
to Chapter 3, Start the NIFB Process, for instructions.

3. Start the NIFB process selecting Start»Programs»
National Instruments»NI-FBUS»NIFB.

♦ Windows 9x—Start the NIFB process by selecting Start»Programs»
National Instruments»NI-FBUS»Nifb. The NIFB process must be
running in the background to use any Fieldbus application.

On successful startup, the NIFB displays a message saying that the process
started up successfully, the title bar of the NIFB window changes to
NI-FBUS (running), and a blue box icon appears on the Windows taskbar.
It may take a few minutes for NIFB to start up and this message to display.

If NI-FBUS does not start up successfully, the base memory address, IRQ
line, or Fieldbus network address is incorrect. If the NIFB process does not
start up successfully, refer to Appendix B, Troubleshooting and
Common Questions.
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Changing Resources to Eliminate Conflicts

Note If you do not suspect you have resource conflicts, proceed to Chapter 3, Start the
NIFB Process.

If you discovered resource conflicts when testing the installation, you need
to change your base address or IRQ settings. To change these settings,
follow these steps, then refer to the Configure the AT-FBUS Board section.

♦ Windows 2000—Windows usually assigns conflict-free resources
automatically. To view assigned resources, complete the following steps:

1. Select Start»Settings»Control Panel»System»Hardware»Device
Manager. From the menu, select View»Show Hidden Devices.

2. From the list of non-Plug & Play devices, double-click on NIFB.

3. Make sure the settings shown match the settings configured on your
board. You may need to shut down your computer and remove the
board to re-configure your board settings to match those shown in the
Device Manager.

4. Click on OK twice.

♦ Windows NT—Windows usually assigns conflict-free resources
automatically. To view assigned resources, complete the following steps:

1. Select Start»Programs»Administrative Tools (Common)»
Windows NT Diagnostics, and select the Resources tab.

2. Click on the Devices button.

3. Double-click on nifb.

4. Make sure the settings shown match the settings configured on your
board. You may need to shut down your computer and remove the
board to re-configure your board settings to match those shown in the
Windows NT Diagnostics.

5. Click on OK twice.

♦ Windows 9x—To change resources to eliminate conflicts, complete the
following steps:

1. Select Start»Settings»Control Panel, and double-click on the
System icon.

2. Click on the Device Manager tab.

3. Locate your board under the heading Fieldbus Adapters.
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4. Click on the name of the board, then click on the Properties button.

5. Use the Resources tab to view or edit the resources assigned to the
board.

Note After you change the resource settings, shut down your computer and move the
hardware jumper and switches to match. See the Change the Hardware Settings section,
earlier in this chapter, for information on changing the hardware settings.

Changing or Deleting Existing Interface Information
♦ Windows 2000/NT—To change or delete information about any interface that

you have already entered, complete the following steps:

1. Select Start»Programs»National Instruments»NI-FBUS»
Interface Config.

2. Click on the Boardx icon, where x refers to the board number of the
interface you want to change or delete.

3. Click on the Edit button. You can edit the interface configuration
information that you entered earlier, or click on Delete to delete this
interface entirely.

Interfaces are numbered beginning with zero. If you delete an
interface, the NI-FBUS Interface Configuration utility renumbers all
the remaining interfaces. For example, if you delete Board0, it appears
that you deleted the last interface, because all the remaining interface
numbers are decreased by one automatically.

♦ Windows 9x—To change the hardware resources in Windows 9x, you must
use the Windows Device Manager rather than the NI-FBUS Interface
Configuration utility. For more information, refer to the Changing
Resources to Eliminate Conflicts section.

Table 2-3. Board Renumbering

Original Address Address after Deleting Board1

Board0 Board0

Board1 (deleted)

Board2 Board1

Board3 Board2
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To delete a National Instruments Fieldbus interface in Windows 9x,
complete the following steps:

1. Select Start»Settings»Control Panel, and double-click on the
System icon.

2. Click on the Device Manager tab.

3. Locate your board under the heading Fieldbus Adapters.

4. Click on the name of the board, then click on the Remove button.

Run the NI-FBUS Interface Configuration utility once to make sure the
interface has been removed.

To re-install the interface, refer to the installation and configuration
instructions earlier in this chapter.

Import Device Descriptions
The device description files contain information about the types of blocks
and parameters supported by your Fieldbus device, along with online help
describing the uses of given parameters. If your Fieldbus device uses
manufacturer-specific device description files, you must import the device
description files (shipped with the device, or available from the device
manufacturer). To do so, complete the following steps:

1. Insert the device description disk or CD (if supplied by your Fieldbus
device manufacturer) into the disk drive of the host computer.

2. Select Start»Programs»National Instruments»NI-FBUS»
Interface Config to run the Interface Configuration utility.

3. Click on the DD Info button. The DD Info dialog box appears.

4. If the base directory field is blank, enter a base directory. The base
directory you enter here will be where NI-FBUS looks for all device
descriptions. Do not change the base directory after you have started
importing device descriptions; otherwise, NI-FBUS will not be able to
find the device descriptions you previously imported. Your device
description files will automatically be placed in the appropriate
manufacturer ID subdirectory under this base directory.

Your base directory will include one folder for each different
manufacturer for which you have imported device description. For
example, if you import the device description for the National
Instruments FP-3000 device, you will find a folder called 4e4943.
This is the National Instruments Foundation Fieldbus device
manufacturer ID number.
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The next layer of folders is the device type. For example, the FP-3000
has a device type ID number of 4005.

Underneath this layer of directories you will find the individual device
description files (.ffo and .sym).

5. If necessary, click on the Browse button to select the standard text
dictionary, provided with NI-FBUS. The text dictionary has a .dct
extension.

6. Click on the Import DD button. The Import DD dialog box appears.

7. Click on the Browse button, browse to the .ffo device description file
path, and click on Open. Typically, the device description for your
Fieldbus device is supplied on a disk from the manufacturer. For each
device, there are two device description files, one that ends in .ffo

and one that ends in .sym. Select the .ffo file, and the corresponding
.sym file will be imported automatically. The file name will be in the
form Digit Digit Digit Digit.ffo (for example, 0101.ffo).

Note If you are importing device descriptions for multiple devices, you might see that they
can have the same filenames. Each file contains information about the device and its
manufacturer, and will be placed appropriately in the hierarchy under the base directory.

8. Click on OK. A window will appear that gives the full path to which
the .ffo and .sym files were copied.

9. Click on OK.

For more information on device descriptions, refer to the Device
Descriptions section in the Foundation Fieldbus Overview document.

Fieldbus Cable Connector Pinout
If you want to make your own Fieldbus cable, make sure that it uses pins 6
and 7 for the Fieldbus signals, as shown in Figure 2-6, and make sure that
it follows the specification in the Fieldbus Standard for Use in Industrial
Control Systems, Part 2, ISA-S50.02.1992. Figure 2-6 shows the connector
pinout of the AT-FBUS.
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Figure 2-6. Fieldbus Connector Pinout for the AT-FBUS

Install and Wire Your Fieldbus Devices
What you need:

❑ Cable compliant with the Fieldbus Standard for Use in Industrial
Control Systems, Part 2, ISA-S50.02.1992

❑ Terminator(s) with capacitor and resistor of appropriate size

Refer to the documentation that came with your device for complete
instructions on how to install and wire your Fieldbus devices.

Termination
You must terminate your wiring in compliance with the Foundation
Fieldbus specification. Foundation Fieldbus requires a resistor and a
capacitor in parallel. You must place termination appropriately on the
network, which will depend on your network topology. Refer to Wiring and
Installation 31.25 kbit/s, Voltage Mode, Wire Medium, or the Relcom, Inc.
Wiring Design and Installation Guide.

Replacing Devices
NI-FBUS is capable of dynamic device replacement. There is no need to
restart NI-FBUS if a device on the link has its application changed (but its
device ID remains the same).

1
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No Connection
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No Connection
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No Connection

Data -
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3
Start the NIFB Process

The NIFB process must be running any time you want to use your
AT-FBUS board as a Fieldbus interface to communicate between the board
and the bus.

♦ Windows 2000

1. Start the NIFB driver by selecting Start»Settings»Control Panel»
System»Hardware»Device Manager»View»Show hidden devices
and clicking on the Start button.

2. Start the NIFB process by selecting Start»Programs»
National Instruments»NI-FBUS»Nifb.

♦ Windows NT—If the NIFB kernel-mode driver has not already been started,
you must do so manually.

1. Start the kernel-mode driver NIFB by selecting Start»Settings»
Control Panel»Devices»Nifb and clicking on the Start button.

2. Start the NIFB process by selecting Start»Programs»
National Instruments»NI-FBUS»Nifb.

Note You also can start the driver by entering net start nifb at the command prompt.

If you receive the message System error 31 has occurred, the cause is most likely
an interrupt or memory address conflict. Set the device to poll mode or change the memory
address value.

♦ Windows 9x—Start the NIFB process by selecting Start»Programs»
National Instruments»NI-FBUS»Nifb.
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Configure NIFB to Load at System Startup
If the driver and the process start up successfully, you can configure the
kernel-mode driver (for Windows NT) and NIFB process to start
automatically when you boot or restart your computer.

Note To do this on a Windows NT machine, you must be running Windows NT 4.0
or later.

♦ Windows 2000—Select Start»Settings»Control Panel»System»
Hardware»View»Show hidden devices»Nifb. Click on the StartUp
button. Select Automatic. Then, place a shortcut to NIFB.exe in your
Startup folder.

♦ Windows NT—Select Start»Settings»Control Panel»Devices»Nifb.
Click on the StartUp button. Select Automatic. Then, place a shortcut to
NIFB.exe in your StartUp folder.

♦ Windows 9x—Add the NIFB shortcut to the StartUp folder. Refer to your
Microsoft Windows online help for information on adding programs to the
StartUp folder.

Begin to Use Your NI-FBUS Software
If you are using the NI-FBUS Communications Manager, proceed to the
NI-FBUS Communication Manager User Manual for information on using
your software. If you are using the NI-FBUS Configurator, proceed to the
NI-FBUS Configurator User Manual for information on using your
software.

If NI-FBUS is unable to connect to and initialize an interface device,
and you decide to continue NI-FBUS startup, NI-FBUS will not try to
reconnect to that interface again. This is true of all interface types supported
by this software.

If a AT-FBUS interface is configured as a basic device, a link master device
must be present on this link before NI-FBUS will start up.
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A
Specifications

This appendix describes the electrical, physical, and environmental
characteristics of the AT-FBUS hardware and the recommended operating
conditions.

Power Requirement
AT-FBUS................................................ 750 mA Typical

AT-FBUS/2............................................. 820 mA Typical

Physical
Dimensions............................................. 10.7 by 19.1 cm

(4.2 by 7.5 in.)

I/O connector.......................................... DB-9 DSUB
(1 per Fieldbus link)

Operating Environment
Component temperature......................... 0 to 70 °C

Relative humidity ................................... 10 to 90%, noncondensing

Storage Environment
Temperature............................................ –40 to 125 °C

Relative humidity ................................... 5 to 90%, noncondensing

EMI ........................................................ FCC Class B Certified
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B
Troubleshooting and
Common Questions

This appendix describes how to troubleshoot common problems that occur
while getting started with Fieldbus.

Error Messages
Unable to download stack to board X

You might have a memory base address conflict. Try configuring your
board to use a different base address, as described in Chapter 2, Installation
and Configuration.

Utility could not access or locate the registry

• If using Windows 2000/NT, make sure you are logged in to Windows
with administrator privileges.

• Your registry entries for NI-FBUS may have been deleted or corrupted.
Uninstall the NI-FBUS software, then reinstall the software as
described in the Install the Software section in Chapter 2, Installation
and Configuration.

Board cannot be found

• Verify the base address, switches, and IRQ settings as described in the
Configure the AT-FBUS Board section in Chapter 2, Installation and
Configuration.

• Select Start»Programs»National Instruments»NI-FBUS»
Interface Config. Make sure your board appears under the list of
interfaces.

• Make sure the kernel-mode driver is started. To start the driver, select
Start»Settings»Control Panel»Devices»Nifb. Click on the Start
button. To avoid manual startup in the future, click on Startup and
select Automatic.
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VCR_FULL_ERROR

Delete the board from the Interface Configuration utility, then re-install.

NIFB Problems
When using the AT-FBUS board with Windows 2000/NT, Nifb returns
an error message stating that the board cannot be found.

• Verify the base address, switches, and IRQ settings as described in the
Configure the AT-FBUS Board section in Chapter 2, Installation and
Configuration.

• Select Start»Programs»National Instruments»NI-FBUS»
Interface Config. Make sure your board appears under the list of
interfaces.

• Make sure the kernel-mode driver is started.

– Windows 2000—Select Start»Settings»Control Panel»System»
Hardware»Device Manager. From the menu, select View»Show
Hidden Devices. From the list of non-Plug & Play devices,
right-click on NIFB and select Properties. Click on the Start
button. To avoid manual startup in the future, click on Startup and
select Automatic.

– Windows NT—Select Start»Settings»Control Panel»Devices»
Nifb. Click on the Start button. To avoid manual startup in the
future, click on Startup and select Automatic.

When a Fieldbus device is connected to the bus, the NIFB process often
hangs when the title bar reads Waiting for Startup Completion. If I
disconnect the cables, it starts fine.

This is probably due to a device address conflict. In the NI-FBUS Interface
Configuration utility, make sure that the interface is not at the same address
as anything else on the link. You can also temporarily give the interface a
visitor address to troubleshoot this problem.

The NIFB process hangs, does not start up, or never shows that it is
running.

• The board’s base memory address conflicts with another device or
does not match the setting on the board’s switches. Check that the
switches match the Windows settings, or try using a different base
memory address. Windows does not always detect all conflicts. Even
if Windows reports no conflicts, trying a different address after you
have eliminated the IRQ or Fieldbus network address will often resolve
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the problem. You have to reboot the machine each time you change
base address and/or IRQ.

• The board’s IRQ conflicts with another device or does not match the
jumper setting on the board. Check the jumper or try setting the board
to polled mode.

• The Fieldbus network address is not unique. Remove the cable from
the board. Restart the NIFB process. If it runs successfully, there is
probably a Fieldbus network address conflict. If you have FP-3000
network modules on the bank, turning their power off and then back on
will cause them to look on the bus for available addresses and change
addresses if necessary. If this does not solve the problem, you can try
to change the board’s address. In the Interface Configuration utility,
select the port and click on Edit. Make sure that the port does not have
an address that conflicts with another device on the bus. You can also
set the interface to a visitor address. In this case, the board will find and
take an unused address. If this corrects the problem, find and change
the address of one of the conflicting devices. Return the board to a
fixed address.

• Check for multiple copies of nifb.dll on the machine. If multiple
copies are found, NI-FBUS was incorrectly re-installed. Uninstall
NI-FBUS, search for any remaining copies of nifb.dll, delete them,
then reinstall the software.

• In Windows 9x, you can check the Windows Device Manager to see if
Windows has detected any problems or conflicts in the resources
assigned to your AT-FBUS board. Your board(s) will appear under the
Fieldbus Adapters category. The Device Manager displays an
exclamation mark (!) on the icon of any AT-FBUS board that has
resource conflicts.

• Check how many boards are showing up in the Interface Configuration
utility. Make sure that this matches the number of boards in the system.
Also check that the number of ports match the physical hardware
(one port versus two port boards).

• Link masters do not always get along together (if you have another link
master on the link). Try setting the board to be a basic device in the
Interface Configuration utility.

If an AT-FBUS interface is configured as a basic device, another link
master device must be present on this link before the NI-FBUS process
will start up. For more about Basic and Link Master devices, refer to
the Foundation Fieldbus Overview document.
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Interface Configuration Problems
When using the NI-FBUS Interface Configuration utility on a
Windows 2000/NT machine, the error message utility could not 
access or locate the registry appears.

1. Make sure you are logged in to Windows with administrator privileges.

2. Your registry entries for NI-FBUS may have been deleted or corrupted.
Uninstall the NI-FBUS software, then reinstall the software as
described in the Install the Software section in Chapter 2, Installation
and Configuration.

In the Interface Configuration utility, I see more boards than what
physically exist in the machine.

♦ Windows 2000/NT—Select Edit for the extra board. In the next window,
select Delete.

♦ Windows 9x—Contact National Instruments to get information on cleaning
the Windows registry.

Caution You should not attempt to make unguided changes in the Windows registry.
Doing so can cause many problems with your system.

Add New Hardware Problems
In Add New Hardware on Windows 9x, there is no category for
Fieldbus.

The category Fieldbus Adapters will not appear under the type of
hardware listing in Add New Hardware unless you reboot the computer
twice after installing the software. After you install your first board, it will
always show up. If the Fieldbus Adapters category does not appear, you
can still follow the instructions in Set the Base Address and IRQ section in
Chapter 2, Installation and Configuration.



Appendix B Troubleshooting and Common Questions

© National Instruments Corporation B-5 AT-FBUS and NI-FBUS Software

Resolving Resource Conflicts

Use a Different Memory Address
The Device Manager in Windows 9x or NT Diagnostics in
Windows 2000/NT does not report all resource conflicts. If you are having
problems with your current resource settings, try different ones. Memory
base address 0x0D4000 is free on many systems.

Put the Board in Polled Mode
Putting the board in polled mode is a good way to eliminate one variable.
To put the board in polled mode:

♦ Windows 2000/NT—Use the Interface Configuration utility:

1. Select Start»Programs»National Instruments»NI-FBUS»
Interface Config.

2. In the Interface Config window, select the icon of the board you want
to change and click on the Edit button. If you are adding a board, click
on the Add Interface Device button.

3. Check the Polled Mode checkbox.

4. Note the memory base address your board is using. Select a different
Basic Configuration that does not include an IRQ. This is the polled
mode option. Then, change the memory base address back to its
original setting.

♦ Windows 98/95—Use the Device Manger:

1. Select Start»Settings»Control Panel»System, then click on the
Device Manager tab.

2. Click on the Fieldbus adapters icon, select the AT-FBUS board, and
click on the Properties button. The AT-FBUS Properties dialog box
appears.

3. Click on the Resources tab.

Note the memory base address your board is using. Select a different Basic
Configuration that does not include an IRQ. This is the polled mode option.
Then, change the memory base address back to its original setting.

Use a Visitor Address
Using a visitor address is a good way to troubleshoot an address conflict
since the board will find and take an available address.
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Problems Using Manufacturer-Defined Features
NI-FBUS uses identifying information in the actual device to locate the
device description for the device. The identifying information includes four
resource block parameters: MANUFAC_ID, DEV_TYPE, DEV_REV, and
DD_REV. If the identifying information is incorrect, NI-FBUS will not be
able to locate the device description for the device. When it has located the
device description, NI-FBUS matches the block types in the device
description with the actual blocks in the device by using the Item ID of the
block characteristics record.

If the blocks in the device do not match the blocks in the description, or if
there is no appropriate device description for the manufacturer, device type,
device revision and device description revision being returned by the
device, then there is a device description mismatch. In either case,
NI-FBUS uses only the standard dictionary (nifb.dct) and you will be
unable to use any manufacturer-supplied functionality.

These parameters can be read from the device’s resource block.
The following procedure will help you troubleshoot a
DD_SIZE_MISMATCH_ERROR by finding out if there is a device
description available on your computer that matches what your device
expects.

Follow these steps to use the NI-FBUS Dialog utility to check device
description files.

1. Start the NIFB process. Wait until the process has finished initializing.

2. Select Start»Programs»National Instruments»NI-FBUS»
NI-FBUS Dialog.

3. Right-click on Open Descriptors and choose Expand All.

4. After the expansion is complete, click on Cancel to close the Expand
All window.

5. Right-click on the resource block for your device (it should be under
Open Descriptors»Session»Interface Name»Device Name»VFD
Name»Resource Block Name). Select Read Object.

6. Select the Read by Name radio button and enter MANUFAC_ID as the
name. Click on the Read button. Write down the hexidecimal number
found in parenthesis (0xnumber) in Table B-1.

7. Repeat step 6 for the name DEV_TYPE.

8. Repeat step 6 for the name DEV_REV.

9. Repeat step 6 for the name DD_REV.
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10. Repeat steps 5–9 for each device, then close the NI-FBUS Dialog
utility.

11. In the Interface Configuration utility, click on the DD Info button.
Write down the base directory specified for device descriptions. Close
the Interface Configuration utility.

12. Use Windows Explorer to view the contents of the base directory
specified in the Interface Configuration utility. The Fieldbus
specification defines the directory hierarchy for storing device
descriptions. There is a different subdirectory for each device
manufacturer. Under the base directory, you should see a directory
with the number from step 6 for the first device.

13. Under the appropriate manufacturer directory, there is a directory for
each device type that you have from that manufacturer. Check to make
sure that you see a directory with the number from step 7.

14. Under the appropriate device type directory, there are the individual
device descriptions. The device description file name is a combination
of the device revision (the number from step 8) and the device
description revision (the number from step 9). The device revision is
the first two digits, and the device description revision is the second
two digits. For example, if your number from step 8 was 2 and from
step 9 was 1, you should see files called 0201.ffo and 0201.sym.
Device descriptions are backwards compatible. This means that
instead of seeing 0201, you might see 0202. This is allowed by the
Fieldbus specification. Also, having additional files in this directory is
not a problem. The NI-FBUS Configurator will use the most recent
device description revision for a given device revision. If you do not
have the appropriate .ffo and .sym files, you must obtain them from
the device manufacturer. Be sure to properly import them by clicking
on DD Info and using the Import DD button in the Interface
Configuration utility.

15. Repeat steps 12–14 for each device.

Table B-1. Device Names

Resource Block Parameter Name

MANUFAC_ID

DEV_TYPE

DEV_REV

DD_REV
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The second cause for this problem is when the contents of the file do not
accurately describe the device characteristics, even if the device
identification information matches the file identification information. This
problem is caused when a device manufacturer makes a change to the
firmware of the device without incrementing the device revision, in
violation of the Foundation Fieldbus recommendation. If this is the case,
you must contact your device manufacturer for a resolution.

Configuring Advanced Parameters

Caution Do not modify the Advanced parameters without good reason. If you must
modify parameters for certain devices, the device manufacturer will recommend settings.
Modifying these parameters can have an adverse affect on data throughput rates. If settings
are incorrectly modified, some devices might disappear off the bus.

In the NI-FBUS Interface Configuration utility, click on the Advanced
button on the dialog box for the port you want to configure. Figure B-1
shows the Advanced Stack Configuration dialog box.

Figure B-1. Advanced Stack Configuration Dialog Box
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The parameters involved in setting addresses are T1 and T3. These
parameters represent delay time values that your board uses to compensate
for the delays inherent in the device and in the set address protocol itself.
T1 describes the expected response delay of the device at a given address.
T3 describes the expected time for the device to respond at its new address.

Uninstalling the Software
To uninstall your NI-FBUS software, select Start»Settings»Control
Panel»Add/Remove Programs.

If you are only using the Communications Manager, select NI-FBUS
Communications Manager to uninstall. If you are using the NI-FBUS
Configurator, select NI-FBUS Configurator.

The uninstall utility does not remove the NI-FBUS directory itself or any
files in the \Data\Nvm directory. To completely uninstall the software,
manually remove the files in the \Data\Nvm directory and the NI-FBUS
directory structure.
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C
Technical Support and
Professional Services

Visit the following sections of the National Instruments Web site at
ni.com for technical support and professional services:

• Support—Online technical support resources include the following:

– Self-Help Resources—For immediate answers and solutions,
visit our extensive library of technical support resources available
in English, Japanese, and Spanish at ni.com/support. These
resources are available for most products at no cost to registered
users and include software drivers and updates, a KnowledgeBase,
product manuals, step-by-step troubleshooting wizards, hardware
schematics and conformity documentation, example code,
tutorials and application notes, instrument drivers, discussion
forums, a measurement glossary, and so on.

– Assisted Support Options—Contact NI engineers and other
measurement and automation professionals by visiting ni.com/

ask. Our online system helps you define your question and
connects you to the experts by phone, discussion forum, or email.

• Training—Visit ni.com/custed for self-paced tutorials, videos, and
interactive CDs. You also can register for instructor-led, hands-on
courses at locations around the world.

• System Integration—If you have time constraints, limited in-house
technical resources, or other project challenges, NI Alliance Program
members can help. To learn more, call your local NI office or visit
ni.com/alliance.

If you searched ni.com and could not find the answers you need, contact
your local office or NI corporate headquarters. Phone numbers for our
worldwide offices are listed at the front of this manual. You also can visit
the Worldwide Offices section of ni.com/niglobal to access the branch
office Web sites, which provide up-to-date contact information, support
phone numbers, email addresses, and current events.
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Glossary

Prefix Meaning Value

m- milli- 10–3

k- kilo- 103

A
Alarm A notification the NI-FBUS Communications Manager software

sends when it detects that a block leaves or returns to a particular
state.

API See Application Programmer Interface.

Application Function blocks.

Application Programmer
Interface

A message format that an application uses to communicate with
another entity that provides services to it.

Asynchronous Communication that occurs at times that are not predetermined.

AT-compatible Compatible with the 16-bit Industry Standard Architecture.

B
Bank The combination of one FieldPoint network module and one or more

terminal bases and I/O modules.

Basic device A device that can communicate on the Fieldbus, but cannot become
the LAS.

Block A logical software unit that makes up one named copy of a block and
the associated parameters its block type specifies. The values of the
parameters persist from one invocation of the block to the next. It can
be a resource block, transducer block, or function block residing
within a virtual field device.

Bus The group of conductors that interconnect individual circuitry in a
computer. Typically, a bus is the expansion vehicle to which I/O or
other devices are connected. Examples of PC buses are the ISA and
PCI buses.
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Bus scheduler See Link Active Scheduler.

C
C Celsius.

Cable A number of wires and shield in a single sheath.

Capacitor An electronic component that stores electrical charge. In a computer,
capacitors are used in dynamic RAM cells and power supplies.

Channel A pin or wire lead to which you apply or from which you read the
analog or digital signal.

Communication stack Performs the services required to interface the user application to the
physical layer.

Control loop A set of connections between blocks used to perform a control
algorithm.

CPU Central processing unit.

D
Data Link Layer The second-lowest layer in the ISO seven-layer model (layer two).

The Data Link Layer splits data into frames to send on the physical
layer, receives acknowledgment frames, and re-transmits frames if
they are not received correctly. It also performs error checking to
maintain a sound virtual channel to the next layer.

DD See Device Description.

Descriptor A number returned to the application by the NI-FBUS
Communications Manager, used to specify a target for future
NI-FBUS calls.

Device A sensor, actuator, or control equipment attached to the Fieldbus.

Device address A memory address that you use to access a device in a computer
system.

Device Description A machine-readable description of all the blocks and block
parameters of a device.

Device ID An identifier for a device that the manufacturer assigns. No two
devices can have the same device ID.
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Device tag A name you assign to a Fieldbus device.

Directory A structure for organizing files into convenient groups. A directory is
like an address showing where files are located. A directory can
contain files or subdirectories of files.

DRAM Dynamic Random Access Memory. Memory that requires electricity
and refreshing to hold data.

Driver Device driver software installed within the operating system.

E
EMI Electromagnetic interference.

Event An occurrence on a device that causes a Fieldbus entity to send the
Fieldbus event message.

F
Field device A Fieldbus device connected directly to a Fieldbus.

Fieldbus An all-digital, two-way communication system that connects control
systems to instrumentation. A process control local area network
defined by ISA standard S50.02.

Fieldbus cable Shielded, twisted pair cable made specifically for Fieldbus that has
characteristics important for good signal transmission and are within
the requirements of the Fieldbus standard.

Fieldbus Foundation An organization that developed a Fieldbus network specifically based
upon the work and principles of the ISA/IEC standards committees.

Fieldbus Network Address Location of a board or device on the Fieldbus; the Fieldbus node
address.

Foundation Fieldbus
specification

The communications network specification that the Fieldbus
Foundation created.

FP-3000 National Instruments network interface module for the FieldPoint I/O
system.
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Function block A named block consisting of one or more input, output, and contained
parameters. The block performs some control function as its
algorithm. Function blocks are the core components you control a
system with. The Fieldbus Foundation defines standard sets of
function blocks. There are ten function blocks for the most basic
control and I/O functions. Manufacturers can define their own
function blocks.

Function Block Application The block diagram that represents your control strategy.

G
Ground An intentional or accidental conducting path between an electrical

system or circuit and the earth or some conducting body acting in
place of the earth. A ground is often used as the common wiring point
or reference in a circuit.

H
H1 The 31.25 kbit/second type of Fieldbus.

HMI Human-Machine Interface. A graphical user interface for the process
with supervisory control and data acquisition capability.

I
I/O Input/output.

IEC International Electrotechnical Commission. A technical standards
committee which is at the same level as the ISO.

in. Inches.

IRQ Interrupt request.

ISA Industry Standard Architecture.

K
Kbits Kilobits.

Kernel The set of programs in an operating system that implements basic
system functions.

Kernel mode The mode in which device drivers run on Windows NT.



Glossary

© National Instruments Corporation G-5 AT-FBUS and NI-FBUS Software

L
LabVIEW DSC The LabVIEW Datalogging and Supervisory Control (DSC) Module

builds on the power of LabVIEW for high channel count and
distributed applications. It adds easy networking, channel and I/O
management, alarm and event management, historical datalogging,
real-time trending, and OPC integration to the LabVIEW
environment.

Link A Foundation Fieldbus network is made up of devices connected by
a serial bus. This serial bus is called a link (also known as a segment).

Link Active Scheduler The Fieldbus device that is currently controlling access to the
Fieldbus. A device that is responsible for keeping a link operational.
The LAS executes the link schedule, circulates tokens, distributes
time, and probes for new devices.

Link master device A device that is capable of becoming the LAS.

Live list The list of all devices that are properly responding to the Pass Token.

Lookout National Instruments Lookout is a full-featured object-based
automation software system that delivers unparalleled power and
ease of use in demanding industrial measurement and automation
applications.

Loop See Control loop.

M
mA milliampere.

Mode Type of communication.

N
Network address The Fieldbus network address of a device.

Nifb.exe The NIFB process that must be running in the background for you to
use your AT-FBUS or PCMCIA-FBUS interface to communicate
between the board and the Fieldbus.

NI-FBUS API The NI-FBUS Communications Manager.

NI-FBUS Communications
Manager

Software shipped with National Instruments Fieldbus interfaces that
lets you read and write values. It does not include configuration
capabilities.
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NI-FBUS Configurator National Instruments Fieldbus configuration software. With it, you
can set device addresses, clear devices, change modes, and read and
write to the devices.

NI-FBUS Fieldbus
Configuration System

See NI-FBUS Configurator.

NI-FBUS process Process that must be running in the background for you to use your
AT-FBUS or PCMCIA-FBUS interface to communicate between the
board and the Fieldbus.

O
Object An element of an object dictionary.

OPC OLE for Process Control.

P
Parameter One of a set of network-visible values that makes up a function block.

PC Personal Computer.

Physical Layer The layer of the communication stack that converts digital Fieldbus
messages from the communication stack to actual physical signals on
the Fieldbus transmission medium and vice versa.

PLC See Programmable Logic Controller.

Poll To repeatedly inspect a variable or function block to acquire data.

Programmable Logic
Controller

A device with multiple inputs and outputs that contains a program
you can alter.

R
Repeater Boost the signals to and from the further link.

Resistor Component made of material that opposes flow of current and
therefore has some value of resistance.

Resource block A special block containing parameters that describe the operation of
the device and general characteristics of a device, such as
manufacturer and device name. Only one resource block per device is
allowed.
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Roundcard A hardware interface for developing Foundation Fieldbus-compliant
devices.

S
s Seconds.

Segment See Link.

Server Device that receives a message request.

Service Services allow user applications to send messages to each other
across the Fieldbus using a standard set of message formats.

Session A communication path between an application and the NI-FBUS
Communications Manager.

Signal An extension of the IEEE 488.2 standard that defines a standard
programming command set and syntax for device-specific
operations.

Stack A set of hardware registers or a reserved amount of memory used for
calculations or to keep track of internal operations.

T
Tag A name you can define for a block, virtual field device, or device.

Terminator A device used to absorb the signal at the end of a wire.

Trend A Fieldbus object that allows a device to sample a process variable
periodically, then transmit a history of the values on the network.

V
VCR See Virtual Communication Relationship.

VFD See Virtual Field Device.
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Virtual Communication
Relationship

Preconfigured or negotiated connections between virtual field
devices on a network.

Virtual Field Device The virtual field device is a model for remotely viewing data
described in the object dictionary. The services provided by the
Fieldbus Messaging Specification allow you to read and write
information about the object dictionary, read and write the data
variables described in the object dictionary, and perform other
activities such as uploading/downloading data and invoking
programs inside a device. A model for remotely viewing data
described in the object dictionary.
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A
advanced parameters, configuring, B-8
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AT-FBUS
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figure, 2-10
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parts locator diagram (figure), 2-4
software settings for, 2-11

base address and IRQ, 2-11
AT-FBUS board

configuration, 2-2

B
board renumbering (table), 2-17

C
cable connector

pinout for Fieldbus cable, 2-19
change the hardware settings, 2-4
changing or deleting existing interface

information, 2-17
common questions, B-1
communication parameters, setting, 2-12
configuration, 2-1

advanced parameters, B-8
AT-FBUS board, 2-2
choosing software, 1-3
driver for Windows 2000, 2-14
select an unused IRQ, 2-3
troubleshooting interface problems, B-4

conflict-free resources (table), 2-3
conflicts

changing resources to eliminate, 2-16

contacting National Instruments, C-1
conventions used in the manual, ix
customer

education, C-1
professional services, C-1
technical support, C-1

D
device descriptions

importing, 2-18
device names, B-7
devices

replacing, 2-20
diagnostic resources, C-1
documentation

conventions used in the manual, ix
how to use the manual set, ix
online library, C-1
related documentation, xi

drivers
instrument, C-1
software, C-1

E
error messages, B-1
example code, C-1

F
Fieldbus

cable connector pinout, 2-19
installing and wiring devices, 2-20
optional network tools, 1-5
software (table), 1-4

frequently asked questions, C-1
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H
hardware

add new hardware problems, B-4
changing settings, 2-4
description, 1-1

help
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