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Important Information

Warranty
The PCMCIA-FBUS is warranted against defects in materials and workmanship for a period of one year from the date of shipment, as
evidenced by receipts or other documentation. National Instruments will, at its option, repair or replace equipment that proves to be defective
during the warranty period. This warranty includes parts and labor.

The media on which you receive National Instruments software are warranted not to fail to execute programming instructions, due to defects
in materials and workmanship, for a period of 90 days from date of shipment, as evidenced by receipts or other documentation. National
Instruments will, at its option, repair or replace software media that do not execute programming instructions if National Instruments receives
notice of such defects during the warranty period. National Instruments does not warrant that the operation of the software shall be
uninterrupted or error free.

A Return Material Authorization (RMA) number must be obtained from the factory and clearly marked on the outside of the package before
any equipment will be accepted for warranty work. National Instruments will pay the shipping costs of returning to the owner parts which are
covered by warranty.

National Instruments believes that the information in this document is accurate. The document has been carefully reviewed for technical
accuracy. In the event that technical or typographical errors exist, National Instruments reserves the right to make changes to subsequent
editions of this document without prior notice to holders of this edition. The reader should consult National Instruments if errors are suspected.
In no event shall National Instruments be liable for any damages arising out of or related to this document or the information contained in it.

EXCEPT AS SPECIFIED HEREIN, NATIONAL INSTRUMENTS MAKES NO WARRANTIES, EXPRESS OR IMPLIED, AND SPECIFICALLY DISCLAIMS ANY WARRANTY OF

MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. CUSTOMER’S RIGHT TO RECOVER DAMAGES CAUSED BY FAULT OR NEGLIGENCE ON THE PART OF

NATIONAL INSTRUMENTS SHALL BE LIMITED TO THE AMOUNT THERETOFORE PAID BY THE CUSTOMER. NATIONAL INSTRUMENTS WILL NOT BE LIABLE FOR

DAMAGES RESULTING FROM LOSS OF DATA, PROFITS, USE OF PRODUCTS, OR INCIDENTAL OR CONSEQUENTIAL DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY

THEREOF. This limitation of the liability of National Instruments will apply regardless of the form of action, whether in contract or tort, including
negligence. Any action against National Instruments must be brought within one year after the cause of action accrues. National Instruments
shall not be liable for any delay in performance due to causes beyond its reasonable control. The warranty provided herein does not cover
damages, defects, malfunctions, or service failures caused by owner’s failure to follow the National Instruments installation, operation, or
maintenance instructions; owner’s modification of the product; owner’s abuse, misuse, or negligent acts; and power failure or surges, fire,
flood, accident, actions of third parties, or other events outside reasonable control.

Copyright
Under the copyright laws, this publication may not be reproduced or transmitted in any form, electronic or mechanical, including photocopying,
recording, storing in an information retrieval system, or translating, in whole or in part, without the prior written consent of National
Instruments Corporation.

Trademarks
FieldPoint™, LabVIEW™, Lookout™, National Instruments™, NI™, ni.com™, NI-FBUS™, and NI-FMON™ are trademarks of
National Instruments Corporation.

Product and company names mentioned herein are trademarks or trade names of their respective companies.

Patents
For patents covering National Instruments products, refer to the appropriate location: Help»Patents in your software, the patents.txt file
on your CD, or ni.com/patents.

WARNING REGARDING USE OF NATIONAL INSTRUMENTS PRODUCTS
(1) NATIONAL INSTRUMENTS PRODUCTS ARE NOT DESIGNED WITH COMPONENTS AND TESTING FOR A LEVEL OF
RELIABILITY SUITABLE FOR USE IN OR IN CONNECTION WITH SURGICAL IMPLANTS OR AS CRITICAL COMPONENTS IN
ANY LIFE SUPPORT SYSTEMS WHOSE FAILURE TO PERFORM CAN REASONABLY BE EXPECTED TO CAUSE SIGNIFICANT
INJURY TO A HUMAN.

(2) IN ANY APPLICATION, INCLUDING THE ABOVE, RELIABILITY OF OPERATION OF THE SOFTWARE PRODUCTS CAN BE
IMPAIRED BY ADVERSE FACTORS, INCLUDING BUT NOT LIMITED TO FLUCTUATIONS IN ELECTRICAL POWER SUPPLY,
COMPUTER HARDWARE MALFUNCTIONS, COMPUTER OPERATING SYSTEM SOFTWARE FITNESS, FITNESS OF COMPILERS
AND DEVELOPMENT SOFTWARE USED TO DEVELOP AN APPLICATION, INSTALLATION ERRORS, SOFTWARE AND
HARDWARE COMPATIBILITY PROBLEMS, MALFUNCTIONS OR FAILURES OF ELECTRONIC MONITORING OR CONTROL
DEVICES, TRANSIENT FAILURES OF ELECTRONIC SYSTEMS (HARDWARE AND/OR SOFTWARE), UNANTICIPATED USES OR
MISUSES, OR ERRORS ON THE PART OF THE USER OR APPLICATIONS DESIGNER (ADVERSE FACTORS SUCH AS THESE ARE
HEREAFTER COLLECTIVELY TERMED “SYSTEM FAILURES”). ANY APPLICATION WHERE A SYSTEM FAILURE WOULD
CREATE A RISK OF HARM TO PROPERTY OR PERSONS (INCLUDING THE RISK OF BODILY INJURY AND DEATH) SHOULD
NOT BE RELIANT SOLELY UPON ONE FORM OF ELECTRONIC SYSTEM DUE TO THE RISK OF SYSTEM FAILURE. TO AVOID
DAMAGE, INJURY, OR DEATH, THE USER OR APPLICATION DESIGNER MUST TAKE REASONABLY PRUDENT STEPS TO
PROTECT AGAINST SYSTEM FAILURES, INCLUDING BUT NOT LIMITED TO BACK-UP OR SHUT DOWN MECHANISMS.
BECAUSE EACH END-USER SYSTEM IS CUSTOMIZED AND DIFFERS FROM NATIONAL INSTRUMENTS' TESTING
PLATFORMS AND BECAUSE A USER OR APPLICATION DESIGNER MAY USE NATIONAL INSTRUMENTS PRODUCTS IN
COMBINATION WITH OTHER PRODUCTS IN A MANNER NOT EVALUATED OR CONTEMPLATED BY NATIONAL
INSTRUMENTS, THE USER OR APPLICATION DESIGNER IS ULTIMATELY RESPONSIBLE FOR VERIFYING AND VALIDATING
THE SUITABILITY OF NATIONAL INSTRUMENTS PRODUCTS WHENEVER NATIONAL INSTRUMENTS PRODUCTS ARE
INCORPORATED IN A SYSTEM OR APPLICATION, INCLUDING, WITHOUT LIMITATION, THE APPROPRIATE DESIGN,
PROCESS AND SAFETY LEVEL OF SUCH SYSTEM OR APPLICATION.



Compliance

FCC/Canada Radio Frequency Interference Compliance*

Determining FCC Class
The Federal Communications Commission (FCC) has rules to protect wireless communications from interference. The FCC
places digital electronics into two classes. These classes are known as Class A (for use in industrial-commercial locations only)
or Class B (for use in residential or commercial locations). Depending on where it is operated, this product could be subject to
restrictions in the FCC rules. (In Canada, the Department of Communications (DOC), of Industry Canada, regulates wireless
interference in much the same way.)
Digital electronics emit weak signals during normal operation that can affect radio, television, or other wireless products. By
examining the product you purchased, you can determine the FCC Class and therefore which of the two FCC/DOC Warnings
apply in the following sections. (Some products may not be labeled at all for FCC; if so, the reader should then assume these are
Class A devices.)
FCC Class A products only display a simple warning statement of one paragraph in length regarding interference and undesired
operation. Most of our products are FCC Class A. The FCC rules have restrictions regarding the locations where FCC Class A
products can be operated.
FCC Class B products display either a FCC ID code, starting with the letters EXN,
or the FCC Class B compliance mark that appears as shown here on the right.
Consult the FCC Web site at http://www.fcc.gov for more information.

FCC/DOC Warnings
This equipment generates and uses radio frequency energy and, if not installed and used in strict accordance with the instructions
in this manual and the CE Mark Declaration of Conformity**, may cause interference to radio and television reception.
Classification requirements are the same for the Federal Communications Commission (FCC) and the Canadian Department
of Communications (DOC).
Changes or modifications not expressly approved by National Instruments could void the user’s authority to operate the
equipment under the FCC Rules.

Class A
Federal Communications Commission
This equipment has been tested and found to comply with the limits for a Class A digital device, pursuant to part 15 of the FCC
Rules. These limits are designed to provide reasonable protection against harmful interference when the equipment is operated
in a commercial environment. This equipment generates, uses, and can radiate radio frequency energy and, if not installed and
used in accordance with the instruction manual, may cause harmful interference to radio communications. Operation of this
equipment in a residential area is likely to cause harmful interference in which case the user will be required to correct
the interference at his own expense.

Canadian Department of Communications
This Class A digital apparatus meets all requirements of the Canadian Interference-Causing Equipment Regulations.
Cet appareil numérique de la classe A respecte toutes les exigences du Règlement sur le matériel brouilleur du Canada.

Class B
Federal Communications Commission
This equipment has been tested and found to comply with the limits for a Class B digital device, pursuant to part 15 of the
FCC Rules. These limits are designed to provide reasonable protection against harmful interference in a residential installation.
This equipment generates, uses, and can radiate radio frequency energy and, if not installed and used in accordance with the
instructions, may cause harmful interference to radio communications. However, there is no guarantee that interference will not
occur in a particular installation. If this equipment does cause harmful interference to radio or television reception, which can
be determined by turning the equipment off and on, the user is encouraged to try to correct the interference by one or more of
the following measures:
• Reorient or relocate the receiving antenna.
• Increase the separation between the equipment and receiver.
• Connect the equipment into an outlet on a circuit different from that to which the receiver is connected.
• Consult the dealer or an experienced radio/TV technician for help.



Canadian Department of Communications
This Class B digital apparatus meets all requirements of the Canadian Interference-Causing Equipment Regulations.
Cet appareil numérique de la classe B respecte toutes les exigences du Règlement sur le matériel brouilleur du Canada.

Compliance to EU Directives
Readers in the European Union (EU) must refer to the Manufacturer’s Declaration of Conformity (DoC) for information**
pertaining to the CE Mark compliance scheme. The Manufacturer includes a DoC for most every hardware product except for
those bought for OEMs, if also available from an original manufacturer that also markets in the EU, or where compliance is not
required as for electrically benign apparatus or cables.
To obtain the DoC for this product, click Declaration of Conformity at ni.com/hardref.nsf/. This Web site lists the DoCs
by product family. Select the appropriate product family, followed by your product, and a link to the DoC appears in Adobe
Acrobat format. Click the Acrobat icon to download or read the DoC.

* Certain exemptions may apply in the USA, see FCC Rules §15.103 Exempted devices, and §15.105(c). Also available in
sections of CFR 47.

** The CE Mark Declaration of Conformity will contain important supplementary information and instructions for the user or
installer.



© National Instruments Corporation vii PCMCIA-FBUS for Windows

Contents

About This Manual
How To Use the Manual Set.......................................................................................... ix
Conventions ...................................................................................................................x
Related Documentation..................................................................................................xi

Chapter 1
Introduction

What You Need to Get Started ......................................................................................1-1
Hardware Description ....................................................................................................1-1
Software Description .....................................................................................................1-2

Choosing Configuration Software...................................................................1-2
Optional Fieldbus Network Tools..................................................................................1-4

Chapter 2
Installation and Configuration

Install the Software ........................................................................................................2-1
Install the Hardware.......................................................................................................2-2
Set the Base Address and IRQ.......................................................................................2-4
Set the Communication Parameters and Interface Name ..............................................2-4
Test the Installation........................................................................................................2-6
Changing the Resources to Eliminate Conflicts ............................................................2-7

Changing or Deleting Existing Interface Information.....................................2-8
Import Device Descriptions ...........................................................................................2-9

Chapter 3
Start the NIFB Process

Configure NIFB to Load at System Startup...................................................................3-1
Begin to Use Your NI-FBUS Software .........................................................................3-2

Appendix A
Specifications

Appendix B
Pinout Information



Contents

PCMCIA-FBUS for Windows viii ni.com

Appendix C
Troubleshooting and
Common Questions

Error Messages .............................................................................................................. C-1
NIFB Problems.............................................................................................................. C-2
Interface Configuration Problems ................................................................................. C-3
Add New Hardware Problems....................................................................................... C-4
Resolving Resource Conflicts ....................................................................................... C-5

Assign Each Card a Unique Base Address ..................................................... C-5
Use a Different Memory Address ................................................................... C-5
Put the Card in Polled Mode ........................................................................... C-5
Use a Visitor Address ..................................................................................... C-6

Problems Using Manufacturer-Defined Features .......................................................... C-6
Configuring Advanced Parameters................................................................................ C-8
Uninstalling the Software .............................................................................................. C-9

Appendix D
Technical Support and Professional Services

Glossary

Index



© National Instruments Corporation ix PCMCIA-FBUS for Windows

About This Manual

This manual contains instructions on how to install and configure the
National Instruments PCMCIA-FBUS card and the NI-FBUS software.
The PCMCIA-FBUS card is intended for use in laptop computers equipped
with a Type II PCMCIA socket.

The NI-FBUS software is intended for use with Windows 2000/NT
because Windows 9x is less robust than Windows 2000/NT. This manual
assumes that you are already familiar with your Windows operating system.

This manual is included with either the NI-FBUS Communications
Manager kit or the NI-FBUS Configurator kit.

How To Use the Manual Set
Use the Foundation Fieldbus Overview to learn the basics of Fieldbus. The
Foundation Fieldbus Overview also includes tutorials to lead you through
developing a simple Fieldbus application.

Use this getting started manual to install and configure your
PCMCIA-FBUS card and the NI-FBUS software. To install your
PCMACIA-FBUS card in the Windows 2000/XP system environment, use
the Installation Guide: Foundation Fieldbus Hardware and NI-FBUS
Software for Windows 2000/XP.

If you are using the NI-FBUS Configurator, use the NI-FBUS Configurator
User Manual to install and use the NI-FBUS Configurator software.

If you are using the NI-FBUS Communications Manager Application
Programmer Interface (API), use the NI-FBUS Communications Manager
User Manual to learn how to use the NI-FBUS Communications Manager
API for your application. Use the NI-FBUS Communications Manager
Function Reference Manual to look up specific information about
NI-FBUS Communications Manager functions, such as syntax and error
messages.
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Conventions
The following conventions appear in this manual:

» The » symbol leads you through nested menu items and dialog box options
to a final action. The sequence File»Page Setup»Options directs you to
pull down the File menu, select the Page Setup item, and select Options
from the last dialog box.

♦ The ♦ symbol indicates that the following text applies only to a specific
product, a specific operating system, or a specific software version.

This icon denotes a tip, which alerts you to advisory information.

This icon denotes a note, which alerts you to important information.

This icon denotes a caution, which advises you of precautions to take to
avoid injury, data loss, or a system crash.

bold Bold text denotes items that you must select or click on in the software,
such as menu items and dialog box options. Bold text also denotes
parameter names.

italic Italic text denotes variables, emphasis, a cross reference, or an introduction
to a key concept. This font also denotes text that is a placeholder for a word
or value that you must supply.

monospace Text in this font denotes text or characters that you should enter from the
keyboard, sections of code, programming examples, and syntax examples.
This font is also used for the proper names of disk drives, paths, directories,
programs, subprograms, subroutines, device names, functions, operations,
variables, filenames and extensions, and code excerpts.

monospace bold Bold text in this font denotes the messages and responses that the computer
automatically prints to the screen. This font also emphasizes lines of code
that are different from the other examples.

monospace italic Italic text in this font denotes text that is a placeholder for a word or value
that you must supply.

NI-FBUS software In this manual, the term NI-FBUS software refers to either the NI-FBUS
Communications Manager or NI-FBUS Configurator software.
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PCMCIA-FBUS In this manual, the term PCMCIA-FBUS refers to both the single-port
PCMCIA-FBUS card and the dual-port PCMCIA-FBUS/2 card, unless
otherwise indicated.

Platform Text in this font denotes a specific platform and indicates that the text
following it applies only to that platform.

Related Documentation
The following documents contain information that you might find helpful
as you read this manual:

General Fieldbus Web sites:

• Fieldbus Foundation—responsible for the definition of the Foundation
Fieldbus specification. www.fieldbus.org

• Relcom, Inc.—Wiring and test equipment for Foundation Fieldbus.
www.relcominc.com/fieldbus

• Fieldbus, Inc.—Device developers and Foundation Fieldbus
consulting. www.fieldbusinc.com

Fieldbus system development documentation:

• Fieldbus Foundation resources

– Wiring and Installation 31.25 kbit/s, Voltage Mode, Wire Medium

• Relcom Fieldbus resources online

– Wiring Design and Installation Guide

– Online Tutorial

– FAQ

– Sample Fieldbus Topologies

• Fieldbus Standard for Use in Industrial Control Systems, Part 2,
ISA-S50.02.1992

Fieldbus device development documentation:

• Developing Your First Foundation Fieldbus Device, available from the
Fieldbus, Inc. Web site at www.fieldbusinc.com

• Foundation Specification: 31.25 kbit/s Physical Layer Profile for the
Foundation Fieldbus Physical Layer Specifications

• Function Block Application Process, Part 1
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• Function Block Application Process, Part 2

• IEC Standard 1158-2 and ISA Standard ISA S50.02

Other related documentation:

• Microsoft Windows 95 Online Help

• PC Card Standard, Release 2.1, Personal Computer Memory Card
International Association (PCMCIA)
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1
Introduction

This chapter lists what you need to get started and includes a brief
description of the PCMCIA-FBUS card and the NI-FBUS software.

What You Need to Get Started
To install your NI-FBUS software, you need the following items:

❑ PCMCIA-FBUS card

❑ PCMCIA-FBUS cable

❑ Installation disks

❑ Windows 2000/NT/9x installed on your computer

Note Because Windows 9x is less robust than Windows 2000/NT, National Instruments
strongly suggests you use a Windows 2000/NT system with the National Instruments
Fieldbus software.

Hardware Description
The PCMCIA-FBUS is a Type II PC card that handles communication
between a PCMCIA-compatible computer and one or more
network-configurable devices that comply with the Fieldbus Foundation
H1 specification. The PCMCIA-FBUS uses the Intel 386EX embedded
processor, shared memory, and an interrupt to communicate with its driver.
The PCMCIA-FBUS supports the Fieldbus transfer rate of 31.25 kb/s.

The single-port PCMCIA Fieldbus card is called the PCMCIA-FBUS and
the dual-port PCMCIA Fieldbus card is called the PCMCIA-FBUS/2.
In this manual, the term PCMCIA-FBUS refers to both the single-port
PCMCIA-FBUS card and the dual-port PCMCIA-FBUS/2 card, unless
otherwise indicated.
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Software Description
Your kit includes either the NI-FBUS Communications Manager software
or the NI-FBUS Configurator software. Depending on the system you
purchase, you may receive both disks; if this is the case, you should use the
NI-FBUS Configurator software.

The NI-FBUS Communications manager software is used by the interface
boards to communicate over the bus. Additionally, it provides a high-level
API advanced users can use to interface with the National Instruments
Foundation Fieldbus communication stack and hardware.

Most users use the NI-FBUS Configurator. In addition to providing the
functionality of the NI-FBUS Communications Manager in a graphical
format, it includes additional functionality to allow you to configure
a Fieldbus network. It can automatically generate the schedule for the
network and configure field devices and hosts to transmit and receive
alarms and trends.

Choosing Configuration Software
Foundation Fieldbus links must be configured. Only with configuration
software can you do things like set device addresses, clear devices, and
download (necessary if you are setting up a system for the first time). Your
configuration software must match the interface card your computer is
using to connect to the bus. National Instruments offers the NI-FBUS
Configurator with a National Instruments Foundation Fieldbus interface
card to let you configure your Fieldbus links.

Interface cards and configuration software are sold separately because
multiple interface cards can reside in the same computer. The NI-FBUS
Configurator, by default, is licensed for use on one machine, with up to four
Fieldbus links (segments). If you have more than four links (ports on the
cards), you need to purchase a link upgrade for each link in excess of four.
To do so, download the order form from ni.com/fieldbus.

Note The connection to one interface port on the interface card is viewed as one link by
the NI-FBUS Configurator, regardless of how many links might actually be joined by
repeaters (important for software licensing of the NI-FBUS Configurator).

If you only want to use the card to read and write values only (not
configure) and you are a programmer, you can make calls to the API in the
NI-FBUS Communications Manager and would not need the NI-FBUS
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Configurator. This would be possible only if you have already used a
third-party’s hardware and configuration software to configure the link.

The following table describes the National Instruments Fieldbus software.

Table 1-1. National Instruments Fieldbus Software

Software Application Short Name Description File Name

NI-FBUS
Communications
Manager

NIFB process “The Blue Box.” This
must be running for you
to use your
PCMCIA-FBUS card
as a Fieldbus interface
to communicate
between the card and
the bus.

nifb.exe

NI-FBUS Interface
Configuration Utility

Interface Config Used to configure your
PCMCIA-FBUS card.

fbconf.exe

NI-FBUS
Configurator

NI-FBUS
Configurator

Used to configure the
devices on the bus, set
the parameters for
control loops, and other
Fieldbus configuration
tasks.

fcs.exe

NI-FBUS Dialog
System

NI-FBUS Dialog Used to view the
devices on the bus and
manually read and
write parameter values.
Not for configuration.

nifbdlg.exe
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Optional Fieldbus Network Tools
Your kit includes either the NI-FBUS Communications Manager software,
NI-FBUS Configurator software, or both. In addition, you can order the
NI-FBUS Monitor, LabVIEW DSC, and/or Lookout from National
Instruments. If you have not already done so, you can also order the
NI-FBUS Configurator.

The NI-FBUS Monitor helps you monitor and debug Fieldbus data traffic.
It is primarily used to debug the development of device and host
applications. It symbolically decodes data packets from the Fieldbus,
monitors the live list (devices currently on the bus), and performs statistical
analysis of packets.

Note If you are using this interface as a bus monitor, the other interface (if this is a
two-port card) cannot be used for NI-FBUS. This means that you must have another link
master on the link—either another PCMCIA-FBUS card, or a device with link master
capabilities. An interface card can either run NI-FBUS software or NI-FMON software at
any given time. If the card has two ports, they both must have the same usage. This is
because a different stack is downloaded to the card for it to be used in conjunction with
NI-FMON. Your interface card must be running NI-FBUS to act as the Link Active
Scheduler. This means that if your interface card is the only link master on the link, you
cannot use that card for running NI-FMON (even if the card has two ports) since that would

NI-FBUS Fieldbus
Monitor

NI-FMON
(also known as
NI Fieldbus
Monitor)

Functions as a bus
monitor, letting you
view all packets sent
over the bus. Primarily
used by developers to
debug new devices.

ni-fmon.exe

Server Explorer Server Explorer Lets you configure the
attributes of the
communication
resource, device, and
items of your network,
and the groups and
items of your OPC
server.

serverexplorer.exe

Table 1-1. National Instruments Fieldbus Software (Continued)

Software Application Short Name Description File Name
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leave the link without a link master. In this situation, you would need to obtain either a link
master field device or another link master interface card in order to use NI-FMON.

LabVIEW DSC helps you perform data acquisition and analysis, create
a human-machine interface (HMI), or develop an advanced supervisory
control application in a graphical development environment.
LabVIEW DSC includes real-time process monitoring, historical trending,
alarm and event reporting, online configuration, and PLC connectivity.

Lookout helps you create graphical representations on a computer screen
of real-world devices such as switches, dial gauges, chart recorders,
pushbuttons, knobs, sliders, and meters. After linking these images to your
field instruments, you can configure Lookout to generate alarms, log data
to disk, animate custom graphics, print reports, automatically adjust
setpoints, historically trend information, warn operators of malfunctions,
and so on.
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2
Installation and Configuration

Install the Software
These installation instructions are for Windows 2000/NT and Windows 9x.
If you are using the Windows XP operating system, refer to the Installation
Guide: Foundation Fieldbus Hardware and NI-FBUS Software for
Windows 2000/XP.

♦ iWindows 2000/NT—Complete the following steps to install your NI-FBUS
software.

Caution If you are reinstalling the NI-FBUS software over an existing version, write down
your card configuration and any port configuration parameters you changed from their
defaults. Reinstalling may cause you to lose any existing card and port configuration
information.

1. Log in as Administrator or as a user that has Administrator
privileges.

2. Insert installation disk 1 or your F-BUS program CD.

3. Select Start»Run.

4. In the Run dialog box, type the following:

x:\setup

where x is the letter of the drive containing the disk (usually a or b).

5. The interactive setup program takes you through the necessary steps to
install the software.

The installation program copies nifb.dll and drvintf.dll into your
\System32 directory, and it copies the nifb.sys driver into the
\drivers directory. The installation program also adds information to the
Windows Registry.
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♦ Windows 9x—Complete the following steps to install your NI-FBUS
software:

1. The NI-FBUS software for Windows 9x requires DCOM. Windows 98
comes with DCOM, but if you are using Windows 95 you need to
install it before installing your NI-FBUS software. You can download
a copy of DCOM from the MicrosoftCOM Web site at
www.microsoft.com/Com.

2. Insert installation disk 1.

3. Select Start»Run.

4. In the Run dialog box, type the following:

x:\setup

where x is the letter of the drive containing the disk (usually a or b).

5. The interactive setup program takes you through the necessary steps to
install the software.

The installation program copies nifb.dll, nifb.vxd, and
drvintf.dll into the \System directory. The installation program also
adds information to the Windows Registry.

Continue to the next section, Install the Hardware, to configure and install
your card.

Install the Hardware

Caution Before you remove the card from the package, touch the antistatic plastic package
to a metal part of your system chassis to discharge electrostatic energy, which can damage
several components on your PCMCIA-FBUS card.

To install the PCMCIA-FBUS card, complete the following steps:

1. Shut down your operating system and power off your system.

2. Insert the card into a free PC Card (PCMCIA) socket. The card has
no jumpers or switches to set. Figure 2-1 shows how to insert the
PCMCIA-FBUS and how to connect the PCMCIA-FBUS cable
and connector to the PCMCIA-FBUS card. However, the
PCMCIA-FBUS/2 card has two connectors. Refer to Appendix B,
Pinout Information, for more information about these two connectors.



Chapter 2 Installation and Configuration

© National Instruments Corporation 2-3 PCMCIA-FBUS for Windows

Figure 2-1. Inserting the PCMCIA-FBUS

3. Connect the PCMCIA-FBUS to the Fieldbus network.

Your kit contains one PCMCIA-FBUS cable. Refer to Appendix B,
Pinout Information, if you need to make a longer cable than the
PCMCIA-FBUS cable provided.

4. Power on your computer.

1 Portable Computer 2 PCMCIA Socket 3 PCMCIA-FBUS Cable

1

2

3
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Set the Base Address and IRQ

Note You can only connect one NI-FBUS port to a link or Fieldbus.

♦ Windows 2000/NT—Use the NI-FBUS Interface Configuration utility to add,
view, or change your base address or IRQ settings.

1. Start the NI-FBUS Interface Configuration utility. Select Start»
Programs»National Instruments FBUS»Interface Config.

2. In the Interface Config window, select the icon of the card you want
to change and click on the Edit button. If you are adding a card, click
on the Add Interface Device button.

3. Choose PCMCIA as the Bus Type. The NI-FBUS Interface
Configuration utility displays the default base address and IRQ line.

4. Change the default base memory address and interrupt request settings
if they do not match the settings on your card.

If you have configured your PCMCIA-FBUS card not to use interrupts,
select No Interrupt from the IRQ drop-down list, and check the
Polled Mode checkbox.

5. Select the number of ports that matches your PCMCIA-FBUS.
For example, select 2 ports for the PCMCIA-FBUS/2.

6. After verifying the information you just entered, click on the OK
or Add button. The dialog box for entering port information for the
Fieldbus interface appears.

7. Click on OK.

Proceed to the next section, Set the Communication Parameters and
Interface Name.

Set the Communication Parameters and Interface Name
Use the NI-FBUS Interface Configuration utility to set the Fieldbus
communication parameters and interface name.

1. Start the NI-FBUS Interface Configuration utility. Select
Start»Programs»National Instruments FBUS»Interface Config.

2. Select the port you want to edit, and click on the Edit button.

The NI-FBUS Interface Configuration utility displays the default
interface name and some configuration information.
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3. Enter an interface name for the port, or use the default name.
The interface name is for local use on the PC.

4. Enter a unique tag in the Device Tag field, or use the default device
tag. The device tag is the name visible on the Fieldbus to the other
devices.

5. Your interface must be given either a fixed or visitor device address for
you to start using NI-FBUS. This address must be unique on the link
to which the interface is connected.

a. To assign a fixed address to your Fieldbus interface, choose Fixed
Address and enter a value in the range 0x10 to 0xF7.

By convention, the lower addresses starting at 0x10 are usually
used for interface boards and link masters. Upper addresses,
starting at 0xF7 and working down, are generally used for other
devices. Using a lower address for your interface will reduce the
likelihood that the interface will conflict with another device on
the bus.

b. If you want your interface to be a temporary device that you do not
intend to connect to the Fieldbus for an extended time, choose
Visitor Address. Over a long period of time, using a visitor
address could break VCR endpoints and cause VCR_FULL_ERROR
errors.

c. If you want third-party Fieldbus configuration software to assign
an address to your interface over the Fieldbus, choose Default
Address. You should only choose to use a default address when
you want third-party configuration software to assign a permanent
address. A device at a default address cannot be communicated
with until a permanent address has been assigned by the
configuration software.

6. Select a Device Type. You should choose to use Link Master Device.

7. Make sure that NI-FBUS is selected for Usage, unless you will be
using the board in conjunction with the NI-FMON software.

If you are using this interface as a bus monitor, the other interface
(if this is a two-port board) cannot be used for NI-FBUS. This means
that you must have another link master on the link—either another
AT-FBUS board, or a device with link master capabilities. See the
Optional Fieldbus Network Tools section in Chapter 1, Introduction,
for more information.

NI-FBUS assigns default values for other network communication
parameters.
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Caution Do not modify the Advanced parameters without good reason. If you must
modify parameters for certain devices, the device manufacturer will recommend settings.
Modifying these parameters can have an adverse affect on data throughput rates. If settings
are incorrectly modified, some devices might disappear off the bus.

8. Click on OK, then click on OK again to exit the configuration utility.

9. Restart the NIFB process to make the changes you made in the
NI-FBUS Interface Configuration utility take effect.

10. Under Windows NT, if you change or delete the interface configuration,
you must stop and restart the nifb.sys driver so that the new
configuration will take effect. You can start or stop the driver by
selecting Start»Settings»Control Panel»Devices»Nifb, and clicking
on the Stop/Start button.

11. Replace the top cover on your computer, if you have not done so
already.

Test the Installation
♦ Windows 2000—Start the NIFB process by selecting Start»Programs»

National Instruments»NI-FBUS»Nifb.

♦ Windows NT—To make sure that your NI-FBUS software is installed
correctly and is working properly, complete the following steps:

1. After you configure your installation, restart Windows NT. You must
restart your computer before you can use the NI-FBUS software.

2. Start the kernel-mode device driver NIFB by selecting Start»
Settings»Control Panel»Devices»Nifb and clicking on the Start
button

You can also start NIFB by entering the following command at the
command prompt:

net start nifb

Tip You can have the device driver start automatically when your computer boots.
Refer to Chapter 3, Start the NIFB Process, for instructions.

3. Start the NIFB process selecting Start»Programs»National
Instruments FBUS»NIFB.

♦ Windows 9x—Start the NIFB process by selecting Start»Programs»
National Instruments FBUS»Nifb. The NIFB process must be running
in the background to use any Fieldbus application.
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On successful startup, the NIFB displays a message saying that the process
started up successfully, the title bar of the NIFB window changes to
NIFB (running), and a blue box icon appears on the Windows taskbar.
It may take a few minutes for NIFB to start up and this message to display.

If NI-FBUS does not start up successfully, the base memory address, IRQ
line, or Fieldbus network address is incorrect. If the NIFB process does not
start up successfully, refer to Appendix C, Troubleshooting and Common
Questions.

Changing the Resources to Eliminate Conflicts

Note If you do not suspect you have resource conflicts, proceed to Chapter 3, Start the
NIFB Process.

If you discovered resource conflicts when testing the installation, you need
to change your base address or IRQ settings.

♦ Windows 2000—You should not normally need to modify the resources that
Windows 2000 assigns to your PCMCIA-FBUS.

To change resources to eliminate conflicts in Windows 2000, complete the
following steps:

1. Select Start»Settings»Control Panel, and double-click on the System
icon.

2. Click on the Hardware tab, select the Device Manager button.

3. Locate your card under the heading National Instruments Fieldbus
Interfaces.

4. Click on the name of the card, then click on the Properties button.

5. Use the Resources tab to view or edit the resources assigned to the
card.

♦ Windows NT—Windows NT usually assigns conflict-free resources
automatically. To view assigned resources in Windows NT, complete the
following steps:

1. Select Start»Programs»Administrative Tools (Common)»
Windows NT Diagnostics, and select the Resources tab.

2. Click on the Devices button.

3. Double-click on nifb.
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4. Make sure the settings shown match the settings configured on your
card.

5. Click on OK twice.

♦ Windows 9x—You should not normally need to modify the resources that
Windows 9x assigns to your PCMCIA-FBUS. If you do not suspect you
have resource conflicts, proceed to Chapter 3, Start the NIFB Process.

To change resources to eliminate conflicts in Windows 9x, complete the
following steps:

1. Select Start»Settings»Control Panel, and double-click on the
System icon.

2. Click on the Device Manager tab.

3. Locate your card under the heading Fieldbus Adapters.

4. Click on the name of the card, then click on the Properties button.

5. Use the Resources tab to view or edit the resources assigned to the
card.

Changing or Deleting Existing Interface Information
♦ Windows 2000/NT—To change or delete information about any interface that

you have already entered, complete the following steps:

1. Select Start»Programs»National Instruments FBUS»Interface
Config

2. Click on the Boardx icon, where x refers to the board number of the
interface you want to change or delete.

3. Click on the Edit button. You can edit the interface configuration
information that you entered earlier, or click on Delete to delete this
interface entirely.

Interfaces are numbered beginning with zero. If you delete an
interface, the NI-FBUS Interface Configuration utility renumbers all
the remaining interfaces. For example, if you delete Board0, it appears
that you deleted the last interface, because all the remaining interface
numbers are decreased by one automatically.
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♦ Windows 9x—To change the hardware resources in Windows 9x, you must
use the Windows Device Manager rather than the NI-FBUS Interface
Configuration utility. For more information, refer to the Changing the
Resources to Eliminate Conflicts section.

To delete a National Instruments Fieldbus interface in Windows 9x,
complete the following steps:

1. Select Start»Settings»Control Panel, and double-click on the
System icon.

2. Click on the Device Manager tab.

3. Locate your card under the heading Fieldbus Adapters.

4. Click on the name of the card, then click on the Remove button.

Run the NI-FBUS Interface Configuration utility once to make sure the
interface has been removed.

To re-install the interface, refer to the installation and configuration
instructions earlier in this chapter.

Import Device Descriptions
The device description files contain information about the types of blocks
and parameters supported by your Fieldbus device, along with online help
describing the uses of given parameters. If your Fieldbus device uses
manufacturer-specific device description files, you must import the device
description files (shipped with the device, or available from the device
manufacturer). To do so, complete the following steps:

1. Insert the device description disk or CD (if supplied by your Fieldbus
device manufacturer) into the disk drive of the host computer.

2. Select Start»Programs»National Instruments FBUS»Interface
Config to run the Interface Configuration utility.

Table 2-1. Board Renumbering

Original Address Address after Deleting Board1

Board0 Board0

Board1 (deleted)

Board2 Board1

Board3 Board2
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3. Click on the DD Info button. The DD Info dialog box appears.

4. If the base directory field is blank, enter a base directory. The base
directory you enter here will be where NI-FBUS looks for all device
descriptions. Do not change the base directory after you have started
importing device descriptions; otherwise, NI-FBUS will not be able
to find the device descriptions you previously imported. Your device
description files will automatically be placed in the appropriate
manufacturer ID subdirectory under this base directory.

Your base directory will include one folder for each different
manufacturer for which you have imported device description.
For example, if you import the device description for the National
Instruments FP-3000 device, you will find a folder called 4e4943.
This is the National Instruments Foundation Fieldbus device
manufacturer ID number.

The next layer of folders is the device type. For example, the FP-3000
has a device type ID number of 4005.

Underneath this layer of directories you will find the individual device
description files (.ffo and .sym).

5. If necessary, click on the Browse button to select the standard text
dictionary, provided with NI-FBUS. The text dictionary has a .dct
extension.

6. Click on the Import DD button. The Import DD dialog box appears.

7. Click on the Browse button, browse to the .ffo device description file
path, and click on Open. Typically, the device description for your
Fieldbus device is supplied on a disk from the manufacturer. For each
device, there are two device description files, one that ends in .ffo

and one that ends in .sym. Select the .ffo file, and the corresponding
.sym file will be imported automatically. The file name will be in the
form Digit Digit Digit Digit.ffo (for example, 0101.ffo).

Note If you are importing device descriptions for multiple devices, you might see that they
can have the same filenames. Each file contains information about the device and its
manufacturer, and will be placed appropriately in the hierarchy under the base directory.

8. Click on OK. A window will appear that gives the full path to which
the .ffo and .sym files were copied.

9. Click on OK.

For more information on device descriptions, refer to the The Role of
Device Descriptions section in the Foundation Fieldbus Overview
document.
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3
Start the NIFB Process

The NIFB process must be running any time you want to use your
PCMCIA-FBUS card as a Fieldbus interface to communicate between
the card and the bus.

♦ Windows 2000—Start the NIFB process by selecting Start»Programs»
National Instruments»NI-FBUS»Nifb.

♦ Windows NT—If the NIFB kernel-mode driver has not already been started,
you must do so manually.

1. Start the kernel mode driver NIFB by selecting Start»Settings»
Control Panel»Devices»Nifb and clicking on the Start button.

2. Start the NIFB process by selecting Start»Programs»National
Instruments NIFB»Nifb.

Note You also can start the driver by entering net start nifb at the command prompt.
This method is especially helpful if you are unable to find nifb on the Device Manager»
View»Show hidden devices list in Windows 2000.

If you receive the message System error 31 has occurred, the cause is most likely
an interrupt or memory address conflict. Set the device to poll mode or change the memory
address value.

♦ Windows 9x—Start the NIFB process by selecting Start»Programs»
National Instruments NIFB»Nifb.

Configure NIFB to Load at System Startup
If the driver and the process start up successfully, you can configure the
kernel-mode driver (for Windows NT) and NIFB process to start
automatically when you boot or restart your computer.

Note To do this on a Windows NT machine, you must be running Windows NT 4.0
or later.
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♦ Windows NT—Select Start»Settings»Control Panel»Devices»Nifb. Click
on the StartUp button. Select Automatic.

♦ Windows 9x—Add the NIFB shortcut to the StartUp folder. Refer to your
Microsoft Windows online help for information on adding programs to the
StartUp folder.

Note In Windows 2000, the WDM driver and the process start up automatically.

Begin to Use Your NI-FBUS Software
If you are using the NI-FBUS Communications Manager, proceed to the
NI-FBUS Communication Manager User Manual for information on using
your software. If you are using the NI-FBUS Configurator, proceed to the
NI-FBUS Configurator User Manual for information on using your
software.

If NI-FBUS is unable to connect to and initialize an interface device,
and you decide to continue NI-FBUS startup, NI-FBUS will not try to
reconnect to that interface again. This is true of all interface types supported
by this software.

If a PCMCIA-FBUS interface is configured as a basic device, a link master
device must be present on this link before NI-FBUS will start up.
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A
Specifications

This appendix describes the electrical, physical, and environmental
characteristics of the PCMCIA-FBUS hardware and the recommended
operating conditions.

Electrical Characteristics
Power requirement
(from PCMCIA socket).......................... 500 mA Typical

Physical Characteristics
Dimensions............................................. 85.6 by 54.0 by 5.0 mm

(3.4 by 2.1 by 0.4 in.)

I/O connector.......................................... Cable with DB-9 DSUB
and 5-position pluggable
screw terminal

Environmental Characteristics

Operating Environment
Component temperature......................... 0 to 70 °C

Relative humidity ................................... 10 to 90% noncondensing

Storage Environment
Temperature ........................................... –40 to 125 °C

Relative humidity ................................... 5 to 90% noncondensing

EMI ........................................................ FCC Class A Verified
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B
Pinout Information

This appendix contains information about the pinout of the Fieldbus
connectors.

One PCMCIA-FBUS cable is included in your kit. The following figures
show the pinout of the Fieldbus connectors so you can make your own cable
if you need a longer cable than the PCMCIA-FBUS cable in your kit.

Figure B-1 shows the PCMCIA-FBUS cable. An arrow on the cable points
to pin 1 of the screw terminal block.

Figure B-1. PCMCIA-FBUS Cable

The PCMCIA-FBUS/2 cable has two Fieldbus connectors that are similar
to the one shown in Figure B-1. The connector labeled “PCMCIA-FBUS,
PORT 1” is the connector for Fieldbus port 1 and the connector labeled
“PCMCIA-FBUS, PORT 2” is the connector for Fieldbus port 2. Refer
to Figures B-2 and B-3 for the pinout of both connectors.

J2

J1

PCMCIA-FBUS, PORT 1

V-
D-

SH
D+

V+
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Figure B-2 shows J1, the Fieldbus connector pinout.

Figure B-2. Fieldbus Connector Pinout

Figure B-3 shows J2, the screw terminal block pinout.

Figure B-3. Screw Terminal Block Pinout

The pinout of the PCMCIA-FBUS uses pins 6 and 7 of the J1 connector for
the Fieldbus signals, as specified in the Fieldbus Standard for Use in
Industrial Control Systems, Part 2, ISA-S50.02.1992. Pins 2 and 4 of the
J2 screw terminal block provide an alternate connection to the Fieldbus.
However, the screw terminal block is not a second, independent link.

All of the signals on the screw terminal block provide a direct connection
to the 9-pin DSUB. National Instruments provides the Power+ and Power–
connections as passive connections from the DSUB to the screw terminal.
The PCMCIA-FBUS itself does not supply power to, or draw power from,
these pins.

No Connection

No Connection

No Connection

No Connection

No Connection

Power –

Power +

Data –

Data +

1
3

2
5

4

7
6

8
9

1
2
3
4
5

Power –
Data –
Shield
Data +
Power +
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C
Troubleshooting and
Common Questions

This appendix describes how to troubleshoot common problems that occur
while getting started with Fieldbus.

Error Messages
Unable to download stack to board X.

You might have a memory base address conflict. Try configuring your card
to use a different base address, as described in Chapter 2, Installation and
Configuration.

Utility could not access or locate the registry.

• If using Windows 2000/NT, make sure you are logged in to
Windows 2000/NT with administrator privileges.

• Your registry entries for NI-FBUS may have been deleted or corrupted.
Uninstall, then reinstall the NI-FBUS software as described in the
Install the Software section in Chapter 2, Installation and
Configuration.

NIFB could not locate any usable Fieldbus boards.

Stop the card, remove it, then reinsert it.

Board cannot be found.

1. Verify the base address and IRQ settings as described in the section
Set the Base Address and IRQ in Chapter 2, Installation and
Configuration.

2. Select Start»Programs»National Instruments FBUS»Interface
Config. Make sure your card appears under the list of interfaces.

3. Make sure the kernel-mode driver is started. To start the driver, select
Start»Settings»Control Panel»Devices»Nifb. Click on the Start
button. To avoid manual startup in the future, click on Startup and
select Automatic.
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VCR_FULL_ERROR

Delete the card from the Interface Configuration utility, then re-install.

NIFB Problems
When using the PCMCIA-FBUS card with Windows 2000/NT, Nifb
returns an error message stating that the board cannot be found.

• Verify the base address and IRQ settings as described in the Set the
Base Address and IRQ section in Chapter 2, Installation and
Configuration.

• Select Start»Programs»National Instruments FBUS»Interface
Config. Make sure your card appears under the list of interfaces.

• Make sure the kernel-mode driver is started. To start the driver, select
Start»Settings»Control Panel»Devices»Nifb. Click on the Start
button. To avoid manual startup in the future, click on Startup and
select Automatic.

When a Fieldbus device is connected to the bus, the NIFB process
often hangs when the title bar reads Waiting for Startup Completion.
If I disconnect the cables, it starts fine.

This is probably due to a device address conflict. In the NI-FBUS Interface
Configuration utility, make sure that the interface is not at the same address
as anything else on the link. You can also temporarily give the interface
a visitor address to troubleshoot this problem.

The NIFB process hangs, does not start up, or never shows that it is running.

• For PCMCIA cards, if you have both Windows 95 and
Windows 2000/NT on your laptop, boot into Windows 95 and note the
resources automatically assigned by Windows 95. Often these
resources will work well under Windows 2000/NT.

• The card’s base memory address conflicts with another device. Try
using a different base memory address. Windows does not always
detect all conflicts. Even if Windows reports no conflicts, trying
a different address after you have eliminated the IRQ or Fieldbus
network address will often resolve the problem. You have to reboot
the machine each time you change base address and/or IRQ.

• The card’s IRQ conflicts with another device. Try setting the card to
polled mode.
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• The Fieldbus network address is not unique. Remove the cable from
the card. Restart the NIFB process. If it runs successfully, there is
probably a Fieldbus network address conflict. If you have FP-3000
network modules on the bank, turning their power off and then back on
will cause them to look on the bus for available addresses and change
addresses if necessary. If this does not solve the problem, you can try
to change the card’s address. In the Interface Configuration utility,
select the port and click on Edit. Make sure that the port does not have
an address that conflicts with another device on the bus. You can also
set the interface to a visitor address. In this case, the card will find and
take an unused address. If this corrects the problem, find and change
the address of one of the conflicting devices. Return the card to a fixed
address.

• Check for multiple copies of nifb.dll on the machine. If multiple
copies are found, NI-FBUS was incorrectly re-installed. Uninstall
NI-FBUS, search for any remaining copies of nifb.dll, delete them,
then reinstall the software.

• In Windows 9x, you can check the Windows Device Manager to see
if Windows has detected any problems or conflicts in the resources
assigned to your card. Your card(s) will appear under the Fieldbus
Adapters category. The Device Manager displays an exclamation
mark (!) on the icon of any card that has resource conflicts.

• Check how many cards are showing up in the Interface Configuration
utility. Make sure that this matches the number of cards in the system.
Also check that the number of ports match the physical hardware
(one port versus two port cards).

• Link masters do not always get along together (if you have another link
master on the link). Try setting the card to be a basic device in the
Interface Configuration utility.

If a PCMCIA-FBUS interface is configured as a basic device, another
link master device must be present on this link before the NI-FBUS
process will start up. For more about Basic and Link Master devices,
refer to the Fieldbus Overview document.

Interface Configuration Problems
When using the NI-FBUS Interface Configuration utility on a
Windows 2000/NT machine, the error message utility could not access
or locate the registry appears.

• Make sure you are logged in to Windows 2000/NT with administrator
privileges.
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• Your registry entries for NI-FBUS may have been deleted or corrupted.
Uninstall, then reinstall the NI-FBUS software as described in the
Install the Software section in Chapter 2, Installation and
Configuration.

• For PCMCIA-FBUS cards, removing third party card manager
software has also been known to correct such problems.

• There is a thermal issue seen with the PCMCIA card in some laptops
with insufficient ventilation. Some laptops even place the PCMCIA
slots over the hard disk or power supply! National Instruments
PCMCIA-FUBS cards are within the PCMCIA specification for
current draw. However, if the laptop builds up heat, this may become
a problem.

In the Interface Configuration Utility, I see more boards than what
physically exist in the machine.

♦ Windows 2000/NT—Select Edit for the extra card. In the next window, select
Delete.

♦ Windows 9x—Contact National Instruments to get information on cleaning
the Windows registry.

Caution You should not attempt to make unguided changes in the Windows registry.
Doing so can cause many problems with your system.

Add New Hardware Problems
In Add New Hardware on Windows 9x, there is no category for
Fieldbus.

The category Fieldbus Adapters will not appear under the type of
hardware listing in Add New Hardware unless you reboot the computer
twice after installing the software. After you install your first card, it will
always show up. If the Fieldbus Adapters category does not appear, you
can still follow the instructions in the Set the Base Address and IRQ section
in Chapter 2, Installation and Configuration.



Appendix C Troubleshooting and Common Questions

© National Instruments Corporation C-5 PCMCIA-FBUS for Windows

Resolving Resource Conflicts

Assign Each Card a Unique Base Address
In Windows 2000/NT, the base address for PCMCIA adapters is assigned
based on the board ID, which is identical for all PCMCIA cards from a
given manufacturer. To fix this problem, either use only one PCMCIA
controller, use Windows 9x, or use Windows 2000/NT.

Use a Different Memory Address
The Device Manager in Windows 9x or NT Diagnostics in Windows NT
does not report all resource conflicts. If you are having problems with your
current resource settings, try different ones. Memory base address
0x0D4000 is free on many systems.

Put the Card in Polled Mode
Putting the card in polled mode is a good way to eliminate one variable.
To put the card in polled mode:

♦ Windows 9x—Use the Device Manager:

1. Select Start»Settings»Control Panel»System, then click on the
Device Manager tab.

2. Click on the Fieldbus adapters icon, select the PCMCIA-FBUS card,
and click on the Properties button. The PCMCIA-FBUS Properties
dialog box appears.

3. Click on the Resources tab.

Note the memory base address your card is using. Select a different Basic
Configuration that does not include an IRQ. This is the polled mode option.
Then, change the memory base address back to its original setting.

♦ Windows 2000/NT—Use the Interface Configuration utility:

1. Select Start»Programs»National Instruments FBUS»Interface
Config.

2. In the Interface Config window, select the icon of the card you want
to change and click on the Edit button. If you are adding a card, click
on the Add Interface Device button.

3. Check the Polled Mode checkbox.
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4. Note the memory base address your card is using. Select a different
Basic Configuration that does not include an IRQ. This is the polled
mode option. Then, change the memory base address back to its
original setting.

Use a Visitor Address
Using a visitor address is a good way to troubleshoot an address conflict
since the card will find and take an available address.

Problems Using Manufacturer-Defined Features
NI-FBUS uses identifying information in the actual device to locate the
device description for the device. The identifying information includes four
resource block parameters: MANUFAC_ID, DEV_TYPE, DEV_REV, and
DD_REV. If the identifying information is incorrect, NI-FBUS will not be
able to locate the device description for the device. When it has located the
device description, NI-FBUS matches the block types in the device
description with the actual blocks in the device by using the Item ID of the
block characteristics record.

If the blocks in the device do not match the blocks in the description, or if
there is no appropriate device description for the manufacturer, device type,
device revision and device description revision being returned by the
device, then there is a device description mismatch. In either case,
NI-FBUS uses only the standard dictionary (nifb.dct) and you will be
unable to use any manufacturer-supplied functionality.

These parameters can be read from the device’s resource block.
The following procedure will help you troubleshoot a
DD_SIZE_MISMATCH_ERROR by finding out if there is a device description
available on your computer that matches what your device expects.

Follow these steps to use the NI-FBUS Dialog utility to check device
description files:

1. Start the NIFB process. Wait until the process has finished initializing.

2. Select Start»Programs»National Instruments FBUS»NI-FBUS
Dialog.

3. Right-click on Open Descriptors and choose Expand All.

4. After the expansion is complete, click on Cancel to close the Expand
All window.
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5. Right-click on the resource block for your device (it should be under
Open Descriptors»Session»Interface Name»Device Name»VFD
Name»Resource Block Name). Select Read Object.

6. Select the Read by Name radio button and enter MANUFAC_ID as the
name. Click on the Read button. Write down the hexidecimal number
found in parenthesis (0xnumber) in Table C-1.

7. Repeat step 6 for the name DEV_TYPE.

8. Repeat step 6 for the name DEV_REV.

9. Repeat step 6 for the name DD_REV.

10. Repeat steps 5–9 for each device, then close the NI-FBUS Dialog
utility.

11. In the Interface Configuration utility, click on the DD Info button.
Write down the base directory specified for device descriptions. Close
the Interface Configuration utility.

12. Use Windows Explorer to view the contents of the base directory
specified in the Interface Configuration utility. The Fieldbus
specification defines the directory hierarchy for storing device
descriptions. There is a different subdirectory for each device
manufacturer. Under the base directory, you should see a directory
with the number from step 6 for the first device.

13. Under the appropriate manufacturer directory, there is a directory for
each device type that you have from that manufacturer. Check to make
sure that you see a directory with the number from step 7.

14. Under the appropriate device type directory, there are the individual
device descriptions. The device description file name is a combination
of the device revision (the number from step 8) and the device
description revision (the number from step 9). The device revision is
the first two digits, and the device description revision is the second
two digits. For example, if your number from step 8 was 2 and from
step 9 was 1, you should see files called 0201.ffo and 0201.sym.

Table C-1. Device Names

Resource Block Parameter Name

MANUFAC_ID

DEV_TYPE

DEV_REV

DD_REV
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Device descriptions are backwards compatible. This means that
instead of seeing 0201, you might see 0202. This is allowed by the
Fieldbus specification. Also, having additional files in this directory
is not a problem. The Configurator will use the most recent device
description revision for a given device revision. If you do not have the
appropriate .ffo and .sym files, you must obtain them from the
device manufacturer. Be sure to properly import them by clicking on
DD Info and using the Import DD button in the Interface
Configuration utility.

15. Repeat steps 12–14 for each device.

The second cause for this problem is when the contents of the file do not
accurately describe the device characteristics, even if the device
identification information matches the file identification information.
This problem is caused when a device manufacturer makes a change to the
firmware of the device without incrementing the device revision, in
violation of the Foundation Fieldbus recommendation. If this is the case,
you must contact your device manufacturer for a resolution.

Configuring Advanced Parameters

Caution Do not modify the Advanced parameters without good reason. If you must
modify parameters for certain devices, the device manufacturer will recommend settings.
Modifying these parameters can have an adverse affect on data throughput rates. If settings
are incorrectly modified, some devices might disappear off the bus.

In the NI-FBUS Interface Configuration utility, click on the Advanced
button on the dialog box for the port you want to configure. Figure C-1
shows the Advanced Stack Configuration dialog box.
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Figure C-1. Advanced Stack Configuration Dialog Box

The parameters involved in setting addresses are T1 and T3. These
parameters represent delay time values that your card uses to compensate
for the delays inherent in the device and in the set address protocol itself.
T1 describes the expected response delay of the device at a given address.
T3 describes the expected time for the device to respond at its new address.

Uninstalling the Software
To uninstall your NI-FBUS software, select Start»Settings»Control
Panel»Add/Remove Programs.

If you are only using the Communications Manager, select NI-FBUS
Communications Manager to uninstall. If you are using the NI-FBUS
Configurator, select NI-FBUS Configurator.

The uninstall utility does not remove the NI-FBUS directory itself or any
files in the \Data\Nvm directory. To completely uninstall the software,
manually remove the files in the \Data\Nvm directory and the NI-FBUS
directory structure.
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D
Technical Support and
Professional Services

Visit the following sections of the National Instruments Web site at
ni.com for technical support and professional services:

• Support—Online technical support resources include the following:

– Self-Help Resources—For immediate answers and solutions,
visit our extensive library of technical support resources available
in English, Japanese, and Spanish at ni.com/support. These
resources are available for most products at no cost to registered
users and include software drivers and updates, a KnowledgeBase,
product manuals, step-by-step troubleshooting wizards, hardware
schematics and conformity documentation, example code,
tutorials and application notes, instrument drivers, discussion
forums, a measurement glossary, and so on.

– Assisted Support Options—Contact NI engineers and other
measurement and automation professionals by visiting
ni.com/ask. Our online system helps you define your question
and connects you to the experts by phone, discussion forum,
or email.

• Training—Visit ni.com/custed for self-paced tutorials, videos, and
interactive CDs. You also can register for instructor-led, hands-on
courses at locations around the world.

• System Integration—If you have time constraints, limited in-house
technical resources, or other project challenges, NI Alliance Program
members can help. To learn more, call your local NI office or visit
ni.com/alliance.

If you searched ni.com and could not find the answers you need, contact
your local office or NI corporate headquarters. Phone numbers for our
worldwide offices are listed at the front of this manual. You also can visit
the Worldwide Offices section of ni.com/niglobal to access the branch
office Web sites, which provide up-to-date contact information, support
phone numbers, email addresses, and current events.
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Glossary

Prefix Meaning Value

m- milli- 10–3

k- kilo- 103

Numbers
4-20 mA system Traditional control system in which a computer or control unit

provides control for a network of devices controlled by 4-20 mA
signals.

A
Address Character code that identifies a specific location (or series of

locations) in memory.

Alarm A notification the NI-FBUS Communications Manager software
sends when it detects that a block leaves or returns to a particular
state.

API Application Programmer Interface.

Attribute Properties of parameters.

B
b Bits.

Bank The combination of one FieldPoint network module and one or more
terminal bases and I/O modules.

Basic device A device that can communicate on the Fieldbus, but cannot become
the LAS.

Block A logical software unit that makes up one named copy of a block and
the associated parameters its block type specifies. The values of the
parameters persist from one invocation of the block to the next. It can
be a resource block, transducer block, or function block residing
within a virtual field device.
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Bus The group of conductors that interconnect individual circuitry in a
computer. Typically, a bus is the expansion vehicle to which I/O or
other devices are connected. Examples of PC busses are the ISA and
PCI buses.

C
C Celsius.

Cable A number of wires and shield in a single sheath.

Communication stack Performs the services required to interface the user application to the
physical layer.

Control loop A set of connections between blocks used to perform a control
algorithm.

Control strategy See Function Block Application.

Controller An intelligent device (usually involving a CPU) that is capable of
controlling other devices.

D
DD See Device Description.

Descriptor A number returned to the application by the NI-FBUS
Communications Manager, used to specify a target for future
NI-FBUS calls.

Device A sensor, actuator, or control equipment attached to the Fieldbus.

Device address A memory address that you use to access a device in a computer
system.

Device Description A machine-readable description of all the blocks and block
parameters of a device.

Device tag A name you assign to a Fieldbus device.

Directory A structure for organizing files into convenient groups. A directory is
like an address showing where files are located. A directory can
contain files or subdirectories of files.

DLL See Dynamic Link Library.

Driver Device driver software installed within the operating system.
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Dynamic Link Library A library of functions and subroutines that links to an application at
run time.

E
EMI Electromagnetic interference.

Event An occurrence on a device that causes a Fieldbus entity to send the
Fieldbus event message.

F
Field device A Fieldbus device connected directly to a Fieldbus.

Fieldbus An all-digital, two-way communication system that connects control
systems to instrumentation. A process control local area network
defined by ISA standard S50.02.

Fieldbus cable Shielded, twisted pair cable made specifically for Fieldbus that has
characteristics important for good signal transmission and are within
the requirements of the Fieldbus standard.

Fieldbus Foundation An organization that developed a Fieldbus network specifically based
upon the work and principles of the ISA/IEC standards committees.

Fieldbus Messaging
Specification

The layer of the communication stack that defines a model for
applications to interact over the Fieldbus. The services FMS provides
allow you to read and write information about the OD, read and write
the data variables described in the OD, and perform other activities
such as uploading/downloading data and invoking programs inside
a device.

Fieldbus Network Address Location of a board or device on the Fieldbus; the Fieldbus node
address.

FMS See Fieldbus Messaging Specification.

Foundation Fieldbus
specification

The communications network specification that the Fieldbus
Foundation created.

FP-3000 National Instruments network interface module for the FieldPoint
I/O system.
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Function block A named block consisting of one or more input, output, and contained
parameters. The block performs some control function as its
algorithm. Function blocks are the core components you control a
system with. The Fieldbus Foundation defines standard sets of
function blocks. There are ten function blocks for the most basic
control and I/O functions. Manufacturers can define their own
function blocks.

Function Block Application The block diagram that represents your control strategy.

H
H1 The 31.25 kbit/second type of Fieldbus.

hex Hexadecimal. A base-16 numbering system which uses 0–9 and A–F.

HMI Human-Machine Interface. A graphical user interface for the process
with supervisory control and data acquisition capability.

Hz Hertz.

I
I/O Input/output.

IEC International Electrotechnical Commission. A technical standards
committee which is at the same level as the ISO.

in. Inches.

IRQ Interrupt request.

ISA Industry Standard Architecture.

K
Kb Kilobytes.

Kbits Kilobits.

Kernel The set of programs in an operating system that implements basic
system functions.

Kernel mode The mode in which device drivers run on Windows NT.
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L
LabVIEW DSC The LabVIEW Datalogging and Supervisory Control (DSC) Module

builds on the power of LabVIEW for high channel count and
distributed applications. It adds easy networking, channel and I/O
management, alarm and event management, historical datalogging,
real-time trending, and OPC integration to the LabVIEW
environment.

LAS See Link Active Scheduler.

Link A Foundation Fieldbus network is made up of devices connected by
a serial bus. This serial bus is called a link (also known as a segment).

Link Active Schedule A schedule of times in the macrocycle when devices must publish
their output values on the Fieldbus.

Link Active Scheduler The Fieldbus device that is currently controlling access to the
Fieldbus. A device that is responsible for keeping a link operational.
The LAS executes the link schedule, circulates tokens, distributes
time, and probes for new devices.

Link master device A device that is capable of becoming the LAS.

Live list The list of all devices that are properly responding to the Pass Token.

Lookout National Instruments Lookout is a full-featured object-based
automation software system that delivers unparalleled power and
ease of use in demanding industrial measurement and automation
applications.

Loop See Control loop.

M
m Meters.

Manufacturer’s
identification

An identifier used to correlate the device type and revision with its
device description and device description revision.

Menu An area accessible from the command bar that displays a subset of the
possible command choices. In the NI-FBUS Configurator, refers to
menus defined by the manufacturer for a given block.

Method Methods describe operating procedures to guide a user through
a sequence of actions.

Mode Type of communication.
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N
Network address The Fieldbus network address of a device.

Nifb.exe The NIFB process that must be running in the background for you to
use your AT-FBUS or PCMCIA-FBUS interface to communicate
between the board and the Fieldbus.

NI-FBUS API The NI-FBUS Communications Manager.

NI-FBUS Communications
Manager

Software shipped with National Instruments Fieldbus interfaces that
lets you read and write values. It does not include configuration
capabilities.

NI-FBUS Configurator National Instruments Fieldbus configuration software. With it, you
can set device addresses, clear devices, change modes, and read and
write to the devices.

NI-FBUS Fieldbus
Configuration System

See NI-FBUS Configurator.

NI-FBUS process Process that must be running in the background for you to use your
AT-FBUS or PCMCIA-FBUS interface to communicate between the
board and the Fieldbus.

O
Object An element of an object dictionary.

Object Dictionary A structure in a device that describes data that can be communicated
on the Fieldbus. The object dictionary is a lookup table that gives
information such as data type and units about a value that can be read
from or written to a device.

OD See Object Dictionary.

OPC OLE for Process Control.

P
Parameter One of a set of network-visible values that makes up a function block.

PC Personal Computer.

PCMCIA Personal Computer Memory Card International Association.
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Physical Layer The layer of the communication stack that converts digital Fieldbus
messages from the communication stack to actual physical signals on
the Fieldbus transmission medium and vice versa.

PLC See Programmable Logic Controller.

Poll To repeatedly inspect a variable or function block to acquire data.

Port A communications connection on a computer or remote controller.

Program A set of instructions the computer can follow, usually in a binary file
format, such as a .exe file.

Programmable Logic
Controller

A device with multiple inputs and outputs that contains a program
you can alter.

R
Repeater Boost the signals to and from the further link.

Resource block A special block containing parameters that describe the operation
of the device and general characteristics of a device, such as
manufacturer and device name. Only one resource block per device
is allowed.

Roundcard A hardware interface for developing Foundation Fieldbus-compliant
devices.

S
s Seconds.

Segment See Link.

Sensor A device that responds to a physical stimulus (heat, light, sound,
pressure, motion, flow, and so on), and produces a corresponding
electrical signal.

Server Device that receives a message request.

Session A communication path between an application and the NI-FBUS
Communications Manager.

Shield Metal grounded cover used to protect a wire, component or piece of
equipment from stray magnetic and/or electric fields.
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Signal An extension of the IEEE 488.2 standard that defines a standard
programming command set and syntax for device-specific
operations.

Stack A set of hardware registers or a reserved amount of memory used for
calculations or to keep track of internal operations.

Static library A library of functions/subroutines that you must link to your
application as one of the final steps of compilation, as opposed to a
Dynamic Link Library, which links to your application at run time.

T
Tag A name you can define for a block, virtual field device, or device.

Trend A Fieldbus object that allows a device to sample a process variable
periodically, then transmit a history of the values on the network.

V
V Volts

VCR See Virtual Communication Relationship.

VFD See Virtual Field Device.

Virtual Communication
Relationship

Preconfigured or negotiated connections between virtual field
devices on a network.

Virtual Field Device The virtual field device is a model for remotely viewing data
described in the object dictionary. The services provided by the
Fieldbus Messaging Specification allow you to read and write
information about the object dictionary, read and write the data
variables described in the object dictionary, and perform other
activities such as uploading/downloading data and invoking
programs inside a device. A model for remotely viewing data
described in the object dictionary.
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Index

A
add new hardware

problems, troubleshooting, C-4
advanced parameters

advanced stack configuration dialog box
(figure), C-9

configuring, C-8

B
base address and IRQ

setting, 2-4
board renumbering (table), 2-9

C
cable

PCMCIA-FBUS (figure), B-1
common questions, C-1

add new hardware problems, C-4
error messages, C-1
interface configuration problems, C-3
NIFB problems, C-2
problems using manufacturer-defined

features, C-6
resolving resource conflicts, C-5

communication parameters
setting, 2-4

configuration
software, 1-2

configuring advanced parameters, C-8
conflict

eliminating by changing resources, 2-7
contacting National Instruments, D-1
conventions used in the manual, x

customer
education, D-1
professional services, D-1
technical support, D-1

D
device descriptions

importing, 2-9
device names (table), C-7
diagnostic resources, D-1
different memory address, C-5
documentation

conventions used in manual, x
how to use manual set, ix
online library, D-1
related documentation, xi

drivers
instrument, D-1
software, D-1

E
error messages, C-1
example code, D-1

F
Fieldbus

optional network tools, 1-4
frequently asked questions, D-1

H
hardware

description, 1-1
installation, 2-2

figure, 2-3



Index

PCMCIA-FBUS for Windows I-2 ni.com

help
professional services, D-1
technical support, D-1

how to use manual set, ix

I
import device descriptions, 2-9
installation and configuration, 2-1

base address and IRQ
setting, 2-4

testing, 2-6
instrument drivers, D-1
interface configuration

problems, troubleshooting, C-3
interface information

changing or deleting existing
information, 2-8

interface name
setting, 2-4

introduction, 1-1

K
KnowledgeBase, D-1

N
National Instruments

customer education, D-1
professional services, D-1
system integration services, D-1
technical support, D-1
worldwide offices, D-1

network
optional tools, 1-4

NIFB
problems, troubleshooting, C-2
process

configuring to load at startup, 3-1
starting, 3-1

O
online technical support, D-1
optional tools, 1-4

P
PCMCIA-FBUS cable (figure), B-1
phone technical support, D-1
pinout

connector (figure), B-2
information, B-1
PCMCIA-FBUS cable (figure), B-1
terminal block (figure), B-2

polled mode, C-5
professional services, D-1
programming examples, D-1

R
related documentation, xi
resource conflicts, resolving, 2-7, C-5

S
software

configuration, choosing, 1-2
description, 1-2
description (table), 1-3
installation, 2-1

Windows 2000/NT, 2-1
Windows 9x, 2-2

uninstalling, C-9
using, 3-2

software drivers, D-1
specifications, A-1
support

technical, D-1
system integration services, D-1
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T
technical support, D-1
telephone technical support, D-1
training, D-1

customer, D-1
troubleshooting, C-1

add new hardware problems, C-4
error messages, C-1
interface configuration problems, C-3
NIFB problems, C-2
problems using manufacturer-defined

features, C-6
resolving resource conflicts, C-5

troubleshooting resources, D-1

U
uninstalling software, C-9
unique base address, C-5

V
visitor address, C-6

W
Web

professional services, D-1
technical support, D-1

what you need to get started, 1-1
Windows 2000/NT

more robust than Windows 9x, 1-1
worldwide technical support, D-1
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