LabVIEW™ Add-On for Tektronix Open Windows Oscilloscopes

Version 1.2

This document provides information about the National Instruments LabVIEW Add-On for Tektronix Open Windows Oscilloscopes. This add-on includes an evaluation copy of LabVIEW with a Tektronix-specific palette of VIs, a Scope Analysis Application demo, and the NI Example Finder with scope-specific examples.

For more information about LabVIEW, refer to the Getting Started with LabVIEW manual that is available in PDF format on the LabVIEW Add-On for Tektronix Open Windows Oscilloscopes CD.

Contents

Hardware and Software Requirements ............................................................. 2
Installation ........................................................................................................ 2
LabVIEW Scope Analysis Application ............................................................. 5
  Specifying a Signal Source Using the Acquire Tab ..................................... 6
  Selecting Analysis and Signal Processing Using the Analyze Tab ............... 7
  Examining Results, Exporting Data, and Generating Reports Using the Present Tab ................................................................. 8
Running the LabVIEW Scope Analysis Application ...................................... 9
Using LabVIEW to Communicate with a Tektronix Open Windows Oscilloscope ........................................................................................................................... 11
  Tektronix-Specific VIs .................................................................................. 11
  VXIplug&play VIs ....................................................................................... 12
NI Example Finder .......................................................................................... 13
  General LabVIEW Examples ..................................................................... 14
  Scope-Specific Examples .......................................................................... 14
Technical Support and Professional Services .................................................. 17
Hardware and Software Requirements


- Tektronix-supplied VXI plug&play instrument drivers for the scopes that you intend to use with the LabVIEW Add-on for Tektronix Open Windows Oscilloscopes. The installation CD includes these drivers in the VXIPnPInstDr directory. You also can download the latest version of these drivers from the NI Instrument Driver Network at ni.com/idnet.

- NI-VISA 2.5 or higher or TekVISA 1.10a or higher. Refer to the NI Web site at ni.com/visa for more information about NI-VISA.

- A TDS5000B-, 6000-, 7000B-, or 8000B-series Tektronix open Windows oscilloscope with TekScope, which is the default software application on the oscilloscope. Refer to the Tektronix documentation for more information about TekScope.

  or

  A PC connected to a Tektronix open Windows oscilloscope through a VISA-compatible interface such as GPIB or Ethernet. The PC must meet the minimum OS and hardware requirements for running LabVIEW. Refer to ni.com/labview for more information about LabVIEW.

Installation

NI recommends that you read these instructions before installing the LabVIEW Add-On for Tektronix Open Windows Oscilloscopes on an oscilloscope. These instructions apply to the TDS5000B-, 6000-, 7000B-, and 8000B-series Tektronix open Windows oscilloscopes.

Remove and install the software components in the order described in these instructions. If you do not follow the suggested order, some components might not install or uninstall correctly. If you want to restore the oscilloscope to the factory default setting, install the necessary Tektronix oscilloscope software. Refer to the Tektronix oscilloscope documentation for more information about restoring the oscilloscope to the factory default settings.

Note These instructions assume that LabVIEW 7 is not installed on the oscilloscope. If LabVIEW 7 is installed, it is not necessary to uninstall it unless you are upgrading from the Evaluation Edition to the Full or Professional Edition.
Refer to the Frequently Asked Questions on the installation CD and at ni.com/tek for help installing or using LabVIEW on a Tektronix open Windows oscilloscope.

Complete the following steps to install the LabVIEW Add-On for Tektronix Open Windows Oscilloscopes.

1. Uninstall the necessary software by selecting Start»Settings»Control Panel from the Windows taskbar and double-click the Add/Remove Programs icon.
   - VXIplug&play driver—Select tktds#k Instrument Driver, where # is the software version. If you cannot find the VXIplug&play instrument driver in the Add/Remove Programs dialog box, select Start»Programs»VXIPNP»Uninstall tktds#k, where # is the oscilloscope series from the Windows taskbar to uninstall the driver.

   **Caution** Do not uninstall NI-Device. This component is factory-installed by Tektronix and is required to operate the oscilloscope.

   - LabVIEW Add-On for Tektronix Open Windows Oscilloscope—Select LabVIEW Tektronix Toolset Ver # entry, where # is the software version.
   - LabVIEW—Select National Instruments Software and click the Change button. Select all LabVIEW components and click the Uninstall button.

   **Note** If you are installing a licensed (purchased) copy of LabVIEW on a 5000B- or 8000B-series oscilloscope, verify the version of TekScope by selecting Help»About from the TekScope menu before installing LabVIEW as described in step 2. 5000B- or 8000B-oscilloscopes running TekScope version 1.10a or earlier include a preinstalled Tektronix-specific version of the NI-488.2 driver that you do not want to overwrite.

2. Install LabVIEW 7.0 Evaluation Edition by running setup.exe from the LVEval70 folder. If you are a licensed user of LabVIEW, install the full version of LabVIEW from the standard LabVIEW 7.0 installation CDs.
To avoid overwriting the preinstalled Tektronix-specific NI-488.2 driver on 5000B- or 8000B-series oscilloscopes running TekScope version 1.10a or earlier, select the custom installation option when you install LabVIEW. When the feature tree appears, click the **Device Drivers** icon and select **NI-488.2**. Select **Do not install this feature** to avoid overwriting the Tektronix-specific NI-488.2 driver. Overwriting the preinstalled Tektronix-specific NI-488.2 driver is not a concern for 5000B- or 8000B-series oscilloscopes running TekScope versions newer than 1.10a, scopes from other series, or for installations on stand-alone PCs.

3. Install the VXIplug&play instrument driver by running `setup.exe` from the subdirectory in the `VXIPnPInstDr` directory that corresponds to the model of oscilloscope you are using. You can use the instrument drivers for remote operation of an oscilloscope using a computer connected to an oscilloscope through a GPIB interface. To remotely control an oscilloscope, install the instrument drivers appropriate for the remote oscilloscope on the controlling computer and the oscilloscope.

    **Note**  The LabVIEW Add-On for Tektronix Open Windows Oscilloscopes CD includes the instrument drivers that were current at the time of the CD release. Tektronix supplies, maintains, and supports the VXIplug&play drivers.

4. Install the LabVIEW Add-On for Tektronix Open Windows Oscilloscopes by running `setup.exe` from the `LVScopeAddOn` directory. If you are installing the LabVIEW Add-On for Tektronix Open Windows Oscilloscopes on a stand-alone computer, the default installation installs the components for all four series of scopes. If you do not want to install the components for all four series of scopes, select the custom installation option and remove the checkmarks from the checkboxes for the models that you do not want to control.
LabVIEW Scope Analysis Application

The LabVIEW Add-On for Tektronix Open Windows Oscilloscopes includes the LabVIEW Scope Analysis Application, a fully-functional stand-alone demo application that performs interactive signal processing and analyzes live or file-based signals from an oscilloscope.

Click the **Scope Analysis Application** button on the LabVIEW Add-On for Tektronix Open Windows Oscilloscopes start screen to open the application. If you have a licensed version of LabVIEW, you can open the LabVIEW Scope Analysis Application by selecting **Start»National Instruments»LabVIEW TDS#k Scope Analysis Application**, where # is the oscilloscope series.

**Note** The application demonstrates features available in the LabVIEW Full Development System, except for the Application Builder, which is necessary to compile and create an executable, stand-alone application like the LabVIEW Scope Analysis Application. The Application Builder is available in the LabVIEW Professional Development System and as an add-on you may purchase separately.

The user interface of the LabVIEW Scope Analysis Application consists of the following three tabs:

- The **Acquire** tab contains controls that you can use to acquire a signal.
- The **Analyze** tab contains controls that you can use to select and configure analysis and signal processing.
- The **Present** tab contains indicators that you can use to examine results and create reports.

Click the **Acquire**, **Analyze**, and **Present** tabs to switch between different sections of the application.

You can change acquisition, triggering, and other parameters on the oscilloscope while the application is running and view the results in visible plots, graphs, or indicators. You can configure horizontal scaling, vertical scaling, triggering, and other scope-specific functions on the oscilloscope or through TekScope, the built-in oscilloscope software. For example, a vertical scaling knob does not appear in the application because you can turn a physical knob on the front of the oscilloscope to change the parameter.
Specifying a Signal Source Using the Acquire Tab

Use the controls on the Acquire tab, shown in Figure 1, to specify the signal source or sources you want to analyze. Use the Wfm. A controls if you have one signal source. Use the Wfm. A and Wfm. B controls if you have two signal sources.

- **Hide**—Hides the waveform on the graph.
- **Pause**—Pauses the waveform acquisition.
- **Source**—Specifies the channel source.
- **Waveform Source**—Specifies the signal source. Select **Channel** to acquire live waveform signals with updates that occur as new data becomes available. Select **File** to use a waveform from a file that you specify in the **Filename** list.
- **Filename**—Specifies the name of a waveform file. This listbox is available only if you set **Waveform Source** to **File**.
- **Delete**—Removes the selected filename from the listbox. This button is available only if you set **Waveform Source** to **File**.
- **Refresh**—Refreshes the file listbox. This button is available only if you set **Waveform Source** to **File**.

![Figure 1. Acquire Tab](image-url)
Selecting Analysis and Signal Processing Using the Analyze Tab

Use the controls on the Analyze tab, shown in Figure 2, to select the type of analysis or signal processing to apply to the signal or signals you specify on the Acquire tab. Select the type of analysis you want from the list on the lower left corner of the Analyze tab. After you select the analysis type, the top of the window displays graphs and numeric indicators for any scalar values associated with the measurement. Use the group of controls that appears on the right of the list to set parameters specific to the type of analysis you select. Click the Analyze Wfm. button to specify which channel you want to analyze or process.

For example, if you select Tone Detection from the list of analysis options, the graph becomes a waveform plot with a single time-domain trace. The trace displays the waveform on the Export Signal control. Three scalar measurements to the right of the graph display detected amplitude, phase, and frequency.

![Figure 2. Analyze Tab](image-url)
Examining Results, Exporting Data, and Generating Reports Using the Present Tab

Use the controls on the Present tab, shown in Figure 3, to examine, export, and report the results of the analysis that you specify on the Analyze tab. The Present tab includes an expanded version of the graph on the Analyze tab and numeric indicators of scalar measurements associated with the current analysis.

Use the buttons on the bottom of the Present tab to generate reports. Click the Export ASCII Data button to generate a file with data from the graph. The file format is standard text with comma separators. You can import this file format into text editors, standard spreadsheet applications, and math software. Click the Export HTML Snapshot button to generate an HTML file with an image of the Present tab in JPEG format.

If you select None (Off) as the analysis option on the Analyze tab, an expanded view of an unanalyzed acquisition appears on the Present tab. Place a checkmark in the Cursors On/Off checkbox to display cursor controls on the time-domain graph. The Cursors indicators display the coordinates of two cursors and the difference between the x and y values of these coordinates. Use the Positioning tool, shown at left, located at the bottom of the graph to move the cursors.

Figure 3. Present Tab
Running the LabVIEW Scope Analysis Application

Complete the following steps to display and analyze signals from an oscilloscope using the LabVIEW Scope Analysis Application.

You can complete this activity in approximately 10 minutes.

1. On the oscilloscope, connect the Probe Comp output to the CH1 on the front of the oscilloscope using the appropriate probe or cable. If you are using an 8000B-series oscilloscope without a Probe Comp output, refer to the Tektronix documentation for information about connecting to a test signal.

2. Select Start»Programs»National Instruments»LabVIEW Scope Analysis Demo (TDS #k)»LabVIEW Scope Analysis Application (TDS #k), where # is the oscilloscope series, to run the LabVIEW Scope Analysis Application. The Establish Software Connection window appears as shown in Figure 4.

3. The Software Connection Name control specifies a unique connection name that the software uses to communicate with the oscilloscope hardware. GPIB8::1::INSTR is the default and works if you are running the application directly on the oscilloscope and TekScope is running. If GPIB8::1::INSTR is not available, verify that TekScope is running. If it is not running, click the Cancel button, restart TekScope, and return to the previous step. If you are running
this application on a remote PC connected to an oscilloscope through an instrument control interface such as GPIB or VXI-11, change **Software Connection Name** to an option that corresponds to the control interface with which you are working.

4. Click the **Start** button. The **LabVIEW Scope Analysis Application** window appears and defaults to the **Acquire** tab. The demo locates a signal on Channel 1 as shown in Figure 5. A trace appears on the waveform graph.

5. Use the knobs and buttons on the oscilloscope to configure the horizontal and vertical parameters of the acquisition data. For example, when you change the horizontal scale on the oscilloscope, the waveform graph in the application changes.

6. Click the **Analyze** tab. The graph displays a histogram of the signal on Channel 1. Experiment by selecting different analysis options. The graphs and controls change based on the analysis option you select.

7. Select the **Statistics/Histogram** analysis option.
8. Use the **Intervals** control to set the number of histogram intervals. Change the number of intervals from 128 to 256 and notice the increase in resolution on the x-axis of the graph.

9. Select the **Spectral Analysis** analysis option. Change the **Averaging Mode** control to enable averaging if you are examining a repeating, triggered signal.

---

**Note**  Refer to the *LabVIEW Analysis Concepts* manual, which is available online at [ni.com/manuals](http://ni.com/manuals) in PDF format, for more information about analysis and mathematical concepts in LabVIEW.

---

10. Click the **Present** tab. The graph for the analysis type you selected on the **Analyze** tab expands to fill the screen.

11. Click the **Export HTML Snapshot** button and enter a valid filename with a `.htm` or `.html` extension in the dialog box that appears. The application takes a screenshot of the window, embeds the graphic in an HTML file, and displays the file in the default Web browser.

---

**Using LabVIEW to Communicate with a Tektronix Open Windows Oscilloscope**

The LabVIEW Add-On for Tektronix Open Windows Oscilloscopes includes **Tektronix** palettes. The TDS 5000B, 6000, 7000B, and 8000B oscilloscope series each have a palette containing five Tektronix-specific VIs.

The LabVIEW Add-On for Tektronix Open Windows Oscilloscope includes two types of scope-specific VIs—Tektronix-specific and VXIplug&play.

---

**Tektronix-Specific VIs**

You can use the Tektronix-specific VIs located on the **Tektronix** palette to perform some of the tasks associated with transferring and manipulating waveforms between a LabVIEW application and an oscilloscope. These Tektronix-specific VIs communicate with the oscilloscope through the standard Tektronix VXIplug&play instrument driver and simplify the following tasks:

- Transferring a waveform and its timing and scaling information to a LabVIEW waveform and cluster.
- Transferring waveform timing and scaling information to a LabVIEW cluster.
- Transferring a waveform and its timing and scaling information from a LabVIEW waveform data type to an oscilloscope reference slot or a file.
- Transferring a waveform from one location on the oscilloscope, such as a channel, reference slot, or file, to another location on the oscilloscope, such as a reference slot or file.

The Tektronix-specific VIs simplify these tasks by grouping related operations. For example, the Tektronix-specific Simple Get Waveform VI can acquire waveform signals either from a live source, such as a channel, reference, or math source, or from a file. A single call to the Tektronix-specific Store Waveform VI can populate either an oscilloscope-based waveform reference or a file.

In contrast, the VXI plug&play driver contains individual VIs for each source/target combination. By using the Tektronix-specific VIs, you can reduce the number of steps necessary to implement the functionality you need when programming the oscilloscope.

Measurement-related data types, such as the waveform data type and predefined clusters, also can simplify tasks. These data types combine the numeric values of a waveform, the sampling rate, the x/y offsets, the x/y scaling factors, and other signal-related information. VXI plug&play VIs generally require more wiring because you pass information using separate wires.

**VXI plug&play VIs**

The VXI plug&play VIs give you more control than the Tektronix-specific VIs but have a steeper learning curve.

**Initialize and Close**

The Initialize and Close VIs are VXI plug&play VIs that are on the Tektronix palette for convenience because you use them in most oscilloscope applications to manipulate a software connection with the oscilloscope. You can use these VIs before and after other VIs that communicate with the oscilloscope. The Initialize VXI plug&play VI establishes a connection using a resource name or an instrument descriptor, which uniquely describes a particular instrument. GPIB8::1::INSTR is the instrument descriptor for VIs that run on the oscilloscope.
Get and Set Waveform

Although Tektronix-specific VIs automatically acquire and store waveforms between a VI and an oscilloscope, you might consider manipulating the waveforms manually if you work directly with the VXIplug&play VIs.

The Get Waveform VXIplug&play VI transfers samples from the oscilloscope to LabVIEW. You must specify the number of samples to expect in the acquisition to preallocate memory. Use the Get Horizontal Reclength or Get Horizontal Parameters VXIplug&play VIs to determine the appropriate value to use before acquiring waveform data.

Set the display status of a channel to on before the Get Waveform VXIplug&play VI retrieves data. The Get Waveform VXIplug&play VI cannot run until references are displayed and occupied. Use the Set Wfm Display Status VXIplug&play VI to change the display status of a channel or reference.

For more information about the Tektronix-specific VIs and the VXIplug&play VIs, select Help»Show Context Help or press the <Ctrl-H> keys to display the Context Help window. The VI description appears in the Context Help window when you move the cursor over the VI icon.

NI Example Finder

The NI Example Finder is a utility that allows you to browse and search installed examples. The version of the NI Example Finder that is included with the LabVIEW Add-On for Tektronix Open Windows Oscilloscopes is sized to fit the 640 × 480 oscilloscope screen and includes Tektronix-specific examples.

You can open the NI Example Finder in any of the following ways:

- Click the Scope-Specific Examples button on the LabVIEW Add-On for Tektronix Open Windows Oscilloscopes start screen.
- Select Help»Tektronix OWS Examples in LabVIEW to open the NI Example Finder and expand the directory structure to the Tektronix-specific examples.
- Select Help»Find Examples in LabVIEW to open the NI Example Finder. Select Toolsets and Modules»Tektronix open Windows Oscilloscope to open the Tektronix-specific examples. This launches the standard NI Example Finder, which might not fit on the oscilloscope screen.
General LabVIEW Examples

LabVIEW includes hundreds of example VIs you can use and incorporate into custom VIs. You can modify an example to fit an application, or you can copy and paste one or more examples into a custom VI. If you have an Internet connection, click the Visit LabVIEW Zone button in the NI Example Finder for additional examples.

Note Tektronix-specific examples are sized to fix the 640 x 480 oscilloscope screen. General LabVIEW examples are usually sized for a larger PC monitor.

Scope-Specific Examples

The LabVIEW Add-On for Tektronix Open Windows Oscilloscopes contains Tektronix-specific examples that include source code. Use these examples as teaching tools and as starting points when you build custom LabVIEW applications.

For more information about LabVIEW, refer to the Getting Started with LabVIEW manual available in PDF format on the LabVIEW Add-On for Tektronix Open Windows Oscilloscopes CD.

Acquire and Display Waveform Data Example

Complete the following steps to create a VI that allows you to control how waveform data from an oscilloscope displays on a graph.

Note You can find the solution VI, named Complete Walkthrough (TK TDS #k), where # is the oscilloscope series, in the NI Example Finder.

You can complete this section in approximately 10 minutes.

1. On the oscilloscope, connect the Probe Comp output to the CH1 using the appropriate probe or cable. If you are using an 8000-series oscilloscope without a Probe Comp output, refer to the Tektronix documentation for information about connecting to a test signal.
2. Click the Scope-Specific Examples button from the LabVIEW Add-on for Tektronix Open Windows Oscilloscopes start screen or select Help » Tektronix OWS in LabVIEW to open the NI Example Finder.
3. Select Toolsets and Modules » Tektronix open Windows Oscilloscope » TDS/CSA # Series » Acquisition » Partial Walkthrough (TK TDS#k) VI in the NI Example Finder, where # is the oscilloscope series, to open the Partial Walkthrough VI.
4. Select File » Save As to save a copy of the VI as Walkthrough Exercise.vi.
5. Verify the front panel is showing by selecting **Window»Show Front Panel**. The front panel is the user interface and appears with a gray background. It includes controls and indicators.

6. Open the **Controls** palette by right-clicking any blank space on the front panel. Click the thumbtack, shown at left, in the upper left corner of the **Controls** palette to place the palette on the screen. You also can open the **Controls** palette by selecting **Windows»Show Controls Palette**.

7. Search for and place the **Waveform Graph** on the front panel.

8. Press the <Ctrl-E> keys to display the block diagram.

9. Open the **Functions** palette by right-clicking any blank space on the block diagram. You also can open the **Functions** palette by selecting **Windows»Show Functions Palette**.

10. Search for and place the Tektronix-specific Simple Get Waveform VI on the block diagram as shown in Figure 6.

![Diagram](image)

**Figure 6.** Placing the Simple Get Waveform VI on the Block Diagram

11. Wire the **Instrument Handle Out** output of the Get Operation Complete VI to the **Instrument Handle In** input of the Simple Get Waveform VI. Wire the **Instrument Handle Out** output of the Simple Get Waveform VI to the **Instrument Handle In** input of the Set Acquisition Mode VI. The wires pass a valid instrument handle to each subVI. The instrument handle is a unique identifier that LabVIEW uses to maintain a software connection with the oscilloscope.
Tip The Context Help window displays basic information about LabVIEW objects, including inputs and outputs, when you move the mouse cursor over each object. To access the Context Help window, select Help » Context Help. You also can press the <Ctrl-H> keys to display the Context Help window.

12. Wire the error out output of the Get Operation Complete VI to the error in input of the Simple Get Waveform VI. Wire the error out output of the Simple Get Waveform VI to the error in input of the Set Acquisition Mode VI. The wires ensure that LabVIEW can handle errors that occur when the VI runs. For example, if the Initialize VI receives an invalid instrument description string, its error out output indicates why the VI did not attempt to retrieve waveform data.

13. Wire the Source Settings control to the Source Settings input of the Simple Get Waveform VI. The control specifies the source of the waveform data. The control is interactive so the user can change the source while the VI runs.

14. Wire the Waveform output of the Simple Get Waveform VI to the Waveform Graph indicator.

15. Wire the Waveform Information output of the Simple Get Waveform VI to the Waveform Information indicator. The wires pass the waveform, scaling, and offset information to front panel indicators that display the information graphically. The block diagram should appear similar to Figure 7.

Figure 7. Wiring the Block Diagram
16. Display the front panel and click the **Run** button, shown at left, to run the VI. A signal should appear on the graph.

17. Click the **Stop** button on the front panel to stop the VI.

18. Save the VI.

**Technical Support and Professional Services**

Visit the following sections of the National Instruments Web site at [ni.com](http://ni.com) for technical support and professional services:

- **Support**—Online technical support resources include the following:
  - **Self-Help Resources**—For immediate answers and solutions, visit our extensive library of technical support resources available in English, Japanese, and Spanish at [ni.com/support](http://ni.com/support). These resources are available for most products at no cost to registered users and include software drivers and updates, a KnowledgeBase, product manuals, step-by-step troubleshooting wizards, conformity documentation, example code, tutorials and application notes, instrument drivers, discussion forums, a measurement glossary, and so on.
  - **Assisted Support Options**—Contact NI engineers and other measurement and automation professionals by visiting [ni.com/support](http://ni.com/support). Our online system helps you define your question and connects you to the experts by phone, discussion forum, or email.

- **Training**—Visit [ni.com/training](http://ni.com/training) for self-paced tutorials, videos, and interactive CDs. You also can register for instructor-led, hands-on courses at locations around the world.

- **System Integration**—If you have time constraints, limited in-house technical resources, or other project challenges, NI Alliance Program members can help. To learn more, call your local NI office or visit [ni.com/alliance](http://ni.com/alliance).

- **Instrument Drivers**—Visit [ni.com/idnet](http://ni.com/idnet) to download instrument drivers. NI provides more than 2,200 instrument drivers from more than 150 vendors.

If you searched [ni.com](http://ni.com) and could not find the answers you need, contact your local office or NI corporate headquarters. You can visit the Worldwide Offices section of [ni.com/niglobal](http://ni.com/niglobal) to access the branch office Web sites, which provide up-to-date contact information, support phone numbers, email addresses, and current events.

Visit the Tektronix Web site at [www.tektronix.com/software](http://www.tektronix.com/software) to download firmware for your Tektronix product.