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RELEASE NOTES

LABVIEW DATALOGGING AND SUPERVISORY
CONTROL MODULE RUN-TIME SYSTEM
Version 6.1

Welcome to the LabVIEW Datalogging and Supervisory Control (DSC)
module Run-Time System, the LabVIEW solution for all kinds of
distributed data logging and automation needs. These release notes
describe system requirements and installation. They also contain
information that was not available for inclusion in the printed
documentation, and a list of known issues.
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Installation
The following sections describe how to install the LabVIEW Datalogging
and Supervisory Control (DSC) module Run-Time System on your
computer.

Installing the LabVIEW DSC Module Run-Time System
1. It is strongly recommended that you exit all programs before running

the setup. Applications that run in the background, such as virus
scanning utilities, may cause the installer to take longer than average
to complete.

2. Insert the LabVIEW DSC module Run-Time System CD in your
CD-ROM drive.

3. Run the installer as follows:

a. If your computer system has the AutoPlay feature enabled,
the installation will begin automatically.

b. If your system does not use AutoPlay, run the following program:

x:\setup.exe

where x is the letter of your CD-ROM drive.

4. Follow the onscreen instructions.

5. Reboot your computer.

Required System Configuration
The LabVIEW DSC module Run-Time System runs on any system with
the following:

• Windows Me/98/95, Windows NT 4.0, Windows 2000,
or Windows XP.

• A minimum of 32 MB of RAM, 128 MB recommended.
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• At least 60 MB of free disk space (for the system to use as swap space),
127 MB of swap space recommended. Increasing your computer
resources will have a significant effect on performance of LabVIEW
DSC module applications.

Additional Installations
In addition to the LabVIEW DSC module Run-Time System itself, you
might need to install additional drivers for use with your application
software during the LabVIEW DSC module Run-Time System setup.
You might also need to install additional data servers for your application
software. Refer to the documentation for your application software for
installation instructions.

Install the Application Software
Follow the instructions provided by the system developer for installing the
application software. After installing the files, note the location of the .scf 
and .ccdb files.

Install the Required Servers
If your application software uses the NI-DAQ Server for LabVIEW, install
the NI-DAQ Server from the LabVIEW DSC module Run-Time System
CD. Other servers must be installed separately.

Update Preference Files
Refer to the documentation for your application software to ensure any
specific preference files for the application are placed in the correct
locations. These files contain non-default settings for LabVIEW DSC
module utilities such as htv.ini. You can edit these files with a simple
text editor such as Notepad. Specific instructions about these preference
files should be included with your application software.

Finish Server Setup
If you are using National Instruments IAS/IAK device servers, you might
need to resolve the paths to the servers stored in the .ccdb file. Use the
Server Explorer to do this. The Server Explorer is installed when you install
the LabVIEW DSC module. Start the Server Explorer from your Windows
program menu or from the Tag Configuration Editor, select File»Open,
locate the .ccdb file for your application software, and choose File»Set
this file as Active CCDB.

VI-based servers (if used by your application) provide their own Server
Registration VIs.
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Configure LabVIEW Startup
Launch the LabVIEW DSC module Run-Time System. The first time you
run it, you might want to configure one or more startup VIs. These startup
VIs are the user interface panels that appear when you launch the Run-Time
System. Use the Select Tools»Datalogging & Supervisory Control»
Advanced»Startup VIs. Use the Configure Startup VIs dialog box to
locate the appropriate startup VIs, as identified in your application software
documentation.

If your application starts the Tag Engine when it launches, and the servers
are not registered properly, you will receive error messages identifying the
servers that did not start. Consult your application software documentation
for more information about which servers are required, and how to register
them.

Uninstalling the LabVIEW DSC Module
To uninstall the LabVIEW DSC module, select Start»Settings»Control
Panel and double-click Add/Remove Programs. In that window, select
and remove the following components:

• NI LabVIEW Datalogging and Supervisory Control Run-Time
System 6.1

• NI DSC Common Tools

• NI Historical Data Viewer

• NI Logos 4.4

• NI Server Explorer

• NI Measurement and Automation Explorer 2.2

All of these components, except for the NI LabVIEW Datalogging and
Supervisory Control Run-Time System 6.1 component, may be shared with
other National Instruments software that you have installed.

New Features for Version 6.1
The following sections describe the new features available in this version
of the LabVIEW DSC module.

String Tag Data Type
When you configure a string tag, you can select whether to treat the data in
the tag as text or as binary information. In the Tag Configuration Editor,
string tag dialog boxes have a new checkbox called Text Data Only. If this
box is checked, the string tag data is published and logged as text, otherwise
it is published and logged as a binary object (BLOB).
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You can set the default type for string tags to either text or BLOB in the
Set Default Parameters dialog box in the Tag Configuration Editor
(Configure»Default Parameters).

When you export your tag configuration to a spreadsheet file, this
information is represented in the Log Resolution column as 0=Binary or
1=TEXT. You can view this information in the Tag Configuration Editor
if you choose Edit»Column Setup and add the Log Resolution column.

Logging and Accessing Data, Alarms, and Events on a Network
Computer

You have the option to log or retrieve historical data, alarms, and events
to or from a computer on the network that has Citadel installed.

You will see new options in the Historical Logging Configuration dialog
box (Configure»Historical in the Tag Configuration Editor) and the Event
Configuration dialog box (Configure»Events in the Tag Configuration
Editor), that allow you to log to a networked computer.

The Shift Display field and Log Format page no longer appear for event
configuration, because the LabVIEW DSC module no longer logs to .evt
files.

Refer to the LabVIEW Datalogging and Supervisory Control Module
Run-Time System Manual for more information about logging historical
data and events.

Viewing Data on a Networked Computer Using Historical Trend
Viewer (HTV)

The Select Tags for HTV dialog box in HTV (Tools»Datalogging &
Supervisory Control»View Historical Trends) has changed so that you
can view data on another computer that has Citadel installed. Refer to the
LabVIEW Datalogging and Supervisory Control Module Run-Time System
Manual for more information about the classic Historical Trend Viewer.

New Options for Viewing Historical Data
Previous versions of BridgeVIEW and the LabVIEW DSC module gave
you the option of viewing historical data with the “classic” Historical Trend
Viewer (HTV) or the Historical Trend control. Version 6.1 of the
LabVIEW DSC module includes the new NI HyperTrend ActiveX control
and support for the new Historical Data Viewer in Measurement &
Automation Explorer (MAX). Refer to the LabVIEW Datalogging and
Supervisory Control Module Run-Time System Manual for more
information about extracting and viewing historical data.
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Logging and Retrieving Data in Sets
To log and retrieve data in sets, you configure the Data Set Logger server
to track your data sets, then you can use the Historical Data Viewer in MAX
to retrieve your data set values. Refer to the LabVIEW Datalogging and
Supervisory Control Module Run-Time System Manual for more
information about logging data in sets.

Compatibility Issues
To run an application created in a previous version of the LabVIEW
Datalogging and Supervisory Control (DSC) module, or in BridgeVIEW,
you will need to have the application developer recompile the VIs in your
application to upgrade them to LabVIEW 6.1. Recompiling VIs requires
the development version of LabVIEW 6.1 as well as the LabVIEW DSC
module.

Known Issues
The following known issue exists in the LabVIEW Datalogging and
Supervisory Control (DSC) module Run-Time System, Version 6.1.

Tag Monitor Security
When you start the Tag Monitor from LabVIEW, the user currently logged
in is set as the active user in the Tag Monitor. If the Tag Monitor continues
running when a new user logs into LabVIEW who also has access to the
Tag Monitor, the active user in the Tag Monitor will not change. In other
words, User A will be logged into Tag Monitor while User B is logged into
LabVIEW. You can always verify which user is logged into the Tag
Monitor by examining the status bar at the bottom of the Tag Monitor
window.

In certain situations, this may lead to undesired access to tag data. However,
you can configure which users and groups have access to the Tag Monitor
itself. If the user who logs in to LabVIEW does not have access to the Tag
Monitor, the Tag Monitor will close.
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At this time, the Tag Monitor does not support a direct login mechanism.
However, if you launch the Tag Monitor from the command line, the
following command line arguments are supported:

Tagmonitor.exe [“filename”] [-usr “username”] [-pwd 

“password”]

Accessing Remote Databases with the Classic Historical Trend Viewer
You can select a .scf file that is located on another computer on the
network with the HTV Select Tags dialog box. If you do, however, HTV
attempts to access the database as if it were a local database rather than
across the network. To access the database correctly, select the computer
and path directly, using the Data Directory field of the Select Tags
dialog box.

Tag Monitor and Binary String Tags
You can define string tags in the LabVIEW DSC module that are treated
either as text data or as binary data. If you use the Tag Monitor to subscribe
to string tags that support binary data, you will see a message indicating
that the tag is of an unsupported data type. Despite this message, you can
still set the value of the tag from the Tag Monitor. When you do you will
be writing text data into the binary tag. Because a binary tag can contain
any information, including text, this is not considered incorrect behavior on
the part of the Tag monitor.

filename Fully qualified path to a Tag Monitor configuration file
you have saved in the past; filenames with spaces must be
enclosed in quotation marks

-usr User login name; the user name must be enclosed in
quotation marks

-pwd Password for the user account specified with –usr; the
password must be enclosed in quotation marks, and
should not contain quotation marks within it
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Alarm and Event Priorities
Alarm and event priorities displayed in the Alarm & Events Display and the
Tag Monitor come from Citadel and use the range 1–10. Because the
LabVIEW DSC module tags allow you to define alarm priorities in the
range 1–15, the Tag Engine converts LabVIEW DSC module priorities to
the 1–10 scale for logging and publishing over the network via Logos and
Citadel. These priorities are converted as shown in the following table.

Replacement Keyboard Driver
The LabVIEW DSC module offers a replacement keyboard driver for use
with Windows NT 4.0 and Windows Me/98/95. This keyboard driver
provides the ability to disable certain Windows keyboard shortcuts such as
<Ctrl-Alt-Del>. This keyboard driver is not for use in Windows 2000 or
Windows XP. Also, for computers using custom keyboard drivers from
third-party manufacturers running Windows NT 4.0, we recommend that
you do not use this keyboard driver.

Table 1. Conversions for Alarm and Event Priorities

Converted From (Value in
LabVIEW DSC Module Tags) Converted To (Value in Citadel)

1 1

2 1

3 2

4 2

5 3

6 5

7 5

8 6

9 7

10 7

11 8

12 8

13 9

14 9

15 10
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Corrections and Additions to LabVIEW DSC Module
Run-Time System Documentation

The following sections contain information that has changed or that was
unavailable for inclusion in the printed LabVIEW Datalogging and
Supervisory Control (DSC) module Run-Time System documentation.

Deleting Databases and Database Views in Historical Data Viewer
The Historical Data Viewer Help does not describe the options for deleting
a database from the Historical Data Viewer in MAX. When you delete
a database from the Historical Data Viewer tree, you have the option of
deleting the database view from the tree or deleting both the database view
and the underlying database and data. A dialog box permits you to choose
the deletion option you want.

Data Set Logger Usage
The Data Set Logger offers many potential combinations of start and end
conditions for you to use when defining data set behavior. You might use
ID Tag Changes for both the start and end condition of a data set. In this
case, if the tag you select as your ID tag is an analog tag with an update
deadband of zero, or if it is a string tag that is configured to always update
the database when a value is written, you will generate a new data set each
time you write a value to the ID tag, even if you write the same value to the
ID tag several times in a row.

For example, if you have a string tag named Serial Number, and write the
value abc123 to it, you will start a new data set whose ID value is abc123.
If you write abc123 to the tag again, and you have configured the tag to
always update whenever a value is written to it, a new data set with the same
ID will be created. The Data Set Logger can handle multiple data sets with
the same ID tag value, but this may not be the behavior you intended.

By default, tags are not configured in this manner. If you have configured
your tags in this way, be aware that this behavior could result. To avoid it,
enable deadbands for the ID tag, or configure the data set to use different
start and end conditions.
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Required Application Files
The following list describes the files that might be needed for running a
LabVIEW DSC module application. These files need to be deployed to the
same location on each client computer.

• VIs (Refer to the LabVIEW Datalogging and Supervisory Control
Module Developer’s Manual for detailed information about which VIs
are required.)

• Tag configuration (.scf) files

• Preference files (.ini, .cfg) from the LabVIEW directory such as the
following:

– lvdsc.ini

– DSCEngine.ini

– LabVIEW.ini.

– \vi.lib\lvdsc\servers\Data Set Logger\ 

dscdatasets.ini

– \project\lvdsc\scf.ini

– \project\lvdsc\htv.ini

– \vi.lib\extensions\uistartup\uistart.cfg

– \vi.lib\extensions\security\lvsec.cfg

Do not include the following file, because it can prevent proper server
registration:

\vi.lib\lvdsc\init.ini

• Hardware configuration files (such as .iak files for FieldPoint,
MAX configuration data, and so on)

• The common configuration database file (.ccdb). This file can be
identified by examining the title bar of the Server Browser utility
(Tools»Datalogging & Supervisory Control»Advanced»Server 
Browser), or by examining the following value in the Windows
Registry key:

HKEY_LOCAL_MACHINE\Software\National Instruments\

NI-Servers

Value: Active CCDB

• Server software for all servers your application depends on for data.
You may have to register VI-based servers yourself.

• lookout.sec

For your application to work, you must put the files in the same directory
where you installed the LabVIEW Datalogging and Supervisory Control
Run-Time System. This directory will contain DSCRTS.EXE. You will not
need to run this executable if an executable was built for your particular
application.
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More Information and Updates
For information on LabVIEW Datalogging and Supervisory Control
module updates, point your browser to

http://www.ni.com/labviewdsc

To download the newest patches and other software updates, point your
browser to

http://digital.ni.com/softlib.nsf
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