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RELEASE NOTES

VALUEMOTION  SOFTWARE VERSION 4.3
ValueMotion Software 4.3 is the motion control software for interfacing
with all National Instruments ValueMotion series motion controllers. Th
ValueMotion software is compatible with Windows 2000/NT/98/95.

These release notes discuss compatibility issues, describe how to ins
your ValueMotion software and hardware, and summarize changes an
improvements associated with this version.

Compatibility Issues
ValueMotion Software 4.3 is backward compatible with ValueMotion 
Software 2.0. Existing programs will continue to work.

Upgrading ValueMotion Software under 
Windows 98 or Windows 2000

If you were using ValueMotion Software 2.0 under Windows 98 or 
Windows 2000, refer to the following sections for operating 
system-specific information.

Windows 98
The National Instruments motion control driver has been changed to u
the new Windows Driver Model (WDM) for improved Power Manageme
and Plug and Play support. If you have plug and play motion controlle
they will be automatically re-installed to use this new WDM driver. If yo
have non-plug and play (ISA bus) boards, you will have to re-install th
using the Windows 98 Add New Hardware Wizard. Be sure to reboot y
computer after installing the software and before adding any motion 
controllers.

Windows 2000
After installing the ValueMotion software, described in the Software 
Installation section of this document, remove all plug and play motion 
controllers using the Windows 2000 Device Manager. As earlier versio
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of the motion control drivers did not have plug and play capability under 
Windows 2000, motion controllers appear in the Device Manager under 
Other Devices as PCI Device. Right-click on PCI Device and select 
Uninstall. When you restart your computer, Windows 2000 will 
automatically re-install the motion controllers correctly.

If you have non-plug and play (ISA bus) boards, refer to the ISA 
Installation section of this document. You will have to re-install the ISA 
controllers using the Windows 2000 Add/Remove Hardware Wizard. 

Software Installation
You must install the ValueMotion software before installing a 
ValueMotion series motion controller for the first time. If you are 
upgrading from a previous version of the ValueMotion software, you do 
not need to remove your ValueMotion controller before installing the 
upgrade. Your existing configuration settings are not affected by the 
upgrade.

Complete the following steps to install your software:

1. If you have an earlier version of the ValueMotion software installed on 
your computer, remove it using the Add/Remove Programs feature in 
Windows. All of your configuration information for previously 
installed ValueMotion and FlexMotion controllers is preserved.

2. Insert the ValueMotion Software 4.3 CD into your CD-ROM drive.

3. Select Install ValueMotion Software 4.3.

4. Follow the installer prompts through the rest of the installation.

5. Refer to the ReadMe.txt file after the installation is complete for 
last-minute information.

The ValueMotion software is installed.

ValueMotion ServoTune
The ValueMotion ServoTune application for tuning servo motors is 
provided free of charge on your ValueMotion Software CD in the 
\Other\ServoTune directory. To install the ServoTune application, run 
setup.exe from the Disk1 subfolder. 

If you are also installing the ValueMotion VI Library 4.3, you do not need 
to install ServoTune. The tuning VIs are included on the ValueMotion 
LabVIEW functions palette.

The serial number for the ServoTune application, which you need during 
installation, is v43m43434.
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Hardware Installation
If this is the first time that you have installed the ValueMotion software on 
your computer, then complete the following steps to install your 
ValueMotion series motion controller.

Note Refer to Chapter 2, Configuration and Installation, of your motion controller 
hardware user manual if you need additional hardware installation and handling 
instructions.

PCI/PXI Installation
Complete the following steps to install your PCI/PXI motion controller:

1. Shut down your computer. 

2. Install the controller in an available slot in your computer.

3. Restart your computer.

4. Click on the Start button on your Windows 2000/NT/98/95 taskbar 
and select Programs»National Instruments Motion Control» 
Explore Motion Control to launch Measurement & Automation 
Explorer. Click on the Devices and Interfaces icon and select your 
installed ValueMotion controller. Measurement & Automation 
Explorer automatically assigns the first available Board ID to your 
controller.

5. Press F1 or select Help»Help Topics to view the online help for 
Measurement & Automation Explorer. The online help contains 
complete information on verifying your configuration and testing the 
installed ValueMotion controller.

Your PCI/PXI motion controller is successfully installed.

ISA Installation

Windows 2000/98/95
Complete the following steps to install your ISA controller:

1. Click on the Start button on your Windows 2000/98/95 taskbar and 
select Settings»Control Panel. 

2. Double-click on the Add/Remove Hardware (Windows 2000) or 
Add New Hardware (Windows 98/95) icon.

3. If you are installing your controller under Windows 98/95, go to step 5. 
If you are installing your controller under Windows 2000, select 
Add/Troubleshoot a Device and click on the Next button.

4. Select Add a New Device and click on the Next button.
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5. Click on the Next button and select No when prompted to search for 
new hardware, and then click on the Next button.

6. Select the National Instruments Motion Controllers hardware type 
and click on the Next button.

7. Select your ValueMotion board type and click on the Next button 
again.

8. After Windows assigns resources to the board, make a note of the 
Input/Output range. Then click on the Next button.

9. Click the Finish button to complete the Add New Hardware Wizard.

10. Refer to Chapter 3, Hardware Overview, of your ValueMotion 
Hardware User Manual for the proper DIP switch settings for the your 
controller to match the address assigned by Windows. 

11. Shut down your computer.

12. Install your controller in an available ISA slot.

13. Restart your computer.

14. Click on the Start button on your Windows 2000/98/95 taskbar and 
select Programs»National Instruments Motion Control»Explore 
Motion Control to launch Measurement & Automation Explorer.

15. Click on the Devices and Interfaces icon and select your installed 
motion controller. Measurement & Automation Explorer 
automatically assigns the first available Board ID to your controller.

16. Press F1 or select Help»Help Topics to view the online help for 
Measurement & Automation Explorer. The online help contains 
complete information on verifying your configuration and testing the 
installed ValueMotion controller.

Your motion controller is successfully installed.

Windows NT 4.0
Complete the following steps to install your ValueMotion controller:

1. Restart your computer after installing the ValueMotion software, but 
do not install your motion controller yet.

2. Click on the Start button on your Windows NT taskbar and select 
Programs»National Instruments Motion Control»Explore Motion 
Control to launch Measurement & Automation Explorer.

3. Right-click on Devices and Interfaces in Measurement & Automation 
Explorer and select Insert from the pop-up menu. Select National 
Instruments Motion Controllers from the Insert New dialog box to 
launch the Add New Motion Control Board Wizard.
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4. In the first dialog box of the Add New Motion Control Board Wizard, 
select your board and a board ID. Click Next to view the resources 
assigned to the board. To change the resource settings, select a resource 
and click Change Settings (these settings can be changed later using 
the Resources tab of the Properties dialog box). 

5. Make a note of the Input/Output range assigned to your controller.

6. Refer to Chapter 3, Hardware Overview, of your ValueMotion 
Hardware User Manual for the proper DIP switch settings for the your 
controller to match the address assigned by Windows. 

7. Shut down your computer.

8. Install the motion controller in an available ISA slot.

9. Restart your computer.

10. Click on the Start button on your Windows NT taskbar and select 
Programs»National Instruments Motion Control»Explore Motion 
Control to launch Measurement & Automation Explorer. 

11. Click on the Devices and Interfaces icon and select your installed 
ValueMotion controller. Measurement & Automation Explorer 
automatically assigns the first available Board ID to your controller.

12. Press F1 or select Help»Help Topics to view the online help for 
Measurement & Automation Explorer. The online help contains 
complete information on verifying your configuration and testing the 
installed ValueMotion controller.

Your motion controller is successfully installed.

Windows 3.1 and DOS Support
The previous release of ValueMotion Software (version 2.0) supports 
Windows 3.1 and DOS with the ISA bus ValueMotion controllers. 
ValueMotion Software 2.0 is located in the Other\Value20 directory on 
the ValueMotion Software 4.3 CD. Installing under Windows 3.1 also 
installs the DOS support in the Valmotn\DOS directory. To install 
ValueMotion 2.0 directly in DOS without Windows 3.1, run the batch file 
in the Other\DOSSetup directory on the ValueMotion Software 4.3 CD. 
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Summary of Changes
Version 4.3 of the ValueMotion software is a minor update to the 
version 2.0 software. Primarily, this update improves the configuration
process. Additionally, support for the new PCI-7324 and PCI-7314 
ValueMotion controllers has been added, the documentation has been
updated, and some minor bugs have been fixed.

Board configuration has been moved from the old Motion Board 
Configuration Utility to the new National Instruments Measurement & 
Automation Explorer, which you can access by selecting Start» 
Programs»National Instruments Motion Control»Explore Motion 
Control .

Using the Online Manuals
The ValueMotion documentation is shipped with your software as Ado
Acrobat portable document format (PDF) files. The software 
documentation is also installed as a Windows online help file.

Note If you do not already have Acrobat Reader version 3.0 or later installed on you
system, you can install it from the ValueMotion Software CD. Run the setup.exe  file 
found in the CD’s Other\Adobe Acrobat  directory. To view the installed PDF 
documents, click on the Start button on the Windows taskbar and select Programs» 
National Instruments Motion Control»ValueMotion  and then the document that you 
wish to view. This automatically launches the Acrobat Reader and opens the selecte
file. You can assemble your own printed manuals, printing either the entire document
set or only the sections relevant to your application.

Click on any entry in the table of contents to jump directly to the 
corresponding manual page. You can jump to major sections within ea
document quickly and easily by clicking on the bookmarks.

When you choose the View»Go To Page option or are printing pages, you
must use the page numbers in the lower left corner of the Acrobat wind
not the number displayed in the bottom center of each manual page or l
in the contents and index. Acrobat assigns consecutive numbers to ea
page throughout the document and displays the page number. The num
may not match those shown at the bottom center of each manual pag

You can use the Acrobat Reader to quickly find and go to every occurre
of any word or phrase in the entire document. Simply select the Tools»Find 
option and type the key word or phrase that you want to find.
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