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RELEASE NOTES

FLEXMOTION  SOFTWARE VERSION 4.5
FlexMotion Software 4.5 is the motion control software for interfacing 
with all National Instruments FlexMotion series motion controllers. The
FlexMotion controllers and their respective bus types are listed in Tab

The FlexMotion software is compatible with Windows 2000/NT/98/95.

These release notes discuss compatibility issues, describe how to ins
your FlexMotion software and hardware, and summarize changes and
improvements associated with this version.

Instructions are also provided for updating firmware on your FlexMotio
controller using National Instruments Measurement & Automation 
Explorer, as well as for using the new online documentation.

Compatibility Issues
FlexMotion Software 4.5 is backward compatible with FlexMotion 
Software 4.0. Existing programs will continue to work.

Note In order for FlexMotion Software 4.5 to work with your existing FlexMotion 
controller, you must update your motion controller firmware.

See the Updating Firmware section of this document for information on 
how to update your FlexMotion controller firmware.

Table 1.  FlexMotion Series Motion Controllers

Controller Bus Type

PCI-FlexMotion-6C PCI

PC-FlexMotion-6C ISA

PXI-7344 PXI/CompactPCI

PCI-7344 PCI

FW-7344* IEEE-1394 (FireWire)

*Windows 2000/98 only.

™

CVI ™, FlexCommander ™, FlexMotion ™, natinst.com  ™, National Instruments ™, and PXI ™ are trademarks of National Instruments 
Corporation. FireWire is a trademark of Apple Computer, Inc., other product and company names mentioned herein are trademarks or trade names 
of their respective companies.
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Upgrading FlexMotion Software under 
Windows 98 or Windows 2000

If you were using FlexMotion Software 4.0 under Windows 98 or 
Windows 2000, refer to the following sections for operating 
system-specific information.

Windows 98
The National Instruments motion control driver has been changed to u
the new Windows Driver Model (WDM) for improved Power Manageme
and Plug and Play support. If you have plug and play motion controlle
they will be automatically re-installed to use this new WDM driver. If yo
have non-plug and play (ISA bus) boards, you will have to re-install th
using the Windows 98 Add New Hardware Wizard. Be sure to reboot y
computer after installing the software and before adding any motion 
controllers.

Windows 2000
After installing the FlexMotion software, described in the Software 
Installation section of this document, remove all plug and play motion 
controllers using the Windows 2000 Device Manager. As earlier versio
of the motion control drivers did not have plug and play capability und
Windows 2000, motion controllers appear in the Device Manager unde
Other Devices as PCI Device. Right-click on PCI Device and select 
Uninstall. When you restart your computer Windows 2000 will 
automatically re-install the motion controllers correctly.

If you have non-plug and play (ISA bus) boards, refer to the ISA 
Installation (PC-FlexMotion-6C Only) section of this document. You will 
have to re-install the ISA controllers using the Windows 2000 Add/Remo
Hardware Wizard.

Software Installation
You must install the FlexMotion software before installing a FlexMotio
series motion controller for the first time. If you are upgrading from a 
previous version of the FlexMotion software, you do not need to remo
your FlexMotion controller before installing the upgrade. Your existing
configuration settings are not affected by the upgrade.
FlexMotion Software Version 4.5 2 www.natinst.com
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Complete the following steps to install your software:

1. If you have an earlier version of the FlexMotion software installed 
your computer, remove it using the Add/Remove Programs feature
Windows. All of your configuration information for previously 
installed ValueMotion and FlexMotion controllers is preserved.

2. Insert the FlexMotion Software 4.5 CD into your CD-ROM drive.

3. Select Install FlexMotion Software 4.5.

4. Follow the installer prompts through the rest of the installation.

5. Refer to the ReadMe.txt  file after the installation is complete for 
last-minute information.

The FlexMotion software is installed.

FlexMotion ServoTune
The FlexMotion ServoTune application for tuning servo motors is 
provided free of charge on your FlexMotion Software CD in the 
\Other\ServoTune  directory. To install the ServoTune application, 
run setup.exe  from the Disk1  subfolder. 

If you are also installing the FlexMotion VI Library 4.5, you do not need
install ServoTune. The tuning VIs are included on the FlexMotion 
LabVIEW function palette.

The serial number for the ServoTune application, which you need duri
installation, is f45m45454 .

Hardware Installation
If this is the first time that you have installed the FlexMotion software o
your computer, then complete the following steps to install your 
FlexMotion series motion controller.

Note Refer to Chapter 2, Configuration and Installation, of your motion controller 
hardware user manual for additional hardware installation and handling instructions.

PCI/PXI/FW Installation
Complete the following steps to install your PCI/PXI/FW motion 
controller:

1. Shut down your computer. 

2. If you are installing a PCI or PXI controller, install the controller in a
available slot in your computer. If you are installing the FW-7344, 
connect the controller to your computer’s IEEE-1394 port.
© National Instruments Corporation 3 FlexMotion Software Version 4.5
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3. Restart your computer.

4. Click on the Start button on your Windows 2000/NT/98/95 taskbar 
and select Programs»National Instruments Motion Control» 
Explore Motion Control  to launch Measurement & Automation 
Explorer. Click on the Devices and Interfaces icon and select your 
installed FlexMotion controller. Measurement & Automation Explore
automatically assigns the first available Board ID to your controlle

5. Press F1 or select Help»Help Topics to view the online help for 
Measurement & Automation Explorer. The online help contains 
complete information on verifying your configuration, testing the 
installed FlexMotion controller, and downloading new firmware.

Your PCI/PXI/FW motion controller is successfully installed.

ISA Installation (PC-FlexMotion-6C Only)

Windows 2000/98/95
Complete the following steps to install your PC-FlexMotion-6C controll

1. Click on the Start button on your Windows 2000/98/95 taskbar and
select Settings»Control Panel. 

2. Double-click on the Add/Remove Hardware (Windows 2000) or 
Add New Hardware (Windows 98/95) icon.

3. If you are installing your controller under Windows 98/95, go to step
If you are installing your controller under Windows 2000, select 
Add/Troubleshoot a Device and click on the Next button.

4. Select Add a New Device and click on the Next button.

5. Click on the Next button and select No when prompted to search for 
new hardware, and then click on the Next button.

6. Select the National Instruments Motion Controllers  hardware type 
and click on the Next button.

7. Select the PC-FlexMotion-6C board type and click on the Next button 
again.

8. After Windows assigns resources to the board, make a note of the
Input/Output range. Then click on the Next button.

9. Click the Finish button to complete the Add New Hardware Wizard

10. Refer to Chapter 3, Hardware Overview, of the FlexMotion-6C 
Hardware User Manual for the proper DIP switch settings for the 
PC-FlexMotion-6C controller to match the address assigned by 
Windows. 

Note There is no jumper to set for the interrupt number.
FlexMotion Software Version 4.5 4 www.natinst.com
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11. Shut down your computer.

12. Install the PC-FlexMotion-6C controller in an available ISA slot.

13. Restart your computer.

14. Click on the Start button on your Windows 2000/98/95 taskbar and
select Programs»National Instruments Motion Control»Explore 
Motion Control  to launch Measurement & Automation Explorer.

15. Click on the Devices and Interfaces icon and select your installed 
PC-FlexMotion-6C controller. Measurement & Automation Explore
automatically assigns the first available Board ID to your controlle

16. Press F1 or select Help»Help Topics to view the online help for 
Measurement & Automation Explorer. The online help contains 
complete information on verifying your configuration, testing the 
installed FlexMotion controller, and downloading new firmware.

Your PC-FlexMotion-6C motion controller is successfully installed.

Windows NT 4.0
Complete the following steps to install your PC-FlexMotion-6C controll

1. Restart your computer after installing the FlexMotion software, but
not install your PC-FlexMotion-6C controller yet.

2. Click on the Start button on your Windows NT taskbar and select 
Programs»National Instruments Motion Control»Explore Motion 
Control  to launch Measurement & Automation Explorer.

3. Right-click on Devices and Interfaces in Measurement & Automation 
Explorer and select Insert from the pop-up menu. Select National 
Instruments Motion Controllers  from the Insert New dialog box to 
launch the Add New Motion Control Board Wizard.

4. In the first dialog box of the Add New Motion Control Board Wizard
select your board and a board ID. Click Next to view the resources 
assigned to the board. To change the resource settings, select a res
and click Change Settings (these settings can be changed later usin
the Resources tab of the Properties dialog box). 

5. Make a note of the Input/Output range assigned to your controller

6. Refer to Chapter 3, Hardware Overview, of the FlexMotion-6C 
Hardware User Manual for the proper DIP switch settings for the 
PC-FlexMotion-6C controller to match the address assigned by 
Windows. 

Note There is no jumper to set for the interrupt number.

7. Shut down your computer.

8. Install the PC-FlexMotion-6C controller in an available ISA slot.
© National Instruments Corporation 5 FlexMotion Software Version 4.5
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9. Restart your computer.

10. Click on the Start button on your Windows NT taskbar and select 
Programs»National Instruments Motion Control»Explore Motion 
Control  to launch Measurement & Automation Explorer. 

11. Click on theDevices and Interfaces icon and select your installed 
PC-FlexMotion-6C controller. Measurement & Automation Explore
automatically assigns the first available Board ID to your controlle

12. Press F1 or select Help»Help Topics to view the online help for 
Measurement & Automation Explorer. The online help contains 
complete information on verifying your configuration, testing the 
installed FlexMotion controller, and downloading new firmware.

Your PC-FlexMotion-6C motion controller is successfully installed.

Updating Firmware
Before using your FlexMotion series motion controller, you need to ver
that your controller is using the latest revision of each of its firmware 
components.

FlexMotion firmware files have the following extensions:

• The 68331 firmware files have a .cpu  extension.

• The DSP firmware files have a .rbf  extension.

• The FPGA1 firmware files have a .fp1  extension.

• The FPGA2 firmware files have a .fp2  extension.

The firmware files for the FlexMotion-6C and 7344 are different, even 
though they have the same extensions. All FlexMotion-6C firmware file
start with “flex.” All 7344 files start with “7344.” 

Caution In the case of the FlexMotion-6C controllers, downloading new FPGA1 firmw
resets any parameters that you saved with the Save Default Parameters function to 
default values. If you saved default values onboard, make a note of these values for
firmware updating purposes.

You can check these revisions and perform required updates using 
Measurement & Automation Explorer as follows:

1. Click on the Start button on your Windows 2000/NT/98/95 taskbar 
and select Programs»National Instruments Motion Control» 
Explore Motion Control  to launch Measurement & Automation 
Explorer.

2. Click on the plus sign next to Devices and Interfaces.
FlexMotion Software Version 4.5 6 www.natinst.com
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3. Right-click on your FlexMotion controller and select Update 
Firmware . You can compare the dates of the firmware sectors in t
left pane, which are the firmware versions loaded on your controller
the dates in the right pane, which are the current firmware revision

4. Right-click on the firmware sector that you want to update in the le
pane of the download dialog box and select Update Firmware Sector. 
The firmware file corresponding to the sector in the right pane is th
downloaded to the FlexMotion controller. If all the firmware sectors
are out of date, right-click on the controller name in the left pane a
select Update All Firmware Sectors. All the sectors on the controller
are then updated with the firmware files in the right pane.

Note Once the FLASH memory on your FlexMotion controller is updated with the lat
firmware, the controller automatically uses the upgraded firmware each time you po
it up.

Windows 3.1 and DOS Support
The previous release of FlexMotion Software (version 4.0) supports 
Windows 3.1 and DOS with the PC-FlexMotion-6C controller. FlexMotio
Software 4.0 is located in the Other\Flex40  directory on the FlexMotion 
Software 4.5 CD. Installing under Windows 3.1 also installs the DOS 
support in the Flexmotn\DOS  directory. To install FlexMotion 4.0 directly 
in DOS without Windows 3.1, run the batch file in the Other\DOSSetup  
directory on the FlexMotion Software 4.5 CD. 

Note To use FlexMotion 4.0 software with a PC-FlexMotion-6C, you should downloa
the 4.0 firmware files to the controller. If you recently purchased a PC-FlexMotion-6C
controller, it may contain version 4.5 firmware. You will need to download the 4.0 
firmware using the FlexCommander application that came with FlexMotion Software
in Windows 3.1 or Windows NT/98/95. Refer to the Upgrade Your Firmware topic in the 
FlexMotion Software 4.0 Online Help for information on downloading your firmware 
using FlexCommander.
© National Instruments Corporation 7 FlexMotion Software Version 4.5
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Summary of Changes and Improvements
There are several changes and improvements to the FlexMotion softw
that make it easier to use and expand its functionality. However, code 
you have created and validated in the past still operates with the new 
software. What follows is a broad description of changes in version 4.5

Board configuration has been moved from the old Motion Board 
Configuration Utility to the new National Instruments Measurement & 
Automation Explorer, which you can access by selecting Start» 
Programs»National Instruments Motion Control» Explore Motion 
Control .

Firmware updating has also been moved from FlexCommander to 
Measurement & Automation Explorer. This change is explained in detai
the Updating Firmware section of this document.

New Functions

The functions in Table 2 are new in FlexMotion Software Version 4.5.

Table 2.  New FlexMotion Functions

New Function Description

Configure PWM Output Enables and disables PWM outputs and sets the PWM cloc
frequency.

Load PWM Duty Cycle Sets the duty cycle for a PWM output.

Set ADC Range Sets the voltage range for the analog to digital converters o
a per-channel basis. This function is only supported by 
7344 motion controllers.

Load Counts/Steps per RevolutionLoads the quadrature counts or steps per revolution 
for an axis. This function can accept values up to 
268,435,455 counts or steps per revolution.

Select Signal Specifies the source and destination of various motion 
signals, including high-speed capture inputs, breakpoint 
outputs, RTSI lines, and RTSI software ports. This function is
only supported by 7344 motion controllers.

Set Encoder Frequency Selects the maximum count frequency for an encoder chann
by configuring its digital filter. This function is only 
supported by 7344 motion controllers.

Read Program Status Reads the status of an onboard program. 

Enable Gearing Single Axis Enables a slave axis for master-slave gearing.
FlexMotion Software Version 4.5 8 www.natinst.com
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Check Move Complete Status Checks the move complete status for an axis, vector space
group of axes, or group of vector spaces.

Check Blend Complete Status Checks the blend complete status for an axis, vector space
group of axes, or group of vector spaces,

Wait for Move Complete Waits up to the specified period of time for a move to be 
completed on an axis, vector space, group of axes, or grou
of vector spaces.

Wait for Blend Complete Waits up to the specified period of time for a blend to be 
completed on an axis, vector space, group of axes, or grou
of vector spaces

Reset Default Parameters Resets the power-up defaults to the factory default settings

Enable Auto Start Allows you to automatically run a program when the 
controller powers up.

Enable Shutdown Enables the shutdown functionality of the controller.

Load Base Velocity Sets the base velocity used by the trajectory control circuitr
for the axis specified.

Enable 1394 Watchdog Enables or disables the watchdog timer on the 
1394 motherboard. This function is only supported by 
FW-7344 motion controllers.

Table 2.  New FlexMotion Functions (Continued)

New Function Description
© National Instruments Corporation 9 FlexMotion Software Version 4.5
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Using the Online Manuals
The FlexMotion documentation is shipped with your software as Adob
Acrobat portable document format (PDF) files. The software 
documentation is also installed as a Windows online help file.

Note If you do not already have Acrobat Reader version 3.0 or later installed on you
system, you can install it from the FlexMotion Software CD. Run the setup.exe  file 
found in the CD’s Other\Adobe Acrobat  directory. To view the installed PDF 
documents, click on the Start button on the Windows taskbar and select Programs» 
National Instruments Motion Control»FlexMotion and then the document that you 
wish to view. This automatically launches the Acrobat Reader and opens the selecte
file. You can assemble your own printed manuals, printing either the entire document
set or only the sections relevant to your application.

Click on any entry in the table of contents to jump directly to the 
corresponding manual page. You can jump to major sections within ea
document quickly and easily by clicking on the bookmarks.

When you choose the View»Go To Page option or are printing pages, you
must use the page numbers in the lower left corner of the Acrobat wind
not the number displayed in the bottom center of each manual page or l
in the contents and index. Acrobat assigns consecutive numbers to ea
page throughout the document and displays the page number. The num
may not match those shown at the bottom center of each manual pag

You can use the Acrobat Reader to quickly find and go to every occurre
of any word or phrase in the entire document. Simply select the Tools»Find 
option and type the key word or phrase that you want to find.
FlexMotion Software Version 4.5 10 www.natinst.com
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