Getting Started with LabVIEW
Virtual Instruments

LabVIEW programs are called virtual instruments, or VIs, because their appearance and operation imitate physical instruments, such as oscilloscopes and multimeters. LabVIEW contains a comprehensive set of tools for acquiring, analyzing, displaying, and storing data, as well as tools to help you troubleshoot code you write.

In LabVIEW, you build a user interface, or front panel, with controls and indicators. Controls are knobs, push buttons, dials, and other input mechanisms. Indicators are graphs, LEDs, and other output displays. After you build the user interface, you add code using VIs and structures to control the front panel objects. The block diagram contains this code.

You can use LabVIEW to communicate with hardware such as data acquisition, vision, and motion control devices, as well as GPIB, PXI, VXI, RS232, and RS485 instruments.

Building a Virtual Instrument

In the following exercises, you will build a VI that generates a signal and displays that signal in a graph. After you complete the exercises, the front panel of the VI will look similar to the front panel in Figure 1-1.

⚠️ You can complete the exercises in this chapter in approximately 40 minutes.
Launching LabVIEW

The **Getting Started** window, shown in Figure 1-2, appears when you launch LabVIEW. Use this window to create new VIs, select among the most recently opened LabVIEW files, find examples, and launch the *LabVIEW Help*. You also can access information and resources to help you learn about LabVIEW, such as specific manuals, help topics, and resources on the National Instruments Web site, [ni.com](http://ni.com).
Opening a New VI from a Template

LabVIEW provides built-in template VIs that include the subVIs, functions, structures, and front panel objects you need to get started building common measurement applications.

Complete the following steps to create a VI that generates a signal and displays it on the front panel.

1. Launch LabVIEW.
2. In the Getting Started window, click the New or VI from Template link to display the New dialog box.

3. From the Create New list, select VI>From Template>Tutorial (Getting Started)>Generate and Display. This template VI generates and displays a signal.

A preview and a brief description of the template VI appear in the Description section. Figure 1-3 shows the New dialog box and the preview of the Generate and Display template VI.

4. Click the OK button to create a VI from the template. You also can double-click the name of the template VI in the Create New list to create a VI from a template.
5. Examine the front panel of the VI.
   The user interface, or front panel, appears with a gray background and includes controls and indicators. The title bar of the front panel indicates that this window is the front panel for the Generate and Display VI.

   **Note** If the front panel is not visible, you can display the front panel by selecting **Window»Show Front Panel**. You also can switch between the front panel window and block diagram window at any time by pressing the <Ctrl-E> keys. The <Ctrl> key in keyboard shortcuts corresponds to the (Mac OS) <Option> or <Command> key or (Linux) <Alt> key.

6. Select **Window»Show Block Diagram** and examine the block diagram of the VI.
   The block diagram appears with a white background and includes VIs and structures that control the front panel objects. The title bar of the block diagram indicates that this window is the block diagram for the Generate and Display VI.

7. On the front panel toolbar, click the **Run** button, shown at left. You also can press the <Ctrl-R> keys to run a VI.
   A sine wave appears on the graph on the front panel.

8. Stop the VI by clicking the **STOP** button, shown at left, on the front panel.

### Adding a Control to the Front Panel

Controls on the front panel simulate the input mechanisms on a physical instrument and supply data to the block diagram of the VI. Many physical instruments have knobs you can turn to change an input value.

Complete the following steps to add a knob control to the front panel.

**Tip** Throughout these exercises, you can undo recent edits by selecting **Edit»Undo** or pressing the <Ctrl-Z> keys.

1. If the **Controls** palette, shown in Figure 1-4, is not visible on the front panel, select **View»Controls Palette**.

   **Tip** You can right-click any blank space on the front panel or the block diagram to display a temporary version of the **Controls** or **Functions** palettes. The **Controls** or **Functions** palette appears with a thumbtack icon in the upper left corner. Click the thumbtack to pin the palette so it is no longer temporary.
2. If you are a new LabVIEW user, the Controls palette opens with the Express subpalette visible by default. If you do not see the Express subpalette, click Express on the Controls palette to display the Express subpalette.

![Controls Palette](image)

**Figure 1-4. Controls Palette**

3. Move the cursor over the icons on the Express subpalette to locate the Numeric Controls palette.

When you move the cursor over icons on the Controls palette, the name of the subpalette, control, or indicator appears in a tip strip below the icon.

4. Click the Numeric Controls icon to display the Numeric Controls palette.

5. Click the knob control on the Numeric Controls palette to attach the control to the cursor, then place the knob on the front panel to the left of the waveform graph.

You will use this knob in a later exercise to control the amplitude of a signal.

6. Select File > Save As and save the VI as Acquiring a Signal.vi in an easily accessible location.
Changing a Signal Type

The block diagram has a blue icon labeled Simulate Signal. This icon represents the Simulate Signal Express VI. The Simulate Signal Express VI simulates a sine wave by default.

Complete the following steps to change this signal to a sawtooth wave.

1. Display the block diagram by pressing the <Ctrl-E> keys or by clicking the block diagram.

   Locate the Simulate Signal Express VI, shown at left. An Express VI is a component of the block diagram that you can configure to perform common measurement tasks. The Simulate Signal Express VI simulates a signal based on the configuration that you specify.

2. Right-click the Simulate Signal Express VI and select Properties from the shortcut menu to display the Configure Simulate Signal dialog box. (Mac OS) Press <Command>-click to perform the same action as right-click.

   You also can double-click the Express VI to display the Configure Simulate Signal dialog box. If you wire data to an Express VI and run it, the Express VI displays real data in the configuration dialog box. If you close and reopen the Express VI, the VI displays sample data in the configuration dialog box until you run the VI again.

3. Select Sawtooth from the Signal type pull-down menu.

   The waveform on the graph in the Result Preview section changes to a sawtooth wave. The Configure Simulate Signal dialog box should appear similar to Figure 1-5.
4. Click the OK button to save the current configuration and close the Configure Simulate Signal dialog box.

5. Move the cursor over the down arrows at the bottom of the Simulate Signal Express VI. The down arrows indicate you can reveal hidden inputs and outputs by extending the border of the Express VI.

6. When a double-headed arrow appears, shown at left, click and drag the border of the Express VI to add two rows. When you release the border, the Amplitude input appears. Because the Amplitude input appears on the block diagram, you can configure the amplitude of the sawtooth wave on the block diagram. In Figure 1-5, notice that Amplitude is an option in the Configure Simulate Signal dialog box. When inputs, such as Amplitude, appear on the block diagram and in the configuration dialog box, you can configure the inputs in either location.
Wiring Objects on the Block Diagram

To use the knob to change the amplitude of the signal, you must connect two objects on the block diagram.

Complete the following steps to wire the knob to the Amplitude input of the Simulate Signal Express VI.

1. On the block diagram, move the cursor over the Knob terminal, shown at left.
   The cursor becomes an arrow, or the Positioning tool, shown at left. Use the Positioning tool to select, position, and resize objects.

2. Use the Positioning tool to select the Knob terminal and make sure it is to the left of the Simulate Signal Express VI and inside the gray loop, shown at left.
   The terminals inside the loop are representations of front panel controls and indicators. Terminals are entry and exit ports that exchange information between the front panel and block diagram.

3. Deselect the Knob terminal by clicking a blank space on the block diagram. If you want to use a different tool with an object, you must deselect the object to switch the tool.

4. Move the cursor over the arrow on the Knob terminal, shown at left.
   The cursor becomes a wire spool, or the Wiring tool, shown at left. Use the Wiring tool to wire objects together on the block diagram.

5. When the Wiring tool appears, click the arrow on the Knob terminal and then click the arrow on the Amplitude input of the Simulate Signal Express VI, shown at left, to wire the two objects together.
   A wire appears and connects the two objects. Data flows along this wire from the Knob terminal to the Express VI.

6. Select File→Save to save the VI.
Running a VI

Running a VI executes the solution.

Complete the following steps to run the Acquiring a Signal VI.

1. Display the front panel by pressing the <Ctrl-E> keys or by clicking the front panel.
2. Click the Run button or press the <Ctrl-R> keys to run the VI.
3. Move the cursor over the knob.
   The cursor becomes a hand, or the Operating tool, shown at left. Use the Operating tool to change the value of a control.
4. Using the Operating tool, turn the knob to adjust the amplitude of the sawtooth wave.
   The amplitude of the sawtooth wave changes as you turn the knob. As you change the amplitude, the Operating tool displays a tip strip that indicates the numeric value of the knob. The y-axis on the graph scales automatically to account for the change in amplitude.
   To indicate that the VI is running, the Run button changes to a darkened arrow, shown at left. You can change the value of most controls while a VI runs, but you cannot edit the VI in other ways while the VI runs.
5. Click the STOP button, shown at left, to stop the VI.
   The STOP button stops the VI after the VI completes the current iteration. The Abort Execution button, shown at left, stops the VI immediately, before the VI finishes the current iteration. Aborting a VI that uses external resources, such as external hardware, might leave the resources in an unknown state by not resetting or releasing them properly. Design the VIs you create with a stop button to avoid this problem.
Modifying a Signal

Complete the following steps to scale the signal by 10 and display the results in the graph on the front panel.

1. On the block diagram, use the Positioning tool to double-click the wire that connects the Simulate Signal Express VI to the Waveform Graph terminal, shown at left.
2. Press the <Delete> key to delete this wire.
3. If the Functions palette, shown in Figure 1-6, is not visible, select View » Functions Palette to display it. The Functions palette opens with the Express subpalette visible by default. If you have selected another subpalette, you can return to the Express subpalette by clicking Express on the Functions palette.

4. On the Arithmetic & Comparison palette, select the Formula Express VI, shown at left, and place it on the block diagram inside the loop between the Simulate Signal Express VI and the Waveform Graph terminal. You can move the Waveform Graph terminal to the right to make more room between the Express VI and the terminal.

   The Configure Formula dialog box appears when you place the Express VI on the block diagram. When you place an Express VI on the block diagram, the configuration dialog box for that VI always appears automatically.

5. Click the Help button, shown at left, in the bottom right corner of the Configure Formula dialog box to display the LabVIEW Help topic for this Express VI.

   The Formula help topic describes the Express VI, the configuration dialog box options, and the inputs and outputs of the Express VI. Each Express VI has a corresponding help topic you can access by clicking...
the Help button in the configuration dialog box or by right-clicking the
Express VI and selecting Help from the shortcut menu.

6. In the Formula topic, find the dialog box option whose description
indicates that it enters a variable into the formula.

7. Minimize the LabVIEW Help to return to the Configure Formula
dialog box.

8. Change the text in the Label text box of the dialog box option you read
about from X1 to Sawtooth to indicate the input value to the Formula
Express VI. When you click in the String text box at the top of the
Configure Formula dialog box, the text changes to match the label
you entered.

9. Define the value of the scaling factor by entering *10 after Sawtooth
in the String text box.

You can use the Input buttons in the configuration dialog box or you
can use the *, 1, and 0 keyboard buttons to enter the scaling factor. If
you use the Input buttons in the configuration dialog box, LabVIEW
places the formula input after the Sawtooth input in the String text
box. If you use the keyboard, click in the String text box after
Sawtooth and enter the formula you want to appear in the text box.
The **Configure Formula** dialog box should appear similar to Figure 1-7.

![Configure Formula Dialog Box](image)

**Figure 1-7.** Configure Formula Dialog Box

*Note* If you enter a formula in the **String** text box that is not valid, the **Errors** LED, in the upper right corner turns gray and displays the text **Invalid Formula**.

10. Click the **OK** button to save the current configuration and close the **Configure Formula** dialog box.

11. Move the cursor over the arrow on the **Sawtooth** output of the Simulate Signal Express VI.

12. When the Wiring tool appears, click the arrow on the **Sawtooth** output and then click the arrow on the **Sawtooth** input of the Formula Express VI, shown at left, to wire the two objects together.

13. Use the Wiring tool to wire the **Result** output of the Formula Express VI to the **Waveform Graph** terminal.
Examine the wires connecting the Express VIs and terminals. The arrows on the Express VIs and terminals indicate the direction that the data flows along these wires. The block diagram should appear similar to Figure 1-8.

**Tip** You can right-click any wire and select **Clean Up Wire** from the shortcut menu to have LabVIEW automatically find a route for the wire around existing objects on the block diagram. LabVIEW also routes a wire to decrease the number of bends in the wire.

Figure 1-8. Block Diagram of the Acquiring a Signal VI

14. Press the <Ctrl-S> keys or select **File** » **Save** to save the VI.

**Displaying Two Signals on a Graph**

To compare the signal generated by the Simulate Signal Express VI and the signal modified by the Formula Express VI on the same graph, use the Merge Signals function.

Complete the following steps to display two signals on the same graph.

1. On the block diagram, move the cursor over the arrow on the **Sawtooth** output of the Simulate Signal Express VI.

2. Use the Wiring tool to wire the **Sawtooth** output to the **Waveform Graph** terminal.

The Merge Signals function, shown at left, appears where the two wires connect. A function is a built-in execution element, comparable to an operator, function, or statement in a text-based programming language. The Merge Signals function takes the two separate signals and combines them so that both can display on the same graph.
The block diagram should appear similar to Figure 1-9.

Figure 1-9. Block Diagram Showing the Merge Signals Function

3. Press the <Ctrl-S> keys or select File→Save to save the VI.
4. Return to the front panel, run the VI, and turn the knob control.
   The graph plots the sawtooth wave and the scaled signal. The maximum value on the y-axis automatically changes to be 10 times the knob value. This scaling occurs because you configured the Formula Express VI to generate a slope of 10.
5. Click the STOP button to stop the VI.

Customizing a Knob Control

The knob control changes the amplitude of the sawtooth wave, so labeling it Amplitude accurately describes the behavior of the knob.

Complete the following steps to customize the appearance of the knob.
1. On the front panel, right-click the knob and select Properties from the shortcut menu to display the Knob Properties dialog box.
2. In the Label section on the Appearance page, delete the label Knob and enter Amplitude in the text box.
3. Click the **Scale** tab and in the **Scale Style** section, place a checkmark in the **Show color ramp** checkbox.

   The knob on the front panel updates to reflect these changes.

4. Click the **OK** button to save the current configuration and close the **Knob Properties** dialog box.

5. Save the VI.

6. Reopen the **Knob Properties** dialog box and experiment with other properties of the knob. For example, on the **Scale** page, try changing the colors for the **Marker text color** by clicking the color box.

7. Click the **Cancel** button to avoid applying any changes you made while experimenting. If you want to keep the changes you made, click the **OK** button.

The **Knob Properties** dialog box should appear similar to Figure 1-10.

![Knob Properties Dialog Box](image-url)
Customizing a Waveform Graph

The waveform graph indicator displays the two signals. To indicate which plot is the scaled signal and which is the simulated signal, you can customize the plots.

Complete the following steps to customize the appearance of the waveform graph indicator.
1. On the front panel, move the cursor over the top of the plot legend on the waveform graph.
   Though the graph has two plots, the plot legend displays only one plot.
2. When a double-headed arrow appears, shown in Figure 1-11, click and drag the border of the plot legend to add one item to the legend. When you release the mouse button, the second plot name appears.

3. Right-click the waveform graph and select Properties from the shortcut menu to display the Waveform Graph Properties dialog box.
4. On the Plots page, select Sawtooth from the pull-down menu. In the Colors section, click the Line color box to display the color picker. Select a new line color.
5. Select Sawtooth (Formula Result) from the pull-down menu.
6. Place a checkmark in the Do not use waveform names for plot names checkbox.
7. In the Name text box, delete the current label and change the name of this plot to Scaled Sawtooth.
8. Click the OK button to save the current configuration and close the Waveform Graph Properties dialog box. The plot color on the front panel changes.

9. Reopen the Waveform Graph Properties dialog box and experiment with other properties of the graph. For example, on the Scales page, try disabling automatic scaling and changing the minimum and maximum value of the y-axis.

10. Click the Cancel button to avoid applying any changes you made while experimenting. If you want to keep the changes you made, click the OK button.

11. Save and close the VI.

Summary

The following topics are a summary of the main concepts you learned in this chapter.

New Dialog Box and Template VIs

The New dialog box contains many template VIs, including the ones used in this manual. The template VIs help you start building VIs for common measurements and other tasks. The template VIs include the Express VIs, functions, and front panel objects you need to get started building common measurement applications.

Use one of the following methods to access the New dialog box:

• Click the New, VI from Template, or More links in the Getting Started window after you start LabVIEW.
• Select File»New from the menu bar of the Getting Started window, the front panel, or the block diagram.

Front Panel

The front panel is the user interface of a VI. You build the front panel by using controls and indicators, which are the interactive input and output terminals of the VI, respectively. Controls and indicators are located on the Controls palette.

Controls are knobs, push buttons, dials, and other input mechanisms. Controls simulate instrument input mechanisms and supply data to the block diagram of the VI.
Indicators are graphs, LEDs, and other displays. Indicators simulate instrument output mechanisms and display data the block diagram acquires or generates.

**Block Diagram**

The block diagram contains the graphical source code, also known as G code or block diagram code, for how the VI runs. The block diagram code uses graphical representations of functions to control the front panel objects. Front panel objects appear as icon terminals on the block diagram. Wires connect control and indicator terminals to Express VIs, VIs, and functions. Data flows through the wires from controls to VIs and functions, from VIs and functions to other VIs and functions, and from VIs and functions to indicators. The movement of data through the nodes on the block diagram determines the execution order of the VIs and functions. This movement of data is known as dataflow programming.

**Front Panel and Block Diagram Tools**

The Positioning tool appears when you move the cursor over an object in the front panel window or on the block diagram. The cursor becomes an arrow that you can use to select, position, and resize objects. The Wiring tool appears when you move the cursor over a terminal of a block diagram object. The cursor becomes a spool that you can use to connect objects on the block diagram through which you want data to flow.

**Running and Stopping a VI**

Running a VI executes the solution of the VI. Click the Run button or press the <Ctrl-R> keys to run a VI. The Run button changes to a darkened arrow to indicate the VI is running. You can stop a VI immediately by clicking the Abort Execution button. However, aborting a VI that uses external resources might leave the resources in an unknown state. Design the VIs you create with a stop button to avoid this problem. A stop button stops a VI after the VI completes its current iteration.

**Express VIs**

Use Express VIs located on the Functions palette for common measurement tasks. When you place an Express VI on the block diagram, the dialog box you use to configure that Express VI appears by default. Set the options in this configuration dialog box to specify how the Express VI behaves. You also can double-click an Express VI or right-click an Express VI and select Properties from the shortcut menu to display the configuration dialog box. If you wire data to an Express VI and run it, the
Express VI displays real data in the configuration dialog box. If you close and reopen the Express VI, the VI displays sample data in the configuration dialog box until you run the VI again.

Express VIs appear on the block diagram as expandable nodes with icons surrounded by a blue field. You can resize an Express VI to display its inputs and outputs. The inputs and outputs you can display for the Express VI depend on how you configure the VI.

**LabVIEW Documentation Resources**

The *LabVIEW Help* contains information about LabVIEW programming concepts, step-by-step instructions for using LabVIEW, and reference information about LabVIEW VIs, functions, palettes, menus, tools, properties, methods, events, dialog boxes, and so on. The *LabVIEW Help* also lists the LabVIEW documentation resources available from National Instruments. To access help information for Express VIs, click the Help button in the configuration dialog box while you configure an Express VI. You also can access the *LabVIEW Help* by right-clicking a VI or function on the block diagram or on a pinned palette and selecting Help from the shortcut menu or by selecting Help>Search the LabVIEW Help.

After you install a LabVIEW add-on such as a toolkit, module, or driver, the documentation for that add-on appears in the *LabVIEW Help* or appears in a separate help system you access by selecting Help>Add-On Help, where Add-On Help is the name of the separate help system for the add-on.

**Property Dialog Boxes**

Use property dialog boxes or shortcut menus to configure how controls and indicators appear or behave on the front panel. Right-click a control or indicator on the front panel and select Properties from the shortcut menu to access the property dialog box for that object. You cannot access property dialog boxes for a control or indicator when a VI is running.

**Shortcuts**

This chapter introduced the following keyboard shortcuts.

*Note* The <Ctrl> key in these shortcuts corresponds to the (Mac OS) <Option> or <Command> key or (Linux) <Alt> key.
<table>
<thead>
<tr>
<th>Shortcut</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;Ctrl-R&gt;</td>
<td>Runs a VI.</td>
</tr>
<tr>
<td>&lt;Ctrl-Z&gt;</td>
<td>Undoes the last action.</td>
</tr>
<tr>
<td>&lt;Ctrl-E&gt;</td>
<td>Switches between the block diagram and the front panel window.</td>
</tr>
<tr>
<td>&lt;Ctrl-S&gt;</td>
<td>Saves a VI.</td>
</tr>
</tbody>
</table>