NI-XNET 1.6 - PharLap, VxWorks, Windows 7/Vista/XP 32-bit 1 Ratings | 4.00 out of 5 |   Print

Available Downloads:

Download Options:

  1. Standard Download:NIXNET160.exe (540.36 MB).

    Checksum (MD5): 815a8edeb851c000604ea9ba8191e649

    Using the Standard Download:
    • downloads directly to your PC
    • can be a less stable experience for downloading files should the download be unintentionally interrupted due to dropped connectivity
    • does not provide ability to "pause and resume"
Updates and Notifications:
Critical Updates and Security Notifications are posted on ni.com. Before downloading, click here to review this information.
Supporting Files:

Download Language: English; German; Japanese

Product Line: CAN

Version: 1.6

Release date: 08-21-2012

Software type: Driver

Operating system: PharLap; VxWorks; Windows 7; Windows Vista; Windows XP 32-bit

Supported hardware:

  • NI 9861
  • NI 9862
  • NI 9866
  • NI PCI-8511 CAN/LS1
  • NI PCI-8511 CAN/LS2
  • NI PCI-8512 CAN/HS1
  • NI PCI-8512 CAN/HS2
  • NI PCI-8513 CAN/XS1
  • NI PCI-8513 CAN/XS2
  • NI PCI-8516 LIN/2
  • NI PCI-8517 FlexRay2
  • NI PXI-8511 CAN/LS1
  • NI PXI-8511 CAN/LS2
  • NI PXI-8512 CAN/HS1
  • NI PXI-8512 CAN/HS2
  • NI PXI-8513 CAN/XS1
  • NI PXI-8513 CAN/XS2
  • NI PXI-8516 LIN/2
  • NI PXI-8517 FlexRay2
  • PXI-8512/2
  • cDAQ-9138
  • cDAQ-9139
  • cDAQ-9171
  • cDAQ-9171 OEM
  • cDAQ-9174
  • cDAQ-9178
  • cDAQ-9181
  • cDAQ-9188
  • cDAQ-9191
  • cRIO-9012
  • cRIO-9014
  • cRIO-9022
  • cRIO-9024
  • cRIO-9081
  • cRIO-9082
  • cRIO-9111
  • cRIO-9112
  • cRIO-9113
  • cRIO-9114
  • cRIO-9116
  • cRIO-9118

Description

The NI-XNET product line is a combination of accelerated controller area network (CAN), FlexRay interfaces and Local Interconnect Network (LIN), an optimized driver, easy-to-use APIs, and configuration and debug utilities. With NI-XNET interfaces, you can develop applications for prototyping, simulating, and testing LIN, FlexRay and CAN networks faster and more easily in NI LabVIEW and LabVIEW Real-Time as well as C/C++.

The NI-XNET 1.6 release adds the following features:

  • Added support for the NI cDAQ-9138 and NI cDAQ-9139 NI CompactDAQ Stand-Alone Chassis (Windows and RT).
  • New feature: Raised the FlexRay limit of 8 PDUs per frame to 16.

The NI-XNET 1.6 release changes the following:

  • NI-DAQmx 9.6 is now the minimum required version when using XNET C Series devices with Compact DAQ.
  • The XNET Database Open.vi and XNET String to IO Name.vi VIs have been deprecated, because they were required only for LabVIEW 8.5.x and 8.6.x.

Supported Platforms

Supported Operating Systems

You can install and run this version of the NI-XNET software on the following operating systems:

  • Windows 7 (32-bit and 64-bit)
  • Windows Vista Business edition, Service Pack (SP) 1 or greater (32-bit and 64-bit)
  • Windows XP (32-bit) SP3 or later
  • Windows Server 2003 R2, SP2 or greater (32-bit)
  • Windows Server 2008 R2, SP1 or greater (64-bit, not supported on Server Core Role)

The NI-XNET installer does not support Windows NT/Me/2000/98/95 or the Windows Server non-R2 editions.

Note:  Support for Windows Server 2003 R2 may require disabling physical address extensions (PAE). To learn how this may affect your use of Windows Server 2003 and what actions you may need to take, visit ni.com/info and enter the info code PAESupport.

NI-XNET does not support guest accounts on Windows 7/Vista/XP. You must log into an administrative or user account to use NI-XNET on these OSes.

Caution  If you plan to perform an upgrade of your system from a prior version of Microsoft Windows to Microsoft Windows Vista, you are required to uninstall all National Instruments software prior to performing the upgrade. After the upgrade has been completed, you can reinstall your National Instruments software.

Supported Hardware

This version of the NI-XNET software supports the following National Instruments hardware products on Windows and LabVIEW RT:

  • NI PCI-8511 (Low-Speed/Fault-Tolerant CAN)
  • NI PCI-8512 (High-Speed CAN)
  • NI PCI-8513 (Software-Selectable HS/LS/SW CAN)
  • NI PCI-8516 (LIN)
  • NI PCI-8517 (FlexRay)
  • NI PXI-8511 (Low-Speed/Fault-Tolerant CAN)
  • NI PXI-8512 (High-Speed CAN)
  • NI PXI-8513 (Software-Selectable HS/LS/SW CAN)
  • NI PXI-8516 (LIN)
  • NI PXI-8517 (FlexRay)
  • C Series modules:
    • NI 9861 (C Series Low-Speed CAN)
    • NI 9862 (C Series High-Speed CAN)
    • NI 9866 (C Series LIN)

      Supported platforms for XNET C Series modules:
      • CompactDAQ - NI-DAQmx 9.6 (or newer) required:
        • NI cDAQ-9171
        • NI cDAQ-9174
        • NI cDAQ-9178
        • NI cDAQ-9181
        • NI cDAQ-9188
        • NI cDAQ-9191
        • NI cDAQ-9138 (Windows & RT)
        • NI cDAQ-9139 (Windows & RT)
      • CompactRIO - NI-RIO 4.0 (or newer) and LabVIEW 2010 SP1 (or newer) required for the following targets:
        • Real-Time Controller: NI cRIO-9012, NI cRIO-9014, NI cRIO-9022, and NI cRIO-9024
        • CompactRIO Reconfigurable Chassis: NI cRIO-9111, NI cRIO-9112, NI cRIO-9113, NI cRIO-9114, NI cRIO-9116, and NI cRIO-9118
        • LabVIEW FPGA 2010 SP1 (or newer) is required to build and deploy a bitstream with NI 986x modules in the project.
      • CompactRIO - NI-RIO 4.0 (or newer) and LabVIEW 2011 (or newer) required for the following targets:
        • Integrated CompactRIO Real-Time Controller: NI cRIO-9081, NI cRIO-9082
        • LabVIEW FPGA 2011 (or newer) is required to build and deploy a bitstream with NI 986x modules in the project.

The NI-XNET software supports only National Instruments CAN, FlexRay, and LIN hardware products. For information about software for CAN products from other vendors, refer to the documentation you received with those products.

Supported Development Environments

This version of the NI-XNET software supports the following development environments:

  • LabVIEW 2009 (32-bit), LabVIEW 2010 (32-bit), LabVIEW 2011 (32-bit), and LabVIEW 2012 (32-bit)
  • LabVIEW Real-Time (RT) 2009, 2010, 2011, and 2012
  • LabWindows/CVI 8.5 and higher
  • Microsoft Visual C/C++ 6.0

 

Installation Instructions

The NI-XNET installer is packaged as a self-extracting archive that will automatically launch the driver installer. By default, files are extracted to C:\National Instruments Downloads\NI-XNET\1.6

Perform the following steps to install NI-XNET:

  1. Download and run the self-extracting executable NIXNET160.exe. This will install NI-XNET 1.6 and all necessary driver files.

To conserve disk space you can delete your extracted files. It is recommended that you keep the extracted installation files in case you need to add features from the NI-XNET distribution in the future or you need to include the NI-XNET installer in a installer you build.

Your Feedback

Rate this document

Answered Your Question?
Yes No

Submit