NI-RIO 3.5.1 - Patch - FlexRIO only - Windows 0 Ratings | 0.00 out of 5 |   Print

Available Downloads:

Updates and Notifications:
Critical Updates and Security Notifications are posted on ni.com. Before downloading, click here to review this information.

Download Language: English; Japanese

Product Line: Reconfigurable I/O

Version: 3.5.1

Release date: 08-25-2010

Software type: Driver

Operating system: Windows

Description

This patch fixes a critical issue for NI FlexRIO when using the dynamic reference wire in LabVIEW 2010.  Applications that meet all of the following criteria are affected:

  • Implement peer-to-peer streaming on a LabVIEW FPGA target
  • Use the dynamic FPGA reference wire in LabVIEW FPGA 2010
  • Use NI-RIO 3.5

In affected applications, LabVIEW FPGA will incorrectly assign DMA resources to the peer-to-peer streams, which could result in potential hardware resource conflicts.

To correct this issue, NI recommends installing this patch to upgrade the NI-RIO driver to version 3.5.1.

For further details about this error please refer to the following knowledgebase:

Knowledgebase 5CBE82DP:  The Dynamic FPGA VI Reference Wire is Incompatible with Peer-to-Peer Streaming

Your Feedback

Rate this document

Answered Your Question?
Yes No

Submit