NI CompactRIO 15.0 - NI CompactRIO Device Drivers August 2015 17 Ratings | 3.65 out of 5 |   Print

Available Downloads:

Updates and Notifications:
Critical Updates and Security Notifications are posted on ni.com. Before downloading, click here to review this information.
Supporting Files:

Download Language: Chinese (Simplified); English; Japanese

Product Line: Reconfigurable I/O

Version: 15.0

Release date: 08-03-2015

Software type: Driver

Operating system: Windows 10; Windows 8; Windows 8.1; Windows 7; Windows Vista; Windows XP 32-bit; Windows Server 2012 R2 64-bit; Windows Server 2008; Windows Server 2003 R2 32-bit

Description

Note: This driver is the most recent version of the NI CompactRIO Device Drivers. Search to find out if a patch or more recent version is available. To verify which versions of the NI-RIO driver are compatible with your version of LabVIEW refer to NI-RIO and LabVIEW Compatibility page or go to ni.com/info and enter RIO LVVersions.

NI CompactRIO Device Drivers 15.0 installs support for alll SingleBoard RIO and CompactRIO embedded targets. NI-RIO 14.5.0 supports Windows XP SP2 and later (32 bit), Windows Vista, (32-bit and 64-bit), Windows 7 (32-bit and 64-bit), Windows Server 2003 R2 (32-bit), and Windows Server 2008 R2 (64-bit).

Versions of LabVIEW supported by NI CompactRIO 15.0.0
LabVIEW 2015
LabVIEW 2014 SP1
LabVIEW 2013 SP1
LabVIEW 2012 SP1

Updates for NI CompactRIO 15.0.0
Updated from NI CompactRIO 14.5
New Controller Support (sbRIO-9607, sbRIO-9627, sbRIO-9637)
Added support for LabVIEW 2014 SP1
Added support for LabVIEW Real-Time 2014 SP1
Added support for LabVIEW FPGA 2014 SP1
Removed support for LabVIEW 2011 SP1

Known Issues for NI CompactRIO 15.0.0
Check the readme.html above for Known Issues
Also check this KnowledgeBase 45IB71LX for a list of known issues based on recent versions of the NI-RIO driver.

Additional Notes
Note: Support for Windows Server 2003 R2 may require disabling physical address extensions (PAE). To learn how this might affect your use of Windows Server 2003 and what actions you might have to take, visit ni.com/info and enter the info code PAESupport
Please see KB 6NOAD3JQ for more information recommending customers using a cRIO-9066, cRIO-9067, cRIO-9068, NI 9149 should upgrade to this version of the NI-RIO driver.

Starting on April 1st, 2016, the operating systems Windows XP, Windows Vista, and Windows Server 2003 will no longer officially be supported by NI software products.

Installation Instructions

Complete the following steps to install the NI CompactRIO 15.0.0

  1. Install LabVIEW.
  2. Install any LabVIEW Modules (Real-Time/FPGA).
  3. Install NI CompactRIO 15.0.

Your Feedback

Rate this document

Answered Your Question?
Yes No

Submit