NI Modulation Toolkit 16.0 1 Ratings | 1.00 out of 5 |   Print

Available Downloads:

Updates and Notifications:
Critical Updates and Security Notifications are posted on ni.com. Before downloading, click here to review this information.
Supporting Files:

Download Language: English

Product Line: RF

Version: 16.0

Release date: 06-23-2016

Software type: Addons

Operating system: Windows 10; Windows 8.1 32-bit; Windows 8.1 64-bit; Windows 7 32-bit; Windows 7 64-bit; Windows Server 2012 R2 64-bit; Windows Server 2008 R2 64-bit

Description

New Features

NI LabVIEW Modulation Toolkit 16.0 adds support for LabVIEW 2016 (32- and 64-bit)

NI LabVIEW Modulation Toolkit 15.0 includes the following new features:

  • Support for LabVIEW 2015 (32- and 64-bit)
  • Support for QAM 512, 1024, 2048, 4096

NI LabVIEW Modulation Toolkit 4.4 includes the following new features:

  • Support for LabVIEW 2013 and LabVIEW 2014 (32- and 64-bit)
  • Support for Offset EVM measurement for OQPSK
  • Support for EVM normalization for QAM
  • Support for quadrature skew measurement for OQPSK

NI LabVIEW Modulation Toolkit 4.3.4 adds support for LabVIEW 2012 (32- and 64-bit).

Supported Hardware

Vector Signal Generators

  • NI PXI-5670
  • NI PXI-5671
  • NI PXIe-5672
  • NI PXIe-5673
  • NI PXIe-5673E

Device-specific information about these modules is included in the NI RF Signal Generators Help.

Arbitrary Waveform Generators

  • NI PXIe-5442
  • NI PXIe-5450
  • NI PXIe-5451

Vector Signal Analyzers

  • NI PXI-5660
  • NI PXI-5661
  • NI PXIe-5663
  • NI PXIe-5663E
  • NI PXIe-5665
  • NI PXIe-5668R

Device-specific information about these modules is included in the NI RF Vector Signal Analyzers Help.

Vector Signal Transceivers

  • NI PXIe-5644R
  • NI PXIe-5645R
  • NI PXIe-5646R

Device-specific information about these modules is included in the NI RF Vector Signal Transceivers Help.

Digitizers

  • NI PXI-5621
  • NI PXI-5620
  • NI PXI-5122
  • NI PXI-5124
  • NI PCI-5122
  • NI PCI-5124
  • NI PXI-5922
  • NI PXI-5142
  • NI PXIe-5122
  • NI PXIe-5622

Device-specific information about these modules is included in the NI High-Speed Digitizers Help.

System Requirements

Supported Operating Systems

NI LabVIEW Modulation Toolkit 16.0 supports the following operating systems:

  • Windows 10/8.11/7 SP12 (32-bit and 64-bit)
  • Windows Server 2012 R21 (64-bit)
  • Windows Server 2008 R2 SP12 (64-bit)

1 NI software installs VC2015 Runtime and .NET 4.6.1. Windows 8.1 and Windows Server 2012 R2 require Microsoft updates to support these items. Refer to Microsoft KB2919442 and KB2919355 for more information about how to install these updates.

2 NI software is signed with a SHA-256 certificate. Windows 7 SP1, Windows Embedded Standard 7 SP1, and Windows Server 2008 R2 SP1 require Microsoft updates to support SHA-256. Refer to Microsoft KB3033929 for more information about how to install this security update.

Note  NI LabVIEW Modulation Toolkit 16.0 and later does not support Windows Server non-R2 editions.

NI recommends that you have the most recent service pack for your operating system installed.

Supported Real-Time Operating Environments

NI LabVIEW Modulation Toolkit 16.0 and later supports the following real-time operating environments:

Minimum Requirements

  • Processor—Intel Core i3 or equivalent
  • RAM—2 GB
  • A screen resolution of 1,024 x 768
  • Windows 10/8.1/7, with all available critical updates and service packs
  • If your application runs on an RT target, NI recommends that you have at least 128 MB of RAM

Recommended System

  • Processor—Intel Core i5 or equivalent
  • RAM—4 GB
  • A screen resolution of 1,024 x 768
  • Windows 10/8.1/7, with all available critical updates and service packs
  • If your application runs on an RT target, NI recommends that you have at least 128 MB of RAM

Note   Instrument drivers are not required for NI LabVIEW Modulation Toolkit operation in simulation mode. However, the toolkit installs examples for the supported drivers if they are present on the system. Refer to the Supported Drivers section of this document for more information.

Application Development Environments (ADEs)

Note  You should install ADEs, such as NI LabVIEW before installing NI LabVIEW Modulation Toolkit. To add support for ADEs installed after installing NI LabVIEW Modulation Toolkit, modify your NI LabVIEW Modulation Toolkit installation or launch the NI LabVIEW Modulation Toolkit installer again.

  • NI LabVIEW 2013 SP1, 2014 SP1, 2015 SP1, or 2016
  • NI LabVIEW Real-Time Module 2013 SP1, 2014 SP1, 2015 SP1, or 2016
  • If your application runs on an RT target, NI recommends that you have at least 128 MB of RAM

Installation Instructions

Perform the following steps to install NI LabVIEW Modulation Toolkit:

  1. Download and run the self-extracting executable NIMODTLV1600.exe. This will install NI LabVIEW Modulation Toolkit 16.0 and all necessary driver files.

To conserve disk space you can delete the downloaded .exe file, however it is recommended that you keep the extracted installation files in case you need to add features from the NI LabVIEW Modulation Toolkit distribution in the future, or plan to create your own installers using National Instruments development environments.

Your Feedback

Rate this document

Answered Your Question?
Yes No

Submit