NI LabVIEW Instrument Design Libraries for High Speed Serial Instruments 16.1 0 Ratings | 0.00 out of 5 |   Print

Available Downloads:

Updates and Notifications:
Critical Updates and Security Notifications are posted on ni.com. Before downloading, click here to review this information.
Supporting Files:

Download Language: English

Product Line: LabVIEW

Version: 16.1

Release date: 04-19-2017

Software type: Driver

Operating system: PharLap; Windows 10; Windows 8; Windows 8.1; Windows 7; Windows Server 2012; Windows Server 2008

Description

This software installation provides support for customers using NI 6591R, NI 6592R and 7902 High-Speed Serial instruments. To program these devices, use the LabVIEW FPGA API. The NI 659xR Getting Started Guide and PXIe-7902 Getting Started Guide provides information about how to install, configure, test and begin using a NI High-Speed Serial Instrument.

Supported Hardware

Note: The following hardware requirements apply to NI LabVIEW High Speed Serial Instrument Design Libraries 16.1 software only. LabVIEW FPGA has separate system requirements. Refer to the LabVIEW Readme for these system requirements.

NI LabVIEW Instrument Design Libraries for High-Speed Serial Instruments 16.1 supports the following High-Speed Serial Instruments:

  • NI PXIe-6591R
  • NI PXIe-6592R
  • NI PXIe-7902

Note: Device-specific information about these modules is included in the NI High-Speed Serial Instruments User Manual.

Supported Operating Systems

NI LabVIEW Instrument Design Libraries for High-Speed Serial Instruments 16.1 supports the following operating systems:
Operating System 64-bit 32-bit
Windows 10
Windows 8.1
Windows 7 Professional

Windows Server 2012 R2
-
Windows Server 2008 R2
-
PharLap RTOS


Application Development Environments (ADEs)

Install Application Development Environments, such as NI LabVIEW and NI LabVIEW FPGA before installing NI LabVIEW Instrument Design Libraries for High-Speed Serial Instruments 16.1. NI LabVIEW Instrument Design Libraries for High-Speed Serial Instruments 16.1 supports the following NI Application Development Environment versions:

NI Application Software Versions Supported by NI High-Speed Serial
NI LabVIEW 2016 (32-bit), 2016 (64-bit)*
LabVIEW FPGA 2016
LabVIEW Real-Time 2016

* NI LabVIEW Instrument Design Libraries for High Speed Serial Instruments 16.1 supports running host code in LabVIEW 2016 64-bit

Installation Instructions

Complete the following steps to install NI LabVIEW Instrument Design Libraries for High-Speed Serial Instruments 16.1.

  1. Install LabVIEW. Refer to the LabVIEW Installation Guide for installation instructions for LabVIEW and system requirements for the LabVIEW software. Refer to the LabVIEW Upgrade Notes for additional information about upgrading to the most recent version of LabVIEW for Windows.
    • Documentation for LabVIEW is available at ni.com/manuals and from Start»All Programs»National Instruments»LabVIEW»LabVIEW Manuals.
  2. Install the LabVIEW FPGA Module. Refer to the LabVIEW FPGA Module Release and Upgrade Notes for installation instructions and information about getting started with the LabVIEW FPGA Module.
    • Documentation for the LabVIEW FPGA Module is available at ni.com/manuals and from Start»All Programs»National Instruments»LabVIEW»LabVIEW Manuals.
  3. Install the NI LabVIEW Instrument Design Libraries for High-Speed Serial Instruments 16.1 driver.
    • Documentation for the NI LabVIEW Instrument Design Libraries for High-Speed Serial Instruments 16.1 driver is available at ni.com/manuals and by selecting Start»All Programs»National Instruments»High-Speed Serial Instruments»High-Speed Serial Instruments Documentation.

Note The niSi53xxClockConfig.dll file included as part of the NI LabVIEW Instrument Design Libraries for High-Speed Serial Instruments software may be used only in the use of the NI LabVIEW Instrument Design Libraries for High-Speed Serial Instruments software with the Silicon Labs device in the NI PXIe-6591R, NI PXIe-6592R and NI PXIe-7902 products.

Your Feedback

Rate this document

Answered Your Question?
Yes No

Submit