LabVIEW Internet Toolkit 6.0 - Update - Linux, Mac OS X, Windows/XP/2000/NT 13 Ratings | 4.00 out of 5 |   Print

Available Downloads:

Updates and Notifications:
Critical Updates and Security Notifications are posted on ni.com. Before downloading, click here to review this information.

Download Language: English

Product Line: LabVIEW

Version: 6.0

Release date: 01-01-2006

Software type: Addons

Operating system: Linux; Mac OS X; Windows; Windows XP; Windows 2000; Windows NT

Description

This page provides updates for the LabVIEW Internet Toolkit 6.0. Currently included is an update that fixes a memory leak and provides support for LabVIEW 8.0 and later.

This patch fixes the following issues.

  • There is a memory leak that occurs when using the "XML_Document Load File" method included in the XML DOM parser. The file reference is not closed until exiting LabVIEW.
  • This patch also includes the LabVIEW Internet Toolkit 6.0f1 patch which fixes the following issues.
    • In LabVIEW 8.0 and later, some of the VIs from the Internet toolkit do not work correctly when using the web server functionality to view web pages that contain CGI commands.
    • In LabVIEW 8.0 and later, the "Redirect" shipping example found in [LV DIR]/www/cgi-bin/test/RemotePanels.llb did not work properly due to the issue mentioned above.

Installation Instructions

This patch requires the current version of some Microsoft libraries (i.e. MSVCP71.dll). These libraries may already be on your computer as they are common components installed by many software applications. The quickest way to ensure that the needed libraries are up to date is to download and install the LabVIEW 8.0 Run-Time Engine, which is a free download from National Instruments Drivers and Updates . The Run-Time Engine itself is NOT required for this patch to work, but the installer will update the necessary Microsoft shared libraries.

On Linux, this patch requires the "libstdc++.so.5" library to be installed. This library is on the Linux Installation CDs and is included during a typical installation. If you have a version of this library older than version 5 or you cannot find the library, you will need to install version 5 of this library. Contact your Linux provider to obtain updating instructions.

  • For LabVIEW 8.0 on Windows or Linux
    1. Install LabVIEW 8.0 (or later)
    2. Install LabVIEW Internet Toolkit 6.0
    3. Unzip the contents of this zip file to a temp directory
    4. Open the included llb "InternetToolkit60f2Patch.llb" in LabVIEW.
    5. Open and run the top level VI "ITK 6.0f2 Patch.vi". The patch is applied automatically.
  • For LabVIEW 7.x on Windows or Linux
    1. Install LabVIEW 7.x
    2. Install LabVIEW Internet Toolkit 6.0
    3. Unzip the contents of this zip file to a temp directory
    4. Inside the temp directory, open the folder for your OS.
    5. Place the contents of that folder into the following directory on your computer: [LV DIR]\vi.lib\addons\internet\dom\
  • For LabVIEW 7.x and 8.0 on Mac OS X
    1. Install LabVIEW 7.x or later
    2. Install LabVIEW Internet Toolkit 6.0
    3. Unzip the contents of this zip file to a temp directory
    4. IF YOU ARE USING LabVIEW 8.0 RUN THIS STEP. OTHERWISE, SKIP TO STEP 6.
      Open the included llb "InternetToolkit60f2Patch.llb" in LabVIEW.
    5. Open and run the top level VI "ITK 6.0f2 Patch.vi". The patch is applied automatically. But one part will not be installed.
    6. Inside the temp directory you unzipped this patch to, open the Mac folder.
    7. Unzip the archive into the following directory on your computer: /Library/Frameworks/

NOTE: On Mac OS X copying to this folder is protected by the OS. You will be required to provide a valid administrator login and password.

Your Feedback

Rate this document

Answered Your Question?
Yes No

Submit