NI-SWITCH .NET Class Libraries 1.0 1 Ratings | 2.00 out of 5 |   Print

Available Downloads:

Updates and Notifications:
Critical Updates and Security Notifications are posted on ni.com. Before downloading, click here to review this information.
Supporting Files:

Download Language: English

Product Line: Switches

Version: 1.0

Release date: 01-11-2013

Software type: Code Library/API

Operating system: Windows 8; Windows 7; Windows Vista; Windows Server 2008 R2 64-bit; Windows Server 2003 R2 32-bit

Description

The .NET class libraries for NI-SWITCH provide IVI class compliant .NET class libraries to the underlying driver API. 

The .NET class libraries for NI-SWITCH support the 4.6.1 version of NI-SWITCH driver, and the 4.0 version of .NET framework.

Minimum System Requirements: 

  • Microsoft operating system: 
    • Windows 8 (32-bit or 64-bit) 
    • Windows 7 (32-bit or 64-bit) 
    • Windows Vista (32-bit or 64-bit) 
    • Windows XP, Service Pack 3 (32-bit) 
    • Windows Server 2003 R2 (32-bit) 
    • Windows Server 2008 R2 (64-bit) 
  • Microsoft .NET Framework 4.0
  • Visual Studio 2010: 
    • Ultimate Edition 
    • Premium Edition 
    • Professional Edition 
    • Visual C# Express Edition 
    • Visual Basic Express Edition 
  • Microsoft Internet Explorer 6.0 or later 

Note: The NI-SWITCH .NET class libraries do not include the required NI-SWITCH instrument driver. You must install the NI-SWITCH instrument driver for the NI-SWITCH .NET class libraries to function. 

Refer to NI Drivers and Updates and enter NI-SWITCH into the search field to download the latest version of the NI-SWITCH device driver.

Installation Instructions

  • The NI-SWITCH .NET class libraries are not compatible with non-R2 editions of Windows Server.
  • This version of the NI-SWITCH .NET class libraries supports, and was tested with, the latest operating system service packs that were available at the time this version was released. National Instruments strongly recommends using the NI-SWITCH .NET class libraries with the latest operating system service pack.
  • If you want to upgrade your operating system from one major version to another, National Instruments recommends first uninstalling all National Instruments software, including application software and drivers. This is typically not necessary when installing an operating system service pack.
  • In order for links from the NI-SWITCH .NET class libraries help topics to the .NET Framework help topics to work, you must install the product documentation for Visual Studio, which installs the MSDN Library. This requires a secondary installation during the Visual Studio installation process.
  • If you choose to view the Microsoft Visual Studio 2010 help online, the help viewer launches the Microsoft Developer Network (MSDN) Web site, which does not include the NI-SWITCH .NET Help. If help is configured locally, the NI-SWITCH .NET help can be viewed by selecting Start»All Programs»National Instruments»NI-SWITCH»Documentation»NI-SWITCH .NET 4.0 Help.
  • To use this version of NI-SWITCH .NET Class Library with National Instruments Switches, the target system must have the NI-SWITCH 4.6.1 driver or later installed.
  1. Download the .zip file that contains the NI_SWITCH .NET class libraries. Refer to NI Drivers and Updates and enter NI-SWITCH into the search field to download the latest version of the NI-SWITCH device driver.
  2. Unzip the contents of the .zip file to a temporary location.
  3. Launch setup.exe.
  4. Follow the instructions that appear on the screen.

Your Feedback

Rate this document

Answered Your Question?
Yes No

Submit