<!doctype html>
<html>
 <head> 
  <meta http-equiv="Content-Type" content="text/html; charset=UTF-8"> 
  <title>Search and Replace Regular Expression (G Dataflow) - LabVIEW NXG 3.1 Manual - National Instruments</title> 
  
<meta name="Section" content="support" />
<meta name="DeliveredBy" content="Searchable Product Documentation" /> 
  <meta name="Language" content="en" /> 
  <meta name="nigen2" content="4.0" />
<meta name="nigen4" content="4.0" />
<meta name="namespace-version" content="4.0" />
<meta name="DocumentID" content="labview-4.0" />
<meta name="nigen8" content="LabVIEW NXG 4.0" />
 
  <meta name="docstatus" content="current" />
<meta name="robots" content="noindex" />
 
  <meta name="Date" scheme="iso8601" content="2019-08-07T13:28:14" /> 
  <meta name="nigen3" content="labview" />
<meta name="namespace" content="labview" />
<meta name="doctype" content="manual" /> 
  <meta name="Description" content="Searches for a regular expression in the input string and replaces either the first match or every match with a substring you specify. This node does not support null characters in strings. If you include null characters in strings you wire to this node, the node returns an error and may return unex"> 
  <meta name="shorttitle" content="Search and Replace Regular Expression (G Dataflow) - LabVIEW NXG 3.1 Manual"> 
  <meta name="contenttype" content="apireference"> 
  <meta name="nigen1" content="http://s.nicdn.net/documentation/en/labview/4.0/node-ref/images/connpanes/NI.G%20Core.Strings/Search%20and%20Replace%20Regular%20Expression.gvi.png"> 
  <meta name="nigen5" content="vi"> 
  <meta name="PageType" content="leaf"> 
  <meta name="productcategories" content="225237" /> 
  <meta name="nigen7" content="G Dataflow"> 
  <meta name="UpdateDate" scheme="iso8601" content="2019-08-09T00:02:17"> 
  






  
  





	
<!--DNS prefetching-->

	<meta http-equiv="x-dns-prefetch-control" content="on">
	
	<link rel="dns-prefetch" href="//fonts.googleapis.com">
	<link rel="dns-prefetch" href="//fonts.gstatic.com">
	<link rel="dns-prefetch" href="//assets.adobedtm.com">
	<link rel="dns-prefetch" href="//dpm.demdex.net">
	<link rel="dns-prefetch" href="//ds.serving-sys.com">
	<link rel="dns-prefetch" href="//bs.serving-sys.com">
	<link rel="dns-prefetch" href="//nsmetrics.ni.com">
	<link rel="dns-prefetch" href="//cdn.tt.omtrdc.net">
	<link rel="dns-prefetch" href="//ni.tt.omtrdc.net">
	<link rel="dns-prefetch" href="//s7d5.scene7.com">
            

 <!--NIA NON-RESPONSIVE WRAPPER -->
 <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
 <meta name="Wrapper" content="yes" />
         

	<!-- JQUERY 1.11 -->
	
    <script type="text/javascript" src="/niassets/jquery/js/jquery.min.js"></script>

    <!-- SCRIPT FOR USER ACCOUNT/CUST ID-->
    <script src="/niassets/js/niua.min.js"></script>
  
    <!--DTM call-->
        <!-- Adobe Dynamic Tag Manager Loader Code-->
             <script src="//assets.adobedtm.com/a3a673425858388bc1b1e0ed01eb252ad8ce12e0/satelliteLib-1401ce0fc9dae9e8602fcc34896d0a249c42abb2.js"></script>
        <!-- End of Dynamic Tag Manager Loader Code-->
   
   	<!--  we need these patches because things like auto-complete, global gateway and UP use them -->
    <script type="text/javascript" src="/niassets/jquery/js/jquery-migrate-1.2.1.min.js"></script>

    <!-- LATEST COMPILED AND MINIFIED BOOTSTRAP JS -->
    <script type="text/javascript" src="/niassets/bootstrap/js/bootstrap.min.js"></script>
    
    <!-- jQuery UI JS-->
    <script type="text/javascript" src="/niassets/jquery/jqueryui/js/jquery-ui.min.js"></script>
    
    
     
<!-- LATEST COMPILED AND MINIFIED BOOTSTRAP CSS -->
<link rel="stylesheet" href="/niassets/bootstrap/css/bootstrap.min.css">

     
<script type="text/javascript" src= "/niassets/ni.min.js"></script>
  
<!-- jQuery UI -->
<link rel="stylesheet" type="text/css" href="/niassets/jquery/jqueryui/css/jquery-ui.min.css"> 
	
<!--CSS for wrapper-->



<!-- NON RESPONSIVE CSS AND NI.CSS-->
	 <link rel="stylesheet" type="text/css" href="/niassets/ni.min.css">
  <link rel="stylesheet" type="text/css" href="/niassets/wrapper/css/non-responsive-specific.css">
     
 
  <link rel="stylesheet" href="/apps/spd/app.css">
<script type="text/javascript" src="/niassets/jstorage/jstorage.min.js"></script>
<script type="text/javascript" src="/apps/spd/app.js"></script>
<script type="text/javascript" src="/niassets/mathjax/MathJax.js?config=spd"></script>
<!-- old <script type="text/javascript" src="/widgets/mathjax/MathJax.js?config=spd"></script> --> 
<!-- app.js will include the call to update recently viewed topics -->
 
  <link rel="canonical" href="http://www.ni.com/documentation/en/labview/latest/node-ref/search-and-replace-regex/">
 </head> 
 <body> 
    
  
 





 


 

		





 
 






<div class="ni-wrapper-header noindex">
 <!--Downtime Notification-->
    

    <!--NI#include virtual="/ssi/downtime/downtime_main_en.htm" -->

  


 <!--Fixed nav bar only visible in lg and medium devices-->
   <nav class="navbar navbar-default">
     <!--Main Navigation Content-->
  <div class="container-fluid">
    <div class="row">
      <div class = "container">
        <div class="row">
 
  <div class="ni_logo col-md-5 col-xs-4">
	 <a href="//www.ni.com/" class="navbar-brand analytics-utilitylogo-link"></a>
    </div>
            
	<div class="utility-nav col-md-7 pull-right">
	    <ul class="nav nav-pills pull-right">
	     <!--User Profile component-->
		<li class="hidden-xs myaccount-utility">
			<span class="pull-left user"></span>
			<span class="global-header-nav-up-wrap"></span>
		</li>		      
	     <!--Shopping Cart component-->
 
     <li class="cart cart-badge analytics-utilitycart-link" data-badge="0"><a href="http://sine.ni.com/apps/utf8/nios.store?action=view_cart&amp;loc=en-US">&nbsp;</a></li>
 
 
	     <!--Search Button-->

<li class="visible-xs search search-box" role="button" data-toggle="modal" data-target="#wrapperSearchModal">
   <svg version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="48px" height="48px" viewBox="0 0 800 600" enable-background="new 0 0 800 600" xml:space="preserve">
   <g id="XMLID_1_">
	   <g>
		   <path fill="#FFFFFF" d="M637.27,499.09l-38.18,38.18L413.64,351.82c-27.28,19.09-60,30-95.459,30    c-90,0-163.63-73.641-163.63-163.64c0-90,73.63-163.63,163.63-163.63c90,0,163.64,73.63,163.64,163.63    c0,35.46-10.91,68.18-30,95.459L637.27,499.09z M454.55,218.18c0-76.36-60-136.36-136.37-136.36c-76.36,0-136.36,60-136.36,136.36    c0,76.37,60,136.37,136.36,136.37C394.55,354.55,454.55,294.55,454.55,218.18z"/>
	   </g>
   </g>
   </svg>
</li>

	     <!--Nav Toggle Button-->
	 <!--Navbar toggle box component/button-->
		  <button type="button" class="navbar-toggle collapsed" data-toggle="collapse" data-target="#navbar" aria-expanded="false" aria-controls="navbar">
		     <span class="sr-only">Toggle navigation</span>
		     <span class="icon-bar"></span>
		     <span class="icon-bar"></span>
		     <span class="icon-bar"></span>
		  </button>
	    </ul>
	</div>
      </div>
    </div>
  </div> 
  <div class="row">
    <div class = "container">
      <div class="row">
 
		 <div class="ni-nav col-md-8 col-sm-9 pull-left col-xs-12">
		     <div id="navbar" class="navbar-collapse collapse">
			 <ul class="nav navbar-nav">
			    <li class="innovations ">
			 
				
				   <a class="analytics-header-link" href="//www.ni.com/innovations/">INNOVATIONS</a>
			         </li>
			    <li class="products ">
			 
				
				   <a class="analytics-header-link" href="//www.ni.com/shop/">PRODUCTS</a>
			         </li>
			    <li class="support  current">
			 
				
				   <a class="analytics-header-link" href="//www.ni.com/en-us/support.html">SUPPORT</a>
			         </li>
			    <li class="community ">
			 
				
				   <a class="analytics-header-link" href="//forums.ni.com">COMMUNITY</a>
			         </li>
		<li class="nav-myaccount visible-xs" >
		    <span class="pull-left user"></span>
			<div class="mobile-nav-up-wrap">
               <a class="analytics-utilityaccount-link" href="http://www.ni.com/myni/">My Account</a>
               <br>
              <span>
               <a class="analytics-utilityaccount-link" href="http://www.ni.com/myni/">Log in</a>
               </span>
               </div>
          
		</li>
			 </ul>
			  <div class="hidden-xs" id="navSlider">&nbsp;</div>
		     </div>
		        
		     <!--/.nav-collapse -->
		 </div>
 	                                            		 
 	<div class="col-md-4 col-sm-3 pull-right col-xs-4 global-header-search">
		<div class="hidden-xs pull-right">
			<form id="autoComplete-global" name="autoComplete-global" type="GET" action="//search.ni.com/nisearch/app/main">
				<div class="autoCompleteItem-global">
					<div class="input-group stylish-input-group">
					<!--     <input type="text" placeholder="" class="form-control">-->
					<input placeholder="" class="niAutocompleteInput pull-right" data-search-type="globalSearch" type="text" id="n33_autoCompleteInput"  name="q" />
					<input type="hidden" name="pg" id="pg" value="1"/>
					<input type="hidden" name="sn" id="sn" value=""/>
						<span class="input-group-addon">
						   <button type="submit">
						      <span class="search search-icon">
								<svg version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="35px" height="35px" viewBox="0 0 800 600" enable-background="new 0 0 800 600" xml:space="preserve">
									 <g id="XMLID_1_">
										 <g>
											 <path fill="#065FA3" d="M637.27,499.09l-38.18,38.18L413.64,351.82c-27.28,19.09-60,30-95.459,30    c-90,0-163.63-73.641-163.63-163.64c0-90,73.63-163.63,163.63-163.63c90,0,163.64,73.63,163.64,163.63    c0,35.46-10.91,68.18-30,95.459L637.27,499.09z M454.55,218.18c0-76.36-60-136.36-136.37-136.36c-76.36,0-136.36,60-136.36,136.36    c0,76.37,60,136.37,136.36,136.37C394.55,354.55,454.55,294.55,454.55,218.18z"/>
										 </g>
									 </g>
								</svg>
							  </span>
						   </button>  
						</span>
					</div>
				</div>
			</form>
		</div>
	</div>
            
      </div>
    </div>
  </div>
  
</div>

    </nav>

</div>

            <div class="container global-header-breadcrumb">
                
            </div>


 
  <div class="breadcrumb row noindex">
    <div class="ni-body-copy-secondary container">
        <a class="left" href="http://www.ni.com">Home</a>
        <span class="delimiter"></span>
        <a class="left" href="/support/">Support</a>
        <span class="delimiter"></span>
        <a class="left" href="/manuals/">NI Product Manuals</a>
        <span class="delimiter"></span>
        <span class="left breadcrumb-last">LabVIEW NXG 3.1 Manual</span>
    </div>
</div> 
  <div class="container"> 
   <div class="row"> 
    <div class="col-xs-3 spd-toc-col noindex">
   <div class="spd-toc">
      <h2 class="spd-toc-title ">Table Of Contents</h2>
      <ul class="spd-toc-back-links-container">
      </ul>
      <ul class="spd-toc-child-nodes-container">
      </ul>
   </div>
</div> 
    <div class="col-xs-9 spd-body-col">
     <span class="overline"></span>
     <div class="spd-page"> 
      <div class="spd-header-container col-xs-12"> 
       <h1 class="spd-header">Search and Replace Regular Expression (G Dataflow)</h1> 
      </div> 
      <div class="spd-offline-help-viewer col-xs-12 ni-body-copy-secondary noindex">
   <a href="../../labview_4.0_en.nihelp">Download Manual</a> | <a href="http://digital.ni.com/express.nsf/bycode/OfflineManuals">Offline Viewer Required</a>
</div> 
      <form class="spd-search-container col-xs-12" id="spd-search-form">
    <div class="spd-select-container col-xs-3 input-group noindex">
        <select name="select" class="ni-custom-select" id="spd-selected-search">
            <option value="manual">This Manual</option>
			<option value="all">Entire Site</option>
        </select>
    </div>
    <div class="input-group stylish-input-group col-xs-8">
        <input class="form-control" type="text" id="spd-search-input"/>
        <span class="input-group-addon">
            <button type="submit">
                <svg width="35px" height="35px" viewBox="0 0 800 600" >
                    <path fill="#065FA3" d="M637.27,499.09l-38.18,38.18L413.64,351.82c-27.28,19.09-60,30-95.459,30    c-90,0-163.63-73.641-163.63-163.64c0-90,73.63-163.63,163.63-163.63c90,0,163.64,73.63,163.64,163.63    c0,35.46-10.91,68.18-30,95.459L637.27,499.09z M454.55,218.18c0-76.36-60-136.36-136.37-136.36c-76.36,0-136.36,60-136.36,136.36    c0,76.37,60,136.37,136.36,136.37C394.55,354.55,454.55,294.55,454.55,218.18z"></path>
                </svg>
            </button>
        </span>
    </div>  
</form> 
      <div class="spd-version-control col-xs-8 ni-body-copy-secondary">
    <span class="spd-version-name noindex">Version:</span> <span class="col-xs-10 spd-version-picker"></span>
	<div class="spd-something-need-info">
	   <ul class="page-versions"><li><a href="/documentation/en/labview/1.0/node-ref/search-and-replace-regex/">LabVIEW NXG 1.0</a></li><li><a href="/documentation/en/labview/2.0/node-ref/search-and-replace-regex/">LabVIEW NXG 2.0</a></li><li><a href="/documentation/en/labview/2.1/node-ref/search-and-replace-regex/">LabVIEW NXG 2.1</a></li><li><a href="/documentation/en/labview/3.0/node-ref/search-and-replace-regex/">LabVIEW NXG 3.0</a></li><li><a href="/documentation/en/labview/3.1/node-ref/search-and-replace-regex/">LabVIEW NXG 3.1</a></li></ul>  
	</div>
</div> 
      <div class="spd-last-update col-xs-4 ni-body-copy-secondary pull-right noindex">
       <span> 
        <span>Last Modified:</span> February 7, 2019</span>
      </div> 
      <hr class="col-xs-12"> 
      <div class="spd-content-container col-xs-12"> 
       <p><span>Searches for a regular expression in the input string and replaces either the first match or every match with a substring you specify.</span></p> 
       <p>This node does not support null characters in strings. If you include null characters in strings you wire to this node, the node returns an error and may return unexpected results. </p> 
       <p> This node performs more slowly than <span>Search and Replace Pattern</span> but gives you more options for matching strings. For example, <span>Search and Replace Regular Expression</span> supports the parenthesis and vertical bar (|) characters. </p>
       <img alt="connector_pane_image" class="connector-pane" src="http://s.nicdn.net/documentation/en/labview/4.0/node-ref/images/connpanes/NI.G%20Core.Strings/Search%20and%20Replace%20Regular%20Expression.gvi.png">
       <script>
		/*Tab Code*/
		$('.nav-tabs a').on('shown.bs.tab', function(e) {
			var tabHref = $(e.target).attr("href");
			var tabContent = $(tabHref);
			if (tabContent.data("hasBeenOpened") != true) {
			MathJax.Hub.Queue(["Rerender", MathJax.Hub, tabContent[0]]);
			tabContent.data("hasBeenOpened", true);
			}
		});
        </script>
       <div class="spd-tabctrl-component js"> 
        <div class="spd-tabctrl-header"> 
         <!--Nav tabs--> 
         <ul class="nav nav-tabs noindex" role="tablist"> 
          <li role="presentation" class=" active "><a href="#tabs-io" aria-controls="tabs-io" role="tab" data-toggle="tab">Inputs/Outputs</a></li> 
          <li role="presentation" class=" "><a href="#tabs-details" aria-controls="tabs-details" role="tab" data-toggle="tab">Details</a></li> 
          <li role="presentation" class=" "><a href="#tabs-compatibility" aria-controls="tabs-compatibility" role="tab" data-toggle="tab">Compatibility</a></li> 
         </ul> 
         <div class="bottom-border-div"> 
         </div> 
        </div> 
        <!--Tab panes--> 
        <div class="tab-content"> 
         <div role="tabpanel" class="tab-pane active  " id="tabs-io">
          <script type="text/javascript">
					/*Twisties Code*/  
					$('.collapse').on('shown.bs.collapse', function(e) {
						$(this).parent().find(".glyphicon-triangle-right").removeClass("glyphicon-triangle-right").addClass("glyphicon-triangle-bottom");
						if ($(e.currentTarget).data("hasBeenOpened") != true) {
							MathJax.Hub.Queue(["Rerender", MathJax.Hub, e.currentTarget]);
							$(e.currentTarget).data("hasBeenOpened", true);
						}
					}).on('hidden.bs.collapse', function() {
						$(this).parent().find(".glyphicon-triangle-bottom").removeClass("glyphicon-triangle-bottom").addClass("glyphicon-triangle-right");
					});
                </script>
          <div class="spd-parameter"> 
           <div class="param-datatype">
            <img src="http://s.nicdn.net/documentation/images/lvdatatypes/cbool.png" alt="datatype_icon">
           </div> 
           <div class="param-name"> 
            <h2>replace all</h2> 
           </div> 
           <div class="param-abstract"> 
            <p><span>Boolean value that determines whether to replace all substrings that match the pattern you specify or just the first.</span></p>
            <a name="d142643e15"> 
             <!-- --></a>
            <table id="d142643e15" class="spd-table spd-table-bdr"> 
             <thead></thead> 
             <tbody> 
              <tr> 
               <td>True</td> 
               <td>The node replaces all matching substrings.</td> 
              </tr> 
              <tr> 
               <td>False</td> 
               <td>The node replaces the first matching substring.</td> 
              </tr> 
             </tbody> 
            </table> 
            <p><strong>Default: </strong>False </p> 
           </div> 
          </div> 
          <div class="spd-parameter"> 
           <div class="param-datatype">
            <img src="http://s.nicdn.net/documentation/images/lvdatatypes/cstr.png" alt="datatype_icon">
           </div> 
           <div class="param-name"> 
            <h2>string</h2> 
           </div> 
           <div class="param-abstract"> 
            <p><span>String on which the node operates.</span></p> 
           </div> 
          </div> 
          <div class="spd-parameter"> 
           <div class="param-datatype">
            <img src="http://s.nicdn.net/documentation/images/lvdatatypes/cstr.png" alt="datatype_icon">
           </div> 
           <div class="param-name"> 
            <h2>search expression</h2> 
           </div> 
           <div class="param-abstract"> 
            <p><span>The pattern you want to search for in the input string. This string cannot contain null characters. Use Perl Compatible Regular Expressions to refine searches.</span> </p> 
            <div class="spd-twisties"> 
             <div data-toggle="collapse" data-target="#details311"> 
              <p><span class="glyphicon glyphicon-triangle-right"></span>Definitions of Regular Expressions </p> 
             </div> 
             <div id="details311" class="collapse"> 
              <p>Use the following regular expressions to search the input string. </p>
              <a name="GUID-184371D0-0B58-4787-81BE-8D1E85047077__d5416e44"> 
               <!-- --></a>
              <table id="GUID-184371D0-0B58-4787-81BE-8D1E85047077__d5416e44" class="spd-table spd-table-bdr"> 
               <thead> 
                <tr> 
                 <th id="d146184e253">Regular Expression </th> 
                 <th id="d146184e256">Description </th> 
                 <th id="d146184e259">Examples </th> 
                </tr> 
               </thead> 
               <tbody> 
                <tr> 
                 <td headers="d146184e253 "><span class="spd-font-mono">.</span> (period) </td> 
                 <td headers="d146184e256 ">Matches any single character except a newline character. Within square brackets, <span class="spd-font-mono">.</span> is literal. </td> 
                 <td headers="d146184e259 "> <p>Input String: <span class="spd-font-mono">Welcome to LabVIEW.</span> </p> <p>Regular Expression: <span class="spd-font-mono">t....</span> </p> <p>Match: <span class="spd-font-mono">to La</span> </p> <p>If you use <span class="spd-font-mono">[z.]</span> as the regular expression, the period is literal and matches either <span class="spd-font-mono">.</span> or <span class="spd-font-mono">z.</span> In this example, <span class="spd-font-mono">[z.]</span> returns <span class="spd-font-mono">.</span> as the match. </p> </td> 
                </tr> 
                <tr> 
                 <td headers="d146184e253 "><span class="spd-font-mono">*</span> </td> 
                 <td headers="d146184e256 ">Marks the single preceding character, character group, or character class as one that can appear zero or more times in the input. <span>Because an asterisk can mark a pattern as one that appears zero times, regular expressions that include an asterisk can return an empty string if the whole pattern is marked with an asterisk. This quantifier applies to as many characters as possible. </span> </td> 
                 <td headers="d146184e259 "> <p>Input String: <span class="spd-font-mono">Hello LabVIEW!</span> </p> <p>Regular Expression: <span class="spd-font-mono">el*</span> </p> <p>Match: <span class="spd-font-mono">ell</span> </p> <p>Expressions such as <span class="spd-font-mono">w*</span> or <span class="spd-font-mono">(welcome)*</span> match an empty string if the node finds no other matches. </p> </td> 
                </tr> 
                <tr> 
                 <td headers="d146184e253 "><span class="spd-font-mono">+</span> </td> 
                 <td headers="d146184e256 ">Marks the single preceding character, character group, or character class as one that can appear one or more times in the input. <span>This quantifier applies to as many characters as possible. </span> </td> 
                 <td headers="d146184e259 "> <p>Input String: <span class="spd-font-mono">Hello LabVIEW!</span> </p> <p>Regular Expression: <span class="spd-font-mono">el+</span> </p> <p>Match: <span class="spd-font-mono">ell</span> </p> </td> 
                </tr> 
                <tr> 
                 <td rowspan="2" headers="d146184e253 "><span class="spd-font-mono">?</span> </td> 
                 <td rowspan="2" headers="d146184e256 "> <p>Marks the single preceding character, character group, or character class as one that can appear zero or one time in the input. <span>This quantifier applies to as many characters as possible.</span> </p> <p>When used immediately after a quantifier, <span class="spd-font-mono">?</span> modifies the quantifier to match as few times as possible. Modifiable quantifiers include <span class="spd-font-mono">*</span>, <span class="spd-font-mono">+</span>, and <span class="spd-font-mono">{}</span>. </p> </td> 
                 <td headers="d146184e259 "> <p>Input String: <span class="spd-font-mono">Hello LabVIEW!</span> </p> <p>Regular Expression: <span class="spd-font-mono">el?</span> </p> <p>Match: <span class="spd-font-mono">el</span> </p> </td> 
                </tr> 
                <tr> 
                 <td headers="d146184e259 "> <p>Input String: <span class="spd-font-mono">&lt;ul&gt;&lt;li&gt;Hello&lt;/li&gt;&lt;li&gt;LabVIEW&lt;/li&gt;&lt;/ul&gt;</span> </p> <p>Regular Expression: <span class="spd-font-mono">&lt;li&gt;.+?&lt;/li&gt;</span> </p> <p>Match: <span class="spd-font-mono">&lt;li&gt;Hello&lt;/li&gt;</span> </p> <p>In the second example, if you remove <span class="spd-font-mono">?</span> from the regular expression, the new match becomes <span class="spd-font-mono">&lt;li&gt;Hello&lt;/li&gt;&lt;li&gt;LabVIEW&lt;/li&gt;</span> because <span class="spd-font-mono">+</span> matches as many characters as possible unless you include <span class="spd-font-mono">?</span> immediately after <span class="spd-font-mono">+</span>. You can use this regular expression to match any string within <span class="spd-font-mono">&lt;li&gt;&lt;/li&gt;</span> tags. </p> </td> 
                </tr> 
                <tr> 
                 <td rowspan="2" headers="d146184e253 "><span class="spd-font-mono">{n,N}</span> </td> 
                 <td rowspan="2" headers="d146184e256 ">Marks the single preceding character, character group, or character class as one that can appear the number of times you specify, where <span class="spd-font-mono">n</span> is the minimum and <span class="spd-font-mono">N</span> is the maximum. You also can specify a single number. If you specify a range, this quantifier matches as many times as possible. </td> 
                 <td headers="d146184e259 "> <p>Input String: <span class="spd-font-mono">&lt;ul&gt;&lt;li&gt;Hello&lt;/li&gt;&lt;li&gt;Lab&lt;/li&gt;&lt;li&gt;VIEW&lt;/li&gt;&lt;li&gt;!&lt;/li&gt;&lt;/ul&gt;</span> </p> <p>Regular Expression: <span class="spd-font-mono">(&lt;li&gt;.+?&lt;/li&gt;){2}</span> </p> <p>Match: <span class="spd-font-mono">&lt;li&gt;Hello&lt;/li&gt;&lt;li&gt;Lab&lt;/li&gt;</span> </p> </td> 
                </tr> 
                <tr> 
                 <td headers="d146184e259 "> <p>Input String: <span class="spd-font-mono">&lt;ul&gt;&lt;li&gt;Hello&lt;/li&gt;&lt;li&gt;Lab&lt;/li&gt;&lt;li&gt;VIEW&lt;/li&gt;&lt;li&gt;!&lt;/li&gt;&lt;/ul&gt;</span> </p> <p>Regular Expression: <span class="spd-font-mono">(&lt;li&gt;.+?&lt;/li&gt;){1,3}</span> </p> <p>Match: <span class="spd-font-mono">&lt;li&gt;Hello&lt;/li&gt;&lt;li&gt;Lab&lt;/li&gt;&lt;li&gt;VIEW&lt;/li&gt;</span> </p> <p>In the second example, the minimum match limit is one and the maximum is three. Because the regular expression matches as many times as possible within the limit you specify, the regular expression returns three. </p> </td> 
                </tr> 
                <tr> 
                 <td headers="d146184e253 "><span class="spd-font-mono">[]</span> </td> 
                 <td headers="d146184e256 "> <p>Creates a character class, which allows you to match any one of a set of characters that you specify. For example, <span class="spd-font-mono">[abc]</span> matches <span class="spd-font-mono">a</span>, <span class="spd-font-mono">b</span>, or <span class="spd-font-mono">c</span>. </p> <p>You can use <span class="spd-font-mono">-</span> to specify a range of characters. For example, <span class="spd-font-mono">[a-z]</span> matches any single lowercase letter. </p> <p>This node interprets special characters inside square brackets literally, with the exception of <span class="spd-font-mono">^</span>, <span class="spd-font-mono">-</span>, and <span class="spd-font-mono">\</span>. </p> </td> 
                 <td headers="d146184e259 "> <p>Input string: <span class="spd-font-mono">version=14.0.1</span> </p> <p>Regular Expression: <span class="spd-font-mono">[0-9]+(\.[0-9]+)*</span> </p> <p>Match: <span class="spd-font-mono">14.0.1</span> </p> <p>The expression <span class="spd-font-mono">[0-9]</span> matches any digit. The plus sign matches the previous character class, <span class="spd-font-mono">[0-9]</span>, one or more times but as many times as possible. The parentheses create a character group, which creates a submatch of the <span class="spd-font-mono">.</span> character and all following digits. The expression <span class="spd-font-mono">\.</span> matches a literal <span class="spd-font-mono">.</span> character. The plus sign matches the previous character class, <span class="spd-font-mono">[0-9]</span>, one or more times but matches as many times as possible. The asterisk matches the previous character group, <span class="spd-font-mono">(\.[0-9]+)</span>, zero or more times, so the regular expression still matches integers if there is no <span class="spd-font-mono">.</span> character. You can use this regular expression to match any integer, decimal number, version number, IPv4 address, or other number sequence separated by <span class="spd-font-mono">.</span> characters. </p> </td> 
                </tr> 
                <tr> 
                 <td rowspan="2" headers="d146184e253 "><span class="spd-font-mono">()</span> </td> 
                 <td rowspan="2" headers="d146184e256 "> <p>Creates a character group, which allows you to match an entire set of characters that you specify. A quantifier that immediately follows a character group quantifies the entire group. </p> <p>Parentheses also create submatches where each individual character group returns a submatch. If you nest a character group within another character group, the regular expression creates a submatch for the outer group before the inner group. Expand <span>Match Regular Expression</span> to access submatch outputs. </p> <p>You also can refer back to submatches later in an expression using backreferences. Refer to the <em>Backreferences</em> section for more information about using backreferences in regular expressions. </p> </td> 
                 <td headers="d146184e259 "> <p> Input String: <span class="spd-font-mono">Hello LabVIEW!</span> </p> <p>Regular Expression: <span class="spd-font-mono">(el.)..(L..)</span> </p> <p>Match: <span class="spd-font-mono">ello Lab</span> </p> <p>Submatch 1: <span class="spd-font-mono">ell</span> </p> <p>Submatch 2: <span class="spd-font-mono">Lab</span> </p> </td> 
                </tr> 
                <tr> 
                 <td headers="d146184e259 "> <p>Input String: <span class="spd-font-mono">Hello LabVIEW!</span> </p> <p>Regular Expression: <span class="spd-font-mono">(.(el.).).(L..)</span> </p> <p>Match: <span class="spd-font-mono">Hello Lab</span> </p> <p>Submatch 1: <span class="spd-font-mono">Hello</span> </p> <p>Submatch 2: <span class="spd-font-mono">ell</span> </p> <p>Submatch 3: <span class="spd-font-mono">Lab</span> </p> </td> 
                </tr> 
                <tr> 
                 <td headers="d146184e253 "><span class="spd-font-mono">|</span> </td> 
                 <td headers="d146184e256 ">Separates alternate possible matches. This character is useful when you want to match any of a number of character groups. A regular expression that contains <span class="spd-font-mono">|</span> returns the first match that the node finds in the input string regardless of the order of your possible matches. For example, both regular expressions <span class="spd-font-mono">dog|cat</span> and <span class="spd-font-mono">cat|dog</span> match <span class="spd-font-mono">dog</span> in <span class="spd-font-mono">the dog chased the cat</span>. </td> 
                 <td headers="d146184e259 "> <p>Input String: <span class="spd-font-mono">value=FALSE total=12.34 token=TRUE</span> </p> <p>Regular Expression: <span class="spd-font-mono">(value|token)=(TRUE|FALSE)</span> </p> <p>Match: <span class="spd-font-mono">value=FALSE</span> </p> <p>Submatch 1: <span class="spd-font-mono">value</span> </p> <p>Submatch 2: <span class="spd-font-mono">FALSE</span> </p> <p>The regular expression returns the first possible match in the input string. If <span class="spd-font-mono">token=TRUE</span> appeared before <span class="spd-font-mono">value=FALSE</span> in the input string, the regular expression would match <span class="spd-font-mono">token=TRUE</span> instead. </p> </td> 
                </tr> 
                <tr> 
                 <td rowspan="2" headers="d146184e253 "><span class="spd-font-mono">^</span> </td> 
                 <td rowspan="2" headers="d146184e256 "> <p>Anchors a match to the beginning of a string when used as the first character of a pattern. </p> <p>If you set the <strong>multiline?</strong> input to True on this node, <span class="spd-font-mono">^</span> matches the beginning of any line within the string using the line endings of the current platform. </p> <p>You also can match any character not in a given character class by adding <span class="spd-font-mono">^</span> to the beginning of a character class. For example, <span class="spd-font-mono">[^0-9]</span> matches any character that is not a digit. <span class="spd-font-mono">[^a-zA-Z0-9]</span> matches any character that is not a lowercase or uppercase letter and also not a digit. </p> </td> 
                 <td headers="d146184e259 "> <p>Input String: <span class="spd-font-mono">Hello LabVIEW!</span> </p> <p>Regular Expression: <span class="spd-font-mono">^[^ ]+</span> </p> <p>Match: <span class="spd-font-mono">Hello</span> </p> <p>The regular expression matches as many characters as possible – other than a space character – from the beginning of the input string. You can use this regular expression to isolate the first word, numeral, or other character combination of a string. </p> </td> 
                </tr> 
                <tr> 
                 <td headers="d146184e259 "> 
                  <div class="p">
                   Input String: 
                   <pre>Hello
LabVIEW</pre> 
                  </div> <p>Regular Expression: <span class="spd-font-mono">^LabVIEW</span> </p> <p>Match: <span class="spd-font-mono">LabVIEW</span> </p> <p>The regular expression matches <span class="spd-font-mono">LabVIEW</span> only if you set <strong>multiline?</strong> to True. </p> </td> 
                </tr> 
                <tr> 
                 <td rowspan="2" headers="d146184e253 "><span class="spd-font-mono">$</span> </td> 
                 <td rowspan="2" headers="d146184e256 "> <p>Anchors a match at the end of a string when used as the last character of a pattern. </p> <p>If you set the <strong>multiline?</strong> input to True, <span class="spd-font-mono">$</span> matches the end of any line within the string using the line endings of the current platform. </p> <p> Referenced a parenthesized item with <span class="spd-font-mono">$n</span>, where <span class="spd-font-mono">n</span> is the index of the parenthesized item. Explicitly insert dollar signs (<span class="spd-font-mono">$</span>) by prefixing them with a backslash (<span class="spd-font-mono">\</span>). For example, <span class="spd-font-mono">\$5</span> represents $5 and <span class="spd-font-mono">$5</span> represents the 5th parenthesized item. </p> </td> 
                 <td headers="d146184e259 "> <p>Input String: <span class="spd-font-mono">Hello LabVIEW!</span> </p> <p>Regular Expression: <span class="spd-font-mono">[^ ]+$</span> </p> <p>Match: <span class="spd-font-mono">LabVIEW!</span> </p> <p> The regular expression matches as many characters as possible – other than a space character – from the end of the input string. You can use this regular expression to isolate the last word, numeral, or other character combination of a string. </p> </td> 
                </tr> 
                <tr> 
                 <td headers="d146184e259 "> 
                  <div class="p">
                   Input String: 
                   <pre>Hello
LabVIEW</pre> 
                  </div> <p>Regular Expression: <span class="spd-font-mono">Hello$</span> </p> <p>Match: <span class="spd-font-mono">Hello</span> </p> <p>The regular expression matches <span class="spd-font-mono">Hello</span> only if you set <strong>multiline?</strong> to True. </p> </td> 
                </tr> 
                <tr> 
                 <td rowspan="3" headers="d146184e253 ">\ </td> 
                 <td rowspan="3" headers="d146184e256 "> <p>Cancels the special meaning of any special character in this list that immediately follows the backslash and instead matches the literal character. </p> <p>The following escaped expressions have special meanings: </p> <a name="GUID-184371D0-0B58-4787-81BE-8D1E85047077__d5416e731"> 
                   <!-- --></a>
                  <ul id="GUID-184371D0-0B58-4787-81BE-8D1E85047077__d5416e731"> 
                   <li><a name="GUID-184371D0-0B58-4787-81BE-8D1E85047077__d5416e733"> 
                     <!-- --></a><span class="spd-font-mono">\b</span>—Represents a word boundary. A word boundary is a character that is not a word character adjacent to a character that is a word character and vice versa. A word character is an alphanumeric character or an underscore (_). For example, <span class="spd-font-mono">\bhat</span> matches <span class="spd-font-mono">hat</span> in <span class="spd-font-mono">hatchet</span> but not in <span class="spd-font-mono">that</span>. <span class="spd-font-mono">hat\b</span> matches <span class="spd-font-mono">hat</span> in <span class="spd-font-mono">that</span> but not in <span class="spd-font-mono">hatchet</span>. <span class="spd-font-mono">\bhat\b</span> matches <span class="spd-font-mono">hat</span> in <span class="spd-font-mono">hat</span> but not in <span class="spd-font-mono">that</span> or <span class="spd-font-mono">hatchet</span>. </li> 
                   <li><a name="GUID-184371D0-0B58-4787-81BE-8D1E85047077__d5416e779"> 
                     <!-- --></a><span class="spd-font-mono">\c</span>—Matches any control or non-printing character; includes any code point in the character set that does not represent a written symbol </li> 
                   <li><a name="GUID-184371D0-0B58-4787-81BE-8D1E85047077__d5416e784"> 
                     <!-- --></a><span class="spd-font-mono">\w</span>—Matches any word character; equivalent to <span class="spd-font-mono">[a-zA-Z0-9_]</span> </li> 
                   <li><a name="GUID-184371D0-0B58-4787-81BE-8D1E85047077__d5416e792"> 
                     <!-- --></a><span class="spd-font-mono">\W</span>—Matches any non-word character; equivalent to <span class="spd-font-mono">[^a-zA-Z0-9_]</span> </li> 
                   <li><a name="GUID-184371D0-0B58-4787-81BE-8D1E85047077__d5416e800"> 
                     <!-- --></a><span class="spd-font-mono">\d</span>—Matches any digit character; equivalent to <span class="spd-font-mono">[0-9]</span> </li> 
                   <li><a name="GUID-184371D0-0B58-4787-81BE-8D1E85047077__d5416e809"> 
                     <!-- --></a><span class="spd-font-mono">\D</span>—Matches any non-digit character; equivalent to <span class="spd-font-mono">[^0-9]</span> </li> 
                   <li><a name="GUID-184371D0-0B58-4787-81BE-8D1E85047077__d5416e817"> 
                     <!-- --></a><span class="spd-font-mono">\N</span>—Matches a previous submatch within the same regular expression where <span class="spd-font-mono">N</span> is a digit; refer to the <em>Backreferences</em> section for more information about using <span class="spd-font-mono">\N</span> </li> 
                   <li><a name="GUID-184371D0-0B58-4787-81BE-8D1E85047077__d5416e831"> 
                     <!-- --></a><span class="spd-font-mono">\s</span>—Matches any whitespace character; includes space, newline, tab, carriage return, and so on </li> 
                   <li><a name="GUID-184371D0-0B58-4787-81BE-8D1E85047077__d5416e836"> 
                     <!-- --></a><span class="spd-font-mono">\S</span>—Matches any non-whitespace character </li> 
                   <li><a name="GUID-184371D0-0B58-4787-81BE-8D1E85047077__d5416e841"> 
                     <!-- --></a><span class="spd-font-mono">\n</span>—Matches a newline character </li> 
                   <li><a name="GUID-184371D0-0B58-4787-81BE-8D1E85047077__d5416e846"> 
                     <!-- --></a><span class="spd-font-mono">\t</span>—Matches a tab character </li> 
                   <li><a name="GUID-184371D0-0B58-4787-81BE-8D1E85047077__d5416e852"> 
                     <!-- --></a><span class="spd-font-mono">\r</span>—Matches a carriage return character </li> 
                   <li><a name="GUID-184371D0-0B58-4787-81BE-8D1E85047077__d5416e857"> 
                     <!-- --></a><span class="spd-font-mono">\f</span>—Matches a formfeed character </li> 
                   <li><a name="GUID-184371D0-0B58-4787-81BE-8D1E85047077__d5416e862"> 
                     <!-- --></a><span class="spd-font-mono">\031</span>—Matches an octal character (31 octal in this case) </li> 
                   <li><a name="GUID-184371D0-0B58-4787-81BE-8D1E85047077__d5416e867"> 
                     <!-- --></a><span class="spd-font-mono">\x3F</span>—Matches a hexadecimal character (3F hexadecimal in this case) </li> 
                  </ul> </td> 
                 <td headers="d146184e259 "> <p>Input String: <span class="spd-font-mono">total=$12.34</span> </p> <p>Regular Expression: <span class="spd-font-mono">\$\d+(\.\d{2})?</span> </p> <p>Match: <span class="spd-font-mono">$12.34</span> </p> <p>The expression <span class="spd-font-mono">\$</span> matches a literal dollar sign because the backslash cancels the special meaning. The expression <span class="spd-font-mono">\d+</span> matches as many digits as possible and must match at least one digit. The expression <span class="spd-font-mono">(\.\d{2})?</span> matches <span class="spd-font-mono">.</span> and two digits, but <span class="spd-font-mono">?</span> makes this portion of the regular expression optional to match. You can use this regular expression to match dollar values that use a <span class="spd-font-mono">.</span> character as a decimal separator. Locales that use a different character as a decimal separator must adapt the regular expression. </p> </td> 
                </tr> 
                <tr> 
                 <td headers="d146184e259 "> <p>Input String: <span class="spd-font-mono">NEWtoken=FALSE token=TRUE checkFile=TRUE total=12.34</span> </p> <p>Regular Expression: <span class="spd-font-mono">\btoken=\w+\s\b\S*</span> </p> <p>Match: <span class="spd-font-mono">token=TRUE checkFile=TRUE</span> </p> <p>The regular expression does not match <span class="spd-font-mono">token=FALSE</span> in <span class="spd-font-mono">NEWtoken=FALSE</span> because <span class="spd-font-mono">\b</span> makes the regular expression match <span class="spd-font-mono">token=</span> only at the beginning of a word. The expression <span class="spd-font-mono">\w+</span> matches as many word characters as possible and must match at least one. In this example, <span class="spd-font-mono">\w+</span> matches <span class="spd-font-mono">TRUE</span>. The expression <span class="spd-font-mono">\s</span> matches a space character. The expression <span class="spd-font-mono">\b\S*</span> matches all non-whitespace characters that begin a word until the function finds another whitespace character. In this example, <span class="spd-font-mono">\b\S*</span> matches <span class="spd-font-mono">checkFile=TRUE</span>. </p> </td> 
                </tr> 
                <tr> 
                 <td headers="d146184e259 "> 
                  <div class="p">
                   Input String: 
                   <pre>Welcome
to   LabVIEW!</pre> 
                  </div> <p>Regular Expression: <span class="spd-font-mono">come\n\S*\t\w*\x21</span> </p> 
                  <div class="p">
                   Match: 
                   <pre>come
to   LabVIEW!</pre> 
                  </div> <p>The expression <span class="spd-font-mono">come\n</span> matches the literal letters followed by a newline character. The expression <span class="spd-font-mono">\S*</span> matches as many non-whitespace characters as possible, which is the word to in this case. The expression <span class="spd-font-mono">\t</span> matches the tab in between <span class="spd-font-mono">to</span> and <span class="spd-font-mono">LabVIEW!</span>. The expression <span class="spd-font-mono">\w*</span> matches as many word characters as possible, which is <span class="spd-font-mono">LabVIEW</span> in this case. The expression <span class="spd-font-mono">\x21</span> matches the exclamation point because <span class="spd-font-mono">21</span> is the hexadecimal code for an exclamation point. </p> </td> 
                </tr> 
               </tbody> 
              </table> 
              <div class="spd-note tip">
               <img class="spd-note-icon" src="http://s.nicdn.net/apps/spd/images/spd-note-tip.png" alt="spd-note-tip">
               <div class="spd-note-body">
                <a name="GUID-184371D0-0B58-4787-81BE-8D1E85047077__d5416e1038"> 
                 <!-- --></a>
                <strong>Tip</strong>&nbsp;&nbsp; 
                <p>To anchor a match at the beginning and end of a string, use <span class="spd-font-mono">^</span> as the first character in a pattern and <span class="spd-font-mono">$</span> as the last character of a pattern. For example, <span class="spd-font-mono">^LabVIEW$</span> matches <span class="spd-font-mono">LabVIEW</span> in <span class="spd-font-mono">LabVIEW</span> but not in <span class="spd-font-mono">LabVIEW!</span> or <span class="spd-font-mono">Hello LabVIEW</span>. Anchoring the match at the beginning and end of the string requires the whole string to match. </p> 
               </div> 
              </div> 
             </div> 
            </div> 
            <div class="spd-twisties"> 
             <div data-toggle="collapse" data-target="#details312"> 
              <p><span class="glyphicon glyphicon-triangle-right"></span>Specifying Backreferences in the Search String </p> 
             </div> 
             <div id="details312" class="collapse"> 
              <p>Use backreferences to refer to previous submatches within the same regular expression. You can use backreferences to create a submatch using a character group in one part of an expression and then match that exact submatch in a later part of the expression. </p> 
              <p>To specify a backreference, use <span class="spd-font-mono">\1</span> to refer to the first submatch, <span class="spd-font-mono">\2</span> to refer to the second, and so on. For example, consider the following regular expression: </p> 
              <p><span class="spd-font-mono">(["*$])(\w+)\1\2\1</span> </p> 
              <p>The first character group contains a character class that matches ", *, or $. The second character group matches one or more word characters. The first backreference, <span class="spd-font-mono">\1</span>, matches the same submatch as the first character group, <span class="spd-font-mono">(["*$])</span>. The second backreference, <span class="spd-font-mono">\2</span>, matches the same submatch as the second character group, <span class="spd-font-mono">(\w+)</span>. The third backreference, <span class="spd-font-mono">\1</span>, is identical to the first backreference and matches the same submatch as the first character group. </p> 
              <p>This example matches strings such as <span class="spd-font-mono">"foo"foo"</span>, <span class="spd-font-mono">*bar*bar*</span>, and <span class="spd-font-mono">$baz$baz$</span>, but does not match strings such as <span class="spd-font-mono">"foo$foo"</span> or <span class="spd-font-mono">"foo*bar"</span>. </p> 
             </div> 
            </div> 
           </div> 
          </div> 
          <div class="spd-parameter"> 
           <div class="param-datatype">
            <img src="http://s.nicdn.net/documentation/images/lvdatatypes/cstr.png" alt="datatype_icon">
           </div> 
           <div class="param-name"> 
            <h2>replace expression</h2> 
           </div> 
           <div class="param-abstract"> 
            <p><span>String that replaces the search pattern in the input string.</span></p> 
            <div class="spd-twisties"> 
             <div data-toggle="collapse" data-target="#details411"> 
              <p><span class="glyphicon glyphicon-triangle-right"></span>Definitions of Special Characters </p> 
             </div> 
             <div id="details411" class="collapse"> 
              <p>Use the following special characters in <strong>replace expression</strong>. </p>
              <a name="GUID-8310696C-49BF-4901-B1A8-6C12D6712D36__d144167e41"> 
               <!-- --></a>
              <table id="GUID-8310696C-49BF-4901-B1A8-6C12D6712D36__d144167e41" class="spd-table spd-table-bdr"> 
               <thead> 
                <tr> 
                 <th id="d146184e1482">Special Character </th> 
                 <th id="d146184e1485">Description </th> 
                 <th id="d146184e1488">Example(s) </th> 
                </tr> 
               </thead> 
               <tbody> 
                <tr id="GUID-8310696C-49BF-4901-B1A8-6C12D6712D36__d144167e63"> 
                 <td rowspan="2" headers="d146184e1482 "><span class="spd-font-mono">$n</span> or <span class="spd-font-mono">${n}</span> </td> 
                 <td rowspan="2" headers="d146184e1485 "> <p>Inserts a string you specify before or after the submatch you specify. Refer to the <em>Specifying Backreferences in <strong>replace expression</strong></em> section below for more information about using backreferences in this input. </p> <p>Use <span class="spd-font-mono">${n}</span> if you have more than nine submatches in a regular expression and want to refer to a submatch after the ninth. <span class="spd-font-mono">$12</span> inserts only the first submatch because the function reads only the first digit that immediately follows <span class="spd-font-mono">$</span>. However, <span class="spd-font-mono">${12}</span> inserts the twelfth submatch. </p> </td> 
                 <td headers="d146184e1488 "> <p>Input String: <span class="spd-font-mono">Welcome LabVIEW!</span> </p> <p>Pattern: <span class="spd-font-mono">(LabVIEW)</span> </p> <p>Replace String: <span class="spd-font-mono">to $1!</span> </p> <p>Result: <span class="spd-font-mono">Welcome to LabVIEW!</span> </p> </td> 
                </tr> 
                <tr> 
                 <td headers="d146184e1488 "> <p>Input String: <span class="spd-font-mono">Welcome to the LabVIEW Help!</span> </p> <p>Pattern: <span class="spd-font-mono">We(l)(co(m)e)( )(to)( )t(he) (Lab)(VIE(W)) He(lp)(!)</span> </p> <p>Replace String: <span class="spd-font-mono">$7${11}ful${12}</span> </p> <p>Result: <span class="spd-font-mono">helpful!</span> </p> </td> 
                </tr> 
                <tr id="GUID-8310696C-49BF-4901-B1A8-6C12D6712D36__d144167e157"> 
                 <td headers="d146184e1482 "><span class="spd-font-mono">\$n</span> </td> 
                 <td headers="d146184e1485 "> Cancels the interpretation of any special character you use in this input. </td> 
                 <td headers="d146184e1488 "> <p>Input String: <span class="spd-font-mono">total=123 per day</span> </p> <p>Pattern: <span class="spd-font-mono">(\d+)(per \w*)?</span> </p> <p>Replace String: <span class="spd-font-mono">\$$1$2</span> </p> <p>Result: <span class="spd-font-mono">total=$123 per day</span> </p> <p>As in this example, use <span class="spd-font-mono">\$</span> to insert the literal character <span class="spd-font-mono">$</span>. </p> <p>Use <span class="spd-font-mono">\\</span> to indicate a literal backslash. </p> </td> 
                </tr> 
               </tbody> 
              </table> 
             </div> 
            </div> 
            <div class="spd-twisties"> 
             <div data-toggle="collapse" data-target="#details412"> 
              <p><span class="glyphicon glyphicon-triangle-right"></span>Specifying Backreferences in <strong>replace expression</strong></p> 
             </div> 
             <div id="details412" class="collapse"> 
              <p>You can specify a backreference in <strong>replace expression</strong> that refers to submatches in the input string. Use <span class="spd-font-mono">$1</span> to refer to the first submatch, <span class="spd-font-mono">$2</span> to refer to the second submatch, and so on. Consider the following example: </p> 
              <p>Input String: <span class="spd-font-mono">$value "TRUE"TRUE" *NULL</span> </p> 
              <p>Pattern: <span class="spd-font-mono">(["*$])(\w+)\1\2\1</span> </p> 
              <p>Replace String: <span class="spd-font-mono">$1$2value$1</span> </p> 
              <p>Result: <span class="spd-font-mono">$value "TRUEvalue" *NULL</span> </p> 
             </div> 
            </div> 
           </div> 
          </div> 
          <div class="spd-parameter"> 
           <div class="param-datatype">
            <img src="http://s.nicdn.net/documentation/images/lvdatatypes/ci32.png" alt="datatype_icon">
           </div> 
           <div class="param-name"> 
            <h2>offset</h2> 
           </div> 
           <div class="param-abstract"> 
            <p><span>Number of characters into the input string at which the node starts searching for a match.</span> If <strong>offset</strong> is less than or equal to 0, the node starts searching at the beginning of the input string. </p> 
            <p><strong>Default: </strong>0 </p> 
           </div> 
          </div> 
          <div class="spd-parameter"> 
           <div class="param-datatype">
            <img src="http://s.nicdn.net/documentation/images/lvdatatypes/cbool.png" alt="datatype_icon">
           </div> 
           <div class="param-name"> 
            <h2>ignore case</h2> 
           </div> 
           <div class="param-abstract"> 
            <p><span>Boolean value that determines whether the string search is case sensitive.</span></p>
            <a name="d99629e15"> 
             <!-- --></a>
            <table id="d99629e15" class="spd-table spd-table-bdr"> 
             <thead></thead> 
             <tbody> 
              <tr> 
               <td>True</td> 
               <td>The search ignores the letter case of the input.</td> 
              </tr> 
              <tr> 
               <td>False</td> 
               <td>The search matches the letter case of the input.</td> 
              </tr> 
             </tbody> 
            </table> 
            <p><strong>Default: </strong>False </p> 
           </div> 
          </div> 
          <div class="spd-parameter"> 
           <div class="param-datatype">
            <img src="http://s.nicdn.net/documentation/images/lvdatatypes/istr.png" alt="datatype_icon">
           </div> 
           <div class="param-name"> 
            <h2>result string</h2> 
           </div> 
           <div class="param-abstract"> 
            <p> <span>String that results after the node operates on the input string.</span> </p> 
           </div> 
          </div> 
          <div class="spd-parameter"> 
           <div class="param-datatype">
            <img src="http://s.nicdn.net/documentation/images/lvdatatypes/ii32.png" alt="datatype_icon">
           </div> 
           <div class="param-name"> 
            <h2>offset past replacement</h2> 
           </div> 
           <div class="param-abstract"> 
            <p><span>The offset of the character immediately following where the last match and replacement occurred in the result string.</span></p> 
            <p>If the node does not find the search string, this output is -1. </p> 
            <p>If <strong>replace all</strong> is False, the next match, if any, is after this point. </p> 
            <div class="spd-note note">
             <img class="spd-note-icon" src="http://s.nicdn.net/apps/spd/images/spd-note-note.png" alt="spd-note-note">
             <div class="spd-note-body">
              <a name="d144351e24"> 
               <!-- --></a>
              <strong>Note</strong>&nbsp;&nbsp; 
              <p><span>A character refers to a code point, a numeric unit between 0 and 10FFFF<sub>16</sub>, defined by the Unicode standard for encoding. For more information about code points, research Unicode.</span></p> 
             </div> 
            </div> 
           </div> 
          </div> 
         </div> 
         <div role="tabpanel" class="tab-pane " id="tabs-details"> 
          <h2>What Happens When There Is No Match?</h2> 
          <p>If the node does not find <strong>search expression</strong>, <strong>result string</strong> returns an empty string and <strong>offset past replacement</strong> returns -1. </p> 
          <h2>Reducing Performance Burden</h2> 
          <p><a name="GUID-1D01EF4D-FCB9-40CD-9440-CF91F4F8EDAD__d99973e56"> 
            <!-- --></a>Characters in UTF-8 can be multiple bytes so string nodes count the number of characters in a string instead of jumping to a point in memory. Since the length and offset parameters are in units of characters, avoid nesting this node with large strings because that can create exponential functions that carry a higher performance burden. </p> 
         </div> 
         <div role="tabpanel" class="tab-pane " id="tabs-compatibility"> 
          <p><strong>Where This Node Can Run: </strong></p> 
          <p>Desktop OS: Windows</p> 
          <p>FPGA: <span>Not supported</span> </p> 
          <p>Web Server: Not supported in VIs that run in a web application </p> 
         </div> 
        </div> 
       </div> 
      </div> 
      <hr class="col-xs-12"> 
      <div class="spd-related-container col-xs-12"> 
       <h3 class="noindex">Related Topics</h3> 
       <ul class="spd-links-related-content"> 
        <li> 
         <div>
          <a href="../search-and-replace-pattern/" title="Searches for a pattern in the input string and replaces either the first match or every match with a substring you specify.">Search and Replace Pattern</a>
         </div> </li> 
        <li> 
         <div>
          <a href="../search-and-replace-string/" title="Replaces all instances of a substring with another substring.">Search and Replace String</a>
         </div> </li> 
        <li> 
         <div>
          <a href="../match-regular-expression/" title="Searches for a pattern of characters in a string as specified by a regular expression. If this node finds a match, it splits the string into three substrings and any number of submatches. Resize the node to view additional submatches found in the string.">Match Regular Expression</a>
         </div> </li> 
        <li> 
         <div>
          <a href="../match-pattern/" title="Searches for a pattern of characters in a string as specified by a limited set of regular expressions.">Match Pattern</a>
         </div> </li> 
       </ul> 
      </div> 
      <div class="spd-recently-viewed col-xs-12 noindex">
  <h3>Recently Viewed Topics</h3>
</div> 
     </div> 
    </div> 
   </div> 
  </div> 
  


























 

		





 

    

  
  <!--Cookie Law component -->
		<div id="cookieLaw" class="ni-darkgrey" style="display: none;">
			<div class="container">
				  <div class="row">
					  <div class="col-xs-12 col-sm-10">
						<p>This site uses cookies to offer you a better browsing experience.  Learn more about <a href="//www.ni.com/legal/privacy/unitedstates/us/">our privacy policy.</a></p>
					  </div>
					  <div class="col-xs-12 col-sm-2 text-right">
					  <button id="btnUnderstood" class="ni-uppercase ni-btn ni-btn-tertiary" type="button">OK</button>
					  </div>
				  </div>
			</div>
		</div>
			
  
  <!-- FOOTER -->
  <!-- THIS EXTRA DIV IS TO ACCOMODATE IE8 that doesn't recognize "footer" -->
   <div class="footer noindex">
			<footer class="footer noindex">
					<div class="container-fluid">
							<div class="row">
										<div class="container">
													<div class="row clearfix" >
															<!--Footer Nav component -->
   <div class="hidden-xs footer-nav col-xs-12 col-sm-12 col-md-9 col-lg-9">
    <div class="col-xs-4 left">
      <h4>PRODUCT</h4>
      <ul>
          <li>
            <a class="analytics-footer-link" href="//www.ni.com/status/">Order status and history</a>
          </li>
          <li>
            <a class="analytics-footer-link" href="//sine.ni.com/apps/utf8/nios.store?action=purchase_form">Order by part number</a>
          </li>
          <li>
            <a class="analytics-footer-link" href="//sine.ni.com/myproducts/app/main.xhtml?lang=en">Activate a product</a>
          </li>
          <li>
            <a class="analytics-footer-link" href="//sine.ni.com/apps/utf8/niwq.retrieve_quote">Retrieve a quote</a>
          </li>
      </ul>
    </div>
    <div class="col-xs-4">
      <h4>SUPPORT</h4>
      <ul>
          <li>
            <a class="analytics-footer-link" href="//sine.ni.com/srm/app/myServiceRequests">Submit a service request</a>
          </li>
          <li>
            <a class="analytics-footer-link" href="//www.ni.com/manuals/">Manuals</a>
          </li>
          <li>
            <a class="analytics-footer-link" href="//www.ni.com/downloads/drivers/">Drivers</a>
          </li>
          <li>
            <a class="analytics-footer-link" href="//www.ni.com/alliance/">Alliance Partners</a>
          </li>
      </ul>
    </div>
    <div class="col-xs-4">
      <h4>COMPANY</h4>
      <ul>
          <li>
            <a class="analytics-footer-link" href="//www.ni.com/company/">About National Instruments</a>
          </li>
          <li>
            <a class="analytics-footer-link" href="//www.ni.com/en-us/events.html">Events</a>
          </li>
          <li>
            <a class="analytics-footer-link" href="//www.ni.com/careers/">Careers</a>
          </li>
          <li>
            <a class="analytics-footer-link" href="//www.ni.com/contact-us/">Contact Us</a>
          </li>
      </ul>
    </div>
  </div>
															<div class="motto-table col-xs-3">
															<!--Motto component -->
 <div class="motto">
   <h4>MISSION</h4>
   <p>NI equips engineers and scientists with systems that accelerate productivity, innovation, and discovery.</p>
 </div>
          
																<!--Social Media component -->
																<div class="footer-social-media">
<div id="niaSvgSocial">
     <a href="http://www.facebook.com/NationalInstruments"  class="analytics-footer-link" ><svg class="footer-social" viewBox="0 0 35 35"><path style="fill:#FFFFFF;" d="M33.1,0H2C0.9,0,0.1,0.9,0.1,1.9V33c0,1.1,0.9,1.9,1.9,1.9h16.8V21.3h-4.6V16h4.6v-3.9
c0-4.5,2.8-7,6.8-7c1.9,0,3.6,0.1,4.1,0.2v4.7h-2.8c-2.2,0-2.6,1-2.6,2.6v3.4h5.2l-0.7,5.3h-4.6V35H33c1.1,0,1.9-0.9,1.9-1.9V2
		C35,0.9,34.1,0,33.1,0z"/></svg></a>
     <a href="//twitter.com/niglobal"  class="analytics-footer-link" ><svg class="footer-social" viewBox="0 0 35 35"><path style="fill:#FFFFFF;" d="M33,0H2A2,2,0,0,0,0,2V33a2,2,0,0,0,2,2H33a2,2,0,0,0,2-2V2A2,2,0,0,0,33,0ZM26.2,13c0,.19,0,.39,0,.58A12.76,12.76,0,0,1,6.56,24.37a9.45,9.45,0,0,0,1.07.07,9,9,0,0,0,5.58-1.93A4.49,4.49,0,0,1,9,19.4a4.8,4.8,0,0,0,.85.08A4.6,4.6,0,0,0,11,19.32a4.49,4.49,0,0,1-3.6-4.4v-.06a4.41,4.41,0,0,0,2,.56,4.49,4.49,0,0,1-1.38-6,12.73,12.73,0,0,0,9.25,4.69,4.31,4.31,0,0,1-.12-1A4.49,4.49,0,0,1,25,10a8.92,8.92,0,0,0,2.85-1.09,4.43,4.43,0,0,1-2,2.48,9.29,9.29,0,0,0,2.58-.7A9.15,9.15,0,0,1,26.2,13Z"/></svg></a>
     <a href="http://www.linkedin.com/company/3433?trk=tyah"  class="analytics-footer-link" ><svg class="footer-social" viewBox="0 0 35 35"><path style="fill:#FFFFFF;" d="M33.1,0H2C0.9,0,0,0.9,0,2v31c0,1.1,0.9,2,2,2H33c1.1,0,2-0.9,2-2V2C35.1,0.9,34.2,0,33.1,0
	 M10.4,30.6H4.7V13.7h5.7V30.6L10.4,30.6z M7.5,11.5L7.5,11.5c-1.9,0-3.1-1.3-3.1-2.9c0-1.7,1.3-2.9,3.2-2.9s3.1,1.3,3.1,2.9
	S9.5,11.5,7.5,11.5 M30.7,30.6h-5.6v-9.1c0-2.3-0.8-3.8-2.9-3.8c-1.6,0-2.5,1-2.9,2.1c-0.1,0.4-0.2,0.9-0.2,1.4v9.5h-5.6
	c0,0,0.1-15.4,0-16.9H19v2.4c0.7-1.2,2.1-2.8,5.1-2.8c3.7,0,6.5,2.4,6.5,7.6C30.7,21,30.7,30.6,30.7,30.6z"/></svg></a>
     <a href="//www.youtube.com/nationalinstruments"  class="analytics-footer-link" ><svg class="footer-social" viewBox="5 -7 37 43"><path style="fill:#FFFFFF;" d="M43.5,5.7c0,0-0.5-3.1-1.8-4.4c-1.7-1.8-3.6-1.8-4.4-1.8C31-1,21.7-1,21.7-1l0,0
				c0,0-9.4,0-15.6,0.5C5.2-0.4,3.3-0.4,1.6,1.3C0.2,2.7-0.1,5.7-0.1,5.7S-0.6,9.4-0.6,13v3.4c0,3.6,0.5,7.2,0.5,7.2
				s0.5,3.1,1.8,4.4c1.7,1.8,4,1.8,4.9,1.9c3.6,0.4,15.2,0.5,15.2,0.5s9.4,0,15.6-0.5c0.8-0.1,2.8-0.1,4.4-1.8
				c1.4-1.4,1.8-4.4,1.8-4.4s0.5-3.6,0.5-7.2v-3.4C44,9.4,43.5,5.7,43.5,5.7z M17,20.5V8l12.1,6.3L17,20.5z"/></svg></a>
</div>
																</div>
															</div>
													</div>
													<div class="row desktop">
															<div class="container clearfix legal" >
   	<div class="legal-desktop col-xs-8">
    <!--TRUSTe logo component-->
          <div class="left">
   

    
   <a class="analytics-footer-link truste-image" href="//privacy.truste.com/privacy-seal/validation?rid=342a514a-c792-40e3-ae36-17c7491387a7" target="_blank">
              <img class="img-responsive" src="//privacy-policy.truste.com/privacy-seal/seal?rid=342a514a-c792-40e3-ae36-17c7491387a7" alt="TRUSTe"/>
          </a>

                     
          </div>
          <div class="legal-copy">
                <a class="analytics-footer-link" href="//www.ni.com/legal/">Legal</a> <span class="pipe">|</span>
                <a class="analytics-footer-link" href="//www.ni.com/en-us/about-ni/legal/privacy/privacy-statement.html">Privacy </a> 
          &nbsp; &copy <span class="copyright"> </span>  National Instruments. All rights reserved. 
          </div>
    </div>
  
<div class="col-xs-3 col-xs-offset-1">
    <div class="footer-gg">
      <svg version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" width="24px" height="24px" viewBox="0 0 45 45" xml:space="preserve">
      <g id="XMLID_1_">
        <g>
          <path fill="#fff" d="M22,0C9.8,0,0,9.8,0,22s9.8,22,22,22s22-9.8,22-22S34.2,0,22,0z M36.4,35.7c-0.3,0.3-0.6,0.6-0.9,0.9l0,0   c-2.6,2.4-6,4.2-9.6,4.8c2.8-2.5,5.1-5.7,6.7-9.2c1.5,0.9,2.8,2,4.1,3.2C36.5,35.6,36.4,35.7,36.4,35.7z M7.6,8.3   C8,8,8.3,7.6,8.6,7.3l0,0c2.6-2.4,6-4.2,9.6-4.8c-2.8,2.5-5.1,5.7-6.7,9.2c-1.5-0.9-2.8-2-4.1-3.2C7.5,8.4,7.6,8.3,7.6,8.3z    M36.4,8.3l0.1,0.1c-1.3,1.3-2.6,2.4-4.1,3.2c-1.6-3.6-3.8-6.7-6.7-9.2c3.8,0.7,7.1,2.5,9.7,4.9l0,0C35.7,7.6,36,8,36.4,8.3z    M21,14.6c-2.6-0.1-5.2-0.8-7.5-1.9c1.6-3.7,4-6.9,7.2-9.5H21V14.6z M21,16.8V21h-9.4c0.1-2.2,0.4-4.3,1.2-6.3   C15.2,15.8,18,16.6,21,16.8z M21,23v4.2c-2.9,0.1-5.8,0.8-8.3,2.1c-0.6-2-1-4.1-1.2-6.3H21z M21,29.4v11.4h-0.3   c-3.2-2.6-5.8-5.9-7.2-9.5C15.7,30.2,18.3,29.5,21,29.4z M23,29.4c2.6,0.1,5.2,0.8,7.5,1.9c-1.6,3.7-4,7-7.2,9.5H23V29.4z M23,27.2   V23h9.3c-0.1,2.2-0.4,4.3-1,6.3C28.8,28.1,26,27.4,23,27.2z M23,21v-4.2c2.9-0.1,5.7-0.8,8.2-2c0.6,2,1,4.1,1.2,6.3H23V21z    M23,14.6V3.1h0.1c3.2,2.6,5.8,5.9,7.3,9.5C28.2,13.8,25.7,14.5,23,14.6z M10.8,13.7C10.1,16,9.5,18.4,9.4,21H2.1   c0.2-4.2,1.7-8.1,4.1-11.1v0.3C7.6,11.5,9.1,12.7,10.8,13.7z M9.4,23c0.1,2.5,0.5,5,1.4,7.2c-1.7,0.9-3.1,2.2-4.5,3.6v0.3   c-2.4-3-3.9-6.9-4.1-11.1H9.4z M7.6,35.7l-0.1-0.1c1.3-1.3,2.6-2.4,4.1-3.2c1.6,3.6,3.8,6.7,6.7,9.2c-3.7-0.7-6.9-2.4-9.6-4.8l0,0   C8.3,36.4,8,36,7.6,35.7z M33.2,30.3c0.7-2.3,1.3-4.7,1.4-7.2h7.3c-0.2,4.2-1.7,8.1-4.1,11.1v-0.3C36.4,32.5,34.9,31.3,33.2,30.3z    M34.6,21c-0.1-2.5-0.5-5-1.4-7.2c1.7-0.9,3.1-2.2,4.5-3.6V9.8c2.4,3.1,3.9,6.9,4.1,11.1H34.6z"/>
        </g>
      </g>
    </svg>
      <a class="global-gateway analytics-utilitygg-link">
        <span class="country">Choose your country</span>
      </a>
   <!-- global gateway panel -->
   
        <div class="gg-panel">
            <div>
	      <div class="col-xs-6">
	       <ul>
                           <li class="analytics-utilityggsupportedcountry-link">
                             <a href="" data-locale="en-AU">Australia</a>
                            </li>
                           <li class="analytics-utilityggsupportedcountry-link">
                             <a href="" data-locale="pt-BR">Brasil</a>
                            </li>
                           <li class="analytics-utilityggsupportedcountry-link">
                             <a href="" data-locale="en-CA">Canada (English)</a>
                            </li>
                           <li class="analytics-utilityggsupportedcountry-link">
                             <a href="" data-locale="fr-CA">Canada (Français)</a>
                            </li>
                           <li class="analytics-utilityggsupportedcountry-link">
                             <a href="" data-locale="de-DE">Deutschland</a>
                            </li>
                           <li class="analytics-utilityggsupportedcountry-link">
                             <a href="" data-locale="es-ES">España</a>
                            </li>
                           <li class="analytics-utilityggsupportedcountry-link">
                             <a href="" data-locale="fr-FR">France</a>
                            </li>
                           <li class="analytics-utilityggsupportedcountry-link">
                             <a href="" data-locale="en-IN">India</a>
                            </li>
                           <li class="analytics-utilityggsupportedcountry-link">
                             <a href="" data-locale="it-IT">Italia</a>
                            </li>
                           <li class="analytics-utilityggsupportedcountry-link">
                             <a href="" data-locale="hu-HU">Magyarország</a>
                            </li>
                           <li class="analytics-utilityggsupportedcountry-link">
                             <a href="" data-locale="en-MY">Malaysia</a>
                            </li>
                           <li class="analytics-utilityggsupportedcountry-link">
                             <a href="" data-locale="es-MX">México</a>
                            </li>
                           <li class="analytics-utilityggsupportedcountry-link">
                             <a href="" data-locale="nl-NL">Nederland</a>
                            </li>
	        </ul>
	      </div>
	       <div class="col-xs-6">
	       <ul>
		         <li class="analytics-utilityggsupportedcountry-link">
			    <a href="" data-locale="de-AT">Österreich</a>
		         </li>
		         <li class="analytics-utilityggsupportedcountry-link">
			    <a href="" data-locale="pl-PL">Polska</a>
		         </li>
		         <li class="analytics-utilityggsupportedcountry-link">
			    <a href="" data-locale="de-CH">Schweiz</a>
		         </li>
		         <li class="analytics-utilityggsupportedcountry-link">
			    <a href="" data-locale="en-SG">Singapore</a>
		         </li>
		         <li class="analytics-utilityggsupportedcountry-link">
			    <a href="" data-locale="fr-CH">Suisse</a>
		         </li>
		         <li class="analytics-utilityggsupportedcountry-link">
			    <a href="" data-locale="sv-SE">Sverige</a>
		         </li>
		         <li class="analytics-utilityggsupportedcountry-link">
			    <a href="" data-locale="en-GB">United Kingdom</a>
		         </li>
		         <li class="analytics-utilityggsupportedcountry-link">
			    <a href="" data-locale="en-US">United States</a>
		         </li>
		         <li class="analytics-utilityggsupportedcountry-link">
			    <a href="" data-locale="ru-RU">Российская Федерация</a>
		         </li>
		         <li class="analytics-utilityggsupportedcountry-link">
			    <a href="" data-locale="zh-CN">中国 (China)</a>
		         </li>
		         <li class="analytics-utilityggsupportedcountry-link">
			    <a href="" data-locale="ja-JP">日本 (Japan)</a>
		         </li>
		         <li class="analytics-utilityggsupportedcountry-link">
			    <a href="" data-locale="ko-KR">대한민국 (Korea)</a>
		         </li>
		         <li class="analytics-utilityggsupportedcountry-link">
			    <a href="" data-locale="zh-TW">中國台灣 （Taiwan, China)</a>
		         </li>
	        </ul></div>
	 
	    </div>
	    <div>
	      <div class="col-xs-12 gg-panel-bottom ">
                           <a href="http://www.ni.com/global-gateway/" class="analytics-utilityggallcountries-link global-gateway">See All Countries and Regions</a>
                  
	      </div>
         <div class="arrow"></div>
	    </div>
           
            </div>
  </div>
  </div>
															</div>
													</div>
										</div>
							</div>
					</div>
			</footer>
  </div>
 
  



   <!--FOR ADOBE DYNAMIC TAG MANAGER ASYNC-->

    <script type="text/javascript">niAnalyticsBottomCall();</script>
  
  <!-- Publication GUID: GUID-32677CF5-91FE-487E-8230-3DA2DCC0D78B--> 
  <!-- Topic v.9 GUID: GUID-1D01EF4D-FCB9-40CD-9440-CF91F4F8EDAD--> 
 </body>
</html>