Table Of Contents

Software Requirements

Version:
    Last Modified: September 6, 2017

    • Install application software and device drivers appropriate to your hardware configuration. The following software applications and device drivers are compatible with C Series Functional Safety modules:

      • Functional Safety Editor
      • LabVIEW 2017 or later
      • LabVIEW Real-Time Module 2017 or later
      • CompactRIO Device Drivers 17.0 or later
    • You must download a compiled User Program to the C Series Functional Safety module. You can create a User Program using the NI Functional Safety Editor and logic compiler. To download the necessary software, go to ni.com/info and enter Info Code safetydownload.
    • You must have a computer running 64-bit Windows 7, Windows 8.1, or later to install and use the Functional Safety Editor. The application is not compatible with 32-bit Windows versions.
    • The LabVIEW Real-Time Module is only available in 32-bit. If you are using the LabVIEW Real-Time Module, you must download 32-bit application software and device drivers to a computer running a 64-bit operating system.
    spd-note-note
    Note  

    For minimum software support information, visit ni.com/info and enter the Info Code swsupport.


    Recently Viewed Topics